Update to use Tcl/Tk version 8.2. Commented out the STEPIFY stuff for

now since we don't have tkstep82 yet.
This commit is contained in:
Steve Price 1999-12-10 15:47:30 +00:00
parent 6741d38a9f
commit 281d8a6fec
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=23733
3 changed files with 48 additions and 26 deletions

View File

@ -7,37 +7,37 @@
#
DISTNAME= postilion-0.9.2
CATEGORIES= mail tk80
CATEGORIES= mail tk82
MASTER_SITES= http://www.postilion.org/
MAINTAINER= gljohns@bellsouth.net
LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80 \
LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82 \
img.1:${PORTSDIR}/graphics/libimg
BUILD_DEPENDS= tclsh8.0:${PORTSDIR}/lang/tcl80
BUILD_DEPENDS= tclsh8.2:${PORTSDIR}/lang/tcl82
FETCH_BEFORE_ARGS= -b
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl-config=${PREFIX}/lib/tcl8.0
CONFIGURE_ARGS= --with-tcl-config=${PREFIX}/lib/tcl8.2
.if defined(STEPIFY)
LIB_DEPENDS+= tkstep80.1:${PORTSDIR}/x11-toolkits/tkstep80 \
Dnd.1:${PORTSDIR}/x11/libdnd \
tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg \
Xpm.4:${PORTSDIR}/graphics/xpm
CONFIGURE_ARGS+= --with-tk-config=${PREFIX}/lib/tkstep8.0
pre-patch:
${SED} s/'(DND) 0/(DND) 1'/ ${FILESDIR}/options.tcl > \
${WRKSRC}/postilion/options.tcl
.else
pre-extract:
@${ECHO} ""
@${ECHO} "You can build postilion with NeXtStep style widgets by defining STEPIFY"
@${ECHO} ""
LIB_DEPENDS+= tk80.1:${PORTSDIR}/x11-toolkits/tk80
CONFIGURE_ARGS+= --with-tk-config=${PREFIX}/lib/tk8.0
.endif
#.if defined(STEPIFY)
#LIB_DEPENDS+= tkstep80.1:${PORTSDIR}/x11-toolkits/tkstep80 \
# Dnd.1:${PORTSDIR}/x11/libdnd \
# tiff.4:${PORTSDIR}/graphics/tiff \
# jpeg.9:${PORTSDIR}/graphics/jpeg \
# Xpm.4:${PORTSDIR}/graphics/xpm
#CONFIGURE_ARGS+= --with-tk-config=${PREFIX}/lib/tkstep8.0
#pre-patch:
# ${SED} s/'(DND) 0/(DND) 1'/ ${FILESDIR}/options.tcl > \
# ${WRKSRC}/postilion/options.tcl
#.else
#pre-extract:
# @${ECHO} ""
# @${ECHO} "You can build postilion with NeXtStep style widgets by defining STEPIFY"
# @${ECHO} ""
LIB_DEPENDS+= tk82.1:${PORTSDIR}/x11-toolkits/tk82
CONFIGURE_ARGS+= --with-tk-config=${PREFIX}/lib/tk8.2
#.endif
.include <bsd.port.mk>

View File

@ -648,8 +648,8 @@ proc OptionsInit {} {
# Message finding fields
set option(msgfind_format) "%s%n%b%D"
# Should we warn about tk version 8.0
set option(warn_tk80) 1
# Should we warn about tk version 8.2
set option(warn_tk82) 1
## Ispell options
# Turn Ispell On/Off

View File

@ -1,11 +1,33 @@
--- configure.orig Sat Nov 28 18:36:04 1998
+++ configure Sun Feb 21 10:24:44 1999
+++ configure Wed Dec 8 21:56:00 1999
@@ -875,8 +875,8 @@
test -n "$AWK" && break
done
-# Extract the first word of "tclsh8.0", so it can be a program name with args.
-set dummy tclsh8.0; ac_word=$2
+# Extract the first word of "tclsh8.2", so it can be a program name with args.
+set dummy tclsh8.2; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
echo "configure:882: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_tclsh'+set}'`\" = set"; then
@@ -938,8 +938,8 @@
fi
if test "x$wish" = "x"; then
- # Extract the first word of "wish8.0", so it can be a program name with args.
-set dummy wish8.0; ac_word=$2
+ # Extract the first word of "wish8.2", so it can be a program name with args.
+set dummy wish8.2; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
echo "configure:945: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_wish'+set}'`\" = set"; then
@@ -2074,7 +2074,7 @@
for i in $tcl_dirs ; do
tcl_include_dirs="$tcl_include_dirs $i/include"
done
-tcl_include_dirs="$tcl_include_dirs /usr/include/tcl /usr/include"
+tcl_include_dirs="$tcl_include_dirs /usr/local/include/tcl8.0 /usr/local/include/tkstep8.0 /usr/local/include/tk8.0 /usr/include"
+tcl_include_dirs="$tcl_include_dirs /usr/local/include/tcl8.2 /usr/local/include/tkstep8.2 /usr/local/include/tk8.2 /usr/include"
tcl_dir=0
for i in $tcl_include_dirs ; do
if test -r $i/tcl.h ; then