- Removed development port, all changes have meen merged into www/webalizer
This commit is contained in:
parent
f638f46b75
commit
281339739f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42650
@ -268,7 +268,6 @@
|
||||
SUBDIR += web2ldap
|
||||
SUBDIR += web500gw
|
||||
SUBDIR += webalizer
|
||||
SUBDIR += webalizer-2
|
||||
SUBDIR += webcopy
|
||||
SUBDIR += webcrawl
|
||||
SUBDIR += webfs
|
||||
|
@ -1,79 +0,0 @@
|
||||
# New ports collection makefile for: webalizer-2
|
||||
# Date created: 18.Apr.2000
|
||||
# Whom: ache@freebsd.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= webalizer
|
||||
PORTVERSION= 2.1.6
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ftp://ftp.mrunix.net/pub/webalizer/
|
||||
DISTNAME= ${PORTNAME}-2.01-06-src
|
||||
|
||||
MAINTAINER= ache@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
|
||||
|
||||
NO_LATEST_LINK= yes
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--enable-dns \
|
||||
--with-etcdir=${PREFIX}/etc \
|
||||
--with-gdlib=${PREFIX}/lib \
|
||||
--with-gd=${PREFIX}/include/gd
|
||||
CONFIGURE_ENV+= LDFLAGS="-L${PREFIX}/lib"
|
||||
|
||||
MAN1= webalizer.1
|
||||
DOC1= CHANGES COPYING Copyright INSTALL \
|
||||
README README.FIRST DNS.README country-codes.txt
|
||||
SUPP_LANG= catalan chinese czech danish dutch english estonian \
|
||||
finnish french german greek hungarian indonesian italian \
|
||||
korean polish portuguese portuguese_brazil romanian \
|
||||
russian slovak spanish swedish
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src$//}
|
||||
MAKE_ARGS+= CFLAGS="${CFLAGS}"
|
||||
|
||||
.if defined(BATCH)
|
||||
# no cosmetique spaces allowed
|
||||
WEBALIZER_LANG=english
|
||||
.endif
|
||||
|
||||
.if defined(WEBALIZER_LANG)
|
||||
CONFIGURE_ARGS+= --with-language=${WEBALIZER_LANG}
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
@${PERL5} -pi -e "s=/etc=${PREFIX}/etc=" ${WRKSRC}/webalizer.c
|
||||
.if !defined(WEBALIZER_LANG)
|
||||
@${ECHO_MSG} "You can customize the language by typing"
|
||||
@${ECHO_MSG} " make WEBALIZER_LANG=<lang>"
|
||||
@${ECHO_MSG} "where <lang> is one of:"
|
||||
@${ECHO_MSG} ${SUPP_LANG}
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/webalizer ${PREFIX}/bin
|
||||
${LN} -sf webalizer ${PREFIX}/bin/webazolver
|
||||
|
||||
post-install:
|
||||
.for i in ${MAN1}
|
||||
${INSTALL_MAN} ${WRKSRC}/${i} ${PREFIX}/man/man1
|
||||
.endfor
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/webalizer
|
||||
.for i in ${DOC1}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/webalizer/${i}
|
||||
.endfor
|
||||
.endif
|
||||
${MKDIR} ${PREFIX}/share/examples/webalizer
|
||||
.for i in msfree.png sample.conf webalizer.png
|
||||
@${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/examples/webalizer/${i}
|
||||
.endfor
|
||||
@if [ ! -f ${PREFIX}/etc/webalizer.conf-dist ]; then \
|
||||
${INSTALL_DATA} ${WRKSRC}/sample.conf \
|
||||
${PREFIX}/etc/webalizer.conf-dist ; \
|
||||
fi
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1 +0,0 @@
|
||||
MD5 (webalizer-2.01-06-src.tar.bz2) = 9e52cd91de25c87e29b105e5b23dcdfc
|
@ -1,17 +0,0 @@
|
||||
--- linklist.c.bak Fri Sep 29 07:51:02 2000
|
||||
+++ linklist.c Sat Oct 14 17:22:16 2000
|
||||
@@ -197,12 +197,12 @@
|
||||
strncpy(temp_buf,str,79);
|
||||
temp_buf[79]=0;
|
||||
|
||||
- while (!isspace((int)*name)&&*name!=0) name++;
|
||||
+ while (!isspace((unsigned char)*name)&&*name!=0) name++;
|
||||
if (*name==0) name=temp_buf;
|
||||
else
|
||||
{
|
||||
*name++=0;
|
||||
- while (isspace((int)*name)&&*name!=0) name++;
|
||||
+ while (isspace((unsigned char)*name)&&*name!=0) name++;
|
||||
if (*name==0) name=temp_buf;
|
||||
}
|
||||
|
@ -1,65 +0,0 @@
|
||||
--- preserve.c.bak Fri Sep 29 07:51:32 2000
|
||||
+++ preserve.c Sat Oct 14 17:34:03 2000
|
||||
@@ -492,7 +492,7 @@
|
||||
tmp_buf[strlen(tmp_buf)-1]=0;
|
||||
|
||||
if ((fgets(buffer,BUFSIZE,fp)) == NULL) return 10; /* error exit */
|
||||
- if (!isdigit((int)buffer[0])) return 10; /* error exit */
|
||||
+ if (!isdigit((unsigned char)buffer[0])) return 10; /* error exit */
|
||||
|
||||
/* load temporary node data */
|
||||
sscanf(buffer,"%d %lu %lu %lf %lu %lu",
|
||||
@@ -523,7 +523,7 @@
|
||||
tmp_buf[strlen(buffer)-1]=0;
|
||||
|
||||
if ((fgets(buffer,BUFSIZE,fp)) == NULL) return 8; /* error exit */
|
||||
- if (!isdigit((int)buffer[0])) return 8; /* error exit */
|
||||
+ if (!isdigit((unsigned char)buffer[0])) return 8; /* error exit */
|
||||
|
||||
/* load temporary node data */
|
||||
sscanf(buffer,"%d %lu %lu %lf %lu %lu",
|
||||
@@ -563,7 +563,7 @@
|
||||
tmp_buf[strlen(buffer)-1]=0;
|
||||
|
||||
if ((fgets(buffer,BUFSIZE,fp)) == NULL) return 9; /* error exit */
|
||||
- if (!isdigit((int)buffer[0])) return 9; /* error exit */
|
||||
+ if (!isdigit((unsigned char)buffer[0])) return 9; /* error exit */
|
||||
|
||||
/* load temporary node data */
|
||||
sscanf(buffer,"%d %lu %lu %lf %lu %lu",
|
||||
@@ -602,7 +602,7 @@
|
||||
tmp_buf[strlen(buffer)-1]=0;
|
||||
|
||||
if ((fgets(buffer,BUFSIZE,fp)) == NULL) return 11; /* error exit */
|
||||
- if (!isdigit((int)buffer[0])) return 11; /* error exit */
|
||||
+ if (!isdigit((unsigned char)buffer[0])) return 11; /* error exit */
|
||||
|
||||
/* load temporary node data */
|
||||
sscanf(buffer,"%d %lu",&t_rnode.flag,&t_rnode.count);
|
||||
@@ -627,7 +627,7 @@
|
||||
tmp_buf[strlen(buffer)-1]=0;
|
||||
|
||||
if ((fgets(buffer,BUFSIZE,fp)) == NULL) return 12; /* error exit */
|
||||
- if (!isdigit((int)buffer[0])) return 12; /* error exit */
|
||||
+ if (!isdigit((unsigned char)buffer[0])) return 12; /* error exit */
|
||||
|
||||
/* load temporary node data */
|
||||
sscanf(buffer,"%d %lu",&t_anode.flag,&t_anode.count);
|
||||
@@ -652,7 +652,7 @@
|
||||
tmp_buf[strlen(buffer)-1]=0;
|
||||
|
||||
if ((fgets(buffer,BUFSIZE,fp)) == NULL) return 13; /* error exit */
|
||||
- if (!isdigit((int)buffer[0])) return 13; /* error exit */
|
||||
+ if (!isdigit((unsigned char)buffer[0])) return 13; /* error exit */
|
||||
|
||||
/* load temporary node data */
|
||||
sscanf(buffer,"%lu",&t_snode.count);
|
||||
@@ -677,7 +677,7 @@
|
||||
tmp_buf[strlen(buffer)-1]=0;
|
||||
|
||||
if ((fgets(buffer,BUFSIZE,fp)) == NULL) return 14; /* error exit */
|
||||
- if (!isdigit((int)buffer[0])) return 14; /* error exit */
|
||||
+ if (!isdigit((unsigned char)buffer[0])) return 14; /* error exit */
|
||||
|
||||
/* load temporary node data */
|
||||
sscanf(buffer,"%d %lu %lu %lf %lu %lu",
|
@ -1,62 +0,0 @@
|
||||
--- webalizer.c.orig Fri Oct 6 11:59:08 2000
|
||||
+++ webalizer.c Sat Oct 14 17:17:29 2000
|
||||
@@ -569,7 +569,7 @@
|
||||
|
||||
/* convert month name to lowercase */
|
||||
for (i=4;i<7;i++)
|
||||
- log_rec.datetime[i]=tolower(log_rec.datetime[i]);
|
||||
+ log_rec.datetime[i]=tolower((unsigned char)log_rec.datetime[i]);
|
||||
|
||||
/* get year/month/day/hour/min/sec values */
|
||||
for (i=0;i<12;i++)
|
||||
@@ -1459,19 +1459,19 @@
|
||||
while ( (fgets(buffer,BUFSIZE,fp)) != NULL)
|
||||
{
|
||||
/* skip comments and blank lines */
|
||||
- if ( (buffer[0]=='#') || isspace((int)buffer[0]) ) continue;
|
||||
+ if ( (buffer[0]=='#') || isspace((unsigned char)buffer[0]) ) continue;
|
||||
|
||||
/* Get keyword */
|
||||
cp1=buffer;cp2=keyword;
|
||||
- while ( isalnum((int)*cp1) ) *cp2++ = *cp1++;
|
||||
+ while ( isalnum((unsigned char)*cp1) ) *cp2++ = *cp1++;
|
||||
*cp2='\0';
|
||||
|
||||
/* Get value */
|
||||
cp2=value;
|
||||
- while ( (*cp1!='\n')&&(*cp1!='\0')&&(isspace((int)*cp1)) ) cp1++;
|
||||
+ while ( (*cp1!='\n')&&(*cp1!='\0')&&(isspace((unsigned char)*cp1)) ) cp1++;
|
||||
while ( (*cp1!='\n')&&(*cp1!='\0') ) *cp2++ = *cp1++;
|
||||
*cp2--='\0';
|
||||
- while ( (isspace((int)*cp2)) && (cp2 != value) ) *cp2--='\0';
|
||||
+ while ( (isspace((unsigned char)*cp2)) && (cp2 != value) ) *cp2--='\0';
|
||||
|
||||
/* check if blank keyword/value */
|
||||
if ( (keyword[0]=='\0') || (value[0]=='\0') ) continue;
|
||||
@@ -1720,7 +1720,7 @@
|
||||
|
||||
int isurlchar(char ch)
|
||||
{
|
||||
- if (isalnum((int)ch)) return 1; /* allow letters, numbers... */
|
||||
+ if (isalnum((unsigned char)ch)) return 1; /* allow letters, numbers... */
|
||||
return (strchr(":/\\.,' *-+_@~()[]",ch)!=NULL); /* and a few special ones */
|
||||
}
|
||||
|
||||
@@ -1813,7 +1813,7 @@
|
||||
if (*cp1=='+') *cp1=' '; /* change + to space */
|
||||
if (sp_flg && *cp1==' ') { cp1++; continue; } /* compress spaces */
|
||||
if (*cp1==' ') sp_flg=1; else sp_flg=0; /* (flag spaces here) */
|
||||
- *cp2++=tolower(*cp1); /* normal character */
|
||||
+ *cp2++= *cp1; /* normal character */
|
||||
cp1++;
|
||||
}
|
||||
}
|
||||
@@ -1848,7 +1848,7 @@
|
||||
int i=group_domains+1;
|
||||
|
||||
cp = str+strlen(str)-1;
|
||||
- if (isdigit((int)*cp)) return NULL; /* ignore IP addresses */
|
||||
+ if (isdigit((unsigned char)*cp)) return NULL; /* ignore IP addresses */
|
||||
|
||||
while (cp!=str)
|
||||
{
|
@ -1,33 +0,0 @@
|
||||
--- output.c.orig Fri Sep 29 07:51:42 2000
|
||||
+++ output.c Sat Oct 14 17:18:55 2000
|
||||
@@ -1450,10 +1450,17 @@
|
||||
rptr=*pointer++;
|
||||
if (rptr->flag == OBJ_REG)
|
||||
{
|
||||
- fprintf(out_fp,"%-8lu %6.02f%% %s\n",
|
||||
- rptr->count,
|
||||
- (t_hit==0)?0:((float)rptr->count/t_hit)*100.0,
|
||||
- rptr->string);
|
||||
+ if (strstr(rptr->string,"://")!=NULL)
|
||||
+ fprintf(out_fp,"%-8lu %6.02f%% <A HREF=\"%s\">%s</A>\n",
|
||||
+ rptr->count,
|
||||
+ (t_hit==0)?0:((float)rptr->count/t_hit)*100.0,
|
||||
+ rptr->string,
|
||||
+ rptr->string);
|
||||
+ else
|
||||
+ fprintf(out_fp,"%-8lu %6.02f%% %s\n",
|
||||
+ rptr->count,
|
||||
+ (t_hit==0)?0:((float)rptr->count/t_hit)*100.0,
|
||||
+ rptr->string);
|
||||
r_reg--;
|
||||
}
|
||||
}
|
||||
@@ -1932,7 +1939,7 @@
|
||||
{
|
||||
domain = hptr->string+strlen(hptr->string)-1;
|
||||
while ( (*domain!='.')&&(domain!=hptr->string)) domain--;
|
||||
- if ((domain==hptr->string)||(isdigit((int)*++domain)))
|
||||
+ if ((domain==hptr->string)||(isdigit((unsigned char)*++domain)))
|
||||
{
|
||||
ctry[0].count+=hptr->count;
|
||||
ctry[0].files+=hptr->files;
|
@ -1 +0,0 @@
|
||||
A web server log file analysis program
|
@ -1,23 +0,0 @@
|
||||
What is The Webalizer?
|
||||
----------------------
|
||||
|
||||
A fast, free web server log file analysis program. Produces
|
||||
HTML output for viewing with a web browser. Written in C on
|
||||
a Linux platform, however designed to be as ANSI/POSIX
|
||||
compliant as possible so porting to other UNIX platforms should
|
||||
be painless. Binary distributions for most popular platforms
|
||||
are available. Features multiple language support, incremental
|
||||
processing capabilities, reverse DNS lookup support, export via
|
||||
tab seperated ascii files to popular databases and spreadsheets,
|
||||
and much more. Supports standard CLF and combined logs, as well
|
||||
as wu-ftpd xferlog and squid proxy logs, which can be either in
|
||||
standard text format or gzip compressed.
|
||||
|
||||
Keywords: Web Analysis, Log Analysis, Usage Statistics, Linux, Unix
|
||||
Author: Bradford L. Barrett
|
||||
Maintained-by: Bradford L. Barrett
|
||||
WWW: http://www.mrunix.net/webalizer/
|
||||
Alternate-site:http://samhain.unix.cslab.tuwien.ac.at/webalizer/
|
||||
FTP: ftp://www.mrunix.net/pub/webalizer/
|
||||
Platforms: Linux, SCO, other UNIX's
|
||||
Copying-policy: GPL
|
@ -1,17 +0,0 @@
|
||||
bin/webalizer
|
||||
@exec ln -sf %f %B/webazolver
|
||||
@unexec rm -f %B/webazolver
|
||||
etc/webalizer.conf-dist
|
||||
share/doc/webalizer/CHANGES
|
||||
share/doc/webalizer/COPYING
|
||||
share/doc/webalizer/Copyright
|
||||
share/doc/webalizer/INSTALL
|
||||
share/doc/webalizer/DNS.README
|
||||
share/doc/webalizer/README
|
||||
share/doc/webalizer/README.FIRST
|
||||
share/doc/webalizer/country-codes.txt
|
||||
@dirrm share/doc/webalizer
|
||||
share/examples/webalizer/msfree.png
|
||||
share/examples/webalizer/sample.conf
|
||||
share/examples/webalizer/webalizer.png
|
||||
@dirrm share/examples/webalizer
|
Loading…
Reference in New Issue
Block a user