Update to 2012-04-25
This commit is contained in:
parent
7cd1f746f8
commit
280ccec97b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=295505
@ -6,8 +6,8 @@
|
||||
#
|
||||
|
||||
PORTNAME= ffmpeg
|
||||
DISTVERSION= 2012-01-22
|
||||
PORTREVISION= 3
|
||||
DISTVERSION= 2012-04-25
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= multimedia audio ipv6 net
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= mm/ffmpeg
|
||||
@ -24,7 +24,7 @@ CONFLICTS= ffmpeg-0.*
|
||||
|
||||
LATEST_LINK= ffmpeg-devel
|
||||
|
||||
GIT_SNAPSHOT= b4ec645f471faa5142ce492e39c7527eddda46de
|
||||
GIT_SNAPSHOT= 8f899545502c287653223ca27522c4abcd3a2e91
|
||||
GIT_SUFFIX= ${GIT_SNAPSHOT:C/^(.......).*$/\1/g}
|
||||
|
||||
USE_XZ= yes
|
||||
@ -41,7 +41,6 @@ OPTIONS= AACPLUS "Enable aac via libaacplus" off \
|
||||
ASS "Subtitles rendering via libass" off \
|
||||
CDIO "Audio CD grabbing with libcdio" off \
|
||||
CELT "Enable CELT/Opus decoding via libcelt" off \
|
||||
DIRAC "Dirac codec via libdirac" off \
|
||||
FAAC "FAAC mp4/aac audio encoder" off \
|
||||
FFSERVER "Build and install ffserver" on \
|
||||
FREETYPE "Text on top of video frames (freetype2)" on \
|
||||
@ -71,7 +70,6 @@ OPTIONS= AACPLUS "Enable aac via libaacplus" off \
|
||||
XVID "Xvid encoder via xvidcore" on
|
||||
|
||||
COMPAT_HEADERS=libavcodec/avcodec.h \
|
||||
libavcodec/opt.h \
|
||||
libavcodec/vdpau.h \
|
||||
libavcodec/xvmc.h \
|
||||
libavdevice/avdevice.h \
|
||||
@ -113,7 +111,6 @@ CONFIGURE_ARGS+=--prefix="${PREFIX}" \
|
||||
--enable-shared \
|
||||
--enable-gpl \
|
||||
--enable-postproc \
|
||||
--enable-avconv \
|
||||
--enable-avfilter \
|
||||
--enable-pthreads \
|
||||
--enable-x11grab \
|
||||
@ -162,7 +159,7 @@ FFMPEG_CFLAGS+= -msse
|
||||
# PORTDOCS
|
||||
.if !defined(NOPORTDOCS)
|
||||
BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
|
||||
MAN1+= avconv.1 ffmpeg.1 ffprobe.1
|
||||
MAN1+= ffmpeg.1 ffprobe.1
|
||||
.endif
|
||||
|
||||
# optimizations
|
||||
@ -229,14 +226,6 @@ CONFIGURE_ARGS+= --enable-libcelt
|
||||
CONFIGURE_ARGS+= --disable-libcelt
|
||||
.endif
|
||||
|
||||
# dirac
|
||||
.if defined(WITH_DIRAC)
|
||||
LIB_DEPENDS+= dirac_encoder.1:${PORTSDIR}/multimedia/dirac
|
||||
CONFIGURE_ARGS+= --enable-libdirac
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-libdirac
|
||||
.endif
|
||||
|
||||
# faac
|
||||
.if defined(WITH_FAAC)
|
||||
FFMPEG_NONFREE= yes
|
||||
@ -435,7 +424,7 @@ CONFIGURE_ARGS+= --disable-libvpx
|
||||
|
||||
# x264
|
||||
.if !defined(WITHOUT_X264)
|
||||
LIB_DEPENDS+= x264.119:${PORTSDIR}/multimedia/x264
|
||||
LIB_DEPENDS+= x264.123:${PORTSDIR}/multimedia/x264
|
||||
CONFIGURE_ARGS+= --enable-libx264
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-libx264
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (ffmpeg-HEAD-b4ec645.tar.xz) = 27031646723a47de1ceb44c98b807a0158ea5b97745b08728166ec6866bfb304
|
||||
SIZE (ffmpeg-HEAD-b4ec645.tar.xz) = 4270676
|
||||
SHA256 (ffmpeg-HEAD-8f89954.tar.xz) = 449df98678488a8f8e827dc0c5d4692fc3f23165c665bca059f9f9f3ca0087c4
|
||||
SIZE (ffmpeg-HEAD-8f89954.tar.xz) = 4895512
|
||||
|
@ -1,19 +1,11 @@
|
||||
--- libavcodec/Makefile.orig 2011-10-10 09:57:41.000000000 +0200
|
||||
+++ libavcodec/Makefile 2011-10-10 10:19:10.382958515 +0200
|
||||
@@ -686,14 +686,14 @@
|
||||
# well.
|
||||
OBJS-$(!CONFIG_SMALL) += inverse.o
|
||||
|
||||
--include $(SRC_PATH)/$(SUBDIR)$(ARCH)/Makefile
|
||||
+-include $(SRC_PATH)/$(SUBDIR)$(FFMPEG_ARCH)/Makefile
|
||||
|
||||
SKIPHEADERS += %_tablegen.h \
|
||||
%_tables.h \
|
||||
--- libavcodec/Makefile.orig 2012-04-24 23:45:09.000000000 +0200
|
||||
+++ libavcodec/Makefile 2012-04-25 11:22:11.486007377 +0200
|
||||
@@ -750,7 +750,7 @@
|
||||
aac_tablegen_decl.h \
|
||||
fft-internal.h \
|
||||
tableprint.h \
|
||||
- $(ARCH)/vp56_arith.h
|
||||
+ $(FFMPEG_ARCH)/vp56_arith.h
|
||||
SKIPHEADERS-$(CONFIG_DXVA2) += dxva2.h dxva2_internal.h
|
||||
SKIPHEADERS-$(CONFIG_LIBDIRAC) += libdirac.h
|
||||
SKIPHEADERS-$(CONFIG_LIBSCHROEDINGER) += libschroedinger.h
|
||||
SKIPHEADERS-$(CONFIG_MPEG_XVMC_DECODER) += xvmc.h
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- libavfilter/Makefile.orig 2011-10-10 09:57:41.000000000 +0200
|
||||
+++ libavfilter/Makefile 2011-10-10 10:20:17.318954919 +0200
|
||||
@@ -148,7 +148,7 @@
|
||||
OBJS-$(CONFIG_MP_FILTER) += libmpcodecs/pullup.o
|
||||
|
||||
|
||||
--include $(SRC_PATH)/$(SUBDIR)$(ARCH)/Makefile
|
||||
+-include $(SRC_PATH)/$(SUBDIR)$(FFMPEG_ARCH)/Makefile
|
||||
|
||||
DIRS = x86 libmpcodecs
|
||||
|
@ -1,4 +1,3 @@
|
||||
bin/avconv
|
||||
bin/ffmpeg
|
||||
bin/ffprobe
|
||||
%%FFSERVER%%bin/ffserver
|
||||
@ -23,7 +22,6 @@ include/ffmpeg/lzo.h
|
||||
include/ffmpeg/mathematics.h
|
||||
include/ffmpeg/md5.h
|
||||
include/ffmpeg/mem.h
|
||||
include/ffmpeg/opt.h
|
||||
include/ffmpeg/pixfmt.h
|
||||
include/ffmpeg/postprocess.h
|
||||
include/ffmpeg/rational.h
|
||||
@ -33,13 +31,13 @@ include/ffmpeg/xvmc.h
|
||||
include/libavcodec/avcodec.h
|
||||
include/libavcodec/avfft.h
|
||||
include/libavcodec/dxva2.h
|
||||
include/libavcodec/opt.h
|
||||
include/libavcodec/vaapi.h
|
||||
include/libavcodec/vda.h
|
||||
include/libavcodec/vdpau.h
|
||||
include/libavcodec/version.h
|
||||
include/libavcodec/xvmc.h
|
||||
include/libavdevice/avdevice.h
|
||||
include/libavfilter/asrc_abuffer.h
|
||||
include/libavfilter/avcodec.h
|
||||
include/libavfilter/avfilter.h
|
||||
include/libavfilter/avfiltergraph.h
|
||||
@ -53,11 +51,13 @@ include/libavutil/adler32.h
|
||||
include/libavutil/aes.h
|
||||
include/libavutil/attributes.h
|
||||
include/libavutil/audioconvert.h
|
||||
include/libavutil/audio_fifo.h
|
||||
include/libavutil/avassert.h
|
||||
include/libavutil/avconfig.h
|
||||
include/libavutil/avstring.h
|
||||
include/libavutil/avutil.h
|
||||
include/libavutil/base64.h
|
||||
include/libavutil/bprint.h
|
||||
include/libavutil/bswap.h
|
||||
include/libavutil/common.h
|
||||
include/libavutil/cpu.h
|
||||
@ -67,6 +67,7 @@ include/libavutil/error.h
|
||||
include/libavutil/eval.h
|
||||
include/libavutil/fifo.h
|
||||
include/libavutil/file.h
|
||||
include/libavutil/intfloat.h
|
||||
include/libavutil/intfloat_readwrite.h
|
||||
include/libavutil/imgutils.h
|
||||
include/libavutil/intreadwrite.h
|
||||
@ -84,6 +85,8 @@ include/libavutil/random_seed.h
|
||||
include/libavutil/rational.h
|
||||
include/libavutil/samplefmt.h
|
||||
include/libavutil/sha.h
|
||||
include/libavutil/timecode.h
|
||||
include/libavutil/timestamp.h
|
||||
include/libpostproc/postprocess.h
|
||||
include/libswresample/swresample.h
|
||||
include/libswscale/swscale.h
|
||||
@ -91,7 +94,7 @@ include/postproc/postprocess.h
|
||||
lib/libavcodec.a
|
||||
lib/libavcodec.so
|
||||
lib/libavcodec.so.1
|
||||
lib/libavcodec.so.53.57.105
|
||||
lib/libavcodec.so.54.15.100
|
||||
lib/libavdevice.a
|
||||
lib/libavdevice.so
|
||||
lib/libavdevice.so.1
|
||||
@ -99,22 +102,22 @@ lib/libavdevice.so.53.4.100
|
||||
lib/libavfilter.a
|
||||
lib/libavfilter.so
|
||||
lib/libavfilter.so.1
|
||||
lib/libavfilter.so.2.59.101
|
||||
lib/libavfilter.so.2.72.100
|
||||
lib/libavformat.a
|
||||
lib/libavformat.so
|
||||
lib/libavformat.so.1
|
||||
lib/libavformat.so.53.30.100
|
||||
lib/libavformat.so.54.3.100
|
||||
lib/libavutil.a
|
||||
lib/libavutil.so
|
||||
lib/libavutil.so.1
|
||||
lib/libavutil.so.51.34.101
|
||||
lib/libavutil.so.51.47.100
|
||||
lib/libpostproc.a
|
||||
lib/libpostproc.so
|
||||
lib/libpostproc.so.1
|
||||
lib/libpostproc.so.52.0.100
|
||||
lib/libswresample.a
|
||||
lib/libswresample.so
|
||||
lib/libswresample.so.0.6.100
|
||||
lib/libswresample.so.0.11.100
|
||||
lib/libswresample.so.1
|
||||
lib/libswscale.a
|
||||
lib/libswscale.so
|
||||
|
Loading…
Reference in New Issue
Block a user