This port needs USES=c++11-lang. Additionally, it unconditionally uses

libc++ if it's compiled on FreeBSD, so fix that too.

PR:		231714
Submitted by:	Piotr Kubaj
Approved by:	portmgr (tier-2 blanket)
This commit is contained in:
Mark Linimon 2018-11-02 15:12:08 +00:00
parent c4a1423577
commit 27bc72f6d1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=483815
2 changed files with 21 additions and 5 deletions

View File

@ -13,12 +13,10 @@ COMMENT= Straightforward binding of libsass for Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_powerpc64= fails to compile: cc1plus: error: unrecognized command line option -std=c++0x
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
LIB_DEPENDS= libsass.so:textproc/libsass
USES= localbase python
USES= compiler:c++11-lang localbase python
USE_PYTHON= autoplist distutils
MAKE_ENV= SYSTEM_SASS=1

View File

@ -1,11 +1,29 @@
--- setup.py.orig 2017-11-16 05:28:26 UTC
--- setup.py.orig 2018-09-16 19:57:43 UTC
+++ setup.py
@@ -37,7 +37,7 @@ def _maybe_clang(flags):
compiler.linker_so[0] = os.environ['CXX']
return compiler
distutils.sysconfig.customize_compiler = customize_compiler
- flags[:] = ['-c', '-O3'] + flags + ['-stdlib=libc++']
+ flags[:] = ['-c'] + flags + ['-stdlib=libc++']
+ flags[:] = ['-c'] + flags
def _maybe_macos(flags):
@@ -59,7 +59,7 @@ if system_sass:
_maybe_macos(flags)
if platform.system() == 'FreeBSD':
- link_flags = ['-fPIC', '-lc++']
+ link_flags = ['-fPIC']
else:
link_flags = ['-fPIC', '-lstdc++']
libraries = ['sass']
@@ -173,7 +173,7 @@ else:
f.write(cencode_body)
if platform.system() == 'FreeBSD':
- link_flags = ['-fPIC', '-lc++']
+ link_flags = ['-fPIC']
else:
link_flags = ['-fPIC', '-lstdc++']