math/cryptominisat and math/py-cryptominisat: Update to 5.6.1.
Reviewed by: mat Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D15735
This commit is contained in:
parent
1cbdeda5a7
commit
2787ef7869
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=472633
@ -1,28 +1,28 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= cryptominisat
|
||||
PORTVERSION= 5.0.1
|
||||
PORTREVISION= 9
|
||||
DISTVERSION= 5.6.1
|
||||
CATEGORIES= math
|
||||
|
||||
MAINTAINER= 6yearold@gmail.com
|
||||
MAINTAINER= arrowd@FreeBSD.org
|
||||
COMMENT= General-purpose award-winning SAT solver
|
||||
|
||||
LICENSE= MIT LGPL21
|
||||
LICENSE_COMB= multi
|
||||
LICENSE_FILE_LGPL21= ${WRKSRC}/LICENSE-SCALMC
|
||||
|
||||
BUILD_DEPENDS= xxd:editors/vim-console # for xxd tool
|
||||
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
|
||||
LICENSE_FILE_LGPL21= ${WRKSRC}/LICENSE.txt
|
||||
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
BROKEN_powerpc64= fails to compile: main.cpp: undefined reference to boost::program_options::abstract_variables_map::operator[]
|
||||
|
||||
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
|
||||
|
||||
USES= cmake:outsource compiler:c++11-lib
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= msoos
|
||||
|
||||
USES= cmake compiler:c++11-lib
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
CMAKE_ARGS= -DNOM4RI=1 -DENABLE_PYTHON_INTERFACE=OFF
|
||||
CMAKE_ON= NOM4RI
|
||||
CMAKE_OFF= ENABLE_PYTHON_INTERFACE
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1473692160
|
||||
SHA256 (msoos-cryptominisat-5.0.1_GH0.tar.gz) = 789d53c90ecbd5910f48e4e1bd835e374b268e0b3872a81fd5c6178a30a5e263
|
||||
SIZE (msoos-cryptominisat-5.0.1_GH0.tar.gz) = 596710
|
||||
TIMESTAMP = 1528624412
|
||||
SHA256 (msoos-cryptominisat-5.6.1_GH0.tar.gz) = f86c1cc94abcb9b9f9227fab2ea29f869b0b47f8dc83946e06e7d98b97cac2aa
|
||||
SIZE (msoos-cryptominisat-5.6.1_GH0.tar.gz) = 675234
|
||||
|
@ -2,9 +2,11 @@ bin/cryptominisat5
|
||||
bin/cryptominisat5_simple
|
||||
include/cryptominisat5/cryptominisat.h
|
||||
include/cryptominisat5/cryptominisat_c.h
|
||||
include/cryptominisat5/dimacsparser.h
|
||||
include/cryptominisat5/solvertypesmini.h
|
||||
include/cryptominisat5/streambuffer.h
|
||||
lib/cmake/cryptominisat5/cryptominisat5Config.cmake
|
||||
lib/cmake/cryptominisat5/cryptominisat5Targets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
lib/cmake/cryptominisat5/cryptominisat5Targets.cmake
|
||||
lib/libcryptominisat5.so
|
||||
lib/libcryptominisat5.so.5.0
|
||||
lib/libcryptominisat5.so.5.6
|
||||
|
@ -1,20 +1,21 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= cryptominisat
|
||||
PORTVERSION= 5.0.0
|
||||
PORTREVISION= 2
|
||||
DISTVERSION= 5.6.1
|
||||
CATEGORIES= math python
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= 6yearold@gmail.com
|
||||
MAINTAINER= arrowd@FreeBSD.org
|
||||
COMMENT= Bindings to CryptoMiniSat (a SAT solver)
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
LICENSE= MIT LGPL21
|
||||
LICENSE_COMB= multi
|
||||
LICENSE_FILE_LGPL21= ${WRKSRC}/../LICENSE.txt
|
||||
LICENSE_FILE_MIT= ${WRKSRC}/../LICENSE.txt
|
||||
|
||||
LIB_DEPENDS= libcryptominisat5.so:math/cryptominisat
|
||||
|
||||
USES= compiler:c++11-lib python:-2.7
|
||||
USES= compiler:c++11-lib python
|
||||
USE_PYTHON= autoplist distutils
|
||||
USE_GITHUB= yes
|
||||
|
||||
@ -25,7 +26,12 @@ WRKSRC_SUBDIR= python
|
||||
PYDISTUTILS_BUILDTARGET= build_ext --include-dirs=${LOCALBASE}/include
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|@PROJECT_VERSION@|${PORTVERSION}|' ${WRKSRC}/setup.py.in
|
||||
${REINPLACE_CMD} -e 's|@PROJECT_VERSION@|${PORTVERSION}|' \
|
||||
-e 's|$${CMAKE_C_COMPILER}|${CC}|' \
|
||||
-e 's|$${CMAKE_CXX_COMPILER}|${CXX}|' \
|
||||
-e 's|$${PY_C_CONFIG}||' \
|
||||
-e 's|$${PY_LD_CONFIG}||' \
|
||||
-e 's|$${APPLE}||' ${WRKSRC}/setup.py.in
|
||||
${CP} ${WRKSRC}/setup.py.in ${WRKSRC}/setup.py
|
||||
|
||||
post-install:
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1469896511
|
||||
SHA256 (msoos-cryptominisat-5.0.0_GH0.tar.gz) = 4c000daf9886e7c55f05b00247688ed0341a19cda13de49e2f35f40e95cc9910
|
||||
SIZE (msoos-cryptominisat-5.0.0_GH0.tar.gz) = 596712
|
||||
TIMESTAMP = 1528628948
|
||||
SHA256 (msoos-cryptominisat-5.6.1_GH0.tar.gz) = f86c1cc94abcb9b9f9227fab2ea29f869b0b47f8dc83946e06e7d98b97cac2aa
|
||||
SIZE (msoos-cryptominisat-5.6.1_GH0.tar.gz) = 675234
|
||||
|
@ -1,38 +1,27 @@
|
||||
--- setup.py.in.orig 2016-07-06 12:22:54 UTC
|
||||
--- setup.py.in.orig 2018-06-05 06:06:54 UTC
|
||||
+++ setup.py.in
|
||||
@@ -26,9 +26,9 @@ import sys
|
||||
from distutils.core import setup, Extension
|
||||
from distutils import sysconfig
|
||||
@@ -119,12 +119,12 @@ if platform.system() == 'Darwin':
|
||||
|
||||
-cconf = """${PY_C_CONFIG}""".split(" ")
|
||||
-ldconf = """${PY_LD_CONFIG}""".split(" ")
|
||||
-is_apple = """${APPLE}"""
|
||||
+cconf = """""".split(" ")
|
||||
+ldconf = """""".split(" ")
|
||||
+is_apple = """"""
|
||||
|
||||
def cleanup(dat):
|
||||
ret = []
|
||||
@@ -81,12 +81,12 @@ __version__ = '@PROJECT_VERSION@'
|
||||
|
||||
ext_kwds = dict(
|
||||
modules = dict(
|
||||
name = "pycryptosat",
|
||||
- sources = ["${CMAKE_CURRENT_SOURCE_DIR}/pycryptosat.cpp"],
|
||||
+ sources = ["pycryptosat.cpp"],
|
||||
define_macros = [],
|
||||
- sources = ["${CMAKE_CURRENT_SOURCE_DIR}/src/pycryptosat.cpp"],
|
||||
+ sources = ["src/pycryptosat.cpp"],
|
||||
define_macros = [('LIBRARY_VERSION', '"' + __LIBRARY_VERSION__ + '"')],
|
||||
- extra_compile_args = cconf + ['-I${PROJECT_SOURCE_DIR}', '-I${PROJECT_BINARY_DIR}/cmsat5-src'],
|
||||
+ extra_compile_args = cconf + ['-I/usr/local/include', '-I../cmsat5-src'],
|
||||
extra_link_args = ldconf,
|
||||
extra_link_args = extra_link_args,
|
||||
language = "c++",
|
||||
- library_dirs=['.', '${PROJECT_BINARY_DIR}/lib'],
|
||||
+ library_dirs=['.', '/usr/local/lib'],
|
||||
runtime_library_dirs=['${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}'],
|
||||
libraries = ['cryptominisat5']
|
||||
)
|
||||
|
||||
@@ -111,5 +111,5 @@ setup(
|
||||
ext_modules = [Extension(**ext_kwds)],
|
||||
py_modules = ['pycryptosat'],
|
||||
description = "bindings to CryptoMiniSat (a SAT solver)",
|
||||
@@ -150,7 +150,7 @@ setup(
|
||||
description = "Bindings to CryptoMiniSat {} (a SAT solver)".\
|
||||
format(__LIBRARY_VERSION__),
|
||||
# py_modules = ['pycryptosat'],
|
||||
- long_description = open('${CMAKE_CURRENT_SOURCE_DIR}/README.rst').read(),
|
||||
+ long_description = open('README.rst').read(),
|
||||
)
|
||||
cmdclass={
|
||||
'test': TestCommand
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user