- Update to version 0.9.13

PR:		56281
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2003-09-01 18:05:44 +00:00
parent 2f7aa75c57
commit 276df8b742
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=88296
8 changed files with 48 additions and 150 deletions

View File

@ -7,7 +7,7 @@
#
PORTNAME= redland
PORTVERSION= 0.9.12
PORTVERSION= 0.9.13
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.redland.opensource.ac.uk/dist/source/
@ -17,28 +17,33 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A high-level interface for RDF
LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2 \
expat.4:${PORTSDIR}/textproc/expat2 \
xml2.5:${PORTSDIR}/textproc/libxml2 \
xmlparse.1:${PORTSDIR}/www/libwww
LIBWWW_CONFIG?= ${LOCALBASE}/bin/libwww-config
raptor.0:${PORTSDIR}/textproc/raptor
USE_OPENSSL= yes
USE_PERL5= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -I${LOCALBASE}/include"
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-bdb=${LOCALBASE} --with-libwww
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-bdb-lib="${LOCALBASE}/lib" \
--with-bdb-include="${LOCALBASE}/include/db2" \
--with-bdb-dbname="db2" \
--with-libwww
INSTALLS_SHLIB= yes
MAN1= rapper.1
MAN3= libraptor.3 redland.3
MAN1= redland-config.1 redland-db-upgrade.1
MAN3= redland.3
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
's|\@INSTALL\@|/usr/bin/install -c|g ; \
s|^CPPFLAGS = -I|CPPFLAGS = \@CPPFLAGS\@ -I|g ; \
s|^LDFLAGS = \@LIBRDF_|LDFLAGS = \@LDFLAGS\@ \@LIBRDF_|g ; \
s|^LIBS = \@LIBRDF_|LIBS = \@LIBS\@ \@LIBRDF_|g'
@${REINPLACE_CMD} -e 's|ac_subdirs_all raptor|ac_subdirs_all|g ; \
s|-I\\$$(top_srcdir)/raptor||g ; \
s|\\$$(top_builddir)/raptor/libraptor.la|-lraptor|g' \
${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|SUBDIRS = raptor|SUBDIRS =|g ; \
s|$$(top_builddir)/raptor/libraptor.la|-lraptor|g'
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (redland-0.9.12.tar.gz) = 545ffc5e1da2e240392b0dbe32afa821
MD5 (redland-0.9.13.tar.gz) = 090d3da7a8a063c5292243637e4719b9

View File

@ -1,50 +0,0 @@
--- configure.orig Thu Feb 13 11:00:47 2003
+++ configure Fri Apr 18 21:32:50 2003
@@ -6626,9 +6626,9 @@
fi
-CPPFLAGS="$LIBRDF_CPPFLAGS"
-LDFLAGS="$LIBRDF_LDFLAGS"
-LIBS="$LIBRDF_LIBS"
+CPPFLAGS="$LIBRDF_CPPFLAGS $CPPFLAGS"
+LDFLAGS="$LIBRDF_LDFLAGS $LDFLAGS"
+LIBS="$LIBRDF_LIBS $LIBS"
if test "$have_libdb" != yes; then
@@ -7294,9 +7294,9 @@
echo "$ac_t""no" 1>&6
fi
-CPPFLAGS="$LIBRDF_CPPFLAGS"
-LDFLAGS="$LIBRDF_LDFLAGS"
-LIBS="$LIBRDF_LIBS"
+CPPFLAGS="$LIBRDF_CPPFLAGS $CPPFLAGS"
+LDFLAGS="$LIBRDF_LDFLAGS $LDFLAGS"
+LIBS="$LIBRDF_LIBS $LIBS"
@@ -7730,7 +7730,7 @@
have_libxml=0
fi
- CPPFLAGS="$LIBRDF_CPPFLAGS"
+ CPPFLAGS="$LIBRDF_CPPFLAGS $CPPFLAGS"
else
echo "$ac_t""no" 1>&6
@@ -8328,9 +8328,9 @@
CFLAGS="$MAINTAINER_CFLAGS $CFLAGS"
fi
-LIBS=
-CPPFLAGS=
-LDFLAGS=
+#LIBS=
+#CPPFLAGS=
+#LDFLAGS=

View File

@ -1,10 +1,6 @@
bin/rapper
bin/raptor-config
bin/redland-config
bin/redland-db-upgrade
include/librdf.h
include/ntriples.h
include/raptor.h
include/rdf_concepts.h
include/rdf_digest.h
include/rdf_files.h
@ -16,6 +12,7 @@ include/rdf_init.h
include/rdf_iterator.h
include/rdf_list.h
include/rdf_model.h
include/rdf_model_storage.h
include/rdf_node.h
include/rdf_parser.h
include/rdf_query.h
@ -30,9 +27,6 @@ include/rdf_types.h
include/rdf_uri.h
include/rdf_utf8.h
include/redland.h
lib/libraptor.a
lib/libraptor.so
lib/libraptor.so.0
lib/librdf.a
lib/librdf.so
lib/librdf.so.0

View File

@ -7,7 +7,7 @@
#
PORTNAME= redland
PORTVERSION= 0.9.12
PORTVERSION= 0.9.13
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.redland.opensource.ac.uk/dist/source/
@ -17,28 +17,33 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A high-level interface for RDF
LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2 \
expat.4:${PORTSDIR}/textproc/expat2 \
xml2.5:${PORTSDIR}/textproc/libxml2 \
xmlparse.1:${PORTSDIR}/www/libwww
LIBWWW_CONFIG?= ${LOCALBASE}/bin/libwww-config
raptor.0:${PORTSDIR}/textproc/raptor
USE_OPENSSL= yes
USE_PERL5= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -I${LOCALBASE}/include"
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-bdb=${LOCALBASE} --with-libwww
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-bdb-lib="${LOCALBASE}/lib" \
--with-bdb-include="${LOCALBASE}/include/db2" \
--with-bdb-dbname="db2" \
--with-libwww
INSTALLS_SHLIB= yes
MAN1= rapper.1
MAN3= libraptor.3 redland.3
MAN1= redland-config.1 redland-db-upgrade.1
MAN3= redland.3
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
's|\@INSTALL\@|/usr/bin/install -c|g ; \
s|^CPPFLAGS = -I|CPPFLAGS = \@CPPFLAGS\@ -I|g ; \
s|^LDFLAGS = \@LIBRDF_|LDFLAGS = \@LDFLAGS\@ \@LIBRDF_|g ; \
s|^LIBS = \@LIBRDF_|LIBS = \@LIBS\@ \@LIBRDF_|g'
@${REINPLACE_CMD} -e 's|ac_subdirs_all raptor|ac_subdirs_all|g ; \
s|-I\\$$(top_srcdir)/raptor||g ; \
s|\\$$(top_builddir)/raptor/libraptor.la|-lraptor|g' \
${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|SUBDIRS = raptor|SUBDIRS =|g ; \
s|$$(top_builddir)/raptor/libraptor.la|-lraptor|g'
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (redland-0.9.12.tar.gz) = 545ffc5e1da2e240392b0dbe32afa821
MD5 (redland-0.9.13.tar.gz) = 090d3da7a8a063c5292243637e4719b9

View File

@ -1,50 +0,0 @@
--- configure.orig Thu Feb 13 11:00:47 2003
+++ configure Fri Apr 18 21:32:50 2003
@@ -6626,9 +6626,9 @@
fi
-CPPFLAGS="$LIBRDF_CPPFLAGS"
-LDFLAGS="$LIBRDF_LDFLAGS"
-LIBS="$LIBRDF_LIBS"
+CPPFLAGS="$LIBRDF_CPPFLAGS $CPPFLAGS"
+LDFLAGS="$LIBRDF_LDFLAGS $LDFLAGS"
+LIBS="$LIBRDF_LIBS $LIBS"
if test "$have_libdb" != yes; then
@@ -7294,9 +7294,9 @@
echo "$ac_t""no" 1>&6
fi
-CPPFLAGS="$LIBRDF_CPPFLAGS"
-LDFLAGS="$LIBRDF_LDFLAGS"
-LIBS="$LIBRDF_LIBS"
+CPPFLAGS="$LIBRDF_CPPFLAGS $CPPFLAGS"
+LDFLAGS="$LIBRDF_LDFLAGS $LDFLAGS"
+LIBS="$LIBRDF_LIBS $LIBS"
@@ -7730,7 +7730,7 @@
have_libxml=0
fi
- CPPFLAGS="$LIBRDF_CPPFLAGS"
+ CPPFLAGS="$LIBRDF_CPPFLAGS $CPPFLAGS"
else
echo "$ac_t""no" 1>&6
@@ -8328,9 +8328,9 @@
CFLAGS="$MAINTAINER_CFLAGS $CFLAGS"
fi
-LIBS=
-CPPFLAGS=
-LDFLAGS=
+#LIBS=
+#CPPFLAGS=
+#LDFLAGS=

View File

@ -1,10 +1,6 @@
bin/rapper
bin/raptor-config
bin/redland-config
bin/redland-db-upgrade
include/librdf.h
include/ntriples.h
include/raptor.h
include/rdf_concepts.h
include/rdf_digest.h
include/rdf_files.h
@ -16,6 +12,7 @@ include/rdf_init.h
include/rdf_iterator.h
include/rdf_list.h
include/rdf_model.h
include/rdf_model_storage.h
include/rdf_node.h
include/rdf_parser.h
include/rdf_query.h
@ -30,9 +27,6 @@ include/rdf_types.h
include/rdf_uri.h
include/rdf_utf8.h
include/redland.h
lib/libraptor.a
lib/libraptor.so
lib/libraptor.so.0
lib/librdf.a
lib/librdf.so
lib/librdf.so.0