multimedia/libaacs: update 0.9.0 -> 0.11.0
- Update MASTER_SITES - Clean up Makefile PR: 250985 Submitted by: daniel.engberg.lists@pyret.net Relnotes: https://code.videolan.org/videolan/libaacs/-/blob/master/ChangeLog
This commit is contained in:
parent
197b4335e7
commit
26fcbbca38
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559839
@ -2,10 +2,9 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libaacs
|
||||
DISTVERSION= 0.9.0
|
||||
DISTVERSION= 0.11.0
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= ftp://ftp.videolan.org/pub/videolan/${PORTNAME}/${PORTVERSION}/ \
|
||||
http://blu.opsec.eu/
|
||||
MASTER_SITES= https://downloads.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION}/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Advanced Access Content System implementation
|
||||
@ -17,12 +16,12 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
|
||||
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
|
||||
libgpg-error.so:security/libgpg-error
|
||||
|
||||
USES= bison gettext iconv libtool pathfix tar:bzip2
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= LEX="${LOCALBASE}/bin/flex"
|
||||
INSTALL_TARGET= install-strip
|
||||
USES= autoreconf bison libtool pathfix tar:bzip2
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
.include "${.CURDIR}/../libbluray/Makefile.include"
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-optimizations
|
||||
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1518874543
|
||||
SHA256 (libaacs-0.9.0.tar.bz2) = 47e0bdc9c9f0f6146ed7b4cc78ed1527a04a537012cf540cf5211e06a248bace
|
||||
SIZE (libaacs-0.9.0.tar.bz2) = 316323
|
||||
TIMESTAMP = 1604858889
|
||||
SHA256 (libaacs-0.11.0.tar.bz2) = 6d884381fbb659e2a565eba91e72499778635975e4b3d6fd94ab364a25965387
|
||||
SIZE (libaacs-0.11.0.tar.bz2) = 324061
|
||||
|
11
multimedia/libaacs/files/patch-Makefile.am
Normal file
11
multimedia/libaacs/files/patch-Makefile.am
Normal file
@ -0,0 +1,11 @@
|
||||
--- Makefile.am.orig 2020-11-08 18:35:24 UTC
|
||||
+++ Makefile.am
|
||||
@@ -7,7 +7,7 @@ SET_INCLUDES = -I$(top_srcdir)/src -I$(top_builddir)/s
|
||||
|
||||
AM_CFLAGS = -std=c99 $(LIBGCRYPT_CFLAGS) $(GPG_ERROR_CFLAGS)
|
||||
AM_CPPFLAGS = $(SET_FEATURES) $(SET_INCLUDES)
|
||||
-AM_YFLAGS = -d -p libaacs_yy
|
||||
+AM_YFLAGS = -d -p libaacs_yy -Wno-yacc
|
||||
|
||||
lib_LTLIBRARIES = libaacs.la
|
||||
libaacs_la_SOURCES=\
|
10
multimedia/libaacs/files/patch-src_devtools_mkb__dump.c
Normal file
10
multimedia/libaacs/files/patch-src_devtools_mkb__dump.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- src/devtools/mkb_dump.c.orig 2020-11-08 18:24:41 UTC
|
||||
+++ src/devtools/mkb_dump.c
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
#include <inttypes.h>
|
||||
+#include <sys/types.h>
|
||||
|
||||
#include "read_file.h"
|
||||
|
10
multimedia/libaacs/files/patch-src_devtools_uk__dump.c
Normal file
10
multimedia/libaacs/files/patch-src_devtools_uk__dump.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- src/devtools/uk_dump.c.orig 2020-11-08 18:23:30 UTC
|
||||
+++ src/devtools/uk_dump.c
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <sys/types.h>
|
||||
|
||||
#include "read_file.h"
|
||||
|
@ -5,5 +5,5 @@ include/libaacs/filesystem.h
|
||||
lib/libaacs.a
|
||||
lib/libaacs.so
|
||||
lib/libaacs.so.0
|
||||
lib/libaacs.so.0.6.0
|
||||
lib/libaacs.so.0.7.1
|
||||
libdata/pkgconfig/libaacs.pc
|
||||
|
Loading…
Reference in New Issue
Block a user