misc/lbann: New port: Livermore Big Artificial Neural Network toolkit

This commit is contained in:
Yuri Victorovich 2022-12-05 21:43:32 -08:00
parent 4b1102b116
commit 26f7cf9a83
7 changed files with 640 additions and 0 deletions

View File

@ -206,6 +206,7 @@
SUBDIR += lastools
SUBDIR += latex-mk
SUBDIR += lazyread
SUBDIR += lbann
SUBDIR += lc
SUBDIR += lesspipe
SUBDIR += lf

56
misc/lbann/Makefile Normal file
View File

@ -0,0 +1,56 @@
PORTNAME= lbann
DISTVERSIONPREFIX= v
DISTVERSION= 0.102-254
DISTVERSIONSUFFIX= -g2e3012a9a
CATEGORIES= misc # machine-learning
MAINTAINER= yuri@FreeBSD.org
COMMENT= Livermore Big Artificial Neural Network toolkit
WWW= https://github.com/LLNL/lbann
LICENSE= APACHE20
BUILD_DEPENDS= cereal>0:devel/cereal \
dihydrogen>0:math/dihydrogen \
zstr>0:archivers/zstr
LIB_DEPENDS= libconduit.so:science/conduit \
libhdf5.so:science/hdf5 \
libHydrogen_CXX.so:math/hydrogen \
libopenblas.so:math/openblas \
libprotobuf.so:devel/protobuf \
libsiloh5.so:science/silo
USES= cmake:testing compiler:c++17-lang localbase pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= LLNL
GH_TUPLE= KIwabuchi:havoqgt:100f63b:havoqgt/applications/graph/node2vec/havoqgt \
samadejacobs:moses:28932ce:moses/applications/ATOM/moses \
snap-stanford:snap:58a1e6a:snap/applications/graph/node2vec/snap \
catchorg:Clara:2bfd8b2:clara
CMAKE_ARGS= -DCLARA_INCLUDE_PATH=${WRKSRC_clara}/include
CMAKE_OFF= LBANN_WITH_CNPY \
LBANN_WITH_CUDNN \
LBANN_WITH_HWLOC \
LBANN_WITH_PYTHON_FRONTEND \
LBANN_WITH_EMBEDDED_PYTHON \
LBANN_WITH_VISION \
LBANN_WITH_TBINF
CMAKE_ON= LBANN_USE_PROTOBUF_MODULE
CMAKE_TESTING_ON= LBANN_WITH_UNIT_TESTING # requires MPI cluster
LDFLAGS+= -lexecinfo
OPTIONS_SINGLE= MPI
OPTIONS_SINGLE_MPI= MPICH OPENMPI
OPTIONS_DEFAULT= MPICH # should be same as in conduit, hydrogen, dihydrogen
MPICH_USES= mpi:mpich
OPENMPI_USES= mpi:openmpi
post-install: # remove unnecessary files
@${RM} -r ${STAGEDIR}${PREFIX}/share/doc
.include <bsd.port.mk>

11
misc/lbann/distinfo Normal file
View File

@ -0,0 +1,11 @@
TIMESTAMP = 1669925855
SHA256 (LLNL-lbann-v0.102-254-g2e3012a9a_GH0.tar.gz) = e2a956216207fd745ed4eed0bfe763c5807ad4ab1d27417d6678738d07c2db35
SIZE (LLNL-lbann-v0.102-254-g2e3012a9a_GH0.tar.gz) = 7973922
SHA256 (KIwabuchi-havoqgt-100f63b_GH0.tar.gz) = 5f1c1bc00606ae9b7bd17e06ba89f6201e4d60b68860473b2453f190e45a4bd2
SIZE (KIwabuchi-havoqgt-100f63b_GH0.tar.gz) = 12691923
SHA256 (samadejacobs-moses-28932ce_GH0.tar.gz) = 2ffa21181289f9eb186909afa329bcbbc5ca72a6e7312f0d66c588d0d394b395
SIZE (samadejacobs-moses-28932ce_GH0.tar.gz) = 86729395
SHA256 (snap-stanford-snap-58a1e6a_GH0.tar.gz) = 71f7f034a0fbec44aa266263f67fcc0dbdd35a1e5c4ed5b19215521d71d0184b
SIZE (snap-stanford-snap-58a1e6a_GH0.tar.gz) = 8051667
SHA256 (catchorg-Clara-2bfd8b2_GH0.tar.gz) = 679332a04a59d13517a6f56a14b70125a157e6cc7c49bb530b52521c38eef41d
SIZE (catchorg-Clara-2bfd8b2_GH0.tar.gz) = 128573

View File

@ -0,0 +1,14 @@
- workaround for the clang crash: https://github.com/llvm/llvm-project/issues/59308
- clang crashes in debug info generation
--- CMakeLists.txt.orig 2022-12-06 02:37:48 UTC
+++ CMakeLists.txt
@@ -725,7 +725,7 @@ if (LBANN_HAS_CUDA)
endif (LBANN_HAS_CUDA)
# Fix the -g issue with Clang on OSX
-if (APPLE)
+if (TRUE OR APPLE)
# Remove -g from the options
string(REPLACE "-g" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
string(REPLACE "-g" "" CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG}")

View File

@ -0,0 +1,13 @@
- https://gitlab.kitware.com/cmake/cmake/-/issues/24218
--- cmake/modules/SetupProtobuf.cmake.orig 2022-12-02 19:45:09 UTC
+++ cmake/modules/SetupProtobuf.cmake
@@ -65,7 +65,7 @@ else ()
PATH_SUFFIXES lib64/cmake/protobuf lib/cmake/protobuf
NO_DEFAULT_PATH)
if(NOT Protobuf_FOUND)
- find_package(Protobuf "${PROTOBUF_MIN_VERSION}" CONFIG QUIET REQUIRED)
+ find_package(Protobuf "${PROTOBUF_MIN_VERSION}" QUIET REQUIRED)
endif ()
message(STATUS "Found Protobuf: ${Protobuf_DIR}")
endif ()

16
misc/lbann/pkg-descr Normal file
View File

@ -0,0 +1,16 @@
The Livermore Big Artificial Neural Network toolkit (LBANN) is an open-source,
HPC-centric, deep learning training framework that is optimized to compose
multiple levels of parallelism.
LBANN provides model-parallel acceleration through domain decomposition to
optimize for strong scaling of network training. It also allows for composition
of model-parallelism with both data parallelism and ensemble training methods
for training large neural networks with massive amounts of data. LBANN is able
to advantage of tightly-coupled accelerators, low-latency high-bandwidth
networking, and high-bandwidth parallel file systems.
LBANN supports state-of-the-art training algorithms such as unsupervised,
self-supervised, and adversarial (GAN) training methods in addition to
traditional supervised learning. It also supports recurrent neural networks via
back propagation through time (BPTT) training, transfer learning, and
multi-model and ensemble training methods.

529
misc/lbann/pkg-plist Normal file
View File

@ -0,0 +1,529 @@
bin/generate_schema_and_sample_list
bin/lbann
bin/lbann-aecycgan
bin/lbann-cycgan
bin/lbann-gan
bin/lbann-help
bin/lbann-inf
etc/modulefiles/lbann/0.103.0
etc/modulefiles/lbann/0.103.0.lua
include/callbacks.pb.h
include/data_coordinator.pb.h
include/datatype.pb.h
include/layers.pb.h
include/lbann.pb.h
include/lbann/Elemental_extensions.hpp
include/lbann/base.hpp
include/lbann/callbacks/callback.hpp
include/lbann/callbacks/check_dataset.hpp
include/lbann/callbacks/check_gradients.hpp
include/lbann/callbacks/check_init.hpp
include/lbann/callbacks/check_metric.hpp
include/lbann/callbacks/check_nan.hpp
include/lbann/callbacks/check_small.hpp
include/lbann/callbacks/checkpoint.hpp
include/lbann/callbacks/compute_model_size.hpp
include/lbann/callbacks/confusion_matrix.hpp
include/lbann/callbacks/debug.hpp
include/lbann/callbacks/debug_io.hpp
include/lbann/callbacks/dump_error_signals.hpp
include/lbann/callbacks/dump_gradients.hpp
include/lbann/callbacks/dump_minibatch_sample_indices.hpp
include/lbann/callbacks/dump_model_graph.hpp
include/lbann/callbacks/dump_outputs.hpp
include/lbann/callbacks/dump_weights.hpp
include/lbann/callbacks/early_stopping.hpp
include/lbann/callbacks/export_onnx.hpp
include/lbann/callbacks/gpu_memory_usage.hpp
include/lbann/callbacks/hang.hpp
include/lbann/callbacks/imcomm.hpp
include/lbann/callbacks/learning_rate.hpp
include/lbann/callbacks/load_model.hpp
include/lbann/callbacks/ltfb.hpp
include/lbann/callbacks/mixup.hpp
include/lbann/callbacks/monitor_io.hpp
include/lbann/callbacks/perturb_adam.hpp
include/lbann/callbacks/perturb_dropout.hpp
include/lbann/callbacks/perturb_learning_rate.hpp
include/lbann/callbacks/perturb_weights.hpp
include/lbann/callbacks/print_model_description.hpp
include/lbann/callbacks/print_statistics.hpp
include/lbann/callbacks/profiler.hpp
include/lbann/callbacks/replace_weights.hpp
include/lbann/callbacks/save_images.hpp
include/lbann/callbacks/save_model.hpp
include/lbann/callbacks/save_topk_models.hpp
include/lbann/callbacks/set_weights_value.hpp
include/lbann/callbacks/summarize_images.hpp
include/lbann/callbacks/summary.hpp
include/lbann/callbacks/sync_layers.hpp
include/lbann/callbacks/timeline.hpp
include/lbann/callbacks/timer.hpp
include/lbann/callbacks/variable_minibatch.hpp
include/lbann/comm.hpp
include/lbann/comm_impl.hpp
include/lbann/data_coordinator/buffered_data_coordinator.hpp
include/lbann/data_coordinator/buffered_data_coordinator_impl.hpp
include/lbann/data_coordinator/data_coordinator.hpp
include/lbann/data_coordinator/data_coordinator_metadata.hpp
include/lbann/data_coordinator/data_packer.hpp
include/lbann/data_coordinator/io_data_buffer.hpp
include/lbann/data_coordinator/io_data_buffer_impl.hpp
include/lbann/data_readers/compound_data_reader.hpp
include/lbann/data_readers/data_reader.hpp
include/lbann/data_readers/data_reader_HDF5.hpp
include/lbann/data_readers/data_reader_cifar10.hpp
include/lbann/data_readers/data_reader_csv.hpp
include/lbann/data_readers/data_reader_hdf5_legacy.hpp
include/lbann/data_readers/data_reader_image.hpp
include/lbann/data_readers/data_reader_imagenet.hpp
include/lbann/data_readers/data_reader_jag_conduit.hpp
include/lbann/data_readers/data_reader_merge_features.hpp
include/lbann/data_readers/data_reader_merge_samples.hpp
include/lbann/data_readers/data_reader_mesh.hpp
include/lbann/data_readers/data_reader_mnist.hpp
include/lbann/data_readers/data_reader_nci.hpp
include/lbann/data_readers/data_reader_node2vec.hpp
include/lbann/data_readers/data_reader_npz_ras_lipid.hpp
include/lbann/data_readers/data_reader_numpy.hpp
include/lbann/data_readers/data_reader_numpy_npz.hpp
include/lbann/data_readers/data_reader_numpy_npz_conduit.hpp
include/lbann/data_readers/data_reader_pilot2_molecular.hpp
include/lbann/data_readers/data_reader_python.hpp
include/lbann/data_readers/data_reader_sample_list.hpp
include/lbann/data_readers/data_reader_sample_list_impl.hpp
include/lbann/data_readers/data_reader_smiles.hpp
include/lbann/data_readers/data_reader_synthetic.hpp
include/lbann/data_readers/sample_list.hpp
include/lbann/data_readers/sample_list_conduit_io_handle.hpp
include/lbann/data_readers/sample_list_hdf5.hpp
include/lbann/data_readers/sample_list_ifstream.hpp
include/lbann/data_readers/sample_list_impl.hpp
include/lbann/data_readers/sample_list_open_files.hpp
include/lbann/data_readers/sample_list_open_files_impl.hpp
include/lbann/data_readers/utils/input_data_type.hpp
include/lbann/data_store/data_store_conduit.hpp
include/lbann/detect_El_mpi.hpp
include/lbann/execution_algorithms/batch_functional_inference_algorithm.hpp
include/lbann/execution_algorithms/execution_context.hpp
include/lbann/execution_algorithms/factory.hpp
include/lbann/execution_algorithms/kfac.hpp
include/lbann/execution_algorithms/kfac/execution_context.hpp
include/lbann/execution_algorithms/kfac/kfac_block.hpp
include/lbann/execution_algorithms/kfac/kfac_block_bn.hpp
include/lbann/execution_algorithms/kfac/kfac_block_fc_conv.hpp
include/lbann/execution_algorithms/kfac/kfac_block_gru.hpp
include/lbann/execution_algorithms/kfac/kfac_util.hpp
include/lbann/execution_algorithms/ltfb.hpp
include/lbann/execution_algorithms/ltfb/execution_context.hpp
include/lbann/execution_algorithms/ltfb/meta_learning_strategy.hpp
include/lbann/execution_algorithms/ltfb/mutation_strategy.hpp
include/lbann/execution_algorithms/ltfb/random_pairwise_exchange.hpp
include/lbann/execution_algorithms/ltfb/regularized_evolution.hpp
include/lbann/execution_algorithms/ltfb/termination_criteria.hpp
include/lbann/execution_algorithms/ltfb/truncation_selection_exchange.hpp
include/lbann/execution_algorithms/sgd_execution_context.hpp
include/lbann/execution_algorithms/sgd_training_algorithm.hpp
include/lbann/execution_algorithms/training_algorithm.hpp
include/lbann/io/file_io.hpp
include/lbann/io/persist.hpp
include/lbann/io/persist_impl.hpp
include/lbann/layers/activations/activation_layer_builders.hpp
include/lbann/layers/activations/elu.hpp
include/lbann/layers/activations/identity.hpp
include/lbann/layers/activations/leaky_relu.hpp
include/lbann/layers/activations/log_softmax.hpp
include/lbann/layers/activations/relu.hpp
include/lbann/layers/activations/softmax.hpp
include/lbann/layers/data_type_distconv_adapter.hpp
include/lbann/layers/data_type_layer.hpp
include/lbann/layers/distconv_adapter.hpp
include/lbann/layers/image/bilinear_resize.hpp
include/lbann/layers/image/composite_image_transformation.hpp
include/lbann/layers/image/image_layer_builders.hpp
include/lbann/layers/image/rotation.hpp
include/lbann/layers/io/input_layer.hpp
include/lbann/layers/layer.hpp
include/lbann/layers/learning/base_convolution.hpp
include/lbann/layers/learning/channelwise_fully_connected.hpp
include/lbann/layers/learning/channelwise_scale_bias.hpp
include/lbann/layers/learning/convolution.hpp
include/lbann/layers/learning/deconvolution.hpp
include/lbann/layers/learning/distconv/distconv_layers.hpp
include/lbann/layers/learning/embedding.hpp
include/lbann/layers/learning/entrywise_scale_bias.hpp
include/lbann/layers/learning/fully_connected.hpp
include/lbann/layers/learning/gru.hpp
include/lbann/layers/loss/categorical_accuracy.hpp
include/lbann/layers/loss/cross_entropy.hpp
include/lbann/layers/loss/l1_norm.hpp
include/lbann/layers/loss/l2_norm2.hpp
include/lbann/layers/loss/loss_layer_builders.hpp
include/lbann/layers/loss/mean_absolute_error.hpp
include/lbann/layers/loss/mean_squared_error.hpp
include/lbann/layers/loss/top_k_categorical_accuracy.hpp
include/lbann/layers/math/math_builders.hpp
include/lbann/layers/math/matmul.hpp
include/lbann/layers/misc/argmax.hpp
include/lbann/layers/misc/argmin.hpp
include/lbann/layers/misc/channelwise_mean.hpp
include/lbann/layers/misc/channelwise_softmax.hpp
include/lbann/layers/misc/covariance.hpp
include/lbann/layers/misc/dft_abs.hpp
include/lbann/layers/misc/dist_embedding.hpp
include/lbann/layers/misc/mini_batch_index.hpp
include/lbann/layers/misc/mini_batch_size.hpp
include/lbann/layers/misc/misc_builders.hpp
include/lbann/layers/misc/one_hot.hpp
include/lbann/layers/misc/rowwise_weights_norms.hpp
include/lbann/layers/misc/rowwise_weights_norms_impl.hpp
include/lbann/layers/misc/uniform_hash.hpp
include/lbann/layers/misc/variance.hpp
include/lbann/layers/operator_layer.hpp
include/lbann/layers/operator_layer_impl.hpp
include/lbann/layers/regularizers/batch_normalization.hpp
include/lbann/layers/regularizers/dropout.hpp
include/lbann/layers/regularizers/entrywise_batch_normalization.hpp
include/lbann/layers/regularizers/instance_norm.hpp
include/lbann/layers/regularizers/layer_norm.hpp
include/lbann/layers/regularizers/local_response_normalization.hpp
include/lbann/layers/regularizers/selu_dropout.hpp
include/lbann/layers/transform/batchwise_reduce_sum.hpp
include/lbann/layers/transform/bernoulli.hpp
include/lbann/layers/transform/categorical_random.hpp
include/lbann/layers/transform/concatenate.hpp
include/lbann/layers/transform/constant.hpp
include/lbann/layers/transform/crop.hpp
include/lbann/layers/transform/cross_grid_sum.hpp
include/lbann/layers/transform/cross_grid_sum_slice.hpp
include/lbann/layers/transform/discrete_random.hpp
include/lbann/layers/transform/dummy.hpp
include/lbann/layers/transform/evaluation.hpp
include/lbann/layers/transform/gather.hpp
include/lbann/layers/transform/gaussian.hpp
include/lbann/layers/transform/hadamard.hpp
include/lbann/layers/transform/in_top_k.hpp
include/lbann/layers/transform/permute.hpp
include/lbann/layers/transform/pooling.hpp
include/lbann/layers/transform/reduction.hpp
include/lbann/layers/transform/reshape.hpp
include/lbann/layers/transform/scatter.hpp
include/lbann/layers/transform/slice.hpp
include/lbann/layers/transform/sort.hpp
include/lbann/layers/transform/split.hpp
include/lbann/layers/transform/stop_gradient.hpp
include/lbann/layers/transform/sum.hpp
include/lbann/layers/transform/tessellate.hpp
include/lbann/layers/transform/transform_builders.hpp
include/lbann/layers/transform/uniform.hpp
include/lbann/layers/transform/unpooling.hpp
include/lbann/layers/transform/weighted_sum.hpp
include/lbann/layers/transform/weights.hpp
include/lbann/lbann.hpp
include/lbann/macros/common_cereal_registration.hpp
include/lbann/macros/instantiate.hpp
include/lbann/macros/instantiate_device.hpp
include/lbann/macros/register_class_with_cereal.hpp
include/lbann/macros/register_layer_with_cereal.hpp
include/lbann/macros/register_layer_with_cereal_data_parallel_cpu_only.hpp
include/lbann/macros/register_layer_with_cereal_data_parallel_gpu_only.hpp
include/lbann/macros/register_layer_with_cereal_data_parallel_only.hpp
include/lbann/macros/register_layer_with_cereal_gpu_only.hpp
include/lbann/macros/register_operator_with_cereal.hpp
include/lbann/macros/register_template_class_with_cereal.hpp
include/lbann/metrics/layer_metric.hpp
include/lbann/metrics/metric.hpp
include/lbann/models/model.hpp
include/lbann/objective_functions/layer_term.hpp
include/lbann/objective_functions/objective_function.hpp
include/lbann/objective_functions/objective_function_term.hpp
include/lbann/objective_functions/weight_regularization/l2.hpp
include/lbann/operators/activations/activation_builders.hpp
include/lbann/operators/activations/activation_builders_impl.hpp
include/lbann/operators/activations/activations.hpp
include/lbann/operators/builder_macros.hpp
include/lbann/operators/declare_stateless_op.hpp
include/lbann/operators/elementwise_operator.hpp
include/lbann/operators/loss/entrywise.hpp
include/lbann/operators/loss/loss_builders.hpp
include/lbann/operators/loss/loss_builders_impl.hpp
include/lbann/operators/math/abs.hpp
include/lbann/operators/math/binary.hpp
include/lbann/operators/math/binary_with_constant.hpp
include/lbann/operators/math/clamp.hpp
include/lbann/operators/math/math_builders.hpp
include/lbann/operators/math/math_builders_impl.hpp
include/lbann/operators/math/unary.hpp
include/lbann/operators/operator.hpp
include/lbann/optimizers/adagrad.hpp
include/lbann/optimizers/adagrad_impl.hpp
include/lbann/optimizers/adam.hpp
include/lbann/optimizers/adam_impl.hpp
include/lbann/optimizers/data_type_optimizer.hpp
include/lbann/optimizers/data_type_optimizer_impl.hpp
include/lbann/optimizers/hypergradient_adam.hpp
include/lbann/optimizers/hypergradient_adam_impl.hpp
include/lbann/optimizers/optimizer.hpp
include/lbann/optimizers/rmsprop.hpp
include/lbann/optimizers/rmsprop_impl.hpp
include/lbann/optimizers/sgd.hpp
include/lbann/optimizers/sgd_impl.hpp
include/lbann/proto/datatype_helpers.hpp
include/lbann/proto/factories.hpp
include/lbann/proto/init_image_data_readers.hpp
include/lbann/proto/operator_factory.hpp
include/lbann/proto/operator_factory_impl.hpp
include/lbann/proto/proto_common.hpp
include/lbann/trainers/trainer.hpp
include/lbann/transforms/normalize.hpp
include/lbann/transforms/repack_HWC_to_CHW_layout.hpp
include/lbann/transforms/sample_normalize.hpp
include/lbann/transforms/scale.hpp
include/lbann/transforms/scale_and_translate.hpp
include/lbann/transforms/transform.hpp
include/lbann/transforms/transform_pipeline.hpp
include/lbann/transforms/vision/adjust_brightness.hpp
include/lbann/transforms/vision/adjust_contrast.hpp
include/lbann/transforms/vision/adjust_saturation.hpp
include/lbann/transforms/vision/center_crop.hpp
include/lbann/transforms/vision/color_jitter.hpp
include/lbann/transforms/vision/colorize.hpp
include/lbann/transforms/vision/cutout.hpp
include/lbann/transforms/vision/grayscale.hpp
include/lbann/transforms/vision/horizontal_flip.hpp
include/lbann/transforms/vision/normalize_to_lbann_layout.hpp
include/lbann/transforms/vision/random_affine.hpp
include/lbann/transforms/vision/random_crop.hpp
include/lbann/transforms/vision/random_resized_crop.hpp
include/lbann/transforms/vision/random_resized_crop_with_fixed_aspect_ratio.hpp
include/lbann/transforms/vision/resize.hpp
include/lbann/transforms/vision/resized_center_crop.hpp
include/lbann/transforms/vision/to_lbann_layout.hpp
include/lbann/transforms/vision/vertical_flip.hpp
include/lbann/utils/accumulating_timer.hpp
include/lbann/utils/argument_parser.hpp
include/lbann/utils/beta.hpp
include/lbann/utils/cloneable.hpp
include/lbann/utils/cnpy_utils.hpp
include/lbann/utils/commify.hpp
include/lbann/utils/compiler_control.hpp
include/lbann/utils/cufft_wrapper.hpp
include/lbann/utils/cyg_profile.hpp
include/lbann/utils/dataset.hpp
include/lbann/utils/describable.hpp
include/lbann/utils/description.hpp
include/lbann/utils/dim_helpers.hpp
include/lbann/utils/distconv.hpp
include/lbann/utils/dnn_enums.hpp
include/lbann/utils/dnn_lib/convolution.hpp
include/lbann/utils/dnn_lib/cudnn.hpp
include/lbann/utils/dnn_lib/cudnn/convolution.hpp
include/lbann/utils/dnn_lib/cudnn/dropout.hpp
include/lbann/utils/dnn_lib/cudnn/local_response_normalization.hpp
include/lbann/utils/dnn_lib/cudnn/pooling.hpp
include/lbann/utils/dnn_lib/cudnn/softmax.hpp
include/lbann/utils/dnn_lib/cudnn/utils.hpp
include/lbann/utils/dnn_lib/dnn_lib.hpp
include/lbann/utils/dnn_lib/dropout.hpp
include/lbann/utils/dnn_lib/helpers.hpp
include/lbann/utils/dnn_lib/local_response_normalization.hpp
include/lbann/utils/dnn_lib/miopen.hpp
include/lbann/utils/dnn_lib/miopen/convolution.hpp
include/lbann/utils/dnn_lib/miopen/dropout.hpp
include/lbann/utils/dnn_lib/miopen/local_response_normalization.hpp
include/lbann/utils/dnn_lib/miopen/pooling.hpp
include/lbann/utils/dnn_lib/miopen/softmax.hpp
include/lbann/utils/dnn_lib/miopen/utils.hpp
include/lbann/utils/dnn_lib/onednn.hpp
include/lbann/utils/dnn_lib/onednn/softmax.hpp
include/lbann/utils/dnn_lib/openmp.hpp
include/lbann/utils/dnn_lib/openmp/softmax.hpp
include/lbann/utils/dnn_lib/pooling.hpp
include/lbann/utils/dnn_lib/softmax.hpp
include/lbann/utils/entrywise_operator.hpp
include/lbann/utils/enum_iterator.hpp
include/lbann/utils/environment_variable.hpp
include/lbann/utils/exception.hpp
include/lbann/utils/factory.hpp
include/lbann/utils/factory_error_policies.hpp
include/lbann/utils/fft_common.hpp
include/lbann/utils/fftw_wrapper.hpp
include/lbann/utils/file_utils.hpp
include/lbann/utils/from_string.hpp
include/lbann/utils/glob.hpp
include/lbann/utils/gpu/cuda.hpp
include/lbann/utils/gpu/gpu_lib.hpp
include/lbann/utils/gpu/helpers.hpp
include/lbann/utils/gpu/rocm.hpp
include/lbann/utils/gpu/sync_info_helpers.hpp
include/lbann/utils/graph.hpp
include/lbann/utils/hash.hpp
include/lbann/utils/hydrogen_utils.hpp
include/lbann/utils/im2col.hpp
include/lbann/utils/image.hpp
include/lbann/utils/impl/cuda.hpp
include/lbann/utils/impl/gpu_lib.hpp
include/lbann/utils/impl/rocm.hpp
include/lbann/utils/jag_utils.hpp
include/lbann/utils/lbann_library.hpp
include/lbann/utils/make_abstract.hpp
include/lbann/utils/memory.hpp
include/lbann/utils/mild_exception.hpp
include/lbann/utils/number_theory.hpp
include/lbann/utils/numerical_traits.hpp
include/lbann/utils/nvshmem.hpp
include/lbann/utils/omp_diagnostics.hpp
include/lbann/utils/omp_pragma.hpp
include/lbann/utils/onnx_utils.hpp
include/lbann/utils/opencv.hpp
include/lbann/utils/options.hpp
include/lbann/utils/output_helpers.hpp
include/lbann/utils/peek_map.hpp
include/lbann/utils/profiling.hpp
include/lbann/utils/protobuf.hpp
include/lbann/utils/protobuf/decl.hpp
include/lbann/utils/protobuf/impl.hpp
include/lbann/utils/protobuf_serializable.hpp
include/lbann/utils/protobuf_utils.hpp
include/lbann/utils/python.hpp
include/lbann/utils/random.hpp
include/lbann/utils/random_number_generators.hpp
include/lbann/utils/running_statistics.hpp
include/lbann/utils/serialization/cereal_utils.hpp
include/lbann/utils/serialization/rooted_archive_adaptor.hpp
include/lbann/utils/serialization/serialize_half.hpp
include/lbann/utils/serialization/serialize_matrices.hpp
include/lbann/utils/serialization/serialize_matrices_impl.hpp
include/lbann/utils/serialize.hpp
include/lbann/utils/stack_profiler.hpp
include/lbann/utils/stack_trace.hpp
include/lbann/utils/statistics.hpp
include/lbann/utils/summary.hpp
include/lbann/utils/summary_impl.hpp
include/lbann/utils/sync_info_helpers.hpp
include/lbann/utils/system_info.hpp
include/lbann/utils/tagged_dispatch.hpp
include/lbann/utils/tensor.hpp
include/lbann/utils/tensor_impl.hpp
include/lbann/utils/threads/thread_pool.hpp
include/lbann/utils/threads/thread_safe_queue.hpp
include/lbann/utils/threads/thread_topology.hpp
include/lbann/utils/threads/thread_utils.hpp
include/lbann/utils/threads/type_erased_function.hpp
include/lbann/utils/timer.hpp
include/lbann/utils/timer_map.hpp
include/lbann/utils/trainer_file_utils.hpp
include/lbann/utils/type_erased_matrix.hpp
include/lbann/utils/typename.hpp
include/lbann/utils/vectorwrapbuf.hpp
include/lbann/utils/visitor_hooks.hpp
include/lbann/weights/data_type_weights.hpp
include/lbann/weights/data_type_weights_impl.hpp
include/lbann/weights/initializer.hpp
include/lbann/weights/variance_scaling_initializers.hpp
include/lbann/weights/weights.hpp
include/lbann/weights/weights_helpers.hpp
include/lbann/weights/weights_proxy.hpp
include/lbann_config.hpp
include/metrics.pb.h
include/model.pb.h
include/objective_functions.pb.h
include/operators.pb.h
include/optimizers.pb.h
include/reader.pb.h
include/trainer.pb.h
include/training_algorithm.pb.h
include/transforms.pb.h
include/weights.pb.h
lib/cmake/lbann/LBANNConfig.cmake
lib/cmake/lbann/LBANNConfigVersion.cmake
lib/cmake/lbann/LBANNTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/lbann/LBANNTargets.cmake
lib/cmake/lbann/modules/FindBreathe.cmake
lib/cmake/lbann/modules/FindCNPY.cmake
lib/cmake/lbann/modules/FindClara.cmake
lib/cmake/lbann/modules/FindFFTW.cmake
lib/cmake/lbann/modules/FindHWLOC.cmake
lib/cmake/lbann/modules/FindNVSHMEM.cmake
lib/cmake/lbann/modules/FindNVTX.cmake
lib/cmake/lbann/modules/FindRoctracer.cmake
lib/cmake/lbann/modules/FindSphinx.cmake
lib/cmake/lbann/modules/FindVTune.cmake
lib/cmake/lbann/modules/FindZSTR.cmake
lib/cmake/lbann/modules/FindcuDNN.cmake
lib/cmake/lbann/modules/FindcuFFT.cmake
lib/cmake/lbann/modules/FindcuTENSOR.cmake
lib/cmake/lbann/modules/FindcuTT.cmake
lib/cmake/lbann/modules/LBANNCMakeUtilities.cmake
lib/cmake/lbann/modules/LBANNClangFormat.cmake
lib/cmake/lbann/modules/LBANNDebugUtilities.cmake
lib/cmake/lbann/modules/LBANNWritePythonFeatures.cmake
lib/cmake/lbann/modules/SetupCXX.cmake
lib/cmake/lbann/modules/SetupMPI.cmake
lib/cmake/lbann/modules/SetupOpenMP.cmake
lib/cmake/lbann/modules/SetupProtobuf.cmake
lib/libLbannProto.so
lib/liblbann.so
lib/liblbann.so.0.103.0
share/model_zoo/README.md
share/model_zoo/data_readers/CANDLE/data_reader_candle_pilot2_3k_run16.prototext
share/model_zoo/data_readers/CANDLE/pilot2/data_reader_candle_pilot2.prototext
share/model_zoo/data_readers/CANDLE/pilot2/data_reader_candle_pilot2_3k.prototext
share/model_zoo/data_readers/CANDLE/pilot2/data_reader_candle_pilot2_3k_run10.prototext
share/model_zoo/data_readers/CANDLE/pilot2/data_reader_candle_pilot2_3k_run16.prototext
share/model_zoo/data_readers/CANDLE/pilot2/data_reader_candle_pilot2_6k.prototext
share/model_zoo/data_readers/CANDLE/pilot2/data_reader_candle_pilot2_6k_run10.prototext
share/model_zoo/data_readers/data_reader_candle_pilot1.prototext
share/model_zoo/data_readers/data_reader_candle_pilot1_combo.prototext
share/model_zoo/data_readers/data_reader_candle_pilot1_gdc.prototext
share/model_zoo/data_readers/data_reader_candle_pilot1_growth.prototext
share/model_zoo/data_readers/data_reader_cifar10.prototext
share/model_zoo/data_readers/data_reader_jag.prototext
share/model_zoo/data_readers/data_reader_mnist.prototext
share/model_zoo/data_readers/data_reader_mnist_numpy_npz_int16.prototext
share/model_zoo/data_readers/data_reader_nci.prototext
share/model_zoo/data_readers/data_reader_nci.prototext.bve
share/model_zoo/data_readers/data_reader_synthetic.prototext
share/model_zoo/data_readers/data_reader_synthetic_cosmoflow_128.prototext
share/model_zoo/data_readers/data_reader_synthetic_imagenet.prototext
share/model_zoo/models/autoencoder_candle_pilot1/README.md
share/model_zoo/models/autoencoder_candle_pilot1/data_readers/data_reader_candle_pilot1.prototext
share/model_zoo/models/autoencoder_candle_pilot1/model_autoencoder_chem_ecfp.prototext
share/model_zoo/models/autoencoder_candle_pilot1/model_autoencoder_chem_ecfp.py
share/model_zoo/models/autoencoder_candle_pilot1/model_dnn_chem_ecfp.prototext
share/model_zoo/models/autoencoder_candle_pilot1/model_dnn_chem_ecfp.py
share/model_zoo/models/candle/pilot1/ae_nodeselect_gdc.prototext
share/model_zoo/models/candle/pilot1/combo.prototext
share/model_zoo/models/gan/mnist/adversarial_model.prototext
share/model_zoo/models/gan/mnist/discriminator_model.prototext
share/model_zoo/models/python/README.md
share/model_zoo/models/python/common.py
share/model_zoo/models/python/defaults.txt
share/model_zoo/models/python/expandMotifs.py
share/model_zoo/models/python/generator_base.py
share/model_zoo/models/python/indexToStringPrototextFix.py
share/model_zoo/models/python/keras/README.md
share/model_zoo/models/python/keras/kerbann.py
share/model_zoo/models/python/keras/mnist_cnn.prototext
share/model_zoo/models/python/keras/mnist_cnn.py
share/model_zoo/models/python/test.py
share/model_zoo/models/python/test_setup.py
share/model_zoo/optimizers/opt_adagrad.prototext
share/model_zoo/optimizers/opt_adam.prototext
share/model_zoo/optimizers/opt_hypergradient_adam.prototext
share/model_zoo/optimizers/opt_rmsprop.prototext
share/model_zoo/optimizers/opt_sgd.prototext
share/model_zoo/tests/CMakeLists.txt
share/model_zoo/tests/comm_test.cpp
share/model_zoo/tests/conduit_timing_test.cpp
share/model_zoo/tests/data_reader_tests/jag_single_layer_ae.prototext
share/model_zoo/tests/model_jag_single_layer_ae.prototext
share/model_zoo/tests/model_lenet_mnist_ckpt.prototext
share/model_zoo/tests/model_lenet_mnist_dist_ckpt.prototext
share/model_zoo/tests/model_lenet_mnist_lbann2ckpt.prototext
share/model_zoo/tests/test_utils.hpp
share/scripts/plotting/event_pb2.py
share/scripts/plotting/load_events.py
share/scripts/plotting/plot_comp_times.py
share/scripts/plotting/print_times.py
share/scripts/plotting/summary_pb2.py