- Upgrade to 1.4.19 (with SCA fix).
This commit is contained in:
parent
782b0d9f8c
commit
26b5a9dfe6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=380145
@ -1,8 +1,8 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gnupg
|
||||
PORTVERSION= 1.4.18
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.4.19
|
||||
#PORTREVISION= 0
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ${MASTER_SITE_GNUPG}
|
||||
MASTER_SITE_SUBDIR= gnupg
|
||||
|
@ -1,4 +1,4 @@
|
||||
SHA256 (gnupg-1.4.18.tar.bz2) = b7b5fdda78849955e0cdbc5a085f3a08f8b7fba126c622085debb62def5d6388
|
||||
SIZE (gnupg-1.4.18.tar.bz2) = 3649557
|
||||
SHA256 (gnupg-1.4.18.tar.bz2.sig) = 9780cfb92988de68a7ec1b2b6777234700c75b16c4cbfb60b3e8f2a158fad2be
|
||||
SIZE (gnupg-1.4.18.tar.bz2.sig) = 287
|
||||
SHA256 (gnupg-1.4.19.tar.bz2) = 7f09319d044b0f6ee71fe3587bb873be701723ac0952cff5069046a78de8fd86
|
||||
SIZE (gnupg-1.4.19.tar.bz2) = 3713811
|
||||
SHA256 (gnupg-1.4.19.tar.bz2.sig) = 3101cf3b57e31ec32882a31dd1531e96d7968deb9ccd5ec3bac7c4e25c48f154
|
||||
SIZE (gnupg-1.4.19.tar.bz2.sig) = 573
|
||||
|
@ -1,15 +1,15 @@
|
||||
--- doc/Makefile.in.orig 2012-12-21 04:30:34.000000000 +0900
|
||||
+++ doc/Makefile.in 2012-12-21 09:36:23.407499114 +0900
|
||||
@@ -50,7 +50,7 @@
|
||||
esac; \
|
||||
test $$am__dry = yes; \
|
||||
}
|
||||
--- doc/Makefile.in.orig 2015-02-27 17:37:51.000000000 +0900
|
||||
+++ doc/Makefile.in 2015-02-28 23:39:40.404690107 +0900
|
||||
@@ -77,7 +77,7 @@
|
||||
test $$has_opt = yes
|
||||
am__make_dryrun = (target_option=n; $(am__make_running_with_option))
|
||||
am__make_keepgoing = (target_option=k; $(am__make_running_with_option))
|
||||
-pkgdatadir = $(datadir)/@PACKAGE@
|
||||
+pkgdatadir = $(datadir)/doc/gnupg1
|
||||
pkgincludedir = $(includedir)/@PACKAGE@
|
||||
pkglibdir = $(libdir)/@PACKAGE@
|
||||
pkglibexecdir = $(libexecdir)/@PACKAGE@
|
||||
@@ -352,7 +352,11 @@
|
||||
@@ -422,7 +422,11 @@
|
||||
|
||||
# Need this to avoid building of dvis with automake 1.4
|
||||
DVIS =
|
||||
@ -21,16 +21,16 @@
|
||||
|
||||
# we can't add gpg.texi gpgv.texi here because automake does not like them to
|
||||
# be built files.
|
||||
@@ -647,6 +651,8 @@
|
||||
@@ -670,6 +674,8 @@
|
||||
-e 's,\.[0-9a-z]*$$,,;$(transform);G;s,\n,.,'`; \
|
||||
dir='$(DESTDIR)$(man7dir)'; $(am__uninstall_files_from_dir)
|
||||
dir='$(DESTDIR)$(man1dir)'; $(am__uninstall_files_from_dir)
|
||||
install-pkgdataDATA: $(pkgdata_DATA)
|
||||
+ifdef NOPORTDOCS
|
||||
+else
|
||||
@$(NORMAL_INSTALL)
|
||||
@list='$(pkgdata_DATA)'; test -n "$(pkgdatadir)" || list=; \
|
||||
if test -n "$$list"; then \
|
||||
@@ -661,6 +667,7 @@
|
||||
@@ -684,6 +690,7 @@
|
||||
echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pkgdatadir)'"; \
|
||||
$(INSTALL_DATA) $$files "$(DESTDIR)$(pkgdatadir)" || exit $$?; \
|
||||
done
|
||||
|
@ -1,15 +1,15 @@
|
||||
--- g10/Makefile.in.orig 2012-12-21 04:30:34.000000000 +0900
|
||||
+++ g10/Makefile.in 2012-12-21 09:37:38.552438682 +0900
|
||||
@@ -52,7 +52,7 @@
|
||||
esac; \
|
||||
test $$am__dry = yes; \
|
||||
}
|
||||
--- g10/Makefile.in.orig 2015-02-27 17:37:51.000000000 +0900
|
||||
+++ g10/Makefile.in 2015-02-28 23:43:42.178420136 +0900
|
||||
@@ -79,7 +79,7 @@
|
||||
test $$has_opt = yes
|
||||
am__make_dryrun = (target_option=n; $(am__make_running_with_option))
|
||||
am__make_keepgoing = (target_option=k; $(am__make_running_with_option))
|
||||
-pkgdatadir = $(datadir)/@PACKAGE@
|
||||
+pkgdatadir = $(datadir)/doc/gnupg1
|
||||
+pkgdatadir = $(datadir)/gnupg1
|
||||
pkgincludedir = $(includedir)/@PACKAGE@
|
||||
pkglibdir = $(libdir)/@PACKAGE@
|
||||
pkglibexecdir = $(libexecdir)/@PACKAGE@
|
||||
@@ -399,7 +399,11 @@
|
||||
@@ -465,7 +465,11 @@
|
||||
@LIBUSB_CPPFLAGS@ $(am__append_1)
|
||||
needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
|
||||
other_libs = $(LIBICONV) $(DNSLIBS) $(LIBINTL) $(CAPLIBS)
|
||||
@ -21,16 +21,16 @@
|
||||
@ENABLE_BZIP2_SUPPORT_FALSE@bzip2_source =
|
||||
@ENABLE_BZIP2_SUPPORT_TRUE@bzip2_source = compress-bz2.c
|
||||
common_source = \
|
||||
@@ -661,6 +665,8 @@
|
||||
@@ -731,6 +735,8 @@
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
@am__fastdepCC_FALSE@ $(COMPILE) -c `$(CYGPATH_W) '$<'`
|
||||
@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c -o $@ `$(CYGPATH_W) '$<'`
|
||||
install-dist_pkgdataDATA: $(dist_pkgdata_DATA)
|
||||
+ifdef NOPORTDOCS
|
||||
+else
|
||||
@$(NORMAL_INSTALL)
|
||||
@list='$(dist_pkgdata_DATA)'; test -n "$(pkgdatadir)" || list=; \
|
||||
if test -n "$$list"; then \
|
||||
@@ -675,6 +681,7 @@
|
||||
@@ -745,6 +751,7 @@
|
||||
echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pkgdatadir)'"; \
|
||||
$(INSTALL_DATA) $$files "$(DESTDIR)$(pkgdatadir)" || exit $$?; \
|
||||
done
|
||||
|
@ -9,7 +9,7 @@ libexec/gnupg/gpgkeys_hkp
|
||||
man/man1/gpg-zip.1.gz
|
||||
man/man1/gpg.1.gz
|
||||
man/man1/gpgv.1.gz
|
||||
@comment man/man7/gnupg.7.gz
|
||||
%%DATADIR%%1/options.skel
|
||||
%%NLS%%share/locale/be/LC_MESSAGES/gnupg.mo
|
||||
%%NLS%%share/locale/ca/LC_MESSAGES/gnupg.mo
|
||||
%%NLS%%share/locale/cs/LC_MESSAGES/gnupg.mo
|
||||
|
Loading…
Reference in New Issue
Block a user