Import of a perl5 module for access to libtcl

This commit is contained in:
James FitzGibbon 1997-06-16 03:03:56 +00:00
parent e901b7651f
commit 26926d9a4d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=6948
6 changed files with 74 additions and 0 deletions

27
lang/p5-Tcl/Makefile Normal file
View File

@ -0,0 +1,27 @@
# New ports collection makefile for: p5-Tcl
# Version required: b1
# Date created: June 15th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $Id$
DISTNAME= Tcl-b1
PKGNAME= p5-Tcl-b1
CATEGORIES= lang perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Tcl
MAINTAINER= jfitz@FreeBSD.ORG
BUILD_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5
RUN_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5
WRKSRC= ${WRKDIR}/Tcl
MANPREFIX= ${PREFIX}/lib/perl5
MAN3= Tcl.3
do-configure:
@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
.include <bsd.port.mk>

1
lang/p5-Tcl/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (Tcl-b1.tar.gz) = 25cd4b8673aeab94b4e1f758f18a0d62

View File

@ -0,0 +1,9 @@
--- Makefile.PL.orig Sun Jun 15 22:37:16 1997
+++ Makefile.PL Sun Jun 15 22:37:40 1997
@@ -1,3 +1,4 @@
use ExtUtils::MakeMaker;
-WriteMakefile(LIBS => ["-ltcl -lm"],
- INC => "-I/usr/local/include -I/usr/include/tcl");
+WriteMakefile( NAME => "Tcl",
+ LIBS => ["-ltcl -lm"],
+ INC => "-I/usr/include/tcl");

1
lang/p5-Tcl/pkg-comment Normal file
View File

@ -0,0 +1 @@
a Tcl extension module for Perl5

30
lang/p5-Tcl/pkg-descr Normal file
View File

@ -0,0 +1,30 @@
The Tcl extension module gives access to the Tcl library
with functionality and interface similar to the C
functions of Tcl. In other words, you can
create Tcl interpreters
The Tcl interpreters so created are Perl objects
whose destructors delete the interpreters cleanly
when appropriate.
execute Tcl code in an interpreter
The code can come from strings, files or Perl
filehandles.
bind in new Tcl procedures
The new procedures can be either C code (with
addresses presumably obtained using dl_open and
dl_find_symbol) or Perl subroutines (by name,
reference or as anonymous subs). The (optional)
deleteProc callback in the latter case is another
perl subroutine which is called when the command
is explicitly deleted by name or else when the
destructor for the interpreter object is
explicitly or implicitly called.
Manipulate the result field of a Tcl interpreter
Set and get values of variables in a Tcl interpreter
Tie perl variables to variables in a Tcl interpreter
The variables can be either scalars or hashes.

6
lang/p5-Tcl/pkg-plist Normal file
View File

@ -0,0 +1,6 @@
lib/perl5/man/man3/Tcl.3.gz
lib/perl5/site_perl/Tcl.pm
lib/perl5/site_perl/i386-freebsd/auto/Tcl/Tcl.bs
lib/perl5/site_perl/i386-freebsd/auto/Tcl/Tcl.so
lib/perl5/site_perl/i386-freebsd/auto/Tcl/.packlist
@dirrm lib/perl5/site_perl/i386-freebsd/auto/Tcl