Update to version 3.02.
PR: 28037 Submitted by: maintainer
This commit is contained in:
parent
1bc4ab1213
commit
26439d9580
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44130
@ -6,25 +6,26 @@
|
||||
#
|
||||
|
||||
PORTNAME= tkseti
|
||||
PORTVERSION= 2.12
|
||||
CATEGORIES= astro tk82
|
||||
PORTVERSION= 3.04
|
||||
CATEGORIES= astro tk83
|
||||
MASTER_SITES= http://www.cuug.ab.ca/~macdonal/tkseti/
|
||||
|
||||
MAINTAINER= brett@peloton.runet.edu
|
||||
MAINTAINER= petef@databits.net
|
||||
|
||||
RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82 \
|
||||
RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83 \
|
||||
setiathome:${PORTSDIR}/astro/setiathome
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
MAN1= tkseti.1
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/share/doc/tkseti
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/tkseti ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/tkseti.1 ${PREFIX}/man/man1
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/tkseti
|
||||
${INSTALL_DATA} ${WRKSRC}/DOC ${PREFIX}/share/doc/tkseti/DOC
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/tkseti/README
|
||||
|
||||
post-install:
|
||||
@${ECHO} "Please read the documentation for tkseti located in"
|
||||
@${ECHO} "${PREFIX}/share/doc/tkseti/DOC and ${PREFIX}/share/doc/tkseti/README."
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (tkseti-2.12.tar.gz) = 6a372f4605370c0c783183ec034b899c
|
||||
MD5 (tkseti-3.04.tar.gz) = c02fc58627295eefe9fdc924facc0b83
|
||||
|
@ -1,14 +1,14 @@
|
||||
--- tkseti.orig Sun Oct 31 10:12:05 1999
|
||||
+++ tkseti Thu Nov 18 18:48:20 1999
|
||||
--- tkseti.orig Fri Jun 8 16:23:37 2001
|
||||
+++ tkseti Mon Jun 11 10:22:48 2001
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/sh
|
||||
# the next line restarts using wish \
|
||||
-exec wish "$0" ${1+"$@"}
|
||||
+exec wish8.2 "$0" ${1+"$@"}
|
||||
+exec wish8.3 "$0" ${1+"$@"}
|
||||
#############################################################################
|
||||
# Visual Tcl v1.20 Project
|
||||
#
|
||||
@@ -181,11 +181,11 @@
|
||||
@@ -189,11 +189,11 @@
|
||||
TkSETI can be started if the client is already running, or it can start
|
||||
the client manually or automatically for you. This is explained in the
|
||||
Setup section that follows.
|
||||
@ -25,7 +25,7 @@
|
||||
|
||||
tkseti ~/setiathome
|
||||
|
||||
@@ -554,7 +554,7 @@
|
||||
@@ -551,7 +551,7 @@
|
||||
if {[catch {info nameofexecutable} nameofexecutable]} {
|
||||
set nameofexecutable wish
|
||||
}
|
||||
@ -34,7 +34,7 @@
|
||||
|
||||
if {[lsearch $argv "--help"] >= 0} {
|
||||
puts \n$seti(usage)
|
||||
@@ -569,7 +569,7 @@
|
||||
@@ -566,7 +566,7 @@
|
||||
option add *highlightBackground grey85 user
|
||||
|
||||
if {$argc == 0} {
|
||||
@ -42,4 +42,4 @@
|
||||
+ set seti(setidir) /var/db/setiathome
|
||||
} {
|
||||
set seti(setidir) [lindex $argv 0]
|
||||
}
|
||||
if {[string index $seti(setidir) 0] != "/"} {
|
||||
|
@ -1 +1 @@
|
||||
Tk-based interface to seti@home
|
||||
Tk-based interface to SETI@Home
|
||||
|
@ -1,6 +1,9 @@
|
||||
tkseti is a nice Tk interface to the seti@home program. It shows
|
||||
tkseti is a nice Tk interface to the SETI@Home program. It shows
|
||||
current best spikes and gaussians for the user and can be used in
|
||||
multiple directories. It can also fetch the user's statistics from
|
||||
the seti@home web site.
|
||||
|
||||
WWW: http://www.cuug.ab.ca/~macdonal/tkseti/
|
||||
|
||||
- Pete
|
||||
petef@databits.net
|
||||
|
@ -1,4 +1,4 @@
|
||||
bin/tkseti
|
||||
share/doc/tkseti/DOC
|
||||
share/doc/tkseti/README
|
||||
@dirrm share/doc/tkseti
|
||||
%%PORTDOCS%%share/doc/tkseti/DOC
|
||||
%%PORTDOCS%%share/doc/tkseti/README
|
||||
%%PORTDOCS%%@dirrm share/doc/tkseti
|
||||
|
Loading…
Reference in New Issue
Block a user