finance/ktoblzcheck: Update to 1.53
- The build system has been changed to CMake. - Upstream has removed the bankdata updating tool. Bankdata will now be periodically updated by the port itself. - The PYTHON option has been removed. The Python bindings are now compatible with Python 3.x, but would be better off in a slave port. For now, they are disabled since nothing in the ports tree uses them. [1] PR: 249684 [1] Reported by: swills [1]
This commit is contained in:
parent
cd71a906c7
commit
2639322e0f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559580
@ -2,10 +2,12 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ktoblzcheck
|
||||
PORTVERSION= 1.49
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.53
|
||||
CATEGORIES= finance german
|
||||
MASTER_SITES= SF/${PORTNAME}
|
||||
MASTER_SITES= SF/${PORTNAME} \
|
||||
LOCAL/jhale:bankdata
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
|
||||
${PORTNAME}-bankdata-${BANKDATA_DATE}${EXTRACT_SUFX}:bankdata
|
||||
|
||||
MAINTAINER= jhale@FreeBSD.org
|
||||
COMMENT= Check bank codes of German banks
|
||||
@ -13,25 +15,31 @@ COMMENT= Check bank codes of German banks
|
||||
LICENSE= LGPL21+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= libtool pathfix perl5
|
||||
GNU_CONFIGURE= yes
|
||||
USES= cmake pathfix python:3.6+,build
|
||||
USE_LDCONFIG= yes
|
||||
CONFIGURE_ARGS= --with-wget=${FETCH_BINARY}
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
SUB_FILES= pkg-deinstall pkg-message
|
||||
PORTDOCS= README
|
||||
CMAKE_ON= INSTALL_RAW_BANKDATA_FILE
|
||||
CMAKE_OFF= ENABLE_BANKDATA_DOWNLOAD
|
||||
|
||||
OPTIONS_DEFINE= DOCS PYTHON
|
||||
PLIST_SUB= BANKDATA_DATE=${BANKDATA_DATE}
|
||||
PORTDOCS= README.md
|
||||
|
||||
BANKDATA_DATE= 20201207
|
||||
|
||||
OPTIONS_DEFINE= DOCS DOXYGEN
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
PYTHON_USES= python:2.7
|
||||
PYTHON_CONFIGURE_ENABLE= python
|
||||
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
|
||||
dot:graphics/graphviz
|
||||
DOXYGEN_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Doxygen
|
||||
|
||||
TEST_TARGET= check
|
||||
TEST_TARGET= test
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s/-lstdc++//g" ${WRKSRC}/src/lib/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|$${CMAKE_INSTALL_DATADIR}\/man|$${CMAKE_INSTALL_MANDIR}|' ${WRKSRC}/doc/CMakeLists.txt
|
||||
@(cd ${WRKSRC}/src/bankdata && ${RM} bankdata_*.txt blz_*.txt)
|
||||
@${CP} ${WRKDIR}/${PORTNAME}-bankdata-${BANKDATA_DATE}/blz_${BANKDATA_DATE}.txt ${WRKSRC}/src/bankdata
|
||||
@${TOUCH} ${WRKSRC}/src/bankdata/bankdata_${BANKDATA_DATE}.txt
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
|
@ -1,3 +1,5 @@
|
||||
TIMESTAMP = 1488563018
|
||||
SHA256 (ktoblzcheck-1.49.tar.gz) = e8971bc6689ea72b174c194bd43ba2c0b65112b0c3f9fd2371562e0c3ab57d29
|
||||
SIZE (ktoblzcheck-1.49.tar.gz) = 561501
|
||||
TIMESTAMP = 1609010429
|
||||
SHA256 (ktoblzcheck-1.53.tar.gz) = 18b9118556fe83240f468f770641d2578f4ff613cdcf0a209fb73079ccb70c55
|
||||
SIZE (ktoblzcheck-1.53.tar.gz) = 531459
|
||||
SHA256 (ktoblzcheck-bankdata-20201207.tar.gz) = dc801b676b3e936ff3c40b604d28b6bdbc094b95625b2e20799f7c566622b705
|
||||
SIZE (ktoblzcheck-bankdata-20201207.tar.gz) = 356356
|
||||
|
12
finance/ktoblzcheck/files/patch-src_CMakeLists.txt
Normal file
12
finance/ktoblzcheck/files/patch-src_CMakeLists.txt
Normal file
@ -0,0 +1,12 @@
|
||||
Disable the Python bindings for now. They could be in a slave port later if
|
||||
needed, but I am not currently aware of anything that uses them.
|
||||
|
||||
--- src/CMakeLists.txt.orig 2020-12-28 00:28:41 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -9,6 +9,3 @@ add_subdirectory(bankdata)
|
||||
add_subdirectory(include)
|
||||
add_subdirectory(lib)
|
||||
add_subdirectory(bin)
|
||||
-if(Python_Development_FOUND)
|
||||
- add_subdirectory(python)
|
||||
-endif()
|
@ -1,44 +0,0 @@
|
||||
- Use fetch(1) instead of requiring wget or lynx
|
||||
- Download over a secure connection
|
||||
|
||||
--- src/bankdata/online_update.pl.in.orig 2012-10-01 21:03:49 UTC
|
||||
+++ src/bankdata/online_update.pl.in
|
||||
@@ -21,8 +21,8 @@ $pkgdatadir="$datadir/@PACKAGE@";
|
||||
$BANKDATADIR="@BANKDATA_PATH@";
|
||||
|
||||
## Sanity checks
|
||||
-die "Neither wget nor lynx is available on your system, or was available on the system where the installed rpm was built. This tool requires wget or lynx. If you have it i
|
||||
-nstalled, then edit the script and set the variable WGET or LYNX to the full path to wget or lynx. Aborting for now."
|
||||
+die "Neither fetch nor lynx is available on your system, or was available on the system where the installed package was built. This tool requires fetch or lynx. If you have it i
|
||||
+nstalled, then edit the script and set the variable WGET or LYNX to the full path to fetch or lynx. Aborting for now."
|
||||
if $WGET eq "NO" and $LYNX eq "NO";
|
||||
#die "sed or grep is not available on your system. This tool requires it. Aborting."
|
||||
# if $SED eq "NO" || $GREP eq "NO";
|
||||
@@ -35,13 +35,13 @@ die "The directory for the bankdata \"$B
|
||||
|
||||
## Common constants
|
||||
$debug=0; # set this to nonzero for activating debugging mode
|
||||
-$BASE_URL="http://www.bundesbank.de";
|
||||
+$BASE_URL="https://www.bundesbank.de";
|
||||
$MAIN_URL="$BASE_URL";
|
||||
-$MAIN_DOC="$MAIN_URL/Redaktion/DE/Standardartikel/Kerngeschaeftsfelder/Unbarer_Zahlungsverkehr/bankleitzahlen_download.html";
|
||||
+$MAIN_DOC="$MAIN_URL/Redaktion/DE/Standardartikel/Aufgaben/Unbarer_Zahlungsverkehr/bankleitzahlen_download.html";
|
||||
|
||||
if ($debug == 0) {
|
||||
if ($WGET ne "NO") {
|
||||
- $DOWNLOADCMD = "$WGET -O - $MAIN_DOC";
|
||||
+ $DOWNLOADCMD = "$WGET -q -o - $MAIN_DOC";
|
||||
} else {
|
||||
$DOWNLOADCMD = "$LYNX -source $MAIN_DOC";
|
||||
}
|
||||
@@ -145,8 +145,8 @@ if ($debug == 0) {
|
||||
##
|
||||
## 1. Download
|
||||
if ($WGET ne "NO") {
|
||||
- print "$ECHO $WGET -O $install_1 $download\n";
|
||||
- system("$ECHO $WGET -O $install_1 $download");
|
||||
+ print "$ECHO $WGET -q -o $install_1 $download\n";
|
||||
+ system("$ECHO $WGET -q -o $install_1 $download");
|
||||
} else {
|
||||
print "$ECHO $LYNX -source $download $gt $install_1\n";
|
||||
system("$ECHO $LYNX -source $download $gt $install_1");# || die "can't call system: $!";
|
@ -1,14 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
if [ "${2}" = "POST-DEINSTALL" ]; then
|
||||
if [ -d %%DATADIR%% ]; then
|
||||
echo ""
|
||||
echo "--------------------------------------------------------------------"
|
||||
echo "To completely remove the port, you may need to remove"
|
||||
echo "the following directories and the content manually:"
|
||||
echo ""
|
||||
echo " %%DATADIR%%"
|
||||
echo "--------------------------------------------------------------------"
|
||||
echo ""
|
||||
fi
|
||||
fi
|
@ -1,17 +0,0 @@
|
||||
[
|
||||
{ type: install
|
||||
message: <<EOM
|
||||
The bankdata included with the ktoblzcheck distribution is outdated.
|
||||
You should update this bankdata upon installation and periodically
|
||||
afterwards. New bankdata is typically available every three months.
|
||||
|
||||
To update the bankdata, run (as root):
|
||||
|
||||
# %%DATADIR%%/online_update.pl
|
||||
|
||||
The script is interactive and will present you with the bankdata
|
||||
available for download. Follow the prompts and it will write the
|
||||
new bankdata to %%DATADIR%%.
|
||||
EOM
|
||||
}
|
||||
]
|
@ -1,16 +1,74 @@
|
||||
bin/ibanchk
|
||||
bin/ktoblzcheck
|
||||
include/iban.h
|
||||
include/ktoblzcheck.h
|
||||
lib/cmake/KtoBlzCheck/KtoBlzCheckConfig.cmake
|
||||
lib/cmake/KtoBlzCheck/KtoBlzCheckConfigVersion.cmake
|
||||
lib/cmake/KtoBlzCheck/KtoBlzCheckTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
lib/cmake/KtoBlzCheck/KtoBlzCheckTargets.cmake
|
||||
lib/libktoblzcheck.so
|
||||
lib/libktoblzcheck.so.1
|
||||
lib/libktoblzcheck.so.1.5.26
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/ktoblzcheck.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/ktoblzcheck.pyc
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/ktoblzcheck.pyo
|
||||
libdata/pkgconfig/ktoblzcheck.pc
|
||||
man/man1/ibanchk.1.gz
|
||||
man/man1/ktoblzcheck.1.gz
|
||||
%%DATADIR%%/bankdata_20140908.txt
|
||||
%%DATADIR%%/bankdata_20141208.txt
|
||||
%%DATADIR%%/bundesbank.pl
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/README_8md.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/annotated.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/bc_s.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/bdwn.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/classAccountNumberCheck-members.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/classAccountNumberCheck.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/classAccountNumberCheck_1_1Record-members.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/classAccountNumberCheck_1_1Record.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/classIban-members.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/classIban.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/classIbanCheck-members.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/classIbanCheck.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/classes.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/closed.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/dir_2d731f5ea854aa8d4182cb287b4b4714.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/dir_5652562e240707faebb7b26ba93ec871.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/dir_5a44bfe66872ebd87256b63344bc501a.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/dir_6b601777cc03b1c222ba0713691323f0.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/dir_8f1ddfcaba34d370f217a025e0bf2872.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/doc.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/doxygen.css
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/doxygen.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/dynsections.js
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/files.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/folderclosed.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/folderopen.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/functions.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/functions_enum.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/functions_eval.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/functions_func.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/functions_rela.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/functions_type.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/functions_vars.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/globals.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/globals_defs.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/globals_func.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/globals_type.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/iban_8h.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/iban_8h_source.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/index.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/jquery.js
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/ktoblzcheck_8h.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/ktoblzcheck_8h_source.html
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/menu.js
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/menudata.js
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/nav_f.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/nav_g.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/nav_h.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/open.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/splitbar.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/sync_off.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/sync_on.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/tab_a.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/tab_b.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/tab_h.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/tab_s.png
|
||||
%%DOXYGEN%%%%DOCSDIR%%/api/tabs.css
|
||||
%%DATADIR%%/bankdata_%%BANKDATA_DATE%%.txt
|
||||
%%DATADIR%%/blz_%%BANKDATA_DATE%%.txt
|
||||
%%DATADIR%%/ibandata.txt
|
||||
%%DATADIR%%/online_update.pl
|
||||
|
Loading…
Reference in New Issue
Block a user