graphics/py-gphoto2: the port had been updated (+)

- Update to the latest version 2.2.4
- Simplify commit 2e9a47e964 and respect CFLAGS
- Use EXAMPLESDIR_REL and DOCSDIR_REL variables
- Amend the port description text while here
This commit is contained in:
Alexey Dokuchaev 2021-07-04 07:34:26 +00:00
parent 60dba5d9a4
commit 262b774a5f
4 changed files with 13 additions and 27 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= gphoto2
PORTVERSION= 2.0.0
PORTVERSION= 2.2.4
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -13,22 +13,16 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libgphoto2.so:graphics/libgphoto2
USES= compiler pkgconfig python:3.6+ shebangfix
USES= pkgconfig python:3.6+ shebangfix
USE_PYTHON= autoplist concurrent distutils
SHEBANG_FILES= examples/*.py
OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
${REINPLACE_CMD} \
-e 's|share/python-gphoto2/examples|${EXAMPLESDIR:S,${PREFIX}/,,}|' \
-e 's|share/python-gphoto2|${DOCSDIR:S,${PREFIX}/,,}|' \
@${REINPLACE_CMD} -e '/-O3/d' \
-e 's|share/python-gphoto2/examples|${EXAMPLESDIR_REL}|' \
-e 's|share/python-gphoto2|${DOCSDIR_REL}|' \
${WRKSRC}/setup.py
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == gcc
EXTRA_PATCHES= ${FILESDIR}/extra-patch-setup.py
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1576064452
SHA256 (python-gphoto2/gphoto2-2.0.0.tar.gz) = 28294fce05114cd0389040105baa310b6e5082696242fd736aeefee2b55c6c07
SIZE (python-gphoto2/gphoto2-2.0.0.tar.gz) = 7235515
TIMESTAMP = 1604948179
SHA256 (python-gphoto2/gphoto2-2.2.4.tar.gz) = 48b4c4ab70826d3ddaaf7440564d513c02d78680fa690994b0640d383ffb8a7d
SIZE (python-gphoto2/gphoto2-2.2.4.tar.gz) = 1807843

View File

@ -1,11 +0,0 @@
--- setup.py.orig 2018-01-02 11:44:51 UTC
+++ setup.py
@@ -83,7 +83,7 @@ mod_src_dir = os.path.join(
'src', mod_src_dir + '-gp' + '.'.join(map(str, best_match)))
extra_compile_args = [
- '-O3', '-Wno-unused-variable', '-Wno-unused-but-set-variable',
+ '-O3', '-Wno-unused-variable',
'-Wno-unused-label', '-Wno-strict-prototypes',
'-DGPHOTO2_VERSION=' + '0x{:02x}{:02x}{:02x}'.format(*gphoto2_version)]
if 'PYTHON_GPHOTO2_STRICT' in os.environ:

View File

@ -1,3 +1,6 @@
python-gphoto2 provides Python interface to libgphoto2.
python-gphoto2 is a comprehensive Python interface (or binding) to
libgphoto2. It is built using SWIG to automatically generate the
interface code. This gives direct access to nearly all available
libgphoto2 functions, but sometimes in a rather un-Pythonic manner.
WWW: https://pypi.org/project/gphoto2/