- Update to 1.9.
- Fix build with new ocaml-images. PR: ports/144886 Submitted by: Timothy Beyer <beyert@cs.ucr.edu> (based on)
This commit is contained in:
parent
582182f170
commit
25e25d3032
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=252469
@ -7,11 +7,11 @@
|
||||
#
|
||||
|
||||
PORTNAME= advi
|
||||
PORTVERSION= 1.6.0
|
||||
PORTREVISION= 5
|
||||
PORTVERSION= 1.9
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://caml.inria.fr/distrib/bazar-ocaml/${PORTNAME}/
|
||||
EXTRACT_SUFX= .tgz
|
||||
MASTER_SITES= http://gallium.inria.fr/${PORTNAME}/ \
|
||||
http://caml.inria.fr/distrib/bazar-ocaml/${PORTNAME}/
|
||||
|
||||
MAINTAINER= stas@FreeBSD.org
|
||||
COMMENT= Active-DVI viewer
|
||||
@ -25,26 +25,53 @@ LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
|
||||
RUN_DEPENDS= kpsewhich:${PORTSDIR}/print/teTeX-base
|
||||
|
||||
USE_OCAML= yes
|
||||
USE_OCAML_FINDLIB= yes
|
||||
NO_OCAML_RUNDEPENDS=yes
|
||||
USE_GHOSTSCRIPT=yes
|
||||
GNU_CONFIGURE=yes
|
||||
USE_XORG= xpm
|
||||
USE_FREETYPE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
ALL_TARGET= opt
|
||||
INSTALL_TARGET= installopt installman
|
||||
|
||||
CI_DEPEND= ${LOCALBASE}/${OCAML_LIBDIR}/camlimages/ci_core.a
|
||||
OPTIONS= GS "Enable Ghostscript support" on
|
||||
|
||||
CI_DEPEND= ${LOCALBASE}/${OCAML_LIBDIR}/site-lib/camlimages/camlimages.a
|
||||
MAN1= advi.1
|
||||
|
||||
post-extract:
|
||||
.if !defined(NOPORTDOCS)
|
||||
PORTDOCS= *
|
||||
.endif
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if !defined(WITHOUT_GS)
|
||||
USE_GHOSTSCRIPT= yes
|
||||
CONFIGURE_ARGS+= --with-GS=maybe
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-GS=no
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
@${ECHO} "************************************************************"
|
||||
@${ECHO} "ATTENTION! This port required ocaml-images to be built with"
|
||||
@${ECHO} "Ghostscript support enabled. If you build graphics/ocaml-images"
|
||||
@${ECHO} "without GS support, please rebuild it before building this port"
|
||||
@${ECHO} "************************************************************"
|
||||
@${ECHO}
|
||||
|
||||
post-patch:
|
||||
.if defined(NOPORTDOCS)
|
||||
@${REINPLACE_CMD} -E \
|
||||
-e 's,^(COPTIONS[[:space:]]*=).*,\1-ccopt "${CFLAGS}",' \
|
||||
-e 's,^(COPTOPTIONS[[:space:]]*=).*,\1-ccopt "${CFLAGS}",' \
|
||||
-e 's,^(X11_INCLUDES[[:space:]]*=).*,\1-I${LOCALBASE}/include,' \
|
||||
-e 's,install -m 644,\$${BSD_INSTALL_DATA},' \
|
||||
-e 's,install -m 755,\$${BSD_INSTALL_PROGRAM},' \
|
||||
-e 's,^LIBRARIES = graphics,LIBRARIES =,' \
|
||||
${WRKSRC}/Makefile
|
||||
-e 's,(SUBDIRS[[:space:]]*=[[:space:]]*src[[:space:]]+tex[[:space:]]+)doc,\1,g' \
|
||||
${WRKSRC}/Makefile.in
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
#
|
||||
# Install manpage by hand
|
||||
#
|
||||
.if defined(NOPORTDOCS)
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/advi.1 ${MANPREFIX}/man/man1/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (advi-1.6.0.tgz) = da0e71cbc99a8def27873d4f3c756fa6
|
||||
SHA256 (advi-1.6.0.tgz) = ab77eb986987b4e6750e07e3a90f6bf58bea173eaeb2b1ebb0680d7545553e6b
|
||||
SIZE (advi-1.6.0.tgz) = 11436152
|
||||
MD5 (advi-1.9.tar.gz) = a636ee6ce45ab9332a06f57094c42bc3
|
||||
SHA256 (advi-1.9.tar.gz) = 5acefbc42e7ee3a5c59cc24087d52615576d9dd9a3762deabe56bda77113fc64
|
||||
SIZE (advi-1.9.tar.gz) = 8536800
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- grY11.c.orig Sun Aug 13 01:16:56 2006
|
||||
+++ grY11.c Sun Aug 13 01:17:06 2006
|
||||
@@ -473,7 +473,7 @@
|
||||
return Val_unit;
|
||||
}
|
||||
|
||||
-value caml_gr_resize_window (value wid, value w, value h)
|
||||
+value caml_gr_resize_window1 (value wid, value w, value h)
|
||||
{
|
||||
Window win;
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- graphicsY11.ml.orig Sun Aug 13 01:17:58 2006
|
||||
+++ graphicsY11.ml Sun Aug 13 01:18:03 2006
|
||||
@@ -109,7 +109,7 @@
|
||||
= "caml_gr_move_window";;
|
||||
|
||||
external raw_resize_window : window_id -> int -> int -> unit
|
||||
- = "caml_gr_resize_window";;
|
||||
+ = "caml_gr_resize_window1";;
|
||||
|
||||
let resize_subwindow wid height width =
|
||||
if wid != null_window then begin
|
@ -8,10 +8,7 @@ share/texmf/tex/latex/advi/argv.sty
|
||||
share/texmf/tex/latex/advi/bar.eps
|
||||
share/texmf/tex/latex/advi/bubble.sty
|
||||
share/texmf/tex/latex/advi/caml.eps
|
||||
share/texmf/tex/latex/advi/jpfonts.conf
|
||||
share/texmf/tex/latex/advi/scratch_draw_splash.dvi
|
||||
share/texmf/tex/latex/advi/scratch_write_splash.dvi
|
||||
share/texmf/tex/latex/advi/splash.dvi
|
||||
share/texmf/tex/latex/advi/pgfsys-dvips.def
|
||||
share/texmf/tex/latex/advi/superpose.sty
|
||||
share/texmf/tex/latex/advi/xwindows-colors.sty
|
||||
@dirrm share/texmf/tex/latex/advi
|
||||
|
Loading…
Reference in New Issue
Block a user