o Update to 0.7.18.20021107

o Change default to WITHOUT_OPTIMIZED_CFLAGS. Define WITH_OPTIMIZED_CFLAGS
  to get old behavior
o Replace old hack to get the port to link to ports version of
  liba52 with a dlopen(3) option supplied by developer

Approved by:	maintainer
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2002-11-21 01:47:40 +00:00
parent b3b6746994
commit 25b9f3a43a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=70632
18 changed files with 214 additions and 58 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= avifile
PORTVERSION= 0.7.16.20020913
PORTVERSION= 0.7.18.20021107
PORTEPOCH= 2
CATEGORIES= graphics
MASTER_SITES= http://avifile.sourceforge.net/
@ -27,7 +27,6 @@ INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:C/^(.{3}).*/\1/}-${PORTVERSION:C/^(.{6}).+$/\1/}
USE_LIBTOOL= yes
LIBTOOLFILES= acinclude.m4
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib" \
@ -59,8 +58,13 @@ WITHOUT_XVID=yes
.endif
# compilation optimizations
.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
.if defined(WITH_OPTIMIZED_CFLAGS)
CONFIGURE_ARGS+= --enable-release
. if ${ARCH} == "i386"
CONFIGURE_ARGS+= --enable-x86opt
. endif
.else
CONFIGURE_ARGS+= --disable-release
.endif
# soundblaster can be passed ac3 instead of letting avifile decode
@ -145,9 +149,9 @@ PLIST_SUB+= XVID="@comment "
.endif
pre-everything::
.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "You can disable compilation optimizations by defining"
@${ECHO_MSG} " WITHOUT_OPTIMIZED_CFLAGS."
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "You can enable compilation optimizations by defining"
@${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS."
.endif
.if !defined(WITH_AC3_PASSTHROUGH)
@${ECHO_MSG} "You can enable soundblaster ac3 passthrough support by"
@ -179,33 +183,15 @@ packet 'pth' is installed.";\
${FALSE};\
fi
# insure that ports' liba52 is being used
post-extract:
.if !defined(WITHOUT_A52)
@${RM} -Rf ${WRKSRC}/ffmpeg/libavcodec/liba52
@${MKDIR} ${WRKSRC}/ffmpeg/libavcodec/liba52
@${TOUCH} ${WRKSRC}/ffmpeg/libavcodec/liba52/Makefile.in
.endif
# grab does not work outside Linux for now
@${RM} -f ${WRKSRC}/ffmpeg/libav/grab.c
@${TOUCH} ${WRKSRC}/ffmpeg/libav/grab.c
post-patch:
.if !defined(WITHOUT_A52)
@${REINPLACE_CMD} -e 's|-la52|${LIBA52_DEP_LIBS} -la52|' \
${WRKSRC}/configure
# linux/ioctl.h -> sys/ioctl.h
@${REINPLACE_CMD} -e 's|linux/ioctl.h|sys/ioctl.h|' \
${WRKSRC}/drivers/libdha/kernelhelper/dhahelper.h
# XXX - fool ffmpeg to use ports' version of liba52, revise this
# at EVERY avifile update
@${REINPLACE_CMD} -e 's|liba52/liba52.la|${LOCALBASE}/lib/liba52.la|; \
s|SUBDIRS_LIBA52 = liba52|SUBDIRS_LIBA52 =|; \
s|mlib liba52 i386|mlib i386|' \
${WRKSRC}/ffmpeg/libavcodec/Makefile.in
@${REINPLACE_CMD} -e 's|"liba52/a52.h"|<a52dec/a52.h>|' \
${WRKSRC}/ffmpeg/libavcodec/a52dec.c
.endif
.if !defined(WITHOUT_MAD)
@${REINPLACE_CMD} -e 's|MAD_LDADD = \@MAD_LDADD\@|MAD_LDADD = -L${LOCALBASE}/lib \@MAD_LDADD\@|' \
${WRKSRC}/plugins/libmad/Makefile.in
@ -251,10 +237,6 @@ post-patch:
s!AUTOMAKE =!AUTOMAKE = ${TRUE} || !'
post-configure:
# Libtool fix code kindly provided by Mr. Maxim Sobolev <sobomax@FreeBSD.org>
@${REINPLACE_CMD} -e \
's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
${WRKSRC}/libtool
@${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
post-install:

View File

@ -1 +1 @@
MD5 (avifile-0.7.16-20020913.tgz) = c8ea982ee735ccdb995830d18c366f1b
MD5 (avifile-0.7.18-20021107.tgz) = 27acbdb55f19cf474a109c05e0b7b377

View File

@ -0,0 +1,15 @@
--- ffmpeg/libav/http.c.orig Mon Nov 11 18:03:57 2002
+++ ffmpeg/libav/http.c Mon Nov 11 18:04:09 2002
@@ -16,11 +16,11 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
+#include <sys/types.h>
#include <sys/socket.h>
#include "avformat.h"
#include <unistd.h>
#include <ctype.h>
-#include <sys/types.h>
#include <netinet/in.h>
#ifndef __BEOS__
# include <arpa/inet.h>

View File

@ -0,0 +1,15 @@
--- ffmpeg/libav/rtp.c.orig Mon Nov 11 18:05:16 2002
+++ ffmpeg/libav/rtp.c Mon Nov 11 18:05:24 2002
@@ -16,11 +16,11 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <sys/socket.h>
#include "avformat.h"
#include <unistd.h>
#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
#ifndef __BEOS__
# include <arpa/inet.h>

View File

@ -0,0 +1,16 @@
--- ffmpeg/libav/rtpproto.c.orig Mon Nov 11 18:05:59 2002
+++ ffmpeg/libav/rtpproto.c Mon Nov 11 18:06:08 2002
@@ -16,12 +16,12 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <sys/socket.h>
#include "avformat.h"
#include <unistd.h>
#include <stdarg.h>
#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
#ifndef __BEOS__
# include <arpa/inet.h>

View File

@ -0,0 +1,16 @@
--- ffmpeg/libav/rtsp.c.orig Mon Nov 11 18:06:37 2002
+++ ffmpeg/libav/rtsp.c Mon Nov 11 18:06:51 2002
@@ -16,11 +16,12 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <netinet/in.h>
#include "avformat.h"
#include <sys/time.h>
+#include <sys/types.h>
#include <sys/socket.h>
+#include <netinet/in.h>
#ifndef __BEOS__
# include <arpa/inet.h>
#else

View File

@ -0,0 +1,15 @@
--- ffmpeg/libav/tcp.c.orig Mon Nov 11 18:07:22 2002
+++ ffmpeg/libav/tcp.c Mon Nov 11 18:07:27 2002
@@ -16,11 +16,11 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <sys/socket.h>
#include "avformat.h"
#include <unistd.h>
#include <ctype.h>
#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
#ifndef __BEOS__
# include <arpa/inet.h>

View File

@ -0,0 +1,14 @@
--- ffmpeg/libav/udp.c.orig Mon Nov 11 18:07:52 2002
+++ ffmpeg/libav/udp.c Mon Nov 11 18:07:56 2002
@@ -16,10 +16,10 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <sys/socket.h>
#include "avformat.h"
#include <unistd.h>
#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
#ifndef __BEOS__
# include <arpa/inet.h>

View File

@ -12,6 +12,10 @@ include/avifile/audiodecoder.h
include/avifile/audioencoder.h
include/avifile/avifile.h
include/avifile/aviplay.h
include/avifile/avm_args.h
include/avifile/avm_default.h
include/avifile/avm_fourcc.h
include/avifile/avm_locker.h
include/avifile/avm_stl.h
include/avifile/configfile.h
include/avifile/cpuinfo.h
@ -81,6 +85,7 @@ lib/libaviplay.so.0
%%QT%%lib/libqavm.so.0
share/aclocal/avifile.m4
share/avifile/about.ppm
share/avifile/action.cfg
share/avifile/mute.ppm
share/avifile/open.ppm
share/avifile/opena.ppm

View File

@ -6,7 +6,7 @@
#
PORTNAME= avifile
PORTVERSION= 0.7.16.20020913
PORTVERSION= 0.7.18.20021107
PORTEPOCH= 2
CATEGORIES= graphics
MASTER_SITES= http://avifile.sourceforge.net/
@ -27,7 +27,6 @@ INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:C/^(.{3}).*/\1/}-${PORTVERSION:C/^(.{6}).+$/\1/}
USE_LIBTOOL= yes
LIBTOOLFILES= acinclude.m4
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib" \
@ -59,8 +58,13 @@ WITHOUT_XVID=yes
.endif
# compilation optimizations
.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
.if defined(WITH_OPTIMIZED_CFLAGS)
CONFIGURE_ARGS+= --enable-release
. if ${ARCH} == "i386"
CONFIGURE_ARGS+= --enable-x86opt
. endif
.else
CONFIGURE_ARGS+= --disable-release
.endif
# soundblaster can be passed ac3 instead of letting avifile decode
@ -145,9 +149,9 @@ PLIST_SUB+= XVID="@comment "
.endif
pre-everything::
.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "You can disable compilation optimizations by defining"
@${ECHO_MSG} " WITHOUT_OPTIMIZED_CFLAGS."
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "You can enable compilation optimizations by defining"
@${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS."
.endif
.if !defined(WITH_AC3_PASSTHROUGH)
@${ECHO_MSG} "You can enable soundblaster ac3 passthrough support by"
@ -179,33 +183,15 @@ packet 'pth' is installed.";\
${FALSE};\
fi
# insure that ports' liba52 is being used
post-extract:
.if !defined(WITHOUT_A52)
@${RM} -Rf ${WRKSRC}/ffmpeg/libavcodec/liba52
@${MKDIR} ${WRKSRC}/ffmpeg/libavcodec/liba52
@${TOUCH} ${WRKSRC}/ffmpeg/libavcodec/liba52/Makefile.in
.endif
# grab does not work outside Linux for now
@${RM} -f ${WRKSRC}/ffmpeg/libav/grab.c
@${TOUCH} ${WRKSRC}/ffmpeg/libav/grab.c
post-patch:
.if !defined(WITHOUT_A52)
@${REINPLACE_CMD} -e 's|-la52|${LIBA52_DEP_LIBS} -la52|' \
${WRKSRC}/configure
# linux/ioctl.h -> sys/ioctl.h
@${REINPLACE_CMD} -e 's|linux/ioctl.h|sys/ioctl.h|' \
${WRKSRC}/drivers/libdha/kernelhelper/dhahelper.h
# XXX - fool ffmpeg to use ports' version of liba52, revise this
# at EVERY avifile update
@${REINPLACE_CMD} -e 's|liba52/liba52.la|${LOCALBASE}/lib/liba52.la|; \
s|SUBDIRS_LIBA52 = liba52|SUBDIRS_LIBA52 =|; \
s|mlib liba52 i386|mlib i386|' \
${WRKSRC}/ffmpeg/libavcodec/Makefile.in
@${REINPLACE_CMD} -e 's|"liba52/a52.h"|<a52dec/a52.h>|' \
${WRKSRC}/ffmpeg/libavcodec/a52dec.c
.endif
.if !defined(WITHOUT_MAD)
@${REINPLACE_CMD} -e 's|MAD_LDADD = \@MAD_LDADD\@|MAD_LDADD = -L${LOCALBASE}/lib \@MAD_LDADD\@|' \
${WRKSRC}/plugins/libmad/Makefile.in
@ -251,10 +237,6 @@ post-patch:
s!AUTOMAKE =!AUTOMAKE = ${TRUE} || !'
post-configure:
# Libtool fix code kindly provided by Mr. Maxim Sobolev <sobomax@FreeBSD.org>
@${REINPLACE_CMD} -e \
's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
${WRKSRC}/libtool
@${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
post-install:

View File

@ -1 +1 @@
MD5 (avifile-0.7.16-20020913.tgz) = c8ea982ee735ccdb995830d18c366f1b
MD5 (avifile-0.7.18-20021107.tgz) = 27acbdb55f19cf474a109c05e0b7b377

View File

@ -0,0 +1,15 @@
--- ffmpeg/libav/http.c.orig Mon Nov 11 18:03:57 2002
+++ ffmpeg/libav/http.c Mon Nov 11 18:04:09 2002
@@ -16,11 +16,11 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
+#include <sys/types.h>
#include <sys/socket.h>
#include "avformat.h"
#include <unistd.h>
#include <ctype.h>
-#include <sys/types.h>
#include <netinet/in.h>
#ifndef __BEOS__
# include <arpa/inet.h>

View File

@ -0,0 +1,15 @@
--- ffmpeg/libav/rtp.c.orig Mon Nov 11 18:05:16 2002
+++ ffmpeg/libav/rtp.c Mon Nov 11 18:05:24 2002
@@ -16,11 +16,11 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <sys/socket.h>
#include "avformat.h"
#include <unistd.h>
#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
#ifndef __BEOS__
# include <arpa/inet.h>

View File

@ -0,0 +1,16 @@
--- ffmpeg/libav/rtpproto.c.orig Mon Nov 11 18:05:59 2002
+++ ffmpeg/libav/rtpproto.c Mon Nov 11 18:06:08 2002
@@ -16,12 +16,12 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <sys/socket.h>
#include "avformat.h"
#include <unistd.h>
#include <stdarg.h>
#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
#ifndef __BEOS__
# include <arpa/inet.h>

View File

@ -0,0 +1,16 @@
--- ffmpeg/libav/rtsp.c.orig Mon Nov 11 18:06:37 2002
+++ ffmpeg/libav/rtsp.c Mon Nov 11 18:06:51 2002
@@ -16,11 +16,12 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <netinet/in.h>
#include "avformat.h"
#include <sys/time.h>
+#include <sys/types.h>
#include <sys/socket.h>
+#include <netinet/in.h>
#ifndef __BEOS__
# include <arpa/inet.h>
#else

View File

@ -0,0 +1,15 @@
--- ffmpeg/libav/tcp.c.orig Mon Nov 11 18:07:22 2002
+++ ffmpeg/libav/tcp.c Mon Nov 11 18:07:27 2002
@@ -16,11 +16,11 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <sys/socket.h>
#include "avformat.h"
#include <unistd.h>
#include <ctype.h>
#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
#ifndef __BEOS__
# include <arpa/inet.h>

View File

@ -0,0 +1,14 @@
--- ffmpeg/libav/udp.c.orig Mon Nov 11 18:07:52 2002
+++ ffmpeg/libav/udp.c Mon Nov 11 18:07:56 2002
@@ -16,10 +16,10 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <sys/socket.h>
#include "avformat.h"
#include <unistd.h>
#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
#ifndef __BEOS__
# include <arpa/inet.h>

View File

@ -12,6 +12,10 @@ include/avifile/audiodecoder.h
include/avifile/audioencoder.h
include/avifile/avifile.h
include/avifile/aviplay.h
include/avifile/avm_args.h
include/avifile/avm_default.h
include/avifile/avm_fourcc.h
include/avifile/avm_locker.h
include/avifile/avm_stl.h
include/avifile/configfile.h
include/avifile/cpuinfo.h
@ -81,6 +85,7 @@ lib/libaviplay.so.0
%%QT%%lib/libqavm.so.0
share/aclocal/avifile.m4
share/avifile/about.ppm
share/avifile/action.cfg
share/avifile/mute.ppm
share/avifile/open.ppm
share/avifile/opena.ppm