- Update to 5.0.0
PR: 145243 Submitted by: Kevin Oberman <oberman@es.net> (maintainer)
This commit is contained in:
parent
c062e1f1c1
commit
25ac36cc48
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=251982
@ -6,37 +6,21 @@
|
||||
#
|
||||
|
||||
PORTNAME= irrtoolset
|
||||
PORTVERSION= 4.8.5
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 5.0.0
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= ${MASTER_SITE_ISC} \
|
||||
ftp://ftp.ripe.net/tools/
|
||||
MASTER_SITE_SUBDIR=IRRToolSet/${DISTNAME}
|
||||
DISTNAME= IRRToolSet-${PORTVERSION}
|
||||
MASTER_SITES= ISC/IRRToolSet/IRRToolSet-${PORTVERSION}
|
||||
|
||||
MAINTAINER= oberman@es.net
|
||||
COMMENT= A suite of routing policy tools to interact with the IRR
|
||||
|
||||
PLIST_FILES= bin/rpslcheck bin/peval bin/RtConfig
|
||||
PLIST_FILES= bin/rpslcheck bin/peval bin/rtconfig
|
||||
|
||||
USE_BISON= build
|
||||
USE_GMAKE= yes
|
||||
USE_GCC= 3.4
|
||||
GNU_CONFIGURE= Yes
|
||||
USE_AUTOTOOLS= libtool:22
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
MAN1= RtConfig.1 peval.1 rpslcheck.1 IRR-Errors.1
|
||||
MAN3= librpsl.3
|
||||
|
||||
ALL_TARGET= depend all
|
||||
|
||||
post-extract:
|
||||
@${RM} ${WRKSRC}/man/man1/CIDRAdvisor.1 ${WRKSRC}/man/man1/prpath.1
|
||||
@${RM} ${WRKSRC}/man/man1/prtraceroute.1 ${WRKSRC}/man/man1/?oe.1
|
||||
@${MV} ${WRKSRC}/man/man1/Errors.1 ${WRKSRC}/man/man1/IRR-Errors.1
|
||||
|
||||
post-patch:
|
||||
@${SED} -i.orig -e 's|#include <malloc.h>|/* #include <malloc.h> */|' \
|
||||
${WRKSRC}/src/irr/birdwhoisc.cc
|
||||
@${RM} ${WRKSRC}/man/man1/*.orig
|
||||
MAN1= rtconfig.1 peval.1 rpslcheck.1 irrtoolset-errors.1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (IRRToolSet-4.8.5.tar.gz) = 30003e1c0403462d7e0148bca0674062
|
||||
SHA256 (IRRToolSet-4.8.5.tar.gz) = b520b292d4d0fd48b1ee8d66a1f8639ecdc217d80ad278f2fe4bf665d25d87e2
|
||||
SIZE (IRRToolSet-4.8.5.tar.gz) = 988737
|
||||
MD5 (irrtoolset-5.0.0.tar.gz) = 8229443bf995e8f911fe2810229d4eb9
|
||||
SHA256 (irrtoolset-5.0.0.tar.gz) = 67dc89d1762480e54215ec5ab3320061d2f5a310348b24dcaf0e5c19dbb6c009
|
||||
SIZE (irrtoolset-5.0.0.tar.gz) = 611849
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- man/man1/RtConfig.1.orig Sun Oct 1 04:23:32 2006
|
||||
+++ man/man1/RtConfig.1 Thu Dec 7 14:09:06 2006
|
||||
@@ -587,7 +587,7 @@
|
||||
.PP
|
||||
For more error descriptions, please see
|
||||
.B
|
||||
-Errors
|
||||
+IRR-Errors
|
||||
manual page.
|
||||
.SH AUTHORS AND CONTRIBUTORS
|
||||
Cengiz Alaettinoglu <cengiz@isi.edu>
|
@ -1,20 +0,0 @@
|
||||
--- man/man1/peval.1.orig Sun Oct 1 04:23:32 2006
|
||||
+++ man/man1/peval.1 Thu Dec 7 14:07:34 2006
|
||||
@@ -199,7 +199,7 @@
|
||||
Unknown protocol!
|
||||
.RS
|
||||
.PP
|
||||
-Connection to IRR server failed. This can be caused by various reasons, please see Errors manpage, IRR Communication errors.
|
||||
+Connection to IRR server failed. This can be caused by various reasons, please see IRR-Errors manpage, IRR Communication errors.
|
||||
.PP
|
||||
.RE
|
||||
***Error: badly formed filter.
|
||||
@@ -210,7 +210,7 @@
|
||||
.RE
|
||||
For more error descriptions, please see
|
||||
.B
|
||||
-Errors manual page.
|
||||
+IRR-Errors manual page.
|
||||
.SH AUTHORS
|
||||
Cengiz Alaettinoglu <cengiz@isi.edu>
|
||||
.PP
|
@ -1,11 +0,0 @@
|
||||
--- man/man1/rpslcheck.1.orig Thu Jun 8 08:16:26 2006
|
||||
+++ man/man1/rpslcheck.1 Thu Dec 7 14:06:40 2006
|
||||
@@ -143,7 +143,7 @@
|
||||
.RE
|
||||
For more error descriptions, please see
|
||||
.B
|
||||
-Errors
|
||||
+IRR-Errors
|
||||
manual page.
|
||||
.SH AUTHORS
|
||||
Cengiz Alaettinoglu <cengiz@isi.edu>
|
@ -1,12 +1,12 @@
|
||||
RAToolSet is a suite of policy analysis tools. It is implemented in C++ on a
|
||||
UNIX platform. It has been ported successfully to many platforms including
|
||||
Sun Sparc stations running SunOS 4.1.3 or Solaris, FreeBSD, DEC Alphas
|
||||
running OSF/1, and BSDI. It contains the following programs:
|
||||
running OSF/1, and BSDI. It contains the following programs:
|
||||
|
||||
RtConfig routing policies analyzer and router configuration tool
|
||||
rtconfig routing policy analyzer and router configuration tool
|
||||
|
||||
peval a low-level policy evaluation tool
|
||||
|
||||
rpslcheck sytax checks the aut-num policy for an AS.
|
||||
rpslcheck syntax checks the aut-num policy for an AS
|
||||
|
||||
WWW: http://www.isc.org/index.pl?/sw/IRRToolSet/
|
||||
WWW: http://irrtoolset.isc.org/
|
||||
|
Loading…
Reference in New Issue
Block a user