Unbreak on CURRENT. Re-sort MASTER_SITES

PR:		47439
Submitted by:	Sergei Kolobov <sergei@kolobov.com>
This commit is contained in:
Tilman Keskinoz 2003-01-24 23:13:30 +00:00
parent 3b12786f79
commit 2553243461
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=73956
2 changed files with 21 additions and 7 deletions

View File

@ -9,24 +9,27 @@ PORTNAME= opencdk
PORTVERSION= 0.4.1
CATEGORIES= security
MASTER_SITES= http://gd.tuwien.ac.at/privacy/gnupg/alpha/gnutls/opencdk/ \
ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/opencdk/ \
http://www.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/
ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/opencdk/ \
ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
ftp://ftp.gnutls.org/pub/gnutls/opencdk/
MAINTAINER= sergei@kolobov.com
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
gcrypt.6:${PORTSDIR}/security/libgcrypt
LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lgnugetopt"
CONFIGURE_ARGS= --with-libgcrypt-prefix=${LOCALBASE}
USE_REINPLACE= yes
DOCS= AUTHORS NEWS README THANKS
post-patch:
${REINPLACE_CMD} -e 's,#include <malloc.h>,#include<stdlib.h>,' \
${WRKSRC}/src/encrypt.c ${WRKSRC}/src/main.c
post-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/tests/*.c ${EXAMPLESDIR}

View File

@ -0,0 +1,11 @@
--- tests/Makefile.in.orig Fri Jan 24 19:06:07 2003
+++ tests/Makefile.in Fri Jan 24 19:06:36 2003
@@ -97,6 +97,8 @@
EXTRA_DIST = pub.gpg sec.gpg sec-with-pwd.gpg ts.gpg wkold.gpg
+AM_CPPFLAGS = $(LIBGCRYPT_CFLAGS)
+
INCLUDES = -I$(top_srcdir)/src
LDADD = ../src/libopencdk.la $(LIBGCRYPT_LIBS)