upgrade to 1.0.18
This commit is contained in:
parent
57738dc255
commit
25508aacf9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=106298
@ -7,7 +7,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= dbh
|
||||
PORTVERSION= 1.0.17
|
||||
PORTVERSION= 1.0.18
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -16,9 +16,9 @@ DISTNAME= ${PORTNAME}_${PORTVERSION:R}-${PORTVERSION:E}
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Disk Based Hashtables
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GNOME= gnomehack gnometarget pkgconfig
|
||||
USE_LIBTOOL_VER= 13
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (dbh_1.0-17.tar.gz) = 5edde82192ea481a073ee312d4e86104
|
||||
SIZE (dbh_1.0-17.tar.gz) = 594330
|
||||
MD5 (dbh_1.0-18.tar.bz2) = dca09e2949616471669320e3429a49ef
|
||||
SIZE (dbh_1.0-18.tar.bz2) = 344473
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- configure.orig Mon Mar 17 12:08:31 2003
|
||||
+++ configure Wed Jul 30 20:58:14 2003
|
||||
@@ -7349,6 +7349,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
15
databases/dbh/files/patch-ltmain.sh
Normal file
15
databases/dbh/files/patch-ltmain.sh
Normal file
@ -0,0 +1,15 @@
|
||||
--- ltmain.sh.orig Tue Apr 6 15:43:05 2004
|
||||
+++ ltmain.sh Tue Apr 6 15:43:18 2004
|
||||
@@ -5436,10 +5436,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
@ -2,7 +2,8 @@
|
||||
include/dbh.h
|
||||
include/dbh_config.h
|
||||
include/dbh_functions.h
|
||||
lib/libdbh-1.0.so
|
||||
lib/libdbh-1.0.so.1
|
||||
lib/libdbh.a
|
||||
lib/libdbh.so
|
||||
lib/libdbh.so.1
|
||||
libdata/pkgconfig/dbh-1.0.pc
|
||||
|
@ -7,7 +7,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= dbh
|
||||
PORTVERSION= 1.0.17
|
||||
PORTVERSION= 1.0.18
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -16,9 +16,9 @@ DISTNAME= ${PORTNAME}_${PORTVERSION:R}-${PORTVERSION:E}
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Disk Based Hashtables
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GNOME= gnomehack gnometarget pkgconfig
|
||||
USE_LIBTOOL_VER= 13
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (dbh_1.0-17.tar.gz) = 5edde82192ea481a073ee312d4e86104
|
||||
SIZE (dbh_1.0-17.tar.gz) = 594330
|
||||
MD5 (dbh_1.0-18.tar.bz2) = dca09e2949616471669320e3429a49ef
|
||||
SIZE (dbh_1.0-18.tar.bz2) = 344473
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- configure.orig Mon Mar 17 12:08:31 2003
|
||||
+++ configure Wed Jul 30 20:58:14 2003
|
||||
@@ -7349,6 +7349,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
15
databases/dbh10/files/patch-ltmain.sh
Normal file
15
databases/dbh10/files/patch-ltmain.sh
Normal file
@ -0,0 +1,15 @@
|
||||
--- ltmain.sh.orig Tue Apr 6 15:43:05 2004
|
||||
+++ ltmain.sh Tue Apr 6 15:43:18 2004
|
||||
@@ -5436,10 +5436,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
@ -2,7 +2,8 @@
|
||||
include/dbh.h
|
||||
include/dbh_config.h
|
||||
include/dbh_functions.h
|
||||
lib/libdbh-1.0.so
|
||||
lib/libdbh-1.0.so.1
|
||||
lib/libdbh.a
|
||||
lib/libdbh.so
|
||||
lib/libdbh.so.1
|
||||
libdata/pkgconfig/dbh-1.0.pc
|
||||
|
Loading…
Reference in New Issue
Block a user