o Update to 1.1

o Deploy OPTIONS

PR:		72206
Submitted by:	ahze
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2004-11-10 01:02:45 +00:00
parent a2f636b22c
commit 2511267b0f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=121266
16 changed files with 408 additions and 251 deletions

View File

@ -6,171 +6,227 @@
#
PORTNAME= mpeg4ip
PORTVERSION= 1.0
PORTREVISION= 1
PORTVERSION= 1.1
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= ${PKG_NAME_SUFFIX}
MAINTAINER= lioux@FreeBSD.org
COMMENT= Standards-based system to encode, stream and play MPEG-4 audio/video
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm \
pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= faac.0:${PORTSDIR}/audio/faac \
faad.0:${PORTSDIR}/audio/faad \
mp3lame.0:${PORTSDIR}/audio/lame \
id3tag.2:${PORTSDIR}/audio/libid3tag \
a52.0:${PORTSDIR}/audio/liba52 \
mpeg2.0:${PORTSDIR}/multimedia/libmpeg2 \
avcodec.0:${PORTSDIR}/multimedia/ffmpeg
USE_GNOME= gtk20
USE_GMAKE= yes
USE_GNOME= \
gtk20 \
lthack
USE_SDL= sdl
USE_INC_LIBTOOL_VER=13
USE_GMAKE= yes
USE_INC_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_ARGS= --datadir=${DATADIR} \
--with-glib-prefix=${LOCALBASE} \
--with-gtk-prefix=${X11BASE} \
--program-transform-name=''
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-ffmpeg=${LOCALBASE} \
--enable-mp4live \
--disable-static
INSTALLS_SHLIB= yes
DOC_FILES= COPYING README doc/MPEG4IP_Guide.pdf
PORTDOCS= COPYING MPEG4IP_Guide.pdf README
OPTIONS= ARTS "Enable Arts Support" Off \
ESOUND "Enable Esound Support" Off \
IPV6 "Enable IPV6 Support" On \
NAS "Enable Nas Support" Off \
OPTIMIZED_CFLAGS "Enable compilation optimizations" Off \
XVID "Enable XVID Support" On
DOCS_FILES= ${PORTDOCS}
PORTDOCS= MAINREADME.html MP4LIVE_INTERNALS.html MPEG4IP_Guide.pdf \
MP4LIVE_README.html PLAYER_INTERNALS.html PLAYER_README.html \
ReadingList.txt ReadingList.txt encoding.htm m4rm.html \
mp4player.jpg mrm.html pi.html prm.html
MAN1= gmp4player.1 mp4creator.1 mp4encode.1 mp4live.1
MAN3= MP4.3 MP4AddAudioTrack.3 MP4AddHintTrack.3 MP4AddODTrack.3 \
MP4AddRtpESConfigurationPacket.3 MP4AddRtpHint.3 \
MP4AddRtpImmediateData.3 MP4AddRtpPacket.3 MP4AddRtpSampleData.3 \
MP4AddRtpVideoHint.3 MP4AddSceneTrack.3 MP4AddSystemsTrack.3 \
MP4AddTrack.3 MP4AddVideoTrack.3 MP4AppendHintTrackSdp.3 \
MP4AddTrackEdit.3 \
MAN3= MP4.3 MP4AddAudioTrack.3 MP4AddHintTrack.3 MP4AddODTrack.3 \
MP4AddRtpESConfigurationPacket.3 MP4AddRtpHint.3 MP4AddRtpImmediateData.3 \
MP4AddRtpPacket.3 MP4AddRtpSampleData.3 MP4AddRtpVideoHint.3 \
MP4AddSceneTrack.3 MP4AddSystemsTrack.3 MP4AddTrack.3 \
MP4AddTrackEdit.3 MP4AddVideoTrack.3 MP4AppendHintTrackSdp.3 \
MP4AppendSessionSdp.3 MP4BinaryToBase16.3 MP4BinaryToBase64.3 \
MP4CloneTrack.3 \
MP4Close.3 MP4ConvertFromMovieDuration.3 \
MP4CloneTrack.3 MP4Close.3 MP4ConvertFromMovieDuration.3 \
MP4ConvertFromTrackDuration.3 MP4ConvertFromTrackTimestamp.3 \
MP4ConvertToTrackDuration.3 MP4ConvertToTrackTimestamp.3 \
MP4CopySample.3 MP4CopyTrack.3 MP4DeleteTrackEdit.3 \
MP4Create.3 MP4DeleteTrack.3 MP4Dump.3 MP4FindTrackId.3 \
MP4FileInfo.3 \
MP4CopySample.3 MP4CopyTrack.3 MP4Create.3 MP4DeleteTrack.3 \
MP4DeleteTrackEdit.3 MP4Dump.3 MP4FileInfo.3 MP4FindTrackId.3 \
MP4FindTrackIndex.3 MP4GetAudioProfileLevel.3 MP4GetDuration.3 \
MP4GetGraphicsProfileLevel.3 MP4GetHintTrackReferenceTrackId.3 \
MP4GetHintTrackRtpPayload.3 MP4GetHintTrackSdp.3 \
MP4GetNumberOfTracks.3 MP4GetODProfileLevel.3 \
MP4GetRtpHintNumberOfPackets.3 MP4GetRtpPacketBFrame.3 \
MP4GetRtpPacketTransmitOffset.3 MP4GetRtpTimestampStart.3 \
MP4GetSampleDuration.3 MP4GetSampleIdFromTime.3 \
MP4GetSampleIdFromEditTime.3 \
MP4GetSampleRenderingOffset.3 MP4GetSampleSize.3 \
MP4GetSampleSync.3 MP4GetSampleTime.3 MP4GetSceneProfileLevel.3 \
MP4GetSessionSdp.3 MP4GetTimeScale.3 MP4GetTrackAudioType.3 \
MP4GetTrackBitRate.3 MP4GetTrackDuration.3 \
MP4GetTrackESConfiguration.3 MP4GetTrackFixedSampleDuration.3 \
MP4GetTrackMaxSampleSize.3 MP4GetTrackNumberOfSamples.3 \
MP4GetTrackTimeScale.3 MP4GetTrackType.3 \
MP4GetTrackAudioMpeg4Type.3 MP4GetTrackEditDuration.3 \
MP4GetTrackEditDwell.3 MP4GetTrackEditMediaStart.3 \
MP4GetTrackEditStart.3 MP4GetTrackEditTotalDuration.3 \
MP4GetTrackNumberOfEdits.3 \
MP4GetTrackVideoFrameRate.3 MP4GetTrackVideoHeight.3 \
MP4GetHintTrackRtpPayload.3 MP4GetHintTrackSdp.3 MP4GetNumberOfTracks.3 \
MP4GetODProfileLevel.3 MP4GetRtpHintNumberOfPackets.3 MP4GetRtpPacketBFrame.3 \
MP4GetRtpPacketTransmitOffset.3 MP4GetRtpTimestampStart.3 MP4GetSampleDuration.3 \
MP4GetSampleIdFromEditTime.3 MP4GetSampleIdFromTime.3 MP4GetSampleRenderingOffset.3 \
MP4GetSampleSize.3 MP4GetSampleSync.3 MP4GetSampleTime.3 \
MP4GetSceneProfileLevel.3 MP4GetSessionSdp.3 MP4GetTimeScale.3 \
MP4GetTrackAudioMpeg4Type.3 MP4GetTrackAudioType.3 MP4GetTrackBitRate.3 \
MP4GetTrackDuration.3 MP4GetTrackESConfiguration.3 MP4GetTrackEditDuration.3 \
MP4GetTrackEditDwell.3 MP4GetTrackEditMediaStart.3 MP4GetTrackEditStart.3 \
MP4GetTrackEditTotalDuration.3 MP4GetTrackFixedSampleDuration.3 MP4GetTrackMaxSampleSize.3 \
MP4GetTrackNumberOfEdits.3 MP4GetTrackNumberOfSamples.3 MP4GetTrackTimeScale.3 \
MP4GetTrackType.3 MP4GetTrackVideoFrameRate.3 MP4GetTrackVideoHeight.3 \
MP4GetTrackVideoType.3 MP4GetTrackVideoWidth.3 MP4GetVerbosity.3 \
MP4GetVideoProfileLevel.3 MP4MakeIsmaCompliant.3 MP4Modify.3 \
MP4Info.3 \
MP4Optimize.3 MP4Read.3 MP4ReadRtpHint.3 MP4ReadRtpPacket.3 \
MP4ReadSample.3 MP4SetAudioProfileLevel.3 \
MP4ReadSampleFromEditTime.3 MP4ReadSampleFromTime.3 \
MP4SetGraphicsProfileLevel.3 MP4SetHintTrackRtpPayload.3 \
MP4SetHintTrackSdp.3 MP4SetODProfileLevel.3 \
MP4SetRtpTimestampStart.3 MP4SetSampleRenderingOffset.3 \
MP4SetSceneProfileLevel.3 MP4SetSessionSdp.3 MP4SetTimeScale.3 \
MP4SetTrackEditDuration.3 MP4SetTrackEditDwell.3 \
MP4SetTrackEditMediaStart.3 \
MP4SetTrackESConfiguration.3 MP4SetTrackTimeScale.3 \
MP4SetVerbosity.3 MP4SetVideoProfileLevel.3 MP4WriteRtpHint.3 \
MP4WriteSample.3
post-extract:
.for dir in SDL
@${RM} -Rf ${WRKSRC}/lib/${dir}
.endfor
MP4GetVideoProfileLevel.3 MP4Info.3 MP4MakeIsmaCompliant.3 \
MP4Modify.3 MP4Optimize.3 MP4Read.3 MP4ReadRtpHint.3 MP4ReadRtpPacket.3 \
MP4ReadSample.3 MP4ReadSampleFromEditTime.3 MP4ReadSampleFromTime.3 \
MP4SetAudioProfileLevel.3 MP4SetGraphicsProfileLevel.3 MP4SetHintTrackRtpPayload.3 \
MP4SetHintTrackSdp.3 MP4SetODProfileLevel.3 MP4SetRtpTimestampStart.3 \
MP4SetSampleRenderingOffset.3 MP4SetSceneProfileLevel.3 MP4SetSessionSdp.3 \
MP4SetTimeScale.3 MP4SetTrackESConfiguration.3 MP4SetTrackEditDuration.3 \
MP4SetTrackEditDwell.3 MP4SetTrackEditMediaStart.3 MP4SetTrackTimeScale.3 \
MP4SetVerbosity.3 MP4SetVideoProfileLevel.3 MP4WriteRtpHint.3 MP4WriteSample.3
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
BROKEN= "Does not compile on FreeBSD >= 5.x"
.endif
.if exists(${LOCALBASE}/include/systems.h)
CONFLICTS= faad*
# Build fix
.if ${OSVERSION} >= 502100
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-lib::sdp::sdp_decode.c
.else
USE_GCC= 3.4
.endif
# XXX - temporary fix, not suitable for binaries
.if ${ARCH} == "amd64"
CFLAGS+= -fPIC -DPIC
.endif
###
## Auto detect possible extensions
###
# arts
.if exists(${LOCALBASE}/lib/libartsc.so.0)
WITH_ARTS= yes
.endif
# esound
.if ${HAVE_GNOME:Mesound}!=""
WITH_ESOUND= yes
.endif
# nas
.if exists(${LOCALBASE}/lib/libaudio.so.2)
WITH_NAS= yes
.endif
# xvid
.if exists(${LOCALBASE}/lib/libxvidcore.so.4)
WITH_XVID= yes
.endif
###
## Enable extensions based on user choices
###
# arts
.if defined(WITH_ARTS)
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
.endif
# esound
.if defined(WITH_ESOUND)
USE_GNOME+= esound
PKG_NAME_SUFFIX+=-esound
.endif
# nas
.if defined(WITH_NAS)
LIB_DEPENDS+= audio.2:${PORTSDIR}/audio/nas
.endif
# xvid
.if defined(WITH_XVID)
LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
PLIST_SUB+= XVID=""
.else
PLIST_SUB+= XVID="@comment "
.endif
post-patch:
# don't compile or use libmp4v2
@${REINPLACE_CMD} -e 's|mp4v2||' ${WRKSRC}/lib/Makefile.in
@${REINPLACE_CMD} -e 's|-I$(top_srcdir)/lib/mp4v2||; \
s|$$(top_builddir)/lib/mp4v2/libmp4v2.la||; \
s|@LIBS@|@LIBS@ -lmp4v2|' \
${WRKSRC}/player/src/Makefile.in \
${WRKSRC}/lib/mpeg2t/Makefile.in \
${WRKSRC}/util/*/Makefile.in \
${WRKSRC}/server/*/Makefile.in
@${REINPLACE_CMD} -e 's|-I$(top_srcdir)/lib/mp4v2||; \
s|../mp4v2/libmp4v2.la||; s|@LIBS@|@LIBS@ -lmp4v2|' \
${WRKSRC}/lib/mp4av/Makefile.in
@${REINPLACE_CMD} -e 's|mp4venc_template.par||' \
${WRKSRC}/server/util/mp4encode/Makefile.in
@${FIND} ${WRKSRC} -type f -name "*.[ch]" -or -name "*.cpp" | ${XARGS} -n 10 \
${REINPLACE_CMD} -e \
's|<stdint.h>|<inttypes.h>|; \
s|mp4v2/mp4.h|mp4.h|; \
s|<malloc.h>|<stdlib.h>|; \
s|<SDL/|<SDL11/|; \
s|<strstream.h>|<iostream>|'
# replacing distfile's libs with ports' versions
# CFLAGS safeness
# SDL related fixes
# a few others
@${REINPLACE_CMD} -E -e 's|lib/SDL/sdl-config|${SDL_CONFIG}|; \
s|sdl-config|${SDL_CONFIG}|; \
s|^(SDL_LIBS=).+$$|\1"`${SDL_CONFIG} --libs`"|; \
s|-Wmissing-declarations||' \
s|-Wmissing-declarations||; s|-Wmissing-prototypes||; \
s|>&/|>/|' \
${CONFIGURE_WRKSRC}/configure
@${FIND} ${WRKSRC} -type f -name "Makefile.in" | ${XARGS} \
-n 10 ${REINPLACE_CMD} -E -e \
's|-I[^ ]+lib/SDL/include|-I${LOCALBASE}/include/SDL11|; \
s|-O[0-3]|-O|; \
s|\$$[^ ]+/lib/SDL/src/main/libSDLmain.a|${LOCALBASE}/lib/libSDLmain-1.1.a|'
@${REINPLACE_CMD} -E -e \
's!SDL_(AudioDelayMsec|HasAudioDelayMsec).*;$$!0;!' \
${WRKSRC}/player/src/audio_sdl.cpp
# do not install manm man pages
@${REINPLACE_CMD} -E \
-e 's|api.mpt||' \
-e 's|^(install-man.*)install-manm|\1|' \
${WRKSRC}/doc/mp4v2/Makefile.in
# Disable xvid support - mpep4ip doesn't support xvid 1.0.x, but tries
# to use it anyway.
@${REINPLACE_CMD} -e 's|use_mpeg4ip_xvid=false|use_mpeg4ip_xvid=true|g' \
-e 's|#define HAVE_XVID_H 1||g' \
${WRKSRC}/configure
.if ${ARCH} != "i386"
# emms opcode should be noop in non-i386 non-MMX ARCH
@${ECHO_CMD} '#define EMMS()' \
>> ${WRKSRC}/lib/xvid/portab.h
.endif
post-configure:
# disable GNU auto* tools
# remove -Werror
@${FIND} ${WRKSRC} -type f -name "Makefile" | ${XARGS} \
-n 10 ${REINPLACE_CMD} -E -e \
's! (autoconf|autoheader|automake|aclocal)$$! ${TRUE}!; \
s|-Werror||g'
# XXX - reminder for a future release
#post-configure:
# configure is not propagating PTHREAD_LIBS to the makefiles
# investigated by David Yeske <dyeske@yahoo.com>
.if ${OSVERSION} >= 500000
@${REINPLACE_CMD} -E \
-e 's|(-lSDL-...)|"${PTHREAD_LIBS} \1"|' \
${WRKSRC}/player/src/Makefile \
${WRKSRC}/util/yuv/Makefile \
${WRKSRC}/util/iptv/Makefile
.endif
#.if ${OSVERSION} >= 500000
# @${REINPLACE_CMD} -E \
# -e 's|(-lSDL-...)|${PTHREAD_LIBS} \1|' \
# ${WRKSRC}/player/src/Makefile \
# ${WRKSRC}/util/yuv/Makefile \
# ${WRKSRC}/util/iptv/Makefile
#.endif
post-install:
@${MKDIR} ${DATADIR}
@${INSTALL_DATA} \
${WRKSRC}/server/util/mp4encode/mp4venc_template.par \
${DATADIR}
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for files in ${DOC_FILES}
@${INSTALL_DATA} ${WRKSRC}/${files} ${DOCSDIR}/${files:C|^[^/]+/||}
@${INSTALL_DATA} ${WRKSRC}/doc/${files} ${DOCSDIR}
.endfor
.endif
###
## Arch extensions detection
###
# i386 specifics
.if ${ARCH} != "i386"
WITHOUT_MMX= yes
.else
.if ${OSVERSION} < 470000
. if (defined(MACHINE_CPU) && ${MACHINE_CPU:Mi486} == "i486")
WITH_OPTIMIZED_BYTESWAP=yes
OPTIONS+= OPTIMIZED_BYTESWAP "Enable optimized byteswap routines" On
. else
OPTIONS+= OPTIMIZED_BYTESWAP "Enable optimized byteswap routines" Off
. endif
.endif
. if (defined(MACHINE_CPU) && ${MACHINE_CPU:Mmmx} == "mmx")
OPTIONS+= MMX "Enable MMX Optimizations" On
. else
OPTIONS+= MMX "Enable MMX Optimizations" Off
. endif
. if defined(WITH_OPTIMIZED_BYTESWAP)
@ -178,35 +234,26 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-include::mpeg4ip_byteswap.h
. endif
.endif
###
## FreeBSD extensions detection
###
# ipv6
.if ${OSVERSION} >= 400014 && !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
.endif
###
## Enable extensions based on arch detection
###
# mmx
.ifdef(WITHOUT_MMX)
CONFIGURE_ARGS+= --disable-mmx
.else
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.endif
# compiler optimizations
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
pre-everything::
.ifndef(WITHOUT_IPV6)
@${ECHO_MSG} '===> Define WITHOUT_IPV6 if you want to disable IPv6 support'
.endif
.ifndef(WITHOUT_MMX)
@${ECHO_MSG} '===> Define WITHOUT_MMX if your system does not support MMX'
.endif
.ifndef(WITH_OPTIMIZED_BYTESWAP)
@${ECHO_MSG}
@${ECHO_MSG} '===> Define WITH_OPTIMIZED_BYTESWAP to use optimized byteswap'
@${ECHO_MSG} '===> routines. This works only in the i386 architecture, and'
@${ECHO_MSG} '===> only with 486 processors and above.'
.endif
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG}
@${ECHO_MSG} '===> You can enable additional compilation optimizations'
@${ECHO_MSG} '===> by defining WITH_OPTIMIZED_CFLAGS'
.endif
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
MD5 (mpeg4ip-1.0.tar.gz) = 6ac635a1dd02d874054d6092f350157c
SIZE (mpeg4ip-1.0.tar.gz) = 5442521
MD5 (mpeg4ip-1.1.tar.gz) = fef0224a45485653a8db87bdd5c9e745
SIZE (mpeg4ip-1.1.tar.gz) = 4351378

View File

@ -0,0 +1,20 @@
--- lib/sdp/sdp_decode.c.orig Thu Sep 30 01:32:23 2004
+++ lib/sdp/sdp_decode.c Thu Sep 30 01:32:45 2004
@@ -378,7 +378,7 @@
q = NULL;
while (p != NULL) {
if (new->adj_time == p->adj_time) {
- sdp_debug(LOG_NOTICE, "Duplicate time %ld in adj description", p->adj_time);
+ sdp_debug(LOG_NOTICE, "Duplicate time %d in adj description", p->adj_time);
free(new);
return (start);
}
@@ -1580,7 +1580,7 @@
continue;
}
// process <adjustment time> - adjust it from NTP to unix time
- sscanf(sep, "%ld", &adj_time);
+ sscanf(sep, "%d", &adj_time);
// Check for negative sign for offset.
ADV_SPACE(lptr);

View File

@ -0,0 +1,16 @@
--- common/video/libmpeg32/video/Makefile.in.orig Tue Sep 28 23:54:37 2004
+++ common/video/libmpeg32/video/Makefile.in Tue Sep 28 23:55:25 2004
@@ -290,11 +290,11 @@
@AMDEP_TRUE@ ./$(DEPDIR)/seek.Plo ./$(DEPDIR)/slice.Plo \
@AMDEP_TRUE@ ./$(DEPDIR)/vlc.Plo
CCASCOMPILE = $(CCAS) $(AM_CCASFLAGS) $(CCASFLAGS)
-LTCCASCOMPILE = $(LIBTOOL) --mode=compile $(CCAS) $(AM_CCASFLAGS) \
+LTCCASCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CCAS) $(AM_CCASFLAGS) \
$(CCASFLAGS)
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \

View File

@ -0,0 +1,12 @@
--- common/video/mpeg4-2000/idct/idct.hpp.orig Thu Sep 30 01:01:36 2004
+++ common/video/mpeg4-2000/idct/idct.hpp Thu Sep 30 01:01:56 2004
@@ -22,6 +22,9 @@
#ifndef _INT_IDCT_
#define _INT_IDCT_ 1
+#ifndef BLOCK_SIZE
+#define BLOCK_SIZE 5
+#endif
#define IDCT_BLOCK_SIZE 8
class idct{

View File

@ -1,11 +1,45 @@
--- common/video/mpeg4-2000/idct/idct.hpp.orig Fri Jul 23 01:57:47 2004
+++ common/video/mpeg4-2000/idct/idct.hpp Fri Jul 23 02:02:41 2004
@@ -22,7 +22,7 @@
#ifndef _INT_IDCT_
#define _INT_IDCT_ 1
--- common/video/mpeg4-2000/tools/entropy/huffman.cpp.orig Tue Sep 28 22:51:26 2004
+++ common/video/mpeg4-2000/tools/entropy/huffman.cpp Tue Sep 28 22:51:47 2004
@@ -243,9 +243,6 @@
Void CHuffmanTree::printStatistics (Double dEntropy, Double dNOfBits, ostream &stream)
{
stream<<endl<<endl;
- stream<<"//Entropy Per Symbol : "<<dEntropy<<endl;
- stream<<"//Bits Per Symbol : "<<dNOfBits<<endl;
- stream<<"//Table Efficiency : "<<dEntropy/dNOfBits<<endl;
}
-
+#define BLOCK_SIZE 5
#define IDCT_BLOCK_SIZE 8
class idct{
public:
Int CHuffmanCoDec::makeIndexFromSymbolInTable(istream &huffmanTable)
--- common/video/mpeg4-2000/tools/entropy/bitstrm.cpp.orig Tue Sep 28 22:56:07 2004
+++ common/video/mpeg4-2000/tools/entropy/bitstrm.cpp Tue Sep 28 22:56:25 2004
@@ -323,7 +323,6 @@
if (m_pstrmTrace != NULL) {
m_pstrmTrace->width (20);
(*m_pstrmTrace) << rgchSymbolName << "= ";
- (*m_pstrmTrace) << fltValue << "\n";
m_pstrmTrace->flush ();
}
}
@@ -356,8 +355,6 @@
if (m_pstrmTrace != NULL) {
m_pstrmTrace->width (20);
(*m_pstrmTrace) << rgchSymbolName << "= ";
- (*m_pstrmTrace) << vctValue.x << ", ";
- (*m_pstrmTrace) << vctValue.y << "\n ";
m_pstrmTrace->flush ();
}
}
--- common/video/mpeg4-2000/sys/mode.cpp.orig Tue Sep 28 23:05:10 2004
+++ common/video/mpeg4-2000/sys/mode.cpp Tue Sep 28 23:05:59 2004
@@ -409,12 +409,6 @@
// if (bVOPPrint)
cout << "\t" << "Shape:" << "\t\t\t" << nBitsShape << "\n";
cout << "\t" << "Total:" << "\t\t\t" << nBitsTotal << "\n";
- cout << "\t" << "SNR Y:" << "\t\t\t" << dSNRY / nVOPs << " dB\n";
- cout << "\t" << "SNR U:" << "\t\t\t" << dSNRU / nVOPs << " dB\n";
- cout << "\t" << "SNR V:" << "\t\t\t" << dSNRV / nVOPs << " dB\n";
- for(Int iAuxComp=0;iAuxComp<m_iAuxCompCount;iAuxComp++) // MAC (SB) 26-Nov-99
- cout << "\t" << "SNR A[" << iAuxComp << "]:" << "\t\t" << dSNRA[iAuxComp] / nVOPs << " dB\n";
- cout << "\n\t" << "average Qp:" << "\t\t" << (Double)nQp / nQMB << "\n\n";
cout.flush ();
}

View File

@ -0,0 +1,19 @@
--- include/mpeg4ip.h.orig Wed Sep 29 14:43:52 2004
+++ include/mpeg4ip.h Wed Sep 29 14:44:10 2004
@@ -160,14 +160,14 @@
#include <errno.h>
#include <stdlib.h>
-#ifdef HAVE_INTTYPES_H
#include <inttypes.h>
-#endif
#ifdef HAVE_STDINT_H
#include <stdint.h>
#endif
+#if 0
#if !defined(HAVE_INTTYPES_H) || !defined(HAVE_STDINT_H)
#error "Don't have stdint.h or inttypes.h - no way to get uint8_t"
+#endif
#endif
#include <unistd.h>

View File

@ -1,19 +1,28 @@
--- include/mpeg4ip_byteswap.h.orig Wed Nov 13 16:44:43 2002
+++ include/mpeg4ip_byteswap.h Wed Nov 13 16:44:47 2002
@@ -26,2 +26,6 @@
--- include/mpeg4ip_byteswap.h.orig Mon Jul 22 14:27:09 2002
+++ include/mpeg4ip_byteswap.h Sun Nov 7 03:57:01 2004
@@ -24,6 +24,10 @@
#include <config.h>
#endif
+#if (defined(__unix__) || defined(unix)) && !defined(USG)
+#include <sys/param.h>
+#endif
+
#if defined(WORDS_BIGENDIAN)
@@ -51,2 +55,16 @@
#define B2N_64(x) x = swap64(x)
/* All bigendian systems are fine, just ignore the swaps. */
#define B2N_16(x) (x)
@@ -55,6 +59,24 @@
* FreeBSD and Solaris don't have <byteswap.h> or any other such
* functionality!
*/
+
+#elif defined(__FreeBSD__) && __FreeBSD_version >= 470000
+#include <sys/endian.h>
+#define B2N_16(x) (be16toh(x))
+#define B2N_32(x) (be32toh(x))
+# if __FreeBSD_version >= 510000
+#define B2N_64(x) (be64toh(x))
+# else
+#define B2N_64(x) \
+ x = ((((x) & 0xff00000000000000) >> 56) | \
+ (((x) & 0x00ff000000000000) >> 40) | \
@ -23,4 +32,7 @@
+ (((x) & 0x0000000000ff0000) << 24) | \
+ (((x) & 0x000000000000ff00) << 40) | \
+ (((x) & 0x00000000000000ff) << 56))
+# endif
#elif defined(__FreeBSD__) || defined(__sun) || defined(__bsdi__) || defined(_WIN32)
#define B2N_16(x) \

View File

@ -1,11 +0,0 @@
--- lib/Makefile.in.orig Wed Jan 1 21:46:28 2003
+++ lib/Makefile.in Wed Jan 1 21:47:39 2003
@@ -110,7 +110,7 @@
am__include = @am__include@
am__quote = @am__quote@
install_sh = @install_sh@
-SUBDIRS = avi bitstream config_file fposrec gnu mp4 mp4v2 mp4av msg_queue rtp sdp SDL xvid mpeg2t SDL_VisualC
+SUBDIRS = avi bitstream config_file fposrec gnu mp4 mp4v2 mp4av msg_queue rtp sdp xvid mpeg2t
subdir = lib
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = $(top_builddir)/config.h

View File

@ -0,0 +1,15 @@
--- lib/SDLAudio/ltmain.sh.orig Sun Nov 7 21:50:06 2004
+++ lib/SDLAudio/ltmain.sh Sun Nov 7 21:50:28 2004
@@ -5425,10 +5425,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -1,30 +0,0 @@
--- lib/xvid/bitstream/h263.h.orig Wed Nov 13 16:53:29 2002
+++ lib/xvid/bitstream/h263.h Wed Nov 13 16:55:31 2002
@@ -25,6 +25,10 @@
/* #define FFMPEG_VERSION_INT 0x000405 */
/* #define FFMPEG_VERSION "0.4.5" */
+#if (defined(__unix__) || defined(unix)) && !defined(USG)
+#include <sys/param.h>
+#endif
+
#ifdef WIN32
#define CONFIG_WIN32
#endif
@@ -69,11 +73,16 @@
#define DEBUG
#endif
+#if defined(__FreeBSD__) && __FreeBSD_version >= 470000
+#include <sys/endian.h>
+#define be2me_32(x) (be32toh(x))
+#else
// code from bits/byteswap.h (C) 1997, 1998 Free Software Foundation, Inc.
#define bswap_32(x) \
((((x) & 0xff000000) >> 24) | (((x) & 0x00ff0000) >> 8) | \
(((x) & 0x0000ff00) << 8) | (((x) & 0x000000ff) << 24))
#define be2me_32(x) bswap_32(x)
+#endif
#define snprintf _snprintf

View File

@ -0,0 +1,15 @@
--- ltmain.sh.orig Thu Sep 30 04:09:46 2004
+++ ltmain.sh Thu Sep 30 04:11:06 2004
@@ -5425,10 +5425,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -1,7 +1,7 @@
--- mpeg4ip_config.h.in.orig Sun Apr 11 10:24:26 2004
+++ mpeg4ip_config.h.in Sun Apr 11 10:24:48 2004
@@ -22,13 +22,10 @@
#undef HAVE_FPOS_T_POS
--- mpeg4ip_config.h.in.orig Tue May 18 13:31:06 2004
+++ mpeg4ip_config.h.in Wed Sep 29 14:40:59 2004
@@ -25,16 +25,12 @@
#undef HAVE_FPOS_T___POS
/* Define to 1 if you have the `getopt' function. */
-#undef HAVE_GETOPT
@ -13,12 +13,15 @@
-#undef HAVE_GETOPT_LONG
/* Define to 1 if you have the `getopt_long_only' function. */
#undef HAVE_GETOPT_LONG_ONLY
@@ -58,7 +55,6 @@
-#undef HAVE_GETOPT_LONG_ONLY
/* Define to 1 if you have the `getrusage' function. */
#undef HAVE_GETRUSAGE
@@ -67,7 +63,6 @@
#undef HAVE_IPv6
/* Define to 1 if you have the `gnugetopt' library (-lgnugetopt). */
-#undef HAVE_LIBGNUGETOPT
/* Define to 1 if you have the `socket' library (-lsocket). */
#undef HAVE_LIBSOCKET
/* have libmpeg2 decoder library */
#undef HAVE_LIBMPEG2

View File

@ -0,0 +1,10 @@
--- player/src/codec/mp3/mp3_file.cpp.orig Wed Sep 29 00:24:31 2004
+++ player/src/codec/mp3/mp3_file.cpp Wed Sep 29 00:28:47 2004
@@ -126,6 +126,7 @@
descptr[1] = strdup(desc);
CHECK_AND_FREE(ret);
}
+ ret = ID3_v1_genre_description[NULL];
ret = ID3_GetAlbum(&myTag);
if (ret) {

View File

@ -0,0 +1,29 @@
--- player/src/mpeg3_rtp_bytestream.cpp.orig Thu Sep 30 03:10:31 2004
+++ player/src/mpeg3_rtp_bytestream.cpp Thu Sep 30 03:09:12 2004
@@ -32,6 +32,10 @@
#else
#define rtp_message(loglevel, fmt...) message(loglevel, "rtpbyst", fmt)
#endif
+
+uint8_t temp_ref;
+int frame_type;
+
static rtp_packet *end_of_pak (rtp_packet *start)
{
while (start->rtp_next->rtp_pak_ts == start->rtp_pak_ts)
@@ -74,7 +78,6 @@
int32_t diff;
int correct_hdr;
int dropped_seq;
- uint8_t temp_ref;
diff = m_buffer_len - m_bytes_used;
if (diff > 2) {
@@ -86,7 +89,6 @@
#endif
return (m_last_realtime);
}
- int frame_type;
m_buffer_len = 0;
dropped_seq = 0;
while (finished == 0) {

View File

@ -1,21 +1,17 @@
bin/avi2raw
bin/avidump
bin/gmp4player
bin/h264_parse
bin/lboxcrop
bin/mp4creator
bin/mp4dump
bin/mp4encode
bin/mp4extract
bin/mp4info
bin/mp4player
bin/mp4tags
bin/mp4trackdump
bin/mpeg2video_parse
bin/mpeg4ip-config
bin/mpeg4vol
bin/rgb2yuv
bin/xvidenc
bin/yuvdump
include/codec_plugin.h
include/mp4.h
include/mp4av.h
include/mp4av_aac.h
include/mp4av_adts.h
@ -27,92 +23,62 @@ include/mp4av_mpeg4.h
include/mpeg4_audio_config.h
include/mpeg4_sdp.h
include/mpeg4ip.h
include/mpeg4ip_byteswap.h
include/mpeg4ip_config.h
include/mpeg4ip_config_set.h
include/mpeg4ip_getopt.h
include/mpeg4ip_version.h
include/rtp_plugin.h
include/sdp.h
include/sdp_error.h
lib/libconfig_file.a
lib/libconfig_file.la
lib/libconfig_file.so
lib/libconfig_file.so.0
lib/libhttp.a
lib/libhttp.la
lib/libmp4.a
lib/libmp4.la
lib/libhttp.so
lib/libhttp.so.0
lib/libmp4.so
lib/libmp4.so.0
lib/libmp4av.a
lib/libmp4av.la
lib/libmp4av.so
lib/libmp4av.so.0
lib/libmp4util.a
lib/libmp4util.la
lib/libmp4util.so
lib/libmp4util.so.0
lib/libmp4v2.a
lib/libmp4v2.la
lib/libmp4v2.so
lib/libmp4v2.so.0
lib/libmpeg4ip_xvid.a
lib/libmpeg4ip_xvid.la
lib/libmpeg4ip_xvid.so
lib/libmpeg4ip_xvid.so.0
lib/libmsg_queue.a
lib/libmsg_queue.la
lib/libmpeg4ipSDL-1.2.so
lib/libmpeg4ipSDL-1.2.so.7
lib/libmpeg4ipSDL.so
lib/libmsg_queue.so
lib/libmsg_queue.so.0
lib/libsdp.a
lib/libsdp.la
lib/libsdp.so
lib/libsdp.so.0
lib/mp4player_plugin/aac_plugin.a
lib/mp4player_plugin/aac_plugin.la
lib/mp4player_plugin/a52_audio_plugin.so
lib/mp4player_plugin/a52_audio_plugin.so.0
lib/mp4player_plugin/aac_plugin.so
lib/mp4player_plugin/aac_plugin.so.0
lib/mp4player_plugin/celp_plugin.a
lib/mp4player_plugin/celp_plugin.la
lib/mp4player_plugin/celp_plugin.so
lib/mp4player_plugin/celp_plugin.so.0
lib/mp4player_plugin/h261_plugin.a
lib/mp4player_plugin/h261_plugin.la
lib/mp4player_plugin/h261_plugin.so
lib/mp4player_plugin/h261_plugin.so.0
lib/mp4player_plugin/h261_rtp_plugin.a
lib/mp4player_plugin/h261_rtp_plugin.la
lib/mp4player_plugin/h261_rtp_plugin.so
lib/mp4player_plugin/h261_rtp_plugin.so.0
lib/mp4player_plugin/isma_rtp_plugin.a
lib/mp4player_plugin/isma_rtp_plugin.la
lib/mp4player_plugin/isma_enc_rtp_plugin.so
lib/mp4player_plugin/isma_enc_rtp_plugin.so.0
lib/mp4player_plugin/isma_enc_video_rtp_plugin.so
lib/mp4player_plugin/isma_enc_video_rtp_plugin.so.0
lib/mp4player_plugin/isma_rtp_plugin.so
lib/mp4player_plugin/isma_rtp_plugin.so.0
lib/mp4player_plugin/mp3_plugin.a
lib/mp4player_plugin/mp3_plugin.la
lib/mp4player_plugin/mp3_plugin.so
lib/mp4player_plugin/mp3_plugin.so.0
lib/mp4player_plugin/mpeg3_video_plugin.a
lib/mp4player_plugin/mpeg3_video_plugin.la
lib/mp4player_plugin/mpeg2dec_video_plugin.so
lib/mp4player_plugin/mpeg2dec_video_plugin.so.0
lib/mp4player_plugin/mpeg3_video_plugin.so
lib/mp4player_plugin/mpeg3_video_plugin.so.0
lib/mp4player_plugin/mpeg4_iso_plugin.a
lib/mp4player_plugin/mpeg4_iso_plugin.la
lib/mp4player_plugin/mpeg4_iso_plugin.so
lib/mp4player_plugin/mpeg4_iso_plugin.so.0
lib/mp4player_plugin/raw_audio_plugin.a
lib/mp4player_plugin/raw_audio_plugin.la
lib/mp4player_plugin/raw_audio_plugin.so
lib/mp4player_plugin/raw_audio_plugin.so.0
lib/mp4player_plugin/raw_video_plugin.a
lib/mp4player_plugin/raw_video_plugin.la
lib/mp4player_plugin/raw_video_plugin.so
lib/mp4player_plugin/raw_video_plugin.so.0
lib/mp4player_plugin/wav_plugin.a
lib/mp4player_plugin/wav_plugin.la
lib/mp4player_plugin/wav_plugin.so
lib/mp4player_plugin/wav_plugin.so.0
lib/mp4player_plugin/xvid_plugin.a
lib/mp4player_plugin/xvid_plugin.la
lib/mp4player_plugin/xvid_plugin.so
lib/mp4player_plugin/xvid_plugin.so.0
share/mpeg4ip/mp4venc_template.par
@dirrm share/mpeg4ip
%%XVID%%lib/mp4player_plugin/xvid10_plugin.so
%%XVID%%lib/mp4player_plugin/xvid10_plugin.so.0
%%DATADIR%%/mp4venc_template.par
@dirrm %%DATADIR%%
@dirrm lib/mp4player_plugin
@unexec rmdir %D/share/doc/mpeg4ip 2>/dev/null || true