Stage japanese/man
PR: 193007 Submitted by: turutani (scphys.kyoto-uc.ac.jp)
This commit is contained in:
parent
b414c79f50
commit
24d208a48f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=366267
@ -16,18 +16,16 @@ PATCH_DIST_STRIP=-p1
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Manual display command for Japanese (EUC)
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/bin/groff:${PORTSDIR}/japanese/groff \
|
||||
jless:${PORTSDIR}/japanese/less
|
||||
|
||||
MAKE_ENV= GZCAT=${GZCAT} GZIP_CMD="${GZIP_CMD}"
|
||||
USES+= shebangfix
|
||||
SHEBANG_FILES= catman/catman.perl makewhatis/makewhatis.perl
|
||||
SHEBANG_LANG= perl
|
||||
|
||||
MANLANG= "" ja
|
||||
MAN1= jman.1 jmanpath.1 japropos.1 \
|
||||
jwhatis.1 jmakewhatis.1 jcatman.1
|
||||
MAN8= jmakewhatis.local.8 jcatman.local.8
|
||||
MANCOMPRESSED= yes
|
||||
|
||||
NO_STAGE= yes
|
||||
post-patch:
|
||||
.for file in apropos/apropos.sh catman/catman.perl \
|
||||
makewhatis/jmakewhatis.local.man \
|
||||
@ -37,8 +35,4 @@ post-patch:
|
||||
${REINPLACE_CMD} -e "s|/usr/local|${LOCALBASE}|g" ${WRKSRC}/${file}
|
||||
.endfor
|
||||
|
||||
pre-install:
|
||||
@${SETENV} PKG_PREFIX=${PREFIX} \
|
||||
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- man/Makefile Mon Jan 15 20:13:00 2001
|
||||
+++ man/Makefile Wed Jan 24 11:58:56 2001
|
||||
@@ -17,7 +17,7 @@
|
||||
CFLAGS+= -I${LIBDESTDIR}
|
||||
DPADD= ${LIBMAN}
|
||||
LDADD= ${LIBMAN}
|
||||
-.if exists(/usr/lib/libxpg4.a)
|
||||
+.if ${OSVERSION} < 400020
|
||||
LDADD+= -L/usr/lib -lxpg4
|
||||
.endif
|
||||
|
@ -1,36 +0,0 @@
|
||||
diff -ur apropos/Makefile apropos/Makefile
|
||||
--- apropos/Makefile Sun Dec 7 03:59:21 1997
|
||||
+++ apropos/Makefile Mon Jul 29 22:21:06 2002
|
||||
@@ -55,7 +55,7 @@
|
||||
|
||||
.if make(maninstall) || make(install)
|
||||
.if !defined(NOMAN)
|
||||
-.include <bsd.man.mk>
|
||||
+.include <bsd.prog.mk>
|
||||
.elif !target(maninstall)
|
||||
maninstall:
|
||||
.endif
|
||||
diff -ur catman/Makefile catman/Makefile
|
||||
--- catman/Makefile Sun Dec 7 06:11:06 1997
|
||||
+++ catman/Makefile Mon Jul 29 22:21:19 2002
|
||||
@@ -52,7 +52,7 @@
|
||||
|
||||
.if make(maninstall) || make(install)
|
||||
.if !defined(NOMAN)
|
||||
-.include <bsd.man.mk>
|
||||
+.include <bsd.prog.mk>
|
||||
.elif !target(maninstall)
|
||||
maninstall:
|
||||
.endif
|
||||
diff -ur makewhatis/Makefile makewhatis/Makefile
|
||||
--- makewhatis/Makefile Fri Sep 3 07:58:03 1999
|
||||
+++ makewhatis/Makefile Mon Jul 29 22:21:36 2002
|
||||
@@ -92,7 +92,7 @@
|
||||
|
||||
.if make(maninstall) || make(install)
|
||||
.if !defined(NOMAN)
|
||||
-.include <bsd.man.mk>
|
||||
+.include <bsd.prog.mk>
|
||||
.elif !target(maninstall)
|
||||
maninstall:
|
||||
.endif
|
51
japanese/man/files/patch-apropos__Makefile
Normal file
51
japanese/man/files/patch-apropos__Makefile
Normal file
@ -0,0 +1,51 @@
|
||||
--- apropos/Makefile.orig 1997-12-07 19:59:21.000000000 +0900
|
||||
+++ apropos/Makefile 2014-08-26 12:06:55.000000000 +0900
|
||||
@@ -8,7 +8,7 @@
|
||||
TARG= ${.CURDIR}/japropos
|
||||
.endif
|
||||
|
||||
-MLINKS= japropos.1 jwhatis.1
|
||||
+#MLINKS= japropos.1 jwhatis.1
|
||||
|
||||
MANDEPEND= ${MAN1}
|
||||
|
||||
@@ -37,28 +37,24 @@
|
||||
${.CURDIR}/japropos.man.eng | \
|
||||
${compress} > ${.TARGET}
|
||||
|
||||
-install: ${TARG} maninstall after_maninstall
|
||||
- ${INSTALL} -c -o bin -g bin -m 555 ${TARG} ${DESTDIR}${BINDIR}
|
||||
- ln -f ${DESTDIR}${BINDIR}/japropos ${DESTDIR}${BINDIR}/jwhatis
|
||||
+install: ${TARG} man_install after_maninstall
|
||||
+ ${INSTALL} -m 555 ${TARG} ${DESTDIR}${BINDIR}
|
||||
+ ln -sf japropos ${DESTDIR}${BINDIR}/jwhatis
|
||||
+
|
||||
+.if !defined(NO_MAN)
|
||||
+man_install: ${MAN1}
|
||||
+ ${INSTALL} -m 444 ${MAN1} ${DESTDIR}${MANDIR}1
|
||||
+ ln -sf japropos.1.gz ${DESTDIR}${MANDIR}1/jwhatis.1.gz
|
||||
|
||||
-.if !defined(NOMAN)
|
||||
after_maninstall: ${EMAN1}
|
||||
- ${INSTALL} -c -o bin -g bin -m 444 ${EMAN1} \
|
||||
+ ${INSTALL} -m 444 ${EMAN1} \
|
||||
${DESTDIR}${EMANDIR}1/japropos.1.gz
|
||||
- ln -f ${DESTDIR}${EMANDIR}1/japropos.1.gz \
|
||||
- ${DESTDIR}${EMANDIR}1/jwhatis.1.gz
|
||||
+ ln -sf japropos.1.gz ${DESTDIR}${EMANDIR}1/jwhatis.1.gz
|
||||
.else
|
||||
+man_install:
|
||||
after_maninstall:
|
||||
.endif
|
||||
|
||||
.include "../Makefile.inc"
|
||||
|
||||
-.if make(maninstall) || make(install)
|
||||
-.if !defined(NOMAN)
|
||||
-.include <bsd.man.mk>
|
||||
-.elif !target(maninstall)
|
||||
-maninstall:
|
||||
-.endif
|
||||
-.endif
|
||||
-
|
||||
.include <bsd.prog.mk>
|
36
japanese/man/files/patch-catman__Makefile
Normal file
36
japanese/man/files/patch-catman__Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
--- catman/Makefile.orig 1997-12-07 22:11:06.000000000 +0900
|
||||
+++ catman/Makefile 2014-08-26 12:08:09.000000000 +0900
|
||||
@@ -37,25 +37,21 @@
|
||||
${.CURDIR}/jcatman.man.eng | \
|
||||
${compress} > ${.TARGET}
|
||||
|
||||
-install: ${TARG} maninstall after_maninstall
|
||||
- ${INSTALL} -c -o bin -g bin -m 555 ${TARG} ${DESTDIR}${BINDIR}
|
||||
+install: ${TARG} man_install after_maninstall
|
||||
+ ${INSTALL} -m 555 ${TARG} ${DESTDIR}${BINDIR}
|
||||
+
|
||||
+.if !defined(NO_MAN)
|
||||
+man_install: ${MAN1}
|
||||
+ ${INSTALL} -m 444 ${MAN1} ${DESTDIR}${MANDIR}1
|
||||
|
||||
-.if !defined(NOMAN)
|
||||
after_maninstall: ${EMAN1}
|
||||
- ${INSTALL} -c -o bin -g bin -m 444 ${EMAN1} \
|
||||
+ ${INSTALL} -m 444 ${EMAN1} \
|
||||
${DESTDIR}${EMANDIR}1/jcatman.1.gz
|
||||
.else
|
||||
+man_install:
|
||||
after_maninstall:
|
||||
.endif
|
||||
|
||||
.include "../Makefile.inc"
|
||||
|
||||
-.if make(maninstall) || make(install)
|
||||
-.if !defined(NOMAN)
|
||||
-.include <bsd.man.mk>
|
||||
-.elif !target(maninstall)
|
||||
-maninstall:
|
||||
-.endif
|
||||
-.endif
|
||||
-
|
||||
.include <bsd.prog.mk>
|
58
japanese/man/files/patch-makewhatis__Makefile
Normal file
58
japanese/man/files/patch-makewhatis__Makefile
Normal file
@ -0,0 +1,58 @@
|
||||
--- makewhatis/Makefile.orig 1999-09-03 22:58:03.000000000 +0900
|
||||
+++ makewhatis/Makefile 2014-08-26 12:08:52.000000000 +0900
|
||||
@@ -24,7 +24,7 @@
|
||||
TARG2= ${.CURDIR}/jmakewhatis.local
|
||||
.endif
|
||||
|
||||
-MLINKS= jmakewhatis.local.8 jcatman.local.8
|
||||
+#MLINKS= jmakewhatis.local.8 jcatman.local.8
|
||||
|
||||
MANDEPEND= ${MAN1} ${MAN8}
|
||||
|
||||
@@ -70,32 +70,28 @@
|
||||
${.CURDIR}/jmakewhatis.local.man.eng | \
|
||||
${compress} > ${.TARGET}
|
||||
|
||||
-install: ${TARG} ${TARG2} maninstall after_maninstall
|
||||
- ${INSTALL} -c -o bin -g bin -m 555 ${TARG} ${DESTDIR}${BINDIR}
|
||||
- ${INSTALL} -c -o bin -g bin -m 555 ${TARG2} ${DESTDIR}${libexecdir}
|
||||
- ln -f ${DESTDIR}${libexecdir}/jmakewhatis.local \
|
||||
- ${DESTDIR}${libexecdir}/jcatman.local
|
||||
+install: ${TARG} ${TARG2} man_install after_maninstall
|
||||
+ ${INSTALL} -m 555 ${TARG} ${DESTDIR}${BINDIR}
|
||||
+ ${INSTALL} -m 555 ${TARG2} ${DESTDIR}${libexecdir}
|
||||
+ ln -sf jmakewhatis.local ${DESTDIR}${libexecdir}/jcatman.local
|
||||
+
|
||||
+.if !defined(NO_MAN)
|
||||
+man_install: ${MAN1} ${MAN8}
|
||||
+ ${INSTALL} -m 444 ${MAN1} ${DESTDIR}${MANDIR}1
|
||||
+ ${INSTALL} -m 444 ${MAN8} ${DESTDIR}${MANDIR}8
|
||||
+ ln -sf jmakewhatis.local.8.gz ${DESTDIR}${MANDIR}8/jcatman.local.8.gz
|
||||
|
||||
-.if !defined(NOMAN)
|
||||
after_maninstall: ${EMAN1} ${EMAN8}
|
||||
- ${INSTALL} -c -o bin -g bin -m 444 ${EMAN1} \
|
||||
+ ${INSTALL} -m 444 ${EMAN1} \
|
||||
${DESTDIR}${EMANDIR}1/jmakewhatis.1.gz
|
||||
- ${INSTALL} -c -o bin -g bin -m 444 ${EMAN8} \
|
||||
+ ${INSTALL} -m 444 ${EMAN8} \
|
||||
${DESTDIR}${EMANDIR}8/jmakewhatis.local.8.gz
|
||||
- ln -f ${DESTDIR}${EMANDIR}8/jmakewhatis.local.8.gz \
|
||||
- ${DESTDIR}${EMANDIR}8/jcatman.local.8.gz
|
||||
+ ln -sf jmakewhatis.local.8.gz ${DESTDIR}${EMANDIR}8/jcatman.local.8.gz
|
||||
.else
|
||||
+man_install:
|
||||
after_maninstall:
|
||||
.endif
|
||||
|
||||
.include "../Makefile.inc"
|
||||
|
||||
-.if make(maninstall) || make(install)
|
||||
-.if !defined(NOMAN)
|
||||
-.include <bsd.man.mk>
|
||||
-.elif !target(maninstall)
|
||||
-maninstall:
|
||||
-.endif
|
||||
-.endif
|
||||
-
|
||||
.include <bsd.prog.mk>
|
@ -1,12 +0,0 @@
|
||||
--- man/Makefile.orig 2001-01-15 20:13:00.000000000 +0900
|
||||
+++ man/Makefile 2009-09-13 19:12:27.166481760 +0900
|
||||
@@ -12,7 +12,9 @@
|
||||
EMAN1= jman.1.eng.gz
|
||||
BINOWN= man
|
||||
BINMODE=4555
|
||||
+.if !defined(NO_FSCHG)
|
||||
INSTALLFLAGS+= -fschg
|
||||
+.endif
|
||||
|
||||
CFLAGS+= -I${LIBDESTDIR}
|
||||
DPADD= ${LIBMAN}
|
42
japanese/man/files/patch-man__Makefile
Normal file
42
japanese/man/files/patch-man__Makefile
Normal file
@ -0,0 +1,42 @@
|
||||
--- man/Makefile.orig 2014-08-26 12:12:08.000000000 +0900
|
||||
+++ man/Makefile 2014-08-26 12:12:36.000000000 +0900
|
||||
@@ -10,14 +10,14 @@
|
||||
SRCS= man.c manpath.c glob.c locale.c
|
||||
MAN1= jman.1
|
||||
EMAN1= jman.1.eng.gz
|
||||
-BINOWN= man
|
||||
-BINMODE=4555
|
||||
-INSTALLFLAGS+= -fschg
|
||||
+#BINOWN= man
|
||||
+#BINMODE=4555
|
||||
+#INSTALLFLAGS+= -fschg
|
||||
|
||||
CFLAGS+= -g -I${LIBDESTDIR}
|
||||
DPADD= ${LIBMAN}
|
||||
LDADD= ${LIBMAN}
|
||||
-.if exists(/usr/lib/libxpg4.a)
|
||||
+.if ${OSVERSION} < 400020
|
||||
LDADD+= -L/usr/lib -lxpg4
|
||||
.endif
|
||||
|
||||
@@ -48,11 +48,18 @@
|
||||
${.CURDIR}/jman.man.eng | \
|
||||
${compress} > ${EMAN1}
|
||||
|
||||
-.if !defined(NOMAN)
|
||||
+install: ${PROG} man_install afterinstall
|
||||
+ ${INSTALL} -s -m 555 ${PROG} ${DESTDIR}/${BINDIR}
|
||||
+
|
||||
+.if !defined(NO_MAN)
|
||||
+man_install: ${MAN1}
|
||||
+ ${INSTALL} -m 444 ${MAN1} ${DESTDIR}${MANDIR}1
|
||||
+
|
||||
afterinstall: ${EMAN1}
|
||||
- ${INSTALL} -c -o bin -g bin -m 444 ${EMAN1} \
|
||||
+ ${INSTALL} -m 444 ${EMAN1} \
|
||||
${DESTDIR}${EMANDIR}1/jman.1.gz
|
||||
.else
|
||||
+man_install:
|
||||
afterinstall:
|
||||
.endif
|
||||
|
24
japanese/man/files/patch-manpath__Makefile
Normal file
24
japanese/man/files/patch-manpath__Makefile
Normal file
@ -0,0 +1,24 @@
|
||||
--- manpath/Makefile.orig 2001-06-11 21:25:34.000000000 +0900
|
||||
+++ manpath/Makefile 2014-08-26 12:10:04.000000000 +0900
|
||||
@@ -24,10 +24,19 @@
|
||||
${.CURDIR}/jmanpath.man.eng | \
|
||||
${compress} > ${EMAN1}
|
||||
|
||||
-.if !defined(NOMAN)
|
||||
+install: ${PROG} man_install afterinstall
|
||||
+ ${INSTALL} -s -m 555 ${PROG} ${DESTDIR}/${BINDIR}
|
||||
+
|
||||
+.if !defined(NO_MAN)
|
||||
+man_install: ${MAN1}
|
||||
+ ${INSTALL} -m 444 ${MAN1} ${DESTDIR}${MANDIR}1
|
||||
+
|
||||
afterinstall: ${EMAN1}
|
||||
- ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 444 ${EMAN1} \
|
||||
+ ${INSTALL} -m 444 ${EMAN1} \
|
||||
${DESTDIR}${EMANDIR}1/jmanpath.1.gz
|
||||
+.else
|
||||
+man_install:
|
||||
+afterinstall:
|
||||
.endif
|
||||
|
||||
.include "../Makefile.inc"
|
@ -1,14 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
if [ "X$2" = X"PRE-INSTALL" ]; then
|
||||
for d in /usr/local/man /usr/X11R6/man; do
|
||||
if [ -d ${d}/ja_JP.EUC ]; then
|
||||
if [ -d ${d}/ja ]; then
|
||||
(cd ${d}; tar cf - -C ja_JP.EUC . | tar xfp - -C ja; \
|
||||
rm -rf ${d}/ja_JP.EUC; ln -s ja ja_JP.EUC )
|
||||
else
|
||||
(cd ${d}; mv ja_JP.EUC ja; ln -s ja ja_JP.EUC )
|
||||
fi
|
||||
fi
|
||||
done
|
||||
fi
|
@ -1,9 +1,31 @@
|
||||
bin/jmanpath
|
||||
@unexec chflags noschg %B/jman
|
||||
@owner man
|
||||
@mode 4555
|
||||
bin/jman
|
||||
@owner bin
|
||||
@group bin
|
||||
@mode
|
||||
bin/japropos
|
||||
bin/jwhatis
|
||||
bin/jmakewhatis
|
||||
bin/jcatman
|
||||
libexec/jmakewhatis.local
|
||||
libexec/jcatman.local
|
||||
@owner
|
||||
@group
|
||||
man/man1/jman.1.gz
|
||||
man/man1/jmanpath.1.gz
|
||||
man/man1/japropos.1.gz
|
||||
man/man1/jwhatis.1.gz
|
||||
man/man1/jmakewhatis.1.gz
|
||||
man/man1/jcatman.1.gz
|
||||
man/man8/jmakewhatis.local.8.gz
|
||||
man/man8/jcatman.local.8.gz
|
||||
man/ja/man1/jman.1.gz
|
||||
man/ja/man1/jmanpath.1.gz
|
||||
man/ja/man1/japropos.1.gz
|
||||
man/ja/man1/jwhatis.1.gz
|
||||
man/ja/man1/jmakewhatis.1.gz
|
||||
man/ja/man1/jcatman.1.gz
|
||||
man/ja/man8/jmakewhatis.local.8.gz
|
||||
man/ja/man8/jcatman.local.8.gz
|
||||
|
Loading…
Reference in New Issue
Block a user