Update to 1.6.10.

Submitted by:	kwm
This commit is contained in:
Joe Marcus Clarke 2008-03-24 04:24:31 +00:00
parent 4e9d60242d
commit 24c69347cd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=209661
5 changed files with 98 additions and 48 deletions

View File

@ -3,40 +3,53 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
# $MCom: ports/databases/glom/Makefile,v 1.11 2007/07/23 19:45:47 mezz Exp $
# $MCom: ports/databases/glom/Makefile,v 1.18 2008/03/20 09:26:48 kwm Exp $
#
PORTNAME= glom
PORTVERSION= 1.0.4
PORTREVISION= 2
PORTVERSION= 1.6.10
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
MAINTAINER= ports@FreeBSD.org
MAINTAINER= kwm@FreeBSD.org
COMMENT= GNOME database designer and user interface
LIB_DEPENDS= bakery-2.4:${PORTSDIR}/x11-toolkits/bakery \
gdamm-1.3:${PORTSDIR}/databases/libgdamm \
gnomecanvasmm-2.6:${PORTSDIR}/graphics/libgnomecanvasmm26
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
BROKEN= py-gnome-extras has pygda disable because it is broke
gdamm-3.0.10:${PORTSDIR}/databases/libgdamm \
gtksourceviewmm-1.0.1:${PORTSDIR}/x11-toolkits/libgtksourceviewmm \
goocanvas.3:${PORTSDIR}/graphics/goocanvas
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
${LOCALBASE}/libdata/pkgconfig/libgda-postgres-3.0.pc:${PORTSDIR}/databases/libgda3-postgresql
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
${LOCALBASE}/libdata/pkgconfig/libgda-postgres-3.0.pc:${PORTSDIR}/databases/libgda3-postgresql
USE_BZIP2= yes
USE_XLIB= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomedocutils gnomehack gnomeprefix pygnomeextras
USE_LDCONFIG= yes
USE_PGSQL= yes
INSTALLS_OMF= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-postgres-utils=${LOCALBASE}/bin
INSTALLS_ICONS= yes
OPTIONS= SELF_HOSTING "Host the database locally" off
.include <bsd.port.pre.mk>
.if defined(WITH_SELF_HOSTING)
# Note: USE_PGSQL has already been set above.
BUILD_DEPENDS+= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
RUN_DEPENDS+= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
.else
CONFIGURE_ARGS+=--enable-client-only
.endif
post-patch:
@${REINPLACE_CMD} -e 's|-update-mime-database|true|g' \
${WRKSRC}/Makefile.in
@ -44,4 +57,4 @@ post-patch:
post-install:
@-update-mime-database ${PREFIX}/share/mime
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (glom-1.0.4.tar.bz2) = 1bb06562bf52a66747b4ac4a2aefa3a7
SHA256 (glom-1.0.4.tar.bz2) = 05f1f401fb4655c98ffec906878b9d21ed3e5830ea03b0962dcfbee2057c4768
SIZE (glom-1.0.4.tar.bz2) = 882714
MD5 (glom-1.6.10.tar.bz2) = 2949c8b57a1926454009ca71133abf37
SHA256 (glom-1.6.10.tar.bz2) = 4b5616731e3971a65ee368202d0bfb533a6aa423269678bdf2a37bab09dff1d1
SIZE (glom-1.6.10.tar.bz2) = 1356023

View File

@ -1,20 +0,0 @@
--- glom/libglom/python_embed/py_glom_record.cc.orig Sun Jul 15 13:34:18 2007
+++ glom/libglom/python_embed/py_glom_record.cc Sun Jul 15 13:34:44 2007
@@ -122,7 +122,7 @@
-static int
+static Py_ssize_t
Record_tp_as_mapping_length(PyGlomRecord *self)
{
return self->m_pMap_field_values->size();
@@ -146,7 +146,7 @@
}
else
{
- g_warning("Record_tp_as_mapping_getitem(): item not found in m_pMap_field_values. size=%d, item=%s", self->m_pMap_field_values->size(), pchKey);
+ g_warning("Record_tp_as_mapping_getitem(): item not found in m_pMap_field_values. size=%d, item=%s", (int)self->m_pMap_field_values->size(), pchKey);
}
}
else

View File

@ -0,0 +1,11 @@
--- glom/libglom/connectionpool.cc.orig 2008-01-31 11:29:29.000000000 +0100
+++ glom/libglom/connectionpool.cc 2008-01-31 11:38:06.000000000 +0100
@@ -642,7 +642,7 @@ bool ConnectionPool::directory_exists_ur
}
#ifndef GLOM_ENABLE_CLIENT_ONLY
-static sighandler_t previous_sig_handler = SIG_DFL; /* Arbitrary default */
+static __sighandler_t *previous_sig_handler = SIG_DFL; /* Arbitrary default */
/* This is a Linux/Unix signal handler,
* so we can respond to a crash.

View File

@ -7,30 +7,62 @@ lib/libglom.so.0
%%PYTHON_SITELIBDIR%%/glom.la
%%PYTHON_SITELIBDIR%%/glom.so
share/applications/glom.desktop
share/glom/doc/examples/example_smallbusiness.glom
share/glom/glade/glom.glade
share/glom/glom_document.dtd
share/glom/xslt/print_details_to_html.xsl
share/glom/xslt/print_report_to_html.xsl
%%DATADIR%%/doc/examples/example_film_manager.glom
%%DATADIR%%/doc/examples/example_music_collection.glom
%%DATADIR%%/doc/examples/example_project_manager.glom
%%DATADIR%%/doc/examples/example_smallbusiness.glom
%%DATADIR%%/glade/glom.glade
%%DATADIR%%/glom_document.dtd
%%DATADIR%%/xslt/print_details_to_html.xsl
%%DATADIR%%/xslt/print_report_to_html.xsl
share/gnome/help/glom/C/figures/glom_design_fields.png
share/gnome/help/glom/C/figures/glom_design_fields_dialog_calculated.png
share/gnome/help/glom/C/figures/start.png
share/gnome/help/glom/C/glom.xml
share/gnome/help/glom/C/legal.xml
share/gnome/help/glom/de/figures/glom_design_fields.png
share/gnome/help/glom/de/figures/glom_design_fields_dialog_calculated.png
share/gnome/help/glom/de/figures/start.png
share/gnome/help/glom/de/glom.xml
share/gnome/help/glom/de/legal.xml
share/gnome/help/glom/en_GB/figures/glom_design_fields.png
share/gnome/help/glom/en_GB/figures/glom_design_fields_dialog_calculated.png
share/gnome/help/glom/en_GB/figures/start.png
share/gnome/help/glom/en_GB/glom.xml
share/gnome/help/glom/en_GB/legal.xml
share/gnome/help/glom/es/figures/glom_design_fields.png
share/gnome/help/glom/es/figures/glom_design_fields_dialog_calculated.png
share/gnome/help/glom/es/figures/start.png
share/gnome/help/glom/es/glom.xml
share/gnome/help/glom/es/legal.xml
share/gnome/help/glom/sv/figures/glom_design_fields.png
share/gnome/help/glom/sv/figures/glom_design_fields_dialog_calculated.png
share/gnome/help/glom/sv/figures/start.png
share/gnome/help/glom/sv/glom.xml
share/gnome/help/glom/sv/legal.xml
share/mime-info/glom.keys
share/mime-info/glom.mime
share/icons/hicolor/16x16/apps/glom.png
share/icons/hicolor/22x22/apps/glom.png
share/icons/hicolor/24x24/apps/glom.png
share/icons/hicolor/32x32/apps/glom.png
share/icons/hicolor/48x48/apps/glom.png
share/icons/hicolor/scalable/apps/glom.svg
share/locale/ar/LC_MESSAGES/glom.mo
share/locale/ca/LC_MESSAGES/glom.mo
share/locale/cs/LC_MESSAGES/glom.mo
share/locale/de/LC_MESSAGES/glom.mo
share/locale/dz/LC_MESSAGES/glom.mo
share/locale/en_CA/LC_MESSAGES/glom.mo
share/locale/en_GB/LC_MESSAGES/glom.mo
share/locale/es/LC_MESSAGES/glom.mo
share/locale/fi/LC_MESSAGES/glom.mo
share/locale/fr/LC_MESSAGES/glom.mo
share/locale/gl/LC_MESSAGES/glom.mo
share/locale/gu/LC_MESSAGES/glom.mo
share/locale/hu/LC_MESSAGES/glom.mo
share/locale/it/LC_MESSAGES/glom.mo
share/locale/nb/LC_MESSAGES/glom.mo
share/locale/ne/LC_MESSAGES/glom.mo
share/locale/nl/LC_MESSAGES/glom.mo
share/locale/pa/LC_MESSAGES/glom.mo
@ -43,18 +75,32 @@ share/locale/tr/LC_MESSAGES/glom.mo
share/locale/vi/LC_MESSAGES/glom.mo
share/locale/zh_CN/LC_MESSAGES/glom.mo
share/mime/packages/glom.xml
share/omf/glom/glom-C.omf
share/omf/glom/glom-de.omf
share/omf/glom/glom-en_GB.omf
share/omf/glom/glom-es.omf
share/omf/glom/glom-sv.omf
@dirrm share/omf/glom
@dirrm share/gnome/help/glom/sv/figures
@dirrm share/gnome/help/glom/sv
@dirrm share/gnome/help/glom/es/figures
@dirrm share/gnome/help/glom/es
@dirrm share/gnome/help/glom/en_GB/figures
@dirrm share/gnome/help/glom/en_GB
@dirrm share/gnome/help/glom/de/figures
@dirrm share/gnome/help/glom/de
@dirrm share/gnome/help/glom/C/figures
@dirrm share/gnome/help/glom/C
@dirrm share/gnome/help/glom
@dirrm share/glom/xslt
@dirrm share/glom/glade
@dirrm share/glom/doc/examples
@dirrm share/glom/doc
@dirrm share/glom
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
@dirrm %%DATADIR%%/xslt
@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%/doc/examples
@dirrm %%DATADIR%%/doc
@dirrm %%DATADIR%%
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@dirrmtry share/applications
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz