- Fix MASTER_SITES by deleting a no longer available site [1]

- Fix build on 5.x [2]
- Respect PTHREAD_CFLAGS and PTHREAD_LIBS [2]
- Bump PORTREVISION

PR:		58612
Submitted by:	maintainer [1], krion [2]
This commit is contained in:
Kirill Ponomarev 2003-10-28 12:55:09 +00:00
parent 58dd22594e
commit 24abbeac72
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=92448
2 changed files with 119 additions and 6 deletions

View File

@ -7,10 +7,9 @@
PORTNAME= iplog
PORTVERSION= 2.2.3
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://misc.ojnk.net/~odin/stuff/
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ojnk
MAINTAINER= udo.schweigert@siemens.com
@ -19,15 +18,18 @@ COMMENT= TCP/IP traffic logging tool
USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
MAN5= iplog.conf.5
MAN8= iplog.8
.include <bsd.port.pre.mk>
post-patch:
.for file in example-iplog.conf iplog.8 iplog.conf.5 src/iplog.h
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${file}
.for FILE in example-iplog.conf iplog.8 iplog.conf.5 src/iplog.h
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${FILE}
.endfor
@${REINPLACE_CMD} -e 's|-pthread||g' ${WRKSRC}/configure
post-install:
${INSTALL_DATA} ${WRKSRC}/example-iplog.conf ${PREFIX}/etc

View File

@ -0,0 +1,111 @@
--- src/iplog_options.c.orig Mon Jan 1 17:02:14 2001
+++ src/iplog_options.c Tue Oct 28 13:38:06 2003
@@ -440,57 +440,57 @@
static void print_help(void) {
mysyslog(
-"Usage: " PACKAGE " [options] (\"*\" Denotes enabled by default)
---user or -u <user|UID> Run as specified the user or UID.
---group or -g <group|GID> Run with specified the group or GID.
---logfile or -l <file> Log to <file>.
---pid-file <file> Use <file> as the pid file.
---ignore or -d Ignore DNS traffic from nameservers listed in
- /etc/resolv.conf.
---interface or -i <if0,...,ifN> Listen on the specified interface(s).
---promisc or -a <network> Log traffic to all hosts on <network>.
---kill or -k Kill iplog, if it is running.
---restart or -R Restart iplog, if it is running.
---no-fork or -o Run in the foreground.
---stdout or -L Log to stdout.
---help or -h This help screen.
---version or -v Print version information and exit.
-
---facility <facility> Use the specified syslog facility.
---priority <priority> Use the specified syslog priority.
-
---tcp[=true|false|toggle] %cLog TCP traffic.
---udp[=true|false|toggle] %cLog UDP traffic.
---icmp[=true|false|toggle] %cLog ICMP traffic.
-
---log-ip[=true|false|toggle] or -w %cLog IP along with hostname.
---log-dest[=true|false|toggle] or -D %cLog the destination of traffic.
---dns-cache[=true|false|toggle] or -c %cUse the built-in DNS cache.
---get-ident[=true|false|toggle] or -e %cGet ident info on connections
- to listening ports.
-
---tcp-resolve[=true|false|toggle] or -T %cResolve IPs of TCP traffic.
---udp-resolve[=true|false|toggle] or -U %cResolve IPs of UDP traffic.
---icmp-resolve[=true|false|toggle] or -I %cResolve IPs of ICMP traffic.
---disable-resolver or -N %cDo not resolve any IPs.
-
---verbose[=true|false|toggle] or -V %cBe verbose.
---fool-nmap[=true|false|toggle] or -z %cFool nmap's OS detection.
---scans-only[=true|false|toggle] or -m %cOnly log scans.
---detect-syn-flood[=true|false|toggle] or -s %cStop resolving IPs if a
- SYN flood is detected.
-
---log-frag[=true|false|toggle] or -y %cLog fragment attacks.
---log-traceroute[=true|false|toggle] or -t %cLog traceroutes.
---log-ping-flood[=true|false|toggle] or -P %cLog ICMP ping floods.
---log-smurf[=true|false|toggle] or -S %cLog smurf attacks.
---log-bogus[=true|false|toggle] or -b %cLog bogus TCP flags.
---log-portscan[=true|false|toggle] or -p %cLog port scans.
---log-udp-scan[=true|false|toggle] or -F %cLog UDP scans/floods.
---log-fin-scan[=true|false|toggle] or -f %cLog FIN scans.
---log-syn-scan[=true|false|toggle] or -q %cLog SYN scans.
---log-xmas-scan[=true|false|toggle] or -x %cLog Xmas scans.
---log-null-scan[=true|false|toggle] or -n %cLog null scans.",
+"Usage: "PACKAGE" [options] (Denotes enabled by default)\n\n"
+"--user or -u <user|UID> Run as specified the user or UID.\n"
+"--group or -g <group|GID> Run with specified the group or GID.\n"
+"--logfile or -l <file> Log to <file>.\n"
+"--pid-file <file> Use <file> as the pid file.\n"
+"--ignore or -d Ignore DNS traffic from nameservers listed in\n"
+ "/etc/resolv.conf.\n"
+"--interface or -i <if0,...,ifN> Listen on the specified interface(s).\n"
+"--promisc or -a <network> Log traffic to all hosts on <network>.\n"
+"--kill or -k Kill iplog, if it is running.\n"
+"--restart or -R Restart iplog, if it is running.\n"
+"--no-fork or -o Run in the foreground.\n"
+"--stdout or -L Log to stdout.\n"
+"--help or -h This help screen.\n"
+"--version or -v Print version information and exit.\n\n"
+
+"--facility <facility> Use the specified syslog facility.\n"
+"--priority <priority> Use the specified syslog priority.\n\n"
+
+"--tcp[=true|false|toggle] %cLog TCP traffic.\n"
+"--udp[=true|false|toggle] %cLog UDP traffic.\n"
+"--icmp[=true|false|toggle] %cLog ICMP traffic.\n\n"
+
+"--log-ip[=true|false|toggle] or -w %cLog IP along with hostname.\n"
+"--log-dest[=true|false|toggle] or -D %cLog the destination of traffic.\n"
+"--dns-cache[=true|false|toggle] or -c %cUse the built-in DNS cache.\n"
+"--get-ident[=true|false|toggle] or -e %cGet ident info on connections\n"
+ "to listening ports.\n\n"
+
+"--tcp-resolve[=true|false|toggle] or -T %cResolve IPs of TCP traffic.\n"
+"--udp-resolve[=true|false|toggle] or -U %cResolve IPs of UDP traffic.\n"
+"--icmp-resolve[=true|false|toggle] or -I %cResolve IPs of ICMP traffic.\n"
+"--disable-resolver or -N %cDo not resolve any IPs.\n\n"
+
+"--verbose[=true|false|toggle] or -V %cBe verbose.\n"
+"--fool-nmap[=true|false|toggle] or -z %cFool nmaps OS detection.\n"
+"--scans-only[=true|false|toggle] or -m %cOnly log scans.\n"
+"--detect-syn-flood[=true|false|toggle] or -s %cStop resolving IPs if a\n"
+ "SYN flood is detected.\n\n"
+
+"--log-frag[=true|false|toggle] or -y %cLog fragment attacks.\n"
+"--log-traceroute[=true|false|toggle] or -t %cLog traceroutes.\n"
+"--log-ping-flood[=true|false|toggle] or -P %cLog ICMP ping floods.\n"
+"--log-smurf[=true|false|toggle] or -S %cLog smurf attacks.\n"
+"--log-bogus[=true|false|toggle] or -b %cLog bogus TCP flags.\n"
+"--log-portscan[=true|false|toggle] or -p %cLog port scans.\n"
+"--log-udp-scan[=true|false|toggle] or -F %cLog UDP scans/floods.\n"
+"--log-fin-scan[=true|false|toggle] or -f %cLog FIN scans.\n"
+"--log-syn-scan[=true|false|toggle] or -q %cLog SYN scans.\n"
+"--log-xmas-scan[=true|false|toggle] or -x %cLog Xmas scans.\n"
+"--log-null-scan[=true|false|toggle] or -n %cLog null scans.\n",
IS_DEFAULT(LOG_TCP), IS_DEFAULT(LOG_UDP), IS_DEFAULT(LOG_ICMP),
IS_DEFAULT(LOG_IP), IS_DEFAULT(LOG_DEST), IS_DEFAULT(DNS_CACHE),
IS_DEFAULT(GET_IDENT), IS_DEFAULT(TCP_RES), IS_DEFAULT(UDP_RES),