Fix installation of perl binding.
This commit is contained in:
parent
a0e02a961f
commit
24a7220ac3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=348628
@ -9,5 +9,4 @@ MASTERDIR= ${.CURDIR}/../pdflib
|
||||
|
||||
OPTIONS_DEFAULT=PERL
|
||||
|
||||
NO_STAGE= yes
|
||||
.include "${MASTERDIR}/Makefile"
|
||||
|
@ -11,7 +11,7 @@ DISTNAME= PDFlib-Lite-${PORTVERSION}p3
|
||||
MAINTAINER= ale@FreeBSD.org
|
||||
COMMENT= A C library for dynamically generating PDF
|
||||
|
||||
RESTRICTED= many odd restrictions on usage and distribution
|
||||
RESTRICTED= Many odd restrictions on usage and distribution
|
||||
|
||||
OPTIONS_DEFINE= PERL JAVA
|
||||
PERL_DESC= Build perl bindings
|
||||
|
10
print/pdflib/files/patch-bind_pdflib_perl_Makefile
Normal file
10
print/pdflib/files/patch-bind_pdflib_perl_Makefile
Normal file
@ -0,0 +1,10 @@
|
||||
--- bind/pdflib/perl/Makefile.orig 2014-03-19 15:48:26.586002710 +0000
|
||||
+++ bind/pdflib/perl/Makefile 2014-03-19 15:48:50.137000807 +0000
|
||||
@@ -55,6 +55,7 @@
|
||||
../../../progs/pdi/pdfcheck -i ../java/starter.ref -o -
|
||||
|
||||
install:: $(LIBNAME)
|
||||
+ $(MKDIR) -p $(LANG_LIBDIR)
|
||||
$(LIBTOOL) --mode=install \
|
||||
$(INSTALL_DATA) $(LIBNAME) $(LANG_LIBDIR)
|
||||
$(INSTALL_DATA) pdflib_pl.pm $(LANG_LIBDIR)
|
@ -6,9 +6,9 @@ lib/libpdf.a
|
||||
lib/libpdf.la
|
||||
lib/libpdf.so
|
||||
lib/libpdf.so.6
|
||||
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/pdflib_pl.pm
|
||||
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/pdflib_pl.a
|
||||
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/pdflib_pl.la
|
||||
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/pdflib_pl.pm
|
||||
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/pdflib_pl.so
|
||||
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/pdflib_pl.so.0
|
||||
%%JAVA%%lib/libpdf_java.a
|
||||
|
Loading…
Reference in New Issue
Block a user