Upgrade to 2.3.6.

This commit is contained in:
Thierry Thomas 2010-03-26 18:30:47 +00:00
parent 0aedfcd507
commit 2498ef79d7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=251547
13 changed files with 29 additions and 116 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= med
DISTVERSIONPREFIX= full-src-
DISTVERSION= 2.3.5
DISTVERSION= 2.3.6
DISTVERSIONSUFFIX= .noarch
CATEGORIES= french science
MASTER_SITES= http://www.code-aster.org/V2/UPLOAD/DOC/Telechargement/
@ -20,8 +20,8 @@ BUILD_DEPENDS= wish${TK_VER}:${PORTSDIR}/x11-toolkits/tk${SHORT_TK_VER}
LIB_DEPENDS= hdf5.0:${PORTSDIR}/science/hdf5
RUN_DEPENDS= wish${TK_VER}:${PORTSDIR}/x11-toolkits/tk${SHORT_TK_VER}
ASTER_VER= 9.4.0
ASTER_DISTVERSION= ${ASTER_VER}-2
ASTER_VER= 10.1.0
ASTER_DISTVERSION= ${ASTER_VER}-4
EXTRACT_WRKSRC= ${WRKDIR}/aster-${DISTVERSIONPREFIX}${ASTER_VER}/SRC
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@ -37,7 +37,7 @@ CONFIGURE_ENV= HDF5HOME=${LOCALBASE} CPPFLAGS="${PTHREAD_CFLAGS}" \
CONFIGURE_ARGS= --with-f90=${FC} --docdir=${DOCSDIR}
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:262 libtool:22
USE_AUTOTOOLS= autoconf:262
USE_LDCONFIG= yes
DOC2FIX= . gif html jpg png tests

View File

@ -1,3 +1,3 @@
MD5 (aster-full-src-9.4.0-2.noarch.tar.gz) = d28a1aee23413239166e77d4e934395a
SHA256 (aster-full-src-9.4.0-2.noarch.tar.gz) = ab46cac1f1606c1cacda35befd0a8c7992bd2c4568e2f0b59f26676dd5fe38f3
SIZE (aster-full-src-9.4.0-2.noarch.tar.gz) = 149933404
MD5 (aster-full-src-10.1.0-4.noarch.tar.gz) = 49fe55a0a46491124c16965a2db59c5e
SHA256 (aster-full-src-10.1.0-4.noarch.tar.gz) = c72f82abadb627925cbc5cbf9909f969e4c60f29325a62d78664eb03a860468a
SIZE (aster-full-src-10.1.0-4.noarch.tar.gz) = 163690307

View File

@ -1,9 +1,9 @@
--- ./src/cfi/Makefile.in.orig 2008-02-08 15:21:48.000000000 +0100
+++ ./src/cfi/Makefile.in 2008-03-22 14:27:04.000000000 +0100
@@ -57,11 +57,13 @@
DEFAULT_INCLUDES = -I. -I$(top_builddir)/include@am__isrc@
--- ./src/cfi/Makefile.in.orig 2009-09-23 15:02:49.000000000 +0200
+++ ./src/cfi/Makefile.in 2010-01-31 14:17:13.000000000 +0100
@@ -62,8 +62,10 @@
depcomp = $(SHELL) $(top_srcdir)/config/depcomp
am__depfiles_maybe = depfiles
am__mv = mv -f
+# FreeBSD patch: put AM_CFLAGS before CPPFLAGS to be able to compile
+# even if includes from previous version are installed.
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
@ -11,8 +11,4 @@
+ $(AM_CFLAGS) $(CPPFLAGS) $(CFLAGS)
LTCOMPILE = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
- $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ $(AM_CPPFLAGS) $(AM_CFLAGS) $(CPPFLAGS) $(CFLAGS)
CCLD = $(CC)
LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
$(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View File

@ -1,6 +1,6 @@
--- ./src/ci/MEDunvCr.c.orig Thu May 18 11:43:58 2006
+++ ./src/ci/MEDunvCr.c Mon Dec 11 21:31:06 2006
@@ -43,6 +43,12 @@
--- ./src/ci/MEDunvCr.c.orig 2009-07-06 17:49:32.000000000 +0200
+++ ./src/ci/MEDunvCr.c 2010-01-31 14:20:10.000000000 +0100
@@ -50,6 +50,12 @@
#endif
@ -13,15 +13,15 @@
med_err
MEDunvCr(med_idt fid, char *maa)
{
@@ -87,7 +93,11 @@
nSize = strlen(nomu)-1;
if ( sprintf(&nomu[nSize]," %hu",tp.millitm) < 0 ) return -1;
#else
@@ -100,7 +106,11 @@
goto ERROR;
}
strcat(nomu,mypasswd->pw_name);*/
+# ifdef __FreeBSD__
+ if ( !getpwuid(geteuid()) ) return -1;
+ if ( !getpwuid(geteuid()) ) {
+# else
if ( !cuserid(nomu) ) return -1;
if ( !cuserid(nomu) ) {
+# endif
strcat(nomu," ");
temps=time(&temps);
strcat(nomu,ctime(&temps));
MESSAGE("Impossible d'obtenir le nom de l'utilisateur effectif");
goto ERROR;
}

View File

@ -1,11 +0,0 @@
--- ./tools/medimport/2.1.x/MAJ_21_22_chainebuilt.cxx.orig 2008-10-22 15:31:24.000000000 +0200
+++ ./tools/medimport/2.1.x/MAJ_21_22_chainebuilt.cxx 2009-02-10 11:20:33.000000000 +0100
@@ -16,6 +16,8 @@
*
*************************************************************************/
+#include <string.h>
+
#define MESGERR
#include "med_hdfi21.h"

View File

@ -1,11 +0,0 @@
--- ./tools/medimport/2.1.x/MAJ_21_22_champsbuilt.cxx.orig 2008-10-22 15:31:25.000000000 +0200
+++ ./tools/medimport/2.1.x/MAJ_21_22_champsbuilt.cxx 2009-02-10 11:27:28.000000000 +0100
@@ -16,6 +16,8 @@
*
*************************************************************************/
+#include <string.h>
+
#define MESGERR
#ifdef __cplusplus

View File

@ -1,11 +0,0 @@
--- ./tools/medimport/2.1.x/MAJ_21_22_familles_maillagebuilt.cxx.orig 2008-10-22 15:31:25.000000000 +0200
+++ ./tools/medimport/2.1.x/MAJ_21_22_familles_maillagebuilt.cxx 2009-02-10 15:26:48.000000000 +0100
@@ -16,6 +16,8 @@
*
*************************************************************************/
+#include <string.h>
+
#define MESGERR
#ifdef __cplusplus

View File

@ -1,11 +0,0 @@
--- ./tools/medimport/2.1.x/MAJ_21_22_localisation_Gaussbuilt.cxx.orig 2008-10-22 15:31:25.000000000 +0200
+++ ./tools/medimport/2.1.x/MAJ_21_22_localisation_Gaussbuilt.cxx 2009-02-10 11:35:37.000000000 +0100
@@ -16,6 +16,8 @@
*
*************************************************************************/
+#include <string.h>
+
#define MESGERR
#ifdef __cplusplus

View File

@ -1,11 +0,0 @@
--- ./tools/medimport/2.1.x/MAJ_21_22_maillagesbuilt.cxx.orig 2008-10-22 15:31:25.000000000 +0200
+++ ./tools/medimport/2.1.x/MAJ_21_22_maillagesbuilt.cxx 2009-02-10 15:22:38.000000000 +0100
@@ -16,6 +16,8 @@
*
*************************************************************************/
+#include <string.h>
+
#define MESGERR
#ifdef __cplusplus

View File

@ -1,11 +0,0 @@
--- ./tools/medimport/2.1.x/MAJ_21_22_profilsbuilt.cxx.orig 2008-10-22 15:31:25.000000000 +0200
+++ ./tools/medimport/2.1.x/MAJ_21_22_profilsbuilt.cxx 2009-02-10 15:15:28.000000000 +0100
@@ -16,6 +16,8 @@
*
*************************************************************************/
+#include <string.h>
+
#define MESGERR
#ifdef __cplusplus

View File

@ -1,10 +0,0 @@
--- ./tools/medimport/2.3.1/MED231champLireEtUnlinkbuilt.cxx.orig 2008-10-22 15:31:32.000000000 +0200
+++ ./tools/medimport/2.3.1/MED231champLireEtUnlinkbuilt.cxx 2009-02-10 15:29:03.000000000 +0100
@@ -16,6 +16,7 @@
*
*************************************************************************/
+#include <string.h>
#define MESGERR

View File

@ -1,11 +0,0 @@
--- ./tools/medimport/2.3.1/MED231champNormaliserbuilt.cxx.orig 2008-10-22 15:31:32.000000000 +0200
+++ ./tools/medimport/2.3.1/MED231champNormaliserbuilt.cxx 2009-02-10 15:31:10.000000000 +0100
@@ -16,6 +16,8 @@
*
*************************************************************************/
+#include <string.h>
+
#define MESGERR
#ifdef __cplusplus

View File

@ -7,13 +7,17 @@ include/MEDimport.h
include/MEDimport.hxx
include/med.h
include/med.hf
include/medC_win_dll.h
include/med_exit_if.h
include/med_proto.h
include/med_utils.h
include/med_win_dll.h
include/medimport_win_dll.h
include/medimportcxx_win_dll.h
lib/libmed.a
lib/libmed.la
lib/libmed.so
lib/libmed.so.2
lib/libmed2.settings
lib/libmedC.a
lib/libmedC.la
lib/libmedC.so