lang/rust and lang/rust-nightly: Build-conflict with themselves

A newer version of Rust fails to build if an older version is installed
because the build process picks libraries in %%LOCALBASE%%/lib before
those from the build directory.

In the pkg-plist of both ports, `x86_64-unknown-freebsd` is now a
variable automatically set in the Makefile. This avoids the need for a
separate port for DragonFlyBSD. [1]

Still in the pkg-plist, RUST_VSN_HASH is automatically computed in the
lang/rust's Makefile, like it was already done for lang/rust-nightly.

lang/rust-nightly USES libedit. patch-mk_main.mk was copied from
lang/rust so the correct library is picked (ie. the one from Ports, not
the one from the base). This was already fixed in lang/rust.

lang/rust includes bsd.port.options.mk and bsd.port.mk, instead of
bsd.port.pre.mk and bsd.port.post.mk. This was already fixed in
lang/rust-nightly.

Both ports are now closer to each other.

PR:		202869 [1]
Submitted by:	Michael Neumann <mneumann@ntecs.de> [1]
Reviewed by:	kwm
Approved by:	kwm
Differential Revision:	https://reviews.freebsd.org/D3234
This commit is contained in:
Jean-Sébastien Pédron 2015-09-12 14:49:44 +00:00
parent 2ec529422b
commit 23df892f4d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=396750
5 changed files with 191 additions and 125 deletions

View File

@ -48,14 +48,16 @@ RUST_BOOT= rust-stage0-${RUST_BOOT_SIG}.tar.bz2
RUST_BOOT_SIG= 2015-05-24-ba0e1cd-freebsd-x86_64-370db40613f5c08563ed7e38357826dd42d4e0f8
# Rust's libraries are named librustc_${component}-${RUST_VSN_HASH}.so.
# The hash depends on Rust version and channel. See
# $(CFG_FILENAME_EXTRA) definition in src/main.mk.
# The hash depends on Rust version and, if the channel is not "stable",
# the channel name. See $(CFG_FILENAME_EXTRA) definition in mk/main.mk.
RUST_VSN= ${PORTVERSION:R}
RUST_CHANNEL= ${PORTNAME:S/^rust-//}
RUST_VSN_HASH!= /usr/bin/printf '%s' ${RUST_VSN}-${RUST_CHANNEL} | /sbin/md5 -q | cut -c 1-8
PLIST_SUB+= RUST_VSN_HASH=${RUST_VSN_HASH}
USES= gmake python:2,build
PLIST_SUB+= RUST_TARGET=x86_64-unknown-${OPSYS:tl}
USES= gmake libedit python:2,build
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --disable-valgrind --disable-docs \
--enable-clang --mandir=${MANPREFIX}/man \
@ -81,9 +83,29 @@ LLNEXTGEN_BUILD_DEPENDS= LLnextgen:${PORTSDIR}/devel/llnextgen
BROKEN= Only compiles on FreeBSD 10 and 11
.endif
.if ${OPSYS} == DragonFly
IGNORE= please use lang/rust-dragonfly instead
.endif
pre-fetch:
# FIXME: This is the same check for CONFLICTS as the standard
# one, except port origins are not compared. This allows
# the port to conflict with itself, because Rust would pick
# installed Rust libraries instead of freshly built ones.
@conflicts_with=$$( \
{ ${PKG_QUERY} -g "%n-%v %p %o" ${CONFLICTS:C/.+/'&'/} ${CONFLICTS_BUILD:C/.+/'&'/} 2>/dev/null || : ; } \
| while read pkgname prfx orgn; do \
if [ "/${PREFIX}" = "/$${prfx}" ]; then \
${ECHO_CMD} -n " $${pkgname}"; \
fi; \
done); \
if [ -n "$${conflicts_with}" ]; then \
${ECHO_MSG}; \
${ECHO_MSG} "===> ${PKGNAME} conflicts with installed package(s): "; \
for entry in $${conflicts_with}; do \
${ECHO_MSG} " $${entry}"; \
done; \
${ECHO_MSG}; \
${ECHO_MSG} " They will not build together."; \
${ECHO_MSG} " Please remove them first with pkg delete."; \
exit 1;\
fi
post-extract:
@(${RMDIR} ${WRKSRC}/src/compiler-rt && \
@ -98,6 +120,10 @@ post-extract:
${LN} -sf ${DISTDIR}/${RUST_BOOT} ${WRKSRC}/dl
(cd ${WRKSRC} && find . -type d -exec chmod 0755 {} \;)
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/mk/main.mk
# In case the previous "make stage" failed, this ensures rust's
# install.sh won't backup previously staged files before reinstalling
# new ones. Otherwise, the staging directory is polluted with unneeded

View File

@ -0,0 +1,11 @@
--- mk/main.mk.orig 2015-09-03 11:50:44 UTC
+++ mk/main.mk
@@ -107,7 +107,7 @@ ifneq ($(wildcard $(NON_BUILD_TARGET)),)
CFG_INFO := $(info cfg: non-build target triples $(NON_BUILD_TARGET))
endif
-CFG_RUSTC_FLAGS := $(RUSTFLAGS)
+CFG_RUSTC_FLAGS := $(RUSTFLAGS) -L%%LOCALBASE%%/lib
CFG_GCCISH_CFLAGS :=
CFG_GCCISH_LINK_FLAGS :=

View File

@ -32,53 +32,53 @@ lib/rustlib/etc/gdb_rust_pretty_printing.py
lib/rustlib/manifest-rustc
lib/rustlib/rust-installer-version
lib/rustlib/uninstall.sh
lib/rustlib/x86_64-unknown-freebsd/lib/liballoc-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libarena-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libarena-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libcollections-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libcompiler-rt.a
lib/rustlib/x86_64-unknown-freebsd/lib/libcore-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libflate-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libflate-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libfmt_macros-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libgetopts-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libgetopts-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libgraphviz-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libgraphviz-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/liblibc-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/liblog-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/liblog-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libmorestack.a
lib/rustlib/x86_64-unknown-freebsd/lib/librand-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/librbml-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/librbml-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_back-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_bitflags-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_borrowck-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_data_structures-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_driver-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_lint-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_llvm-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_privacy-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_resolve-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_trans-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_typeck-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_unicode-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/librustdoc-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libserialize-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libserialize-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libstd-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libstd-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libsyntax-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libterm-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libterm-%%RUST_VSN_HASH%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libtest-%%RUST_VSN_HASH%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libtest-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/liballoc-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libarena-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libarena-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libcollections-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libcompiler-rt.a
lib/rustlib/%%RUST_TARGET%%/lib/libcore-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libflate-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libflate-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libfmt_macros-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libgetopts-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libgetopts-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libgraphviz-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libgraphviz-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/liblibc-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/liblog-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/liblog-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libmorestack.a
lib/rustlib/%%RUST_TARGET%%/lib/librand-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/librbml-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/librbml-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_back-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_bitflags-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/librustc_borrowck-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_data_structures-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_driver-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_lint-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_llvm-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_privacy-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_resolve-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_trans-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_typeck-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_unicode-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/librustdoc-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libserialize-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libserialize-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libstd-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libstd-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libsyntax-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libterm-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libterm-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libtest-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libtest-%%RUST_VSN_HASH%%.so
man/man1/rustc.1.gz
man/man1/rustdoc.1.gz
@dir lib/rustlib/x86_64-unknown-freebsd/lib
@dir lib/rustlib/x86_64-unknown-freebsd
@dir lib/rustlib/%%RUST_TARGET%%/lib
@dir lib/rustlib/%%RUST_TARGET%%
@dir lib/rustlib
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
%%PORTDOCS%%%%DOCSDIR%%/LICENSE-APACHE

View File

@ -34,12 +34,21 @@ RUST_SOURCE= ${DISTNAME}-src${EXTRACT_SUFX}
RUST_BOOT= rust-stage0-${RUST_BOOT_SIG}.tar.bz2
RUST_BOOT_SIG= 2015-05-24-ba0e1cd-freebsd-x86_64-370db40613f5c08563ed7e38357826dd42d4e0f8
# Rust's libraries are named librustc_${component}-${RUST_VSN_HASH}.so.
# The hash depends on Rust version and, if the channel is not "stable",
# the channel name. See $(CFG_FILENAME_EXTRA) definition in mk/main.mk.
RUST_VSN= ${PORTVERSION}
RUST_CHANNEL= stable
RUST_VSN_HASH!= /usr/bin/printf '%s' ${RUST_VSN} | /sbin/md5 -q | cut -c 1-8
PLIST_SUB+= RUST_VSN_HASH=${RUST_VSN_HASH}
PLIST_SUB+= RUST_TARGET=x86_64-unknown-${OPSYS:tl}
USES= gmake libedit python:2,build
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --disable-valgrind --disable-docs \
--enable-clang --mandir=${MANPREFIX}/man \
--release-channel=stable
PLIST_SUB+= VSN="62abc69f"
--release-channel=${RUST_CHANNEL}
# Use LLVM from ports, instead of the copy shipped with rust.
LLVM_VER= 36
@ -55,15 +64,35 @@ LLNEXTGEN_DESC= Build with grammar verification
LLNEXTGEN_BUILD_DEPENDS= LLnextgen:${PORTSDIR}/devel/llnextgen
.include <bsd.port.pre.mk>
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
BROKEN= Only compiles on FreeBSD 10 and 11
.endif
.if ${OPSYS} == DragonFly
IGNORE= please use lang/rust-dragonfly instead
.endif
pre-fetch:
# FIXME: This is the same check for CONFLICTS as the standard
# one, except port origins are not compared. This allows
# the port to conflict with itself, because Rust would pick
# installed Rust libraries instead of freshly built ones.
@conflicts_with=$$( \
{ ${PKG_QUERY} -g "%n-%v %p %o" ${CONFLICTS:C/.+/'&'/} ${CONFLICTS_BUILD:C/.+/'&'/} 2>/dev/null || : ; } \
| while read pkgname prfx orgn; do \
if [ "/${PREFIX}" = "/$${prfx}" ]; then \
${ECHO_CMD} -n " $${pkgname}"; \
fi; \
done); \
if [ -n "$${conflicts_with}" ]; then \
${ECHO_MSG}; \
${ECHO_MSG} "===> ${PKGNAME} conflicts with installed package(s): "; \
for entry in $${conflicts_with}; do \
${ECHO_MSG} " $${entry}"; \
done; \
${ECHO_MSG}; \
${ECHO_MSG} " They will not build together."; \
${ECHO_MSG} " Please remove them first with pkg delete."; \
exit 1;\
fi
post-extract:
@${MKDIR} ${WRKSRC}/dl
@ -101,4 +130,4 @@ post-install:
${STAGEDIR}${PREFIX}/lib/*.so \
${STAGEDIR}${PREFIX}/lib/rustlib/*/lib/*.so
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,30 +1,30 @@
bin/rust-gdb
bin/rustc
bin/rustdoc
lib/libarena-%%VSN%%.so
lib/libflate-%%VSN%%.so
lib/libfmt_macros-%%VSN%%.so
lib/libgetopts-%%VSN%%.so
lib/libgraphviz-%%VSN%%.so
lib/liblog-%%VSN%%.so
lib/librbml-%%VSN%%.so
lib/librustc-%%VSN%%.so
lib/librustc_back-%%VSN%%.so
lib/librustc_borrowck-%%VSN%%.so
lib/librustc_data_structures-%%VSN%%.so
lib/librustc_driver-%%VSN%%.so
lib/librustc_lint-%%VSN%%.so
lib/librustc_llvm-%%VSN%%.so
lib/librustc_privacy-%%VSN%%.so
lib/librustc_resolve-%%VSN%%.so
lib/librustc_trans-%%VSN%%.so
lib/librustc_typeck-%%VSN%%.so
lib/librustdoc-%%VSN%%.so
lib/libserialize-%%VSN%%.so
lib/libstd-%%VSN%%.so
lib/libsyntax-%%VSN%%.so
lib/libterm-%%VSN%%.so
lib/libtest-%%VSN%%.so
lib/libarena-%%RUST_VSN_HASH%%.so
lib/libflate-%%RUST_VSN_HASH%%.so
lib/libfmt_macros-%%RUST_VSN_HASH%%.so
lib/libgetopts-%%RUST_VSN_HASH%%.so
lib/libgraphviz-%%RUST_VSN_HASH%%.so
lib/liblog-%%RUST_VSN_HASH%%.so
lib/librbml-%%RUST_VSN_HASH%%.so
lib/librustc-%%RUST_VSN_HASH%%.so
lib/librustc_back-%%RUST_VSN_HASH%%.so
lib/librustc_borrowck-%%RUST_VSN_HASH%%.so
lib/librustc_data_structures-%%RUST_VSN_HASH%%.so
lib/librustc_driver-%%RUST_VSN_HASH%%.so
lib/librustc_lint-%%RUST_VSN_HASH%%.so
lib/librustc_llvm-%%RUST_VSN_HASH%%.so
lib/librustc_privacy-%%RUST_VSN_HASH%%.so
lib/librustc_resolve-%%RUST_VSN_HASH%%.so
lib/librustc_trans-%%RUST_VSN_HASH%%.so
lib/librustc_typeck-%%RUST_VSN_HASH%%.so
lib/librustdoc-%%RUST_VSN_HASH%%.so
lib/libserialize-%%RUST_VSN_HASH%%.so
lib/libstd-%%RUST_VSN_HASH%%.so
lib/libsyntax-%%RUST_VSN_HASH%%.so
lib/libterm-%%RUST_VSN_HASH%%.so
lib/libtest-%%RUST_VSN_HASH%%.so
lib/rustlib/components
lib/rustlib/etc/debugger_pretty_printers_common.py
lib/rustlib/etc/gdb_load_rust_pretty_printers.py
@ -32,49 +32,49 @@ lib/rustlib/etc/gdb_rust_pretty_printing.py
lib/rustlib/manifest-rustc
lib/rustlib/rust-installer-version
lib/rustlib/uninstall.sh
lib/rustlib/x86_64-unknown-freebsd/lib/liballoc-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libarena-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libarena-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libcollections-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libcompiler-rt.a
lib/rustlib/x86_64-unknown-freebsd/lib/libcore-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libflate-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libflate-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libfmt_macros-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libgetopts-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libgetopts-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libgraphviz-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libgraphviz-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/liblibc-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/liblog-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/liblog-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libmorestack.a
lib/rustlib/x86_64-unknown-freebsd/lib/librand-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/librbml-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/librbml-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_back-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_bitflags-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_borrowck-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_data_structures-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_driver-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_lint-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_llvm-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_privacy-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_resolve-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_trans-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_typeck-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/librustc_unicode-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/librustdoc-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libserialize-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libserialize-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libstd-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libstd-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libsyntax-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libterm-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libterm-%%VSN%%.so
lib/rustlib/x86_64-unknown-freebsd/lib/libtest-%%VSN%%.rlib
lib/rustlib/x86_64-unknown-freebsd/lib/libtest-%%VSN%%.so
lib/rustlib/%%RUST_TARGET%%/lib/liballoc-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libarena-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libarena-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libcollections-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libcompiler-rt.a
lib/rustlib/%%RUST_TARGET%%/lib/libcore-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libflate-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libflate-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libfmt_macros-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libgetopts-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libgetopts-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libgraphviz-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libgraphviz-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/liblibc-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/liblog-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/liblog-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libmorestack.a
lib/rustlib/%%RUST_TARGET%%/lib/librand-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/librbml-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/librbml-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_back-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_bitflags-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/librustc_borrowck-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_data_structures-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_driver-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_lint-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_llvm-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_privacy-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_resolve-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_trans-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_typeck-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_unicode-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/librustdoc-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libserialize-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libserialize-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libstd-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libstd-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libsyntax-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libterm-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libterm-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libtest-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libtest-%%RUST_VSN_HASH%%.so
man/man1/rustc.1.gz
man/man1/rustdoc.1.gz
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT