- Remove palm/synce-dccm (Project was renamed to palm/synce-vdccm)

- Fix depenceny in palm/synce-serial
This commit is contained in:
Martin Wilke 2008-07-27 14:11:53 +00:00
parent 73749bcf85
commit 23d16d2528
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=217666
17 changed files with 2 additions and 183 deletions

View File

@ -32,7 +32,6 @@
SUBDIR += prc-tools
SUBDIR += romeo
SUBDIR += sitescooper
SUBDIR += synce-dccm
SUBDIR += synce-gnomevfs
SUBDIR += synce-kde
SUBDIR += synce-librapi2
@ -41,6 +40,7 @@
SUBDIR += synce-multisync
SUBDIR += synce-serial
SUBDIR += synce-trayicon
SUBDIR += synce-vdccm
SUBDIR += txt2pdbdoc
SUBDIR += uppc-kmod

View File

@ -1,28 +0,0 @@
# New ports collection makefile for: synce-dccm
# Date created: 14 June 2003
# Whom: Sam Lawrance <boris@brooknet.com.au>
#
# $FreeBSD$
PORTNAME= synce-dccm
PORTVERSION= 0.9.3
CATEGORIES= palm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= synce
DISTNAME= synce-vdccm-${PORTVERSION}
MAINTAINER= ports@logvinov.com
COMMENT= Listener daemon for connections from WinCE devices
BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS+= synce.0:${PORTSDIR}/palm/synce-libsynce
GNU_CONFIGURE= yes
USE_ICONV= yes
WRKSRC= ${WRKDIR}/vdccm-${PORTVERSION}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE} \
--with-libsynce=${LOCALBASE}
USE_LDCONFIG= yes
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
MD5 (synce-vdccm-0.9.3.tar.gz) = 996236320a6b4c9410050c4dc6e53164
SHA256 (synce-vdccm-0.9.3.tar.gz) = e2e26ff503c242189c3cdc4778db72c38d28c86c0a18f7a1d2fda26801789571
SIZE (synce-vdccm-0.9.3.tar.gz) = 354000

View File

@ -1,10 +0,0 @@
--- lib/localsocket.h.orig Fri Jan 26 03:40:07 2007
+++ lib/localsocket.h Fri Jan 26 03:40:23 2007
@@ -24,6 +24,7 @@
#define LOCALSOCKET_H
#include <string>
+#include <sys/socket.h>
#include <sys/un.h>
#include "netsocket.h"

View File

@ -1,14 +0,0 @@
--- lib/tcpconnectedsocket.cpp.orig Thu Jun 29 22:01:48 2006
+++ lib/tcpconnectedsocket.cpp Fri Jan 26 20:36:48 2007
@@ -149,8 +149,10 @@
int TCPConnectedSocket::getMTU()
{
int s;
+ struct protoent *pent;
socklen_t r = sizeof(int);
- if (getsockopt(getDescriptor(), SOL_IP, IP_MTU, &s, &r) < 0) {
+ pent = getprotobyname ("ip");
+ if (getsockopt(getDescriptor(), ((pent != NULL) ? pent->p_proto : 0), IP_MTU, &s, &r) < 0) {
s = -1;
}

View File

@ -1,10 +0,0 @@
--- lib/tcpsocket.h.orig Fri Jan 26 03:21:01 2007
+++ lib/tcpsocket.h Fri Jan 26 03:21:48 2007
@@ -24,6 +24,7 @@
#define TCPSOCKET_H
#include <string>
+#include <sys/socket.h>
#include <netinet/in.h>
#include "netsocket.h"

View File

@ -1,11 +0,0 @@
--- lib/udpsocket.cpp.orig Sun May 7 18:49:36 2006
+++ lib/udpsocket.cpp Fri Jan 26 19:21:19 2007
@@ -10,6 +10,8 @@
//
//
#include "udpsocket.h"
+#include <netinet/in.h>
+#include <sys/socket.h>
#include <netdb.h>
using namespace std;

View File

@ -1,11 +0,0 @@
--- src/vdccm.cpp.orig Fri Jan 26 19:24:38 2007
+++ src/vdccm.cpp Fri Jan 26 19:26:01 2007
@@ -34,7 +34,7 @@
#include <localserversocket.h>
#include <synce_log.h>
#include <iostream>
-#include <wait.h>
+#include <sys/wait.h>
using namespace synce;
using namespace std;

View File

@ -1,14 +0,0 @@
--- src/rapiclient.cpp.orig 2008-04-15 11:35:52.000000000 +0200
+++ src/rapiclient.cpp 2008-04-15 11:37:50.000000000 +0200
@@ -20,6 +20,11 @@
#include <errno.h>
#include <synce.h>
+#if defined(__FreeBSD__) && defined(__sparc64__)
+#include <sys/endian.h>
+#define bswap_16 bswap16
+#define bswap_32 bswap32
+#endif
using namespace std;

View File

@ -1,15 +0,0 @@
--- src/rapiconnection.cpp.orig 2008-04-15 11:39:02.000000000 +0200
+++ src/rapiconnection.cpp 2008-04-15 11:39:14.000000000 +0200
@@ -22,6 +22,12 @@
#include "synce_log.h"
#include <multiplexer.h>
+#if defined(__FreeBSD__) && defined(__sparc64__)
+#include <sys/endian.h>
+#define bswap_16 bswap16
+#define bswap_32 bswap32
+#endif
+
using namespace std;
RapiConnection::RapiConnection(RapiProxyFactory *proxyFactory, string path, RapiServer *rapiServer, string deviceIpAddress) : LocalServerSocket(proxyFactory, path), rapiHandshakeClient(NULL), deviceIpAddress(deviceIpAddress), rapiServer(rapiServer)

View File

@ -1,14 +0,0 @@
--- src/rapihandshakeclient.cpp.orig 2008-04-15 11:38:15.000000000 +0200
+++ src/rapihandshakeclient.cpp 2008-04-15 11:38:23.000000000 +0200
@@ -17,6 +17,11 @@
#include <udpsocket.h>
#include <synce_log.h>
+#if defined(__FreeBSD__) && defined(__sparc64__)
+#include <sys/endian.h>
+#define bswap_16 bswap16
+#define bswap_32 bswap32
+#endif
RapiHandshakeClient::RapiHandshakeClient( int fd, TCPServerSocket *tcpServerSocket )
: RapiClient( fd, tcpServerSocket )

View File

@ -1,15 +0,0 @@
--- src/rapiproxyconnection.cpp.orig 2008-04-15 11:39:47.000000000 +0200
+++ src/rapiproxyconnection.cpp 2008-04-15 11:42:37.000000000 +0200
@@ -19,6 +19,12 @@
#include <iostream>
+#if defined(__FreeBSD__) && defined(__sparc64__)
+#include <sys/endian.h>
+#define bswap_16 bswap16
+#define bswap_32 bswap32
+#endif
+
RapiProxyConnection::RapiProxyConnection(RapiConnection *rapiConnection, RapiProxy *rapiProxy,
RapiProvisioningClient *rapiProvisioningClient)
: rapiConnection(rapiConnection),

View File

@ -1,15 +0,0 @@
--- src/windowscedevice.cpp.orig 2008-04-15 11:28:35.000000000 +0200
+++ src/windowscedevice.cpp 2008-04-15 11:37:11.000000000 +0200
@@ -29,6 +29,12 @@
#include <devicemanager.h>
+#if defined(__FreeBSD__) && defined(__sparc64__)
+#include <sys/endian.h>
+#define bswap_16 bswap16
+#define bswap_32 bswap32
+#endif
+
using namespace std;
WindowsCEDevice::WindowsCEDevice(int fd, TCPServerSocket *tcpServerSocket)

View File

@ -1,10 +0,0 @@
--- testtools/triggerconnection.cpp.orig Fri Jan 26 19:27:52 2007
+++ testtools/triggerconnection.cpp Fri Jan 26 19:28:25 2007
@@ -16,6 +16,7 @@
#include <unistd.h>
#include <sys/types.h>
#include <sys/socket.h>
+#include <netinet/in.h>
int main(int argc, char *argv[])

View File

@ -1,5 +0,0 @@
SynCE is a project for connecting to devices running Windows CE or Pocket PC.
Dccm is a daemon that listens for connections from a Windows CE device.
Once connected, the synce-librapi tools are able to interact with the device.
WWW: http://synce.sourceforge.net/

View File

@ -1,6 +0,0 @@
bin/vdccm
bin/proxyclient
bin/triggerconnection
lib/libdescriptor.la
lib/libdescriptor.so
lib/libdescriptor.so.0

View File

@ -13,7 +13,7 @@ MASTER_SITE_SUBDIR= synce
MAINTAINER= ports@logvinov.com
COMMENT= Wrapper for pppd to initiate communications with Windows Mobile devices
RUN_DEPENDS= vdccm:${PORTSDIR}/palm/synce-dccm
RUN_DEPENDS= vdccm:${PORTSDIR}/palm/synce-vdccm
CONFLICTS= synce-hal-[0-9]*