net/cf: add port

The official command line client for Cloud Foundry.

WWW: http://cloudfoundry.org/
This commit is contained in:
Steve Wills 2015-05-06 18:28:25 +00:00
parent df38f1f73e
commit 23b654137a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=385538
5 changed files with 73 additions and 0 deletions

View File

@ -64,6 +64,7 @@
SUBDIR += c3270
SUBDIR += cagibi
SUBDIR += ccxstream
SUBDIR += cf
SUBDIR += chrony
SUBDIR += citrix_ica
SUBDIR += clamz

56
net/cf/Makefile Normal file
View File

@ -0,0 +1,56 @@
# $FreeBSD$
PORTNAME= cf
PORTVERSION= 6.11.2
DISTVERSIONPREFIX= v
CATEGORIES= net
MAINTAINER= swills@FreeBSD.org
COMMENT= CLI for Cloud Foundry written in Go
BUILD_DEPENDS= ${LOCALBASE}/bin/go:${PORTSDIR}/lang/go \
${LOCALBASE}/bin/go-bindata:${PORTSDIR}/devel/go-bindata
USE_GITHUB= yes
GH_ACCOUNT= cloudfoundry
GH_PROJECT= cli
PLIST_FILES= bin/cf
PORTDOCS= BUILDING.md CHANGELOG.md INSTALL.md LICENSE README.md VERSION
STRIP= # stripping can break go binaries
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e "s/BUILT_FROM_SOURCE/${PORTVERSION}/g" ${WRKSRC}/cf/app_constants.go
@cd ${WRKSRC} ; ${MKDIR} Godeps/_workspace/src/github.com/${GH_ACCOUNT}/${GH_PROJECT} ; \
${CP} -R .gitignore .travis.yml BUILDING.md CHANGELOG.md \
INSTALL.md LICENSE README.md VERSION bin cf \
cf_commands_excluded.json ci excluded.json fileutils fixtures \
flags generic glob installers json main makefile plugin \
plugin_examples release testhelpers utils words \
Godeps/_workspace/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}
do-build:
cd ${WRKSRC}/Godeps/_workspace/src/github.com/${GH_ACCOUNT}/${GH_PROJECT} ; \
${SETENV} GOPATH=${WRKSRC}/Godeps/_workspace go-bindata -pkg \
resources -o cf/resources/i18n_resources.go \
cf/i18n/resources/... cf/i18n/test_fixtures/...
cd ${WRKSRC} ; \
${SETENV} GOPATH=${WRKSRC}/Godeps/_workspace go build -o out/cf ./main
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/out/cf \
${STAGEDIR}${PREFIX}/bin/
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for x in ${PORTDOCS}
${INSTALL_MAN} ${WRKSRC}/${x} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

2
net/cf/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (cloudfoundry-cli-v6.11.2_GH0.tar.gz) = 1c6ad0b18adc631fa4dd1ea3b91bf8103586db7620bc41be1099e9e1c21e0bbb
SIZE (cloudfoundry-cli-v6.11.2_GH0.tar.gz) = 2228133

View File

@ -0,0 +1,11 @@
--- cf/app/app.go.orig 2015-04-29 12:36:58.960111000 +0000
+++ cf/app/app.go 2015-04-29 12:37:20.199807000 +0000
@@ -98,7 +98,7 @@
{{.Version}}
{{.Title "` + T("BUILD TIME:") + `"}}
- {{.Compiled}}
+ BUILT_AT_UNKNOWN_TIME
{{range .Commands}}
{{.SubTitle .Name}}{{range .CommandSubGroups}}
{{range .}} {{.Name}} {{.Description}}

3
net/cf/pkg-descr Normal file
View File

@ -0,0 +1,3 @@
The official command line client for Cloud Foundry.
WWW: http://cloudfoundry.org/