Those ports will be added soon to the ports tree with more adequate names.

There is no history for those porst, so no repocopy.
. french/fr-py-qt4-eric4
. german/de-py-qt4-eric4
. russian/ru-py-qt4-eric4
. devel/py-qt4-eric4
This commit is contained in:
Boris Samorodov 2007-07-25 22:44:09 +00:00
parent 3584fd63cb
commit 23a168004a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=196286
18 changed files with 4 additions and 2318 deletions

4
MOVED
View File

@ -3106,3 +3106,7 @@ devel/rx||2007-07-22|Expired: has been decommissioned and is no longer developed
security/metasploit-devel|security/metasploit|2007-07-23|move to security/metasploit
x11/nvidia-driver-7184|x11/nvidia-driver-71xx|2007-07-23|moved to x11/nvidia-driver-71xx
x11/nvidia-driver-9631|x11/nvidia-driver-96xx|2007-07-23|moved to x11/nvidia-driver-96xx
french/fr-py-qt4-eric4||2007-07-25|Removed
german/de-py-qt4-eric4||2007-07-25|Removed
russian/ru-py-qt4-eric4||2007-07-25|Removed
devel/py-qt4-eric4||2007-07-25|Removed

View File

@ -1906,7 +1906,6 @@
SUBDIR += py-qt4-dbus
SUBDIR += py-qt4-designer
SUBDIR += py-qt4-designerplugin
SUBDIR += py-qt4-eric4
SUBDIR += py-qt4-qct
SUBDIR += py-qt4-qscintilla2
SUBDIR += py-qt4-test

View File

@ -1,29 +0,0 @@
# New ports collection makefile for: py-qt4-eric4
# Date created: 21 Apr 2007
# Whom: Boris Samorodov <bsam@FreeBSD.org>
#
# $FreeBSD$
#
CATEGORIES= devel python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
DISTNAME= ${PORTNAME}-snapshot-${SNAPSHOT}
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui \
${PYTHON_SITELIBDIR}/PyQt4/Qsci.so:${PORTSDIR}/devel/py-qt4-qscintilla2
RUN_DEPENDS= ${BUILD_DEPENDS} \
${PYTHON_SITELIBDIR}/PyQt4/QtNetwork.so:${PORTSDIR}/net/py-qt4-network
INSTALL_CMD= install.py -c -f eric4config.freebsd
PLIST_FILES=
BROKEN= Unfetchable
do-configure:
${SED} -e 's,PYTHON_SITELIBDIR,${PYTHON_SITELIBDIR},' \
-e 's,PREFIX,${PREFIX},' \
-e 's,DOCSDIR,${DOCSDIR},' \
-e 's,EXAMPLESDIR,${EXAMPLESDIR},' \
< ${FILESDIR}/config > ${WRKSRC}/eric4config.freebsd
.include "${.CURDIR}/../../devel/py-qt4-eric4/Makefile.inc"

View File

@ -1,38 +0,0 @@
# This is a set of Makefile macros which allow to build the core and
# localized language packages for devel/py-qt4-eric4. Look at
# german/de-py-qt4-eric4 for an example.
#
# Date created: 23 Apr 2007
# Whom: Boris Samorodov <bsam@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= eric4
PORTVERSION= 4.0.a${SNAPSHOT}
MASTER_SITES= http://www.die-offenbachs.de/detlev/snapshots4/
PKGNAMEPREFIX?= ${I18N_LANG}-${PYTHON_PKGNAMEPREFIX}qt4-
DISTNAME?= ${PORTNAME}-i18n-${I18N_LANG}-snapshot-${SNAPSHOT}
WRKSRC= ${WRKDIR}/${PORTNAME}-snapshot-${SNAPSHOT}
MAINTAINER?= bsam@FreeBSD.org
COMMENT= Full featured Python and Ruby editor and IDE based on Qt4
RUN_DEPENDS?= ${PREFIX}/bin/eric4:${PORTSDIR}/devel/py-qt4-eric4
SNAPSHOT= 20070411
I18N_LANG?= ru
INSTALL_CMD?= install-i18n.py
USE_PYTHON= 2.4+
NO_BUILD= yes
DOCSDIR= ${TARGETDIR}/share/doc/py-qt4-${PORTNAME}
PLIST_FILES?= %%PYTHON_SITELIBDIR%%/${PORTNAME}/${PORTNAME}_${I18N_LANG}.qm
do-install:
@(cd ${WRKSRC}; \
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${INSTALL_CMD})
DESCR= ${.CURDIR}/../../devel/py-qt4-eric4/pkg-descr
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
MD5 (eric4-snapshot-20070411.tar.gz) = c5c9cde9c9d40638e3649964d69ffdbf
SHA256 (eric4-snapshot-20070411.tar.gz) = 410f00bd6fb4752d2173801f427355e9b817407adaf534cea5b20dd3196f1c46
SIZE (eric4-snapshot-20070411.tar.gz) = 2427890

View File

@ -1,22 +0,0 @@
# -*- coding: utf-8 -*-
#
# This module contains the configuration of the individual eric4 installation
#
cfg = {
'ericDir' : 'PYTHON_SITELIBDIR/eric4',
'ericPixDir' : 'PYTHON_SITELIBDIR/eric4',
'ericIconDir' : 'PYTHON_SITELIBDIR/eric4',
'ericDTDDir' : 'PYTHON_SITELIBDIR/eric4',
'ericCSSDir' : 'PYTHON_SITELIBDIR/eric4',
'ericStylesDir' : 'PYTHON_SITELIBDIR/eric4',
'ericDocDir' : 'DOCSDIR',
'ericExamplesDir' : 'EXAMPLESDIR',
'ericTranslationsDir' : 'PYTHON_SITELIBDIR/eric4',
'ericWizardsDir' : 'PYTHON_SITELIBDIR/eric4',
'ericTemplatesDir' : 'PYTHON_SITELIBDIR/eric4',
'ericCodeTemplatesDir' : 'PYTHON_SITELIBDIR/eric4',
'ericOthersDir' : 'PYTHON_SITELIBDIR/eric4',
'bindir' : 'PREFIX/bin',
'mdir' : 'PREFIX/man'
}

View File

@ -1,11 +0,0 @@
--- install.py.orig Sun Apr 22 21:51:14 2007
+++ install.py Sun Apr 22 22:34:37 2007
@@ -409,7 +409,7 @@
'bindir' : platBinDir,
'mdir' : modDir,
}
-configLength = 13
+configLength = 15
def createConfig():
"""

View File

@ -1,12 +0,0 @@
Eric is a full featured Python and Ruby editor and IDE, written in python.
It is based on the cross platform Qt gui toolkit, integrating the highly
flexible Scintilla editor control. It is designed to be usable as everdays'
quick and dirty editor as well as being usable as a professional project
management tool integrating many advanced features Python offers
the professional coder.
This is a port of eric4 (based on Qt4, development version).
WWW: http://www.die-offenbachs.de/detlev/eric.html

File diff suppressed because it is too large Load Diff

View File

@ -11,7 +11,6 @@
SUBDIR += dico
SUBDIR += eficas
SUBDIR += facturier
SUBDIR += fr-py-qt4-eric4
SUBDIR += geonext
SUBDIR += gfaim
SUBDIR += gibi

View File

@ -1,12 +0,0 @@
# New ports collection makefile for: fr-py-qt4-eric4
# Date created: 23 Apr 2007
# Whom: Boris Samorodov <bsam@FreeBSD.org>
#
# $FreeBSD$
#
CATEGORIES= french devel python
I18N_LANG= fr
.include "${.CURDIR}/../../devel/py-qt4-eric4/Makefile.inc"

View File

@ -1,3 +0,0 @@
MD5 (eric4-i18n-fr-snapshot-20070411.tar.gz) = 6bc1accd1beea63c24729aa29f761ae3
SHA256 (eric4-i18n-fr-snapshot-20070411.tar.gz) = 3f46df8651b1ac55a85e18ba9927c7785d54b9e44a58176444a443c0396b08b1
SIZE (eric4-i18n-fr-snapshot-20070411.tar.gz) = 449155

View File

@ -11,7 +11,6 @@
SUBDIR += bsdgroup-firefox-searchplugin
SUBDIR += bsdpaste
SUBDIR += citrix_ica
SUBDIR += de-py-qt4-eric4
SUBDIR += dict
SUBDIR += digibux
SUBDIR += ding

View File

@ -1,12 +0,0 @@
# New ports collection makefile for: de-py-qt4-eric4
# Date created: 23 Apr 2007
# Whom: Boris Samorodov <bsam@FreeBSD.org>
#
# $FreeBSD$
#
CATEGORIES= german devel python
I18N_LANG= de
.include "${.CURDIR}/../../devel/py-qt4-eric4/Makefile.inc"

View File

@ -1,3 +0,0 @@
MD5 (eric4-i18n-de-snapshot-20070411.tar.gz) = 89dd350de0a77a09f6b57ec05454bcba
SHA256 (eric4-i18n-de-snapshot-20070411.tar.gz) = 979d48d989a38b35896907a9a7ca6b28b188f27102abc371c672e8985d770e2a
SIZE (eric4-i18n-de-snapshot-20070411.tar.gz) = 387246

View File

@ -28,7 +28,6 @@
SUBDIR += php_doc
SUBDIR += prawda
SUBDIR += pscyr
SUBDIR += ru-py-qt4-eric4
SUBDIR += rubygem-rutils
SUBDIR += rus-ispell
SUBDIR += rux

View File

@ -1,10 +0,0 @@
# New ports collection makefile for: ru-py-qt4-eric4
# Date created: 23 Apr 2007
# Whom: Boris Samorodov <bsam@FreeBSD.org>
#
# $FreeBSD$
#
CATEGORIES= russian devel python
.include "${.CURDIR}/../../devel/py-qt4-eric4/Makefile.inc"

View File

@ -1,3 +0,0 @@
MD5 (eric4-i18n-ru-snapshot-20070411.tar.gz) = 284737486428763ceb0b1aea5f169089
SHA256 (eric4-i18n-ru-snapshot-20070411.tar.gz) = 5d8385eded4e413d1b32a22b1171a740c99d4729f235ace4849ac7b671472f22
SIZE (eric4-i18n-ru-snapshot-20070411.tar.gz) = 459291