- Change Makefile header

- Change master sites remove GH
- Change maintainer email to @FreeBSD.org
- USE_GNOME cairo instead of graphics/cairo
- Add DOCS Option
- Support STAGEDIR and add OPTIONS_SUB
- Add patch, fix build with Clang

Approved by:	pawel / wg (mentors, implicit)
This commit is contained in:
Rusmir Dusko 2013-10-21 21:23:34 +00:00
parent bac748f555
commit 238e1b9f97
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=331194
3 changed files with 38 additions and 36 deletions

View File

@ -1,22 +1,20 @@
# Created by: nemysis@gmx.ch
# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= bomb-her-man
PORTVERSION= 0.3
PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= GH \
SF/nemysisfreebsdp/:icons
MASTER_SITES= SF/nemysisfreebsdp/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}_icons${EXTRACT_SUFX}:icons
MAINTAINER= nemysis@gmx.ch
MAINTAINER= nemysis@FreeBSD.org
COMMENT= Bomberman clone written in C++
LICENSE= GPLv3
BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
USE_GITHUB= yes
GH_ACCOUNT= Keruspe
@ -26,7 +24,7 @@ GH_COMMIT= 8f5aa22
USES= gmake pkgconfig
USE_SDL= sdl image mixer ttf
USE_GNOME= intltool librsvg2
USE_GNOME= cairo intltool librsvg2
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake:env
ALL_TARGET= # empty
@ -42,41 +40,35 @@ ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
DESKTOP_ENTRIES="Bomb-her-man" "Bomberman clone" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" false
OPTIONS_DEFINE= NLS
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
# Wrong versioning upstream
PORTSCOUT= ignore:1
NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
pre-configure:
@(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
.if ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e 's|itlocaledir = $$(prefix)/$$(DATADIRNAME)/locale|itlocaledir = $$(prefix)/share/locale|' \
@${REINPLACE_CMD} -e 's|$$(prefix)/$$(DATADIRNAME)/locale|$$(prefix)/share/locale|' \
${WRKSRC}/po/Makefile.in.in
.endif
post-install:
.for s in ${ICON_SIZES}
${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View File

@ -0,0 +1,22 @@
--- src/display/display.cpp.orig 2012-05-26 11:11:52.000000000 +0200
+++ src/display/display.cpp 2013-09-17 10:22:23.000000000 +0200
@@ -20,7 +20,7 @@
#include "display.hpp"
#include <sstream>
-#include <librsvg/rsvg-cairo.h>
+#include <librsvg/rsvg.h>
#include <cairo.h>
#include "game/player.hpp"
@@ -116,7 +116,9 @@
throw exceptions::display::NoSDLException("Can't init use of TrueType fonts");
}
- g_type_init();
+ #if !GLIB_CHECK_VERSION(2,35,0)
+ g_type_init();
+ #endif
setMode();
}

View File

@ -61,18 +61,6 @@ share/icons/hicolor/72x72/apps/bomb-her-man.png
share/icons/hicolor/96x96/apps/bomb-her-man.png
%%NLS%%share/locale/fr/LC_MESSAGES/bomb-her-man.mo
share/pixmaps/bomb-her-man.png
@dirrmtry share/icons/hicolor/96x96/apps
@dirrmtry share/icons/hicolor/96x96
@dirrmtry share/icons/hicolor/72x72/apps
@dirrmtry share/icons/hicolor/72x72
@dirrmtry share/icons/hicolor/64x64/apps
@dirrmtry share/icons/hicolor/64x64
@dirrmtry share/icons/hicolor/48x48/apps
@dirrmtry share/icons/hicolor/48x48
@dirrmtry share/icons/hicolor/32x32/apps
@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrm %%DATADIR%%/graphics/scores/2
@dirrm %%DATADIR%%/graphics/scores/1
@dirrm %%DATADIR%%/graphics/scores