New port: special purpose database application

The useracc utility is a special purpose database application
	to store and retrieve data about users in a distributed
	environment. It is usable in situations where a single
	numerical and/or a single non-numerical field for each index
	(possibly a user name) are adequate.

PR:		ports/46394
Submitted by:	Konrad Heuer <kheuer@gwdg.de>
This commit is contained in:
Edwin Groothuis 2003-10-06 01:07:31 +00:00
parent 9fc4aae82d
commit 22c103538d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=90334
6 changed files with 43 additions and 0 deletions

View File

@ -222,6 +222,7 @@
SUBDIR += tora
SUBDIR += typhoon
SUBDIR += unixODBC
SUBDIR += useracc
SUBDIR += usogres
SUBDIR += wfb2sql
SUBDIR += xmbase-grok

View File

@ -0,0 +1,20 @@
# New ports collection makefile for: useracc
# Date created: December 20th, 2002
# Whom: Konrad Heuer
#
# $FreeBSD$
#
PORTNAME= useracc
PORTVERSION= 3.1
CATEGORIES= databases
MASTER_SITES= ftp://gwdu111.gwdg.de/pub/FreeBSD/misc/ \
ftp://gwdu112.gwdg.de/pub/FreeBSD/misc/
MAINTAINER= kheuer@gwdg.de
COMMENT= Special purpose database application
MAN1= useracc.1
MANCOMPRESSED= yes
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (useracc-3.1.tar.gz) = f0744a5bdb184483f304fdb927fd4ba9

View File

@ -0,0 +1,11 @@
--- src/useracc.c.orig Sun Oct 5 18:05:29 2003
+++ src/useracc.c Sun Oct 5 18:05:42 2003
@@ -92,7 +92,7 @@
#include <sys/wait.h>
#include <time.h>
#include <unistd.h>
-#include <varargs.h>
+#include <stdarg.h>
#define ACCFILE "useracc.dat" /* default user accounts file */

View File

@ -0,0 +1,8 @@
The useracc utility is a special purpose database application to
store and retrieve data about users in a distributed environment.
It is usable in situations where a single numerical and/or a single
non-numerical field for each index (possibly a user name) are
adequate.
Konrad Heuer
kheuer@gwdg.de

View File

@ -0,0 +1,2 @@
bin/useracc
etc/rc.d/useracc.sh.sample