mesa*: Update to 21.1.5
- swrast is only a gallium driver now. - Bump needed llvm to 12 - libclc is still a llvm10, moving to >10 needs to change from where we pick libclc as its now part of llvm Differential Revision: https://reviews.freebsd.org/D31165 Reviewed by: kbowling, zeising
This commit is contained in:
parent
1c02555442
commit
22a85734ff
@ -2,7 +2,6 @@
|
||||
|
||||
PORTNAME= libosmesa
|
||||
PORTVERSION= ${MESAVERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
|
||||
COMMENT= Off-Screen Mesa implementation of the OpenGL API
|
||||
@ -15,7 +14,7 @@ USE_XORG= xorgproto
|
||||
|
||||
# Disable some options
|
||||
MESON_ARGS+= -Ddri-drivers="" \
|
||||
-Dgallium-drivers=swrast \
|
||||
-Dgallium-drivers="swrast" \
|
||||
-Dvulkan-drivers="" \
|
||||
-Dplatforms="" \
|
||||
-Dgallium-vdpau=disabled \
|
||||
@ -35,11 +34,7 @@ MESON_ARGS+= -Ddri-drivers="" \
|
||||
-Dzstd=disabled
|
||||
LDFLAGS_i386= -Wl,-znotext
|
||||
|
||||
.if ${ARCH} == sparc64
|
||||
MESON_ARGS+= -Dosmesa=classic
|
||||
.else
|
||||
MESON_ARGS+= -Dosmesa=gallium
|
||||
.endif
|
||||
MESON_ARGS+= -Dosmesa=true
|
||||
|
||||
.include "${MASTERDIR}/Makefile.targets"
|
||||
|
||||
|
@ -1,6 +1,13 @@
|
||||
@comment include/GL/gl.h
|
||||
@comment include/GL/glcorearb.h
|
||||
@comment include/GL/glext.h
|
||||
include/GL/osmesa.h
|
||||
@comment include/KHR/khrplatform.h
|
||||
lib/libOSMesa.so
|
||||
lib/libOSMesa.so.8
|
||||
lib/libOSMesa.so.8.0.0
|
||||
@comment lib/libglapi.so
|
||||
@comment lib/libglapi.so.0
|
||||
@comment lib/libglapi.so.0.0.0
|
||||
libdata/pkgconfig/osmesa.pc
|
||||
@comment share/drirc.d/00-mesa-defaults.conf
|
||||
|
@ -2,7 +2,6 @@
|
||||
|
||||
PORTNAME= mesa-dri
|
||||
PORTVERSION= ${MESAVERSION}
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= graphics
|
||||
|
||||
COMMENT= OpenGL hardware acceleration drivers for DRI2+
|
||||
@ -29,14 +28,14 @@ ZSTD_MESON_ENABLED= zstd
|
||||
.include <bsd.port.options.mk>
|
||||
.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
|
||||
|
||||
ALL_DRI_DRIVERS= I915 I965 R100 R200 SWRAST
|
||||
ALL_DRI_DRIVERS= I915 I965 R100 R200
|
||||
ALL_GALLIUM_DRIVERS= IRIS R300 R600 RADEONSI SVGA SWRAST
|
||||
ALL_VULKAN_DRIVERS= INTEL AMD
|
||||
|
||||
.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == i386 || ${ARCH} == powerpc64
|
||||
GALLIUM_DRIVERS+= SWRAST # llvmpipe
|
||||
.elif ${ARCH:Marm*} || ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == riscv64
|
||||
DRI_DRIVERS+= SWRAST # Mesa Classic swrast
|
||||
|
||||
.if ${ARCH:Marm*}
|
||||
DRI_DRIVERS+= R100
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == i386 \
|
||||
@ -76,11 +75,13 @@ MESON_ARGS+= -Ddri-drivers="${DRI_DRIVERS:ts,:tl}" \
|
||||
|
||||
# Disable some options
|
||||
MESON_ARGS+= -Dgallium-xa=disabled \
|
||||
-Dgallium-vdpau=disabled \
|
||||
-Dgallium-va=disabled \
|
||||
-Dgles1=disabled \
|
||||
-Dgles2=disabled \
|
||||
-Dglx=disabled \
|
||||
-Degl=disabled \
|
||||
-Dosmesa=none \
|
||||
-Dosmesa=false \
|
||||
-Dtools=""
|
||||
|
||||
.for _d in ${ALL_DRI_DRIVERS}
|
||||
|
@ -12,7 +12,7 @@
|
||||
MESAVERSION= ${MESABASEVERSION}${MESASUBVERSION:C/^(.)/.\1/}
|
||||
MESADISTVERSION=${MESABASEVERSION}${MESASUBVERSION:C/^(.)/-\1/}
|
||||
|
||||
MESABASEVERSION= 20.2.3
|
||||
MESABASEVERSION= 21.1.5
|
||||
# if there is a subversion, don't include the '-' between 7.11-rc2.
|
||||
MESASUBVERSION=
|
||||
|
||||
@ -81,16 +81,11 @@ PKGHELP= ${.CURDIR}/pkg-help
|
||||
PKGINSTALL= ${.CURDIR}/pkg-install
|
||||
PKGDEINSTALL= ${.CURDIR}/pkg-deinstall
|
||||
|
||||
.if ${COMPONENT} == clover
|
||||
EXTRA_PATCHES+= ${PATCHDIR}/extra-src_gallium_auxiliary_meson.build \
|
||||
${PATCHDIR}/extra-src_gallium_auxiliary_vl_vl__stubs.c
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
BINARY_ALIAS+= python3=${PYTHON_VERSION}
|
||||
|
||||
LLVM_DEFAULT= 10
|
||||
LLVM_DEFAULT= 12
|
||||
BUILD_DEPENDS+= llvm-config${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
|
||||
.if ${COMPONENT} != libs
|
||||
RUN_DEPENDS+= llvm-config${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1607017629
|
||||
SHA256 (mesa-20.2.3.tar.xz) = ae1b240e11531df528d14dc214d2dc4d2b4f2e835c6230ba0b492b171eceb82b
|
||||
SIZE (mesa-20.2.3.tar.xz) = 13844212
|
||||
TIMESTAMP = 1626357419
|
||||
SHA256 (mesa-21.1.5.tar.xz) = 022c7293074aeeced2278c872db4fa693147c70f8595b076cf3f1ef81520766d
|
||||
SIZE (mesa-21.1.5.tar.xz) = 15286704
|
||||
|
@ -1,18 +0,0 @@
|
||||
--- src/gallium/auxiliary/meson.build.orig 2020-09-23 21:05:28 UTC
|
||||
+++ src/gallium/auxiliary/meson.build
|
||||
@@ -440,7 +440,6 @@ files_libgalliumvl = files(
|
||||
'vl/vl_compositor_cs.h',
|
||||
'vl/vl_csc.c',
|
||||
'vl/vl_csc.h',
|
||||
- 'vl/vl_decoder.c',
|
||||
'vl/vl_decoder.h',
|
||||
'vl/vl_defines.h',
|
||||
'vl/vl_deint_filter.c',
|
||||
@@ -461,7 +460,6 @@ files_libgalliumvl = files(
|
||||
'vl/vl_types.h',
|
||||
'vl/vl_vertex_buffers.c',
|
||||
'vl/vl_vertex_buffers.h',
|
||||
- 'vl/vl_video_buffer.c',
|
||||
'vl/vl_video_buffer.h',
|
||||
'vl/vl_vlc.h',
|
||||
'vl/vl_zscan.c',
|
@ -1,17 +0,0 @@
|
||||
--- src/gallium/auxiliary/vl/vl_stubs.c.orig 2020-09-23 21:12:53 UTC
|
||||
+++ src/gallium/auxiliary/vl/vl_stubs.c
|
||||
@@ -140,6 +140,14 @@ vl_create_mpeg12_decoder(struct pipe_context *pipe,
|
||||
return NULL;
|
||||
}
|
||||
|
||||
+struct pipe_video_buffer *
|
||||
+vl_video_buffer_create_as_resource(struct pipe_context *pipe,
|
||||
+ const struct pipe_video_buffer *tmpl)
|
||||
+{
|
||||
+ assert(0);
|
||||
+ return NULL;
|
||||
+}
|
||||
+
|
||||
/*
|
||||
* vl_zscan
|
||||
*/
|
@ -1,42 +1,28 @@
|
||||
--- meson.build.orig 2020-10-06 07:15:26 UTC
|
||||
--- meson.build.orig 2021-06-30 18:18:55 UTC
|
||||
+++ meson.build
|
||||
@@ -1108,9 +1108,9 @@ else
|
||||
endif
|
||||
|
||||
# Check for GCC style atomics
|
||||
-dep_atomic = null_dep
|
||||
+dep_atomic = cc.find_library('atomic', required : false)
|
||||
|
||||
-if cc.compiles('''#include <stdint.h>
|
||||
+if cc.links('''#include <stdint.h>
|
||||
int main() {
|
||||
struct {
|
||||
uint64_t *v;
|
||||
@@ -1119,26 +1119,9 @@ if cc.compiles('''#include <stdint.h>
|
||||
(int)__atomic_add_fetch(x.v, (uint64_t)1, __ATOMIC_ACQ_REL);
|
||||
|
||||
}''',
|
||||
+ dependencies : dep_atomic,
|
||||
name : 'GCC atomic builtins')
|
||||
pre_args += '-DUSE_GCC_ATOMIC_BUILTINS'
|
||||
-
|
||||
- # Not all atomic calls can be turned into lock-free instructions, in which
|
||||
- # GCC will make calls into the libatomic library. Check whether we need to
|
||||
- # link with -latomic.
|
||||
- #
|
||||
- # This can happen for 64-bit atomic operations on 32-bit architectures such
|
||||
- # as ARM.
|
||||
- if not cc.links('''#include <stdint.h>
|
||||
- int main() {
|
||||
- struct {
|
||||
- uint64_t *v;
|
||||
- } x;
|
||||
- return (int)__atomic_load_n(x.v, __ATOMIC_ACQUIRE) &
|
||||
- (int)__atomic_add_fetch(x.v, (uint64_t)1, __ATOMIC_ACQ_REL);
|
||||
- }''',
|
||||
- name : 'GCC atomic builtins required -latomic')
|
||||
- dep_atomic = cc.find_library('atomic')
|
||||
- endif
|
||||
endif
|
||||
if not cc.links('''#include <stdint.h>
|
||||
uint64_t v;
|
||||
@@ -161,7 +161,7 @@ if dri_drivers.contains('auto')
|
||||
if system_has_kms_drm
|
||||
# TODO: PPC, Sparc
|
||||
if ['x86', 'x86_64'].contains(host_machine.cpu_family())
|
||||
- dri_drivers = ['i915', 'i965', 'r100', 'r200', 'nouveau']
|
||||
+ dri_drivers = ['i915', 'i965', 'r100', 'r200']
|
||||
elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
|
||||
dri_drivers = []
|
||||
elif ['mips', 'mips64'].contains(host_machine.cpu_family())
|
||||
@@ -193,7 +193,7 @@ if gallium_drivers.contains('auto')
|
||||
# TODO: PPC, Sparc
|
||||
if ['x86', 'x86_64'].contains(host_machine.cpu_family())
|
||||
gallium_drivers = [
|
||||
- 'r300', 'r600', 'radeonsi', 'nouveau', 'virgl', 'svga', 'swrast',
|
||||
+ 'r300', 'r600', 'radeonsi', 'virgl', 'svga', 'swrast',
|
||||
'iris'
|
||||
]
|
||||
elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
|
||||
@@ -1041,7 +1041,6 @@ else
|
||||
'-Werror=incompatible-pointer-types',
|
||||
'-Werror=int-conversion',
|
||||
'-Wimplicit-fallthrough',
|
||||
- '-Werror=thread-safety',
|
||||
'-Wno-missing-field-initializers',
|
||||
'-Wno-format-truncation',
|
||||
'-fno-math-errno',
|
||||
|
@ -1,13 +0,0 @@
|
||||
--- src/amd/vulkan/radv_device.c.orig 2020-09-28 22:52:10 UTC
|
||||
+++ src/amd/vulkan/radv_device.c
|
||||
@@ -56,6 +56,10 @@
|
||||
#include "compiler/glsl_types.h"
|
||||
#include "util/driconf.h"
|
||||
|
||||
+#if DETECT_OS_FREEBSD
|
||||
+#define CLOCK_MONOTONIC_RAW CLOCK_MONOTONIC_FAST
|
||||
+#endif
|
||||
+
|
||||
static struct radv_timeline_point *
|
||||
radv_timeline_find_point_at_least_locked(struct radv_device *device,
|
||||
struct radv_timeline *timeline,
|
@ -1,14 +0,0 @@
|
||||
--- src/gallium/drivers/llvmpipe/lp_rast_tri.c.orig 2020-09-28 22:52:10 UTC
|
||||
+++ src/gallium/drivers/llvmpipe/lp_rast_tri.c
|
||||
@@ -465,6 +465,11 @@ lp_rast_triangle_32_3_4(struct lp_rasterizer_task *tas
|
||||
|
||||
#if defined(_ARCH_PWR8) && UTIL_ARCH_LITTLE_ENDIAN
|
||||
|
||||
+#ifdef __clang__
|
||||
+#undef vector
|
||||
+#undef pixel
|
||||
+#undef bool
|
||||
+#endif
|
||||
#include <altivec.h>
|
||||
#include "util/u_pwr8.h"
|
||||
|
@ -1,14 +0,0 @@
|
||||
--- src/gallium/drivers/llvmpipe/lp_setup_tri.c.orig 2020-10-22 23:39:01 UTC
|
||||
+++ src/gallium/drivers/llvmpipe/lp_setup_tri.c
|
||||
@@ -47,6 +47,11 @@
|
||||
#if defined(PIPE_ARCH_SSE)
|
||||
#include <emmintrin.h>
|
||||
#elif defined(_ARCH_PWR8) && UTIL_ARCH_LITTLE_ENDIAN
|
||||
+#ifdef __clang__
|
||||
+#undef vector
|
||||
+#undef pixel
|
||||
+#undef bool
|
||||
+#endif
|
||||
#include <altivec.h>
|
||||
#include "util/u_pwr8.h"
|
||||
#endif
|
@ -0,0 +1,15 @@
|
||||
--- src/intel/compiler/brw_nir_lower_shader_calls.c.orig 2021-06-30 18:18:55 UTC
|
||||
+++ src/intel/compiler/brw_nir_lower_shader_calls.c
|
||||
@@ -151,6 +151,12 @@ instr_is_shader_call(nir_instr *instr)
|
||||
intrin->intrinsic == nir_intrinsic_execute_callable;
|
||||
}
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
+/* brw_nir_rt.h -> glthread.h -> u_thread.h -> pthread_np.h -> sys/cpuset.h -> sys/_bitset.h
|
||||
+ * - defines `struct bitset` which clashes with the following
|
||||
+ */
|
||||
+#define bitset mesa_bitset
|
||||
+#endif
|
||||
struct bitset {
|
||||
BITSET_WORD *set;
|
||||
unsigned size;
|
@ -1,13 +0,0 @@
|
||||
--- src/intel/vulkan/anv_device.c.orig 2020-09-28 22:52:12 UTC
|
||||
+++ src/intel/vulkan/anv_device.c
|
||||
@@ -48,6 +48,10 @@
|
||||
|
||||
#include "genxml/gen7_pack.h"
|
||||
|
||||
+#if DETECT_OS_FREEBSD
|
||||
+#define CLOCK_MONOTONIC_RAW CLOCK_MONOTONIC_FAST
|
||||
+#endif
|
||||
+
|
||||
static const char anv_dri_options_xml[] =
|
||||
DRI_CONF_BEGIN
|
||||
DRI_CONF_SECTION_PERFORMANCE
|
@ -1,11 +0,0 @@
|
||||
--- src/loader/meson.build.orig 2020-12-03 18:59:28.209491000 +0100
|
||||
+++ src/loader/meson.build 2020-12-03 18:59:40.685431000 +0100
|
||||
@@ -41,7 +41,7 @@
|
||||
'-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_search_path),
|
||||
]
|
||||
|
||||
-if with_gallium_iris and get_option('prefer-iris')
|
||||
+if get_option('prefer-iris')
|
||||
loader_c_args += ['-DPREFER_IRIS']
|
||||
endif
|
||||
|
@ -1,15 +0,0 @@
|
||||
# Elf_ doesn't exist, use Elf32_ or Elf64_
|
||||
#
|
||||
--- src/util/build_id.c.orig 2017-12-21 17:31:22 UTC
|
||||
+++ src/util/build_id.c
|
||||
@@ -38,6 +38,10 @@
|
||||
#define ElfW(type) Elf_##type
|
||||
#endif
|
||||
|
||||
+#if defined(__FreeBSD__) && __FreeBSD__ < 12
|
||||
+typedef Elf_Note Elf_Nhdr;
|
||||
+#endif
|
||||
+
|
||||
struct build_id_note {
|
||||
ElfW(Nhdr) nhdr;
|
||||
|
@ -1,50 +1,11 @@
|
||||
--- src/util/os_file.c.orig 2020-10-05 09:57:28 UTC
|
||||
--- src/util/os_file.c.orig 2021-06-30 18:18:56 UTC
|
||||
+++ src/util/os_file.c
|
||||
@@ -80,7 +80,7 @@ os_dupfd_cloexec(int fd)
|
||||
#endif
|
||||
|
||||
|
||||
-#if DETECT_OS_LINUX
|
||||
+#if DETECT_OS_LINUX || DETECT_OS_FREEBSD
|
||||
|
||||
#include <fcntl.h>
|
||||
#include <sys/stat.h>
|
||||
@@ -93,7 +93,11 @@ os_dupfd_cloexec(int fd)
|
||||
@@ -89,7 +89,7 @@ typedef ptrdiff_t ssize_t;
|
||||
static ssize_t
|
||||
readN(int fd, char *buf, size_t len)
|
||||
{
|
||||
+#if DETECT_OS_LINUX
|
||||
int err = -ENODATA;
|
||||
+#elif DETECT_OS_FREEBSD
|
||||
- int err = -ENODATA;
|
||||
+ int err = -1;
|
||||
+#endif
|
||||
size_t total = 0;
|
||||
do {
|
||||
ssize_t ret = read(fd, buf + total, len - total);
|
||||
@@ -185,6 +189,7 @@ os_read_file(const char *filename, size_t *size)
|
||||
return buf;
|
||||
}
|
||||
|
||||
+#if DETECT_OS_LINUX
|
||||
int
|
||||
os_same_file_description(int fd1, int fd2)
|
||||
{
|
||||
@@ -196,6 +201,18 @@ os_same_file_description(int fd1, int fd2)
|
||||
|
||||
return syscall(SYS_kcmp, pid, pid, KCMP_FILE, fd1, fd2);
|
||||
}
|
||||
+#else
|
||||
+int
|
||||
+os_same_file_description(int fd1, int fd2)
|
||||
+{
|
||||
+ /* Same file descriptor trivially implies same file description */
|
||||
+ if (fd1 == fd2)
|
||||
+ return 0;
|
||||
+
|
||||
+ /* Otherwise we can't tell */
|
||||
+ return -1;
|
||||
+}
|
||||
+#endif
|
||||
|
||||
#else
|
||||
|
||||
|
@ -1,26 +0,0 @@
|
||||
--- src/util/os_misc.c.orig 2020-09-28 22:52:13 UTC
|
||||
+++ src/util/os_misc.c
|
||||
@@ -58,7 +58,7 @@
|
||||
# include <log/log.h>
|
||||
#elif DETECT_OS_LINUX || DETECT_OS_CYGWIN || DETECT_OS_SOLARIS || DETECT_OS_HURD
|
||||
# include <unistd.h>
|
||||
-#elif DETECT_OS_OPENBSD
|
||||
+#elif DETECT_OS_OPENBSD || DETECT_OS_FREEBSD
|
||||
# include <sys/resource.h>
|
||||
# include <sys/sysctl.h>
|
||||
#elif DETECT_OS_APPLE || DETECT_OS_BSD
|
||||
@@ -213,9 +213,13 @@ os_get_available_system_memory(uint64_t *size)
|
||||
|
||||
free(meminfo);
|
||||
return false;
|
||||
-#elif DETECT_OS_OPENBSD
|
||||
+#elif defined(DETECT_OS_OPENBSD) || defined(DETECT_OS_FREEBSD)
|
||||
struct rlimit rl;
|
||||
+#if DETECT_OS_OPENBSD
|
||||
int mib[] = { CTL_HW, HW_USERMEM64 };
|
||||
+#elif DETECT_OS_FREEBSD
|
||||
+ int mib[] = { CTL_HW, HW_USERMEM };
|
||||
+#endif
|
||||
int64_t mem_available;
|
||||
size_t len = sizeof(mem_available);
|
||||
|
@ -1,29 +1,27 @@
|
||||
--- src/util/u_process.c.orig 2020-10-05 09:53:46 UTC
|
||||
--- src/util/u_process.c.orig 2021-06-30 18:18:56 UTC
|
||||
+++ src/util/u_process.c
|
||||
@@ -44,6 +44,11 @@
|
||||
#include <mach-o/dyld.h>
|
||||
#endif
|
||||
|
||||
+#if DETECT_OS_FREEBSD
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/sysctl.h>
|
||||
+#endif
|
||||
+
|
||||
#if defined(__linux__) && defined(HAVE_PROGRAM_INVOCATION_NAME)
|
||||
|
||||
static char *path = NULL;
|
||||
@@ -175,6 +180,14 @@ util_get_process_exec_path(char* process_path, size_t
|
||||
int result = _NSGetExecutablePath(process_path, &bufSize);
|
||||
|
||||
return (result == 0) ? strlen(process_path) : 0;
|
||||
+#elif DETECT_OS_FREEBSD
|
||||
+ int mib[4] = { CTL_KERN, KERN_PROC, KERN_PROC_PATHNAME, -1 };
|
||||
+ size_t read_len = len;
|
||||
+
|
||||
+ (void) sysctl(mib, 4, process_path, &read_len, NULL, 0);
|
||||
+ process_path[len - 1] = '\0';
|
||||
+
|
||||
+ return read_len;
|
||||
#elif DETECT_OS_UNIX
|
||||
ssize_t r;
|
||||
|
||||
@@ -94,22 +94,13 @@ __getProgramName()
|
||||
# define GET_PROGRAM_NAME() __getProgramName()
|
||||
#elif defined(HAVE_PROGRAM_INVOCATION_NAME)
|
||||
# define GET_PROGRAM_NAME() program_invocation_short_name
|
||||
-#elif defined(__FreeBSD__) && (__FreeBSD__ >= 2)
|
||||
-# include <osreldate.h>
|
||||
-# if (__FreeBSD_version >= 440000)
|
||||
-# define GET_PROGRAM_NAME() getprogname()
|
||||
-# endif
|
||||
+#elif defined(__FreeBSD__) || defined(__DragonFly__) || defined(__APPLE__) || defined(ANDROID)
|
||||
+# define GET_PROGRAM_NAME() getprogname()
|
||||
#elif defined(__NetBSD__)
|
||||
# include <sys/param.h>
|
||||
# if defined(__NetBSD_Version__) && (__NetBSD_Version__ >= 106000100)
|
||||
# define GET_PROGRAM_NAME() getprogname()
|
||||
# endif
|
||||
-#elif defined(__DragonFly__)
|
||||
-# define GET_PROGRAM_NAME() getprogname()
|
||||
-#elif defined(__APPLE__)
|
||||
-# define GET_PROGRAM_NAME() getprogname()
|
||||
-#elif defined(ANDROID)
|
||||
-# define GET_PROGRAM_NAME() getprogname()
|
||||
#elif defined(__sun)
|
||||
/* Solaris has getexecname() which returns the full path - return just
|
||||
the basename to match BSD getprogname() */
|
||||
|
@ -1,11 +1,9 @@
|
||||
@comment include/GL/gl.h
|
||||
@comment include/GL/gl_mangle.h
|
||||
@comment include/GL/glcorearb.h
|
||||
@comment include/GL/glext.h
|
||||
include/GL/internal/dri_interface.h
|
||||
@comment include/KHR/khrplatform.h
|
||||
@comment include/gbm.h
|
||||
%%INTEL_VDRIVER%%include/vulkan/vulkan_intel.h
|
||||
%%I915_DRIVER%%lib/dri/i915_dri.so
|
||||
%%I965_DRIVER%%lib/dri/i965_dri.so
|
||||
%%IRIS_GDRIVER%%lib/dri/iris_dri.so
|
||||
@ -15,7 +13,6 @@ include/GL/internal/dri_interface.h
|
||||
%%R600_GDRIVER%%lib/dri/r600_dri.so
|
||||
%%R100_DRIVER%%lib/dri/radeon_dri.so
|
||||
%%RADEONSI_GDRIVER%%lib/dri/radeonsi_dri.so
|
||||
%%SWRAST_DRIVER%%lib/dri/swrast_dri.so
|
||||
%%SWRAST_GDRIVER%%lib/dri/swrast_dri.so
|
||||
%%SVGA_GDRIVER%%lib/dri/vmwgfx_dri.so
|
||||
%%PLATFORM_X11%%%%R600_GDRIVER%%lib/libXvMCr600.so
|
||||
|
@ -1,6 +1,5 @@
|
||||
PORTNAME= mesa-gallium-va
|
||||
PORTVERSION= ${MESAVERSION}
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= graphics
|
||||
|
||||
COMMENT= Mesa Gallium VAAPI drivers
|
||||
@ -32,7 +31,7 @@ MESON_ARGS+= -Ddri-drivers="" \
|
||||
-Dgbm=disabled \
|
||||
-Dgles1=disabled \
|
||||
-Dgles2=disabled \
|
||||
-Dosmesa=none \
|
||||
-Dosmesa=false \
|
||||
-Dglx=disabled \
|
||||
-Ddri3=disabled
|
||||
|
||||
|
@ -1,6 +1,5 @@
|
||||
PORTNAME= mesa-gallium-vdpau
|
||||
PORTVERSION= ${MESAVERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
|
||||
COMMENT= Mesa Gallium VDPAU drivers
|
||||
@ -24,7 +23,7 @@ ONLY_FOR_ARCHS_REASON= Used only by amd/radeon hardware
|
||||
MESON_ARGS+= -Ddri-drivers="" \
|
||||
-Dgallium-drivers="r300,r600,radeonsi" \
|
||||
-Dvulkan-drivers="" \
|
||||
-Dgallium-vdpau=disabled \
|
||||
-Dgallium-va=disabled \
|
||||
-Dgallium-omx=disabled \
|
||||
-Dgallium-xa=disabled \
|
||||
-Dgallium-opencl=disabled \
|
||||
@ -33,7 +32,7 @@ MESON_ARGS+= -Ddri-drivers="" \
|
||||
-Dgbm=disabled \
|
||||
-Dgles1=disabled \
|
||||
-Dgles2=disabled \
|
||||
-Dosmesa=none \
|
||||
-Dosmesa=false \
|
||||
-Dglx=disabled \
|
||||
-Ddri3=disabled
|
||||
|
||||
|
@ -2,7 +2,6 @@
|
||||
|
||||
PORTNAME= mesa-gallium-xa
|
||||
PORTVERSION= ${MESAVERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
|
||||
COMMENT= Mesa Gallium XA state tracker
|
||||
@ -33,7 +32,7 @@ MESON_ARGS+= -Ddri-drivers="" \
|
||||
-Dglx=disabled \
|
||||
-Dopengl=false \
|
||||
-Dshared-glapi=disabled \
|
||||
-Dosmesa=none
|
||||
-Dosmesa=false
|
||||
|
||||
LDFLAGS_i386= -Wl,-znotext
|
||||
|
||||
|
@ -2,7 +2,6 @@
|
||||
|
||||
PORTNAME= mesa-libs
|
||||
PORTVERSION= ${MESAVERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
|
||||
COMMENT= OpenGL libraries that support GLX and EGL clients
|
||||
@ -39,15 +38,15 @@ MESON_ARGS+= -Dgallium-drivers="" \
|
||||
-Dgallium-xa=disabled \
|
||||
-Dgallium-nine=false \
|
||||
-Dgallium-clover=disabled \
|
||||
-Dosmesa=none \
|
||||
-Dosmesa=false \
|
||||
-Dtools="" \
|
||||
-Degl=enabled \
|
||||
-Dgbm=enabled \
|
||||
-Dvulkan-drivers="" \
|
||||
-Dglvnd=true \
|
||||
-Dprefer-iris=true
|
||||
# Building EGL and GBM requires a dri driver so add swrast
|
||||
MESON_ARGS+= -Ddri-drivers="swrast"
|
||||
# Building EGL and GBM requires a dri driver so add r100
|
||||
MESON_ARGS+= -Ddri-drivers="r100"
|
||||
|
||||
.if ${PORT_OPTIONS:MPLATFORM_X11}
|
||||
MESA_PLATFORMS+= x11
|
||||
|
@ -1,39 +1,12 @@
|
||||
etc/libmap.d/mesa.conf
|
||||
@comment include/EGL/egl.h
|
||||
@comment include/EGL/eglext.h
|
||||
include/EGL/eglextchromium.h
|
||||
include/EGL/eglmesaext.h
|
||||
@comment include/EGL/eglplatform.h
|
||||
@comment include/GL/gl.h
|
||||
@comment include/GL/glcorearb.h
|
||||
@comment include/GL/glext.h
|
||||
%%GLX%%@comment include/GL/glx.h
|
||||
%%GLX%%@comment include/GL/glxext.h
|
||||
@comment include/GL/internal/dri_interface.h
|
||||
@comment include/GLES/egl.h
|
||||
@comment include/GLES/gl.h
|
||||
@comment include/GLES/glext.h
|
||||
@comment include/GLES/glplatform.h
|
||||
@comment include/GLES2/gl2.h
|
||||
@comment include/GLES2/gl2ext.h
|
||||
@comment include/GLES2/gl2platform.h
|
||||
@comment include/GLES3/gl3.h
|
||||
@comment include/GLES3/gl31.h
|
||||
@comment include/GLES3/gl32.h
|
||||
@comment include/GLES3/gl3ext.h
|
||||
@comment include/GLES3/gl3platform.h
|
||||
@comment include/KHR/khrplatform.h
|
||||
include/gbm.h
|
||||
@comment lib/dri/swrast_dri.so
|
||||
@comment lib/dri/radeon_dri.so
|
||||
lib/libEGL_mesa.so
|
||||
lib/libEGL_mesa.so.0
|
||||
lib/libEGL_mesa.so.0.0.0
|
||||
@comment lib/libGLESv1_CM.so
|
||||
@comment lib/libGLESv1_CM.so.1
|
||||
@comment lib/libGLESv1_CM.so.1.1.0
|
||||
@comment lib/libGLESv2.so
|
||||
@comment lib/libGLESv2.so.2
|
||||
@comment lib/libGLESv2.so.2.0.0
|
||||
%%GLX%%lib/libGLX_mesa.so
|
||||
%%GLX%%lib/libGLX_mesa.so.0
|
||||
%%GLX%%lib/libGLX_mesa.so.0.0.0
|
||||
@ -44,10 +17,6 @@ lib/libglapi.so
|
||||
lib/libglapi.so.0
|
||||
lib/libglapi.so.0.0.0
|
||||
@comment libdata/pkgconfig/dri.pc
|
||||
@comment libdata/pkgconfig/egl.pc
|
||||
libdata/pkgconfig/gbm.pc
|
||||
%%GLX%%@comment libdata/pkgconfig/gl.pc
|
||||
@comment libdata/pkgconfig/glesv1_cm.pc
|
||||
@comment libdata/pkgconfig/glesv2.pc
|
||||
@comment share/drirc.d/00-mesa-defaults.conf
|
||||
share/glvnd/egl_vendor.d/50_mesa.json
|
||||
|
@ -1,6 +1,5 @@
|
||||
PORTNAME= clover
|
||||
PORTVERSION= ${MESAVERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= lang
|
||||
|
||||
COMMENT= Mesa OpenCL implementation for AMD GPUs
|
||||
|
Loading…
Reference in New Issue
Block a user