Merge changes from ports/24975.

PR:		24975
Submitted by:	KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
Jimmy Olgeni 2001-02-09 21:39:51 +00:00
parent 705207d578
commit 2254d6f446
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38147
14 changed files with 194 additions and 68 deletions

View File

@ -7,6 +7,7 @@
PORTNAME= xfce
PORTVERSION= 3.7.2
PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://www.xfce.org/archive/
@ -14,18 +15,24 @@ MAINTAINER= nakai@FreeBSD.org
USE_X_PREFIX= yes
USE_IMLIB= yes
USE_ESOUND= yes
USE_XPM= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lxpg4"
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share \
--datadir=${PREFIX}/share \
--sysconfdir=${PREFIX}/etc \
--with-xpm=${X11BASE}
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-conf-dir=${PREFIX}/etc/xfce \
--with-data-dir=${PREFIX}/share/xfce \
--with-locale-dir=${PREFIX}/share/locale \
--with-xpm=${X11BASE} \
--disable-xinerama
MAN1= xfbd.1 xfce.1 xfclock.1 xfgnome.1 xfhelp.1 xflock.1 xfmountdev.1 \
xfmouse.1 xfpager.1 xfprint.1 xfrun.1 xfsound.1 xfterm.1 xftrash.1 \
xftree.1 xfwm.1 xfglob.1 glob.1
MAN1= glob.1 xfbd.1 xfce.1 xfclock.1 xfglob.1 xfgnome.1 xfhelp.1 \
xflock.1 xfmountdev.1 xfmouse.1 xfpager.1 xfprint.1 xfrun.1 \
xfsound.1 xfterm.1 xftrash.1 xftree.1 xfwm.1
pre-patch:
@${PERL} -pi -e \
's|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
.include <bsd.port.mk>

View File

@ -1,22 +0,0 @@
--- configure.orig Sun Oct 1 01:16:19 2000
+++ configure Thu Nov 2 05:45:10 2000
@@ -2622,6 +2622,8 @@
if test "$cross_compiling" = yes; then
ac_cv_func_mmap_fixed_mapped=no
else
+ ac_save_LIBS="$LIBS"
+ LIBS="-lintl $LIBS"
cat > conftest.$ac_ext <<EOF
#line 2627 "configure"
#include "confdefs.h"
@@ -6667,8 +6669,8 @@
-
-
+XFCE_DIR=`eval echo $XFCE_DIR`
+XFCE_CONFDIR=`eval echo $XFCE_CONFDIR`
sed -e "s%XFCE_DIR%$XFCE_DIR%g" -e "s%XFCE_CONFDIR%$XFCE_CONFDIR%g" scripts/xfce_setup.in > scripts/xfce_setup
sed -e "s%XFCE_DIR%$XFCE_DIR%g" -e "s%XFCE_CONFDIR%$XFCE_CONFDIR%g" scripts/xfce_upgrade.in > scripts/xfce_upgrade
sed -e "s%XFCE_DIR%$XFCE_DIR%g" -e "s%XFCE_CONFDIR%$XFCE_CONFDIR%g" scripts/xfhelp.in > scripts/xfhelp

View File

@ -0,0 +1,11 @@
--- libs/configure.h.orig Tue Sep 5 02:26:09 2000
+++ libs/configure.h Wed Feb 7 00:53:01 2001
@@ -22,7 +22,7 @@
#define CLOSE_STRING4 "quit"
/* #ifdef __alpha */
-#if defined(__alpha) && !defined(linux)
+#if defined(__alpha) && !(defined(linux) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__))
#define NEEDS_ALPHA_HEADER
#undef BROKEN_SUN_HEADERS
#endif /* (__alpha) */

View File

@ -0,0 +1,9 @@
--- other/xfsoundrc.in.orig Tue Sep 5 02:26:09 2000
+++ other/xfsoundrc.in Tue Feb 6 05:07:47 2001
@@ -1,5 +1,5 @@
Play
-xfplay
+internal
XFCE_DIR/sounds/beep03.wav
XFCE_DIR/sounds/pop02.wav

View File

@ -0,0 +1,20 @@
--- xfsound/xfdsp.c.orig Fri Jul 7 05:51:00 2000
+++ xfsound/xfdsp.c Tue Feb 6 04:52:16 2001
@@ -45,7 +45,7 @@
#include <sys/stat.h>
#include <sys/ioctl.h>
#include <sys/types.h>
-#if defined(linux)
+#if defined(linux) || defined(__FreeBSD__)
#include <sys/soundcard.h> /* guess :) */
#endif
@@ -62,7 +62,7 @@
int masterfd;
-#if defined(linux)
+#if defined(linux) || defined(__FreeBSD__)
int
i_play (char *soundfile)
{

View File

@ -0,0 +1,37 @@
--- xfwm/session.c.orig Wed Jan 31 04:50:16 2001
+++ xfwm/session.c Tue Feb 6 04:56:10 2001
@@ -566,8 +566,10 @@
callback_save_yourself2 (SmcConn sm_conn, SmPointer client_data)
{
char *path = NULL;
- char *filename = NULL;
- FILE *f = NULL;
+ char *filename;
+ FILE *f;
+ int fd;
+
Bool success = True;
struct passwd *pwd;
@@ -578,16 +580,18 @@
path = pwd->pw_dir;
}
- filename = tempnam (path, ".fs-");
+ sprintf (filename, "path/.fs-XXXXXXXX");
+ fd = mkstemp (filename);
if (Scr.Options & SessionMgt)
{
- f = fopen (filename, "w");
+ f = fdopen (fd, "w");
success = save_session_state (sm_conn, filename, f);
fclose (f);
}
- if (!success)
+ if (!success || fd < 0)
xfwm_msg (WARN, "SaveSession", "Can't save session\n");
+ close (fd);
/* also save session for builtin session mgt, so user will get
* back to his environmnent even if he doesn't use ICE
*/

View File

@ -45,6 +45,7 @@ etc/xfce/xinitrc
etc/xfce/xinitrc.mwm
etc/xfce/xsession
etc/xfce/xtree.reg
lib/gtk/themes/engines/libxfce.so
share/locale/ca/LC_MESSAGES/xfce.mo
share/locale/cs/LC_MESSAGES/xfce.mo
share/locale/da/LC_MESSAGES/xfce.mo
@ -446,12 +447,12 @@ share/xfce/textures/oldwood.xpm
share/xfce/textures/paper.xpm
share/xfce/textures/silver.xpm
share/xfce/textures/stripe.xpm
@dirrm share/xfce/help
@dirrm share/xfce/sounds
@dirrm share/xfce/textures
@dirrm share/xfce/fonts
@dirrm share/xfce/sounds
@dirrm share/xfce/palettes
@dirrm share/xfce/icons
@dirrm share/xfce/help
@dirrm share/xfce/fonts
@dirrm share/xfce/backdrops
@dirrm share/xfce
@dirrm etc/xfce

View File

@ -7,6 +7,7 @@
PORTNAME= xfce
PORTVERSION= 3.7.2
PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://www.xfce.org/archive/
@ -14,18 +15,24 @@ MAINTAINER= nakai@FreeBSD.org
USE_X_PREFIX= yes
USE_IMLIB= yes
USE_ESOUND= yes
USE_XPM= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lxpg4"
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share \
--datadir=${PREFIX}/share \
--sysconfdir=${PREFIX}/etc \
--with-xpm=${X11BASE}
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-conf-dir=${PREFIX}/etc/xfce \
--with-data-dir=${PREFIX}/share/xfce \
--with-locale-dir=${PREFIX}/share/locale \
--with-xpm=${X11BASE} \
--disable-xinerama
MAN1= xfbd.1 xfce.1 xfclock.1 xfgnome.1 xfhelp.1 xflock.1 xfmountdev.1 \
xfmouse.1 xfpager.1 xfprint.1 xfrun.1 xfsound.1 xfterm.1 xftrash.1 \
xftree.1 xfwm.1 xfglob.1 glob.1
MAN1= glob.1 xfbd.1 xfce.1 xfclock.1 xfglob.1 xfgnome.1 xfhelp.1 \
xflock.1 xfmountdev.1 xfmouse.1 xfpager.1 xfprint.1 xfrun.1 \
xfsound.1 xfterm.1 xftrash.1 xftree.1 xfwm.1
pre-patch:
@${PERL} -pi -e \
's|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
.include <bsd.port.mk>

View File

@ -1,22 +0,0 @@
--- configure.orig Sun Oct 1 01:16:19 2000
+++ configure Thu Nov 2 05:45:10 2000
@@ -2622,6 +2622,8 @@
if test "$cross_compiling" = yes; then
ac_cv_func_mmap_fixed_mapped=no
else
+ ac_save_LIBS="$LIBS"
+ LIBS="-lintl $LIBS"
cat > conftest.$ac_ext <<EOF
#line 2627 "configure"
#include "confdefs.h"
@@ -6667,8 +6669,8 @@
-
-
+XFCE_DIR=`eval echo $XFCE_DIR`
+XFCE_CONFDIR=`eval echo $XFCE_CONFDIR`
sed -e "s%XFCE_DIR%$XFCE_DIR%g" -e "s%XFCE_CONFDIR%$XFCE_CONFDIR%g" scripts/xfce_setup.in > scripts/xfce_setup
sed -e "s%XFCE_DIR%$XFCE_DIR%g" -e "s%XFCE_CONFDIR%$XFCE_CONFDIR%g" scripts/xfce_upgrade.in > scripts/xfce_upgrade
sed -e "s%XFCE_DIR%$XFCE_DIR%g" -e "s%XFCE_CONFDIR%$XFCE_CONFDIR%g" scripts/xfhelp.in > scripts/xfhelp

View File

@ -0,0 +1,11 @@
--- libs/configure.h.orig Tue Sep 5 02:26:09 2000
+++ libs/configure.h Wed Feb 7 00:53:01 2001
@@ -22,7 +22,7 @@
#define CLOSE_STRING4 "quit"
/* #ifdef __alpha */
-#if defined(__alpha) && !defined(linux)
+#if defined(__alpha) && !(defined(linux) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__))
#define NEEDS_ALPHA_HEADER
#undef BROKEN_SUN_HEADERS
#endif /* (__alpha) */

View File

@ -0,0 +1,9 @@
--- other/xfsoundrc.in.orig Tue Sep 5 02:26:09 2000
+++ other/xfsoundrc.in Tue Feb 6 05:07:47 2001
@@ -1,5 +1,5 @@
Play
-xfplay
+internal
XFCE_DIR/sounds/beep03.wav
XFCE_DIR/sounds/pop02.wav

View File

@ -0,0 +1,20 @@
--- xfsound/xfdsp.c.orig Fri Jul 7 05:51:00 2000
+++ xfsound/xfdsp.c Tue Feb 6 04:52:16 2001
@@ -45,7 +45,7 @@
#include <sys/stat.h>
#include <sys/ioctl.h>
#include <sys/types.h>
-#if defined(linux)
+#if defined(linux) || defined(__FreeBSD__)
#include <sys/soundcard.h> /* guess :) */
#endif
@@ -62,7 +62,7 @@
int masterfd;
-#if defined(linux)
+#if defined(linux) || defined(__FreeBSD__)
int
i_play (char *soundfile)
{

View File

@ -0,0 +1,37 @@
--- xfwm/session.c.orig Wed Jan 31 04:50:16 2001
+++ xfwm/session.c Tue Feb 6 04:56:10 2001
@@ -566,8 +566,10 @@
callback_save_yourself2 (SmcConn sm_conn, SmPointer client_data)
{
char *path = NULL;
- char *filename = NULL;
- FILE *f = NULL;
+ char *filename;
+ FILE *f;
+ int fd;
+
Bool success = True;
struct passwd *pwd;
@@ -578,16 +580,18 @@
path = pwd->pw_dir;
}
- filename = tempnam (path, ".fs-");
+ sprintf (filename, "path/.fs-XXXXXXXX");
+ fd = mkstemp (filename);
if (Scr.Options & SessionMgt)
{
- f = fopen (filename, "w");
+ f = fdopen (fd, "w");
success = save_session_state (sm_conn, filename, f);
fclose (f);
}
- if (!success)
+ if (!success || fd < 0)
xfwm_msg (WARN, "SaveSession", "Can't save session\n");
+ close (fd);
/* also save session for builtin session mgt, so user will get
* back to his environmnent even if he doesn't use ICE
*/

View File

@ -45,6 +45,7 @@ etc/xfce/xinitrc
etc/xfce/xinitrc.mwm
etc/xfce/xsession
etc/xfce/xtree.reg
lib/gtk/themes/engines/libxfce.so
share/locale/ca/LC_MESSAGES/xfce.mo
share/locale/cs/LC_MESSAGES/xfce.mo
share/locale/da/LC_MESSAGES/xfce.mo
@ -446,12 +447,12 @@ share/xfce/textures/oldwood.xpm
share/xfce/textures/paper.xpm
share/xfce/textures/silver.xpm
share/xfce/textures/stripe.xpm
@dirrm share/xfce/help
@dirrm share/xfce/sounds
@dirrm share/xfce/textures
@dirrm share/xfce/fonts
@dirrm share/xfce/sounds
@dirrm share/xfce/palettes
@dirrm share/xfce/icons
@dirrm share/xfce/help
@dirrm share/xfce/fonts
@dirrm share/xfce/backdrops
@dirrm share/xfce
@dirrm etc/xfce