Update port to version 1.9dev5, plus misc. cleanups.
Aside from the PR, I also removed the pkg-plist.py file and merged support for the python plist changes in the standard file, using PLIST_SUB. The plist has been resynced with the installed files, since "make package" used to fail. All patch files have been removed, as stated by related PR ports/26492, from maintainer. PR: 26629 (with some changes) Submitted by: maintainer
This commit is contained in:
parent
1ffb51aa31
commit
224c56290e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41877
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= ecasound
|
||||
PORTVERSION= 1.8.5d15
|
||||
PORTVERSION= 1.9dev5
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://ecasound.seul.org/download/ \
|
||||
${MASTER_SITE_SOURCEFORGE}
|
||||
@ -14,6 +14,13 @@ MASTER_SITE_SUBDIR= ecawave
|
||||
|
||||
MAINTAINER= anarcat@tao.ca
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOMAKE= yes
|
||||
USE_AUTOCONF= yes
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.if defined(WITH_MPG123)
|
||||
RUN_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123
|
||||
.endif
|
||||
@ -27,25 +34,19 @@ RUN_DEPENDS+= mikmod:${PORTSDIR}/audio/mikmod
|
||||
.endif
|
||||
|
||||
.if defined(WITH_AUDIOFILE)
|
||||
LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
|
||||
LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-audiofile
|
||||
CONFIGURE_ARGS+= --disable-audiofile
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PYECASOUND)
|
||||
USE_PYTHON= yes
|
||||
PLIST?= ${PKGDIR}/pkg-plist.py
|
||||
USE_PYTHON= yes
|
||||
PLIST_SUB+= WITH_PYECASOUND=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-pyecasound
|
||||
CONFIGURE_ARGS+= --disable-pyecasound
|
||||
PLIST_SUB+= WITH_PYECASOUND="@comment "
|
||||
.endif
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOMAKE= yes
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= ecasound-iam.1 ecasound.1 ecatools.1
|
||||
MAN5= ecasoundrc.5
|
||||
|
||||
|
@ -1 +1 @@
|
||||
MD5 (ecasound-1.8.5d15.tar.gz) = 9e9f1480b026c37e95efdeab16e0dec7
|
||||
MD5 (ecasound-1.9dev5.tar.gz) = 2bfe0c4bf28a036c56333da28c5b8c20
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- config.h.in.orig Wed Nov 22 12:41:03 2000
|
||||
+++ config.h.in Fri Dec 22 13:45:14 2000
|
||||
@@ -52,6 +52,9 @@
|
||||
/* Define if you have the getpagesize function. */
|
||||
#undef HAVE_GETPAGESIZE
|
||||
|
||||
+/* Define if you have the mlockall function. */
|
||||
+#undef HAVE_MLOCKALL
|
||||
+
|
||||
/* Define if you have the <asm/atomic.h> header file. */
|
||||
#undef HAVE_ASM_ATOMIC_H
|
||||
|
@ -1,51 +0,0 @@
|
||||
--- configure.in.orig Thu Dec 7 00:50:49 2000
|
||||
+++ configure.in Fri Dec 22 13:45:14 2000
|
||||
@@ -38,6 +38,7 @@
|
||||
|
||||
dnl --
|
||||
dnl Libtool
|
||||
+AM_PROG_LIBTOOL
|
||||
AC_PATH_PROG(LIBTOOL,libtool,none)
|
||||
if test x$LIBTOOL = xnone; then
|
||||
AC_MSG_ERROR([** Libtool package not installed! **])
|
||||
@@ -46,7 +47,6 @@
|
||||
if test x$GNUM4 = xnone; then
|
||||
AC_MSG_ERROR([** GNU m4 not installed! **])
|
||||
fi
|
||||
-AM_PROG_LIBTOOL
|
||||
|
||||
ACLOCAL=aclocal
|
||||
AUTOMAKE=automake
|
||||
@@ -106,7 +106,7 @@
|
||||
include_debug=yes)
|
||||
AM_CONDITIONAL(INCLUDE_DEBUG, test x$include_debug = xyes)
|
||||
if test x$include_debug = xyes; then
|
||||
-CXXFLAGS="-D_REENTRANT -DENABLE_DBC -g -Wall -Wstrict-prototypes -ffast-math"
|
||||
+CXXFLAGS="$CXXFLAGS -D_REENTRANT -DENABLE_DBC -g -Wall -Wstrict-prototypes -ffast-math"
|
||||
dnl LDFLAGS="-pg -pedantic -funroll-loops"
|
||||
fi
|
||||
|
||||
@@ -123,6 +123,7 @@
|
||||
dnl Checks for functions.
|
||||
dnl ---
|
||||
AC_FUNC_MMAP
|
||||
+AC_CHECK_FUNCS(mlockall)
|
||||
|
||||
dnl ---
|
||||
dnl Checks for libraries.
|
||||
@@ -152,15 +153,6 @@
|
||||
)
|
||||
AC_DEFINE(USE_NCURSES)
|
||||
fi
|
||||
-
|
||||
-dnl ------------------------------------------------------------------
|
||||
-
|
||||
-dnl ---
|
||||
-dnl POSIX.4 threads
|
||||
-dnl ---
|
||||
-AC_CHECK_LIB(pthread,pthread_create, [],
|
||||
- AC_CHECK_LIB(c_r,pthread_create, [],
|
||||
- AC_MSG_ERROR([** POSIX.4 threads not installed or broken **])))
|
||||
|
||||
dnl ------------------------------------------------------------------
|
||||
|
@ -1,16 +0,0 @@
|
||||
--- libecasound/eca-chainsetup-position.cpp.orig Fri Oct 6 18:08:00 2000
|
||||
+++ libecasound/eca-chainsetup-position.cpp Wed Dec 20 00:42:14 2000
|
||||
@@ -43,11 +43,11 @@
|
||||
}
|
||||
|
||||
long int ECA_CHAINSETUP_POSITION::length_in_seconds(void) const {
|
||||
- return(static_cast<double>(length_rep) / srate_rep);
|
||||
+ return(static_cast<long int>(length_rep) / srate_rep);
|
||||
}
|
||||
|
||||
long int ECA_CHAINSETUP_POSITION::position_in_seconds(void) const {
|
||||
- return(static_cast<double>(curpos_rep) / srate_rep);
|
||||
+ return(static_cast<long int>(curpos_rep) / srate_rep);
|
||||
}
|
||||
|
||||
double ECA_CHAINSETUP_POSITION::length_in_seconds_exact(void) const {
|
@ -1,10 +0,0 @@
|
||||
--- libecasound/eca-object-map.cpp/orig Thu Nov 16 20:03:48 2000
|
||||
+++ libecasound/eca-object-map.cpp Mon Dec 18 19:04:48 2000
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <vector>
|
||||
#include <string>
|
||||
#include <map>
|
||||
+#include <sys/types.h>
|
||||
#include <regex.h>
|
||||
|
||||
#include "eca-object-map.h"
|
@ -1,22 +0,0 @@
|
||||
--- libecasound/eca-session.cpp.orig Mon Dec 4 22:22:22 2000
|
||||
+++ libecasound/eca-session.cpp Wed Dec 20 01:21:51 2000
|
||||
@@ -389,14 +389,18 @@
|
||||
int prio = ::atoi(get_argument_number(1, argu).c_str());
|
||||
if (prio != 0)
|
||||
schedpriority_rep = prio;
|
||||
- ecadebug->msg("(eca-session) Raised-priority mode enabled. Locking memory. (prio:" +
|
||||
+ ecadebug->msg("(eca-session) Raised-priority mode enabled (prio:" +
|
||||
kvu_numtostr(schedpriority_rep) + ")");
|
||||
raisepriority_rep = true;
|
||||
+#ifdef HAVE_MLOCKALL
|
||||
if (::mlockall (MCL_CURRENT|MCL_FUTURE)) {
|
||||
ecadebug->msg("(eca-session) Warning! Couldn't lock all memory!");
|
||||
}
|
||||
else
|
||||
ecadebug->msg(ECA_DEBUG::system_objects, "(eca-session) Memory locked!");
|
||||
+#else
|
||||
+ ecadebug->msg("(eca-session) Memory locking not available.");
|
||||
+#endif
|
||||
break;
|
||||
}
|
||||
|
@ -1,16 +0,0 @@
|
||||
--- libecasoundc/Makefile.am.orig Sun Nov 26 22:13:33 2000
|
||||
+++ libecasoundc/Makefile.am Fri Dec 22 02:51:28 2000
|
||||
@@ -9,10 +9,10 @@
|
||||
# remember to update eca-version.cpp
|
||||
if INCLUDE_DEBUG
|
||||
eca_ldflags = -version-info 0:0:0
|
||||
-ecasound_libs = -lecasound_debug
|
||||
+ecasound_libs = -L$(top_builddir)/libecasound/.libs -lecasound_debug
|
||||
else
|
||||
eca_ldflags = -s -version-info 0:0:0
|
||||
-ecasound_libs = -lecasound
|
||||
+ecasound_libs = -L$(top_builddir)/libecasound/.libs -lecasound
|
||||
endif
|
||||
|
||||
if KVUTILS_INSTALLED
|
||||
|
@ -1,14 +0,0 @@
|
||||
--- pyecasound/Makefile.am.orig Tue Dec 5 20:46:42 2000
|
||||
+++ pyecasound/Makefile.am Fri Dec 22 02:53:02 2000
|
||||
@@ -6,9 +6,9 @@
|
||||
# ----------------------------------------------------------------------
|
||||
|
||||
if INCLUDE_DEBUG
|
||||
-ecasound_libs = -lecasound_debug
|
||||
+ecasound_libs = -L$(top_builddir)/libecasound/.libs -lecasound_debug
|
||||
else
|
||||
-ecasound_libs = -lecasound
|
||||
+ecasound_libs = -L$(top_builddir)/libecasound/.libs -lecasound
|
||||
endif
|
||||
|
||||
if KVUTILS_INSTALLED
|
@ -1 +1 @@
|
||||
Software package designed for multitrack audio processing.
|
||||
Software package designed for multitrack audio processing
|
||||
|
@ -1,9 +1,6 @@
|
||||
=======================================================================
|
||||
*** [Extract from] Ecasound - README ***
|
||||
=======================================================================
|
||||
-----------------------------------------------------------------------
|
||||
What is it?
|
||||
-----------------------------------------------------------------------
|
||||
|
||||
Ecasound is a software package designed for multitrack audio
|
||||
processing. It can be used for simple tasks like audio playback,
|
||||
|
@ -1,4 +1,3 @@
|
||||
@name ecasound-1.8.5d15
|
||||
bin/ecaconvert
|
||||
bin/ecafixdc
|
||||
bin/ecanormalize
|
||||
@ -7,19 +6,19 @@ bin/ecasignalview
|
||||
bin/ecasound
|
||||
bin/ecasound-config
|
||||
bin/ecasoundc-config
|
||||
include/ecasound/audio-stamp.h
|
||||
include/ecasound/audiofx.h
|
||||
include/ecasound/audiofx_amplitude.h
|
||||
include/ecasound/audiofx_analysis.h
|
||||
include/ecasound/audiofx_compressor.h
|
||||
include/ecasound/audiofx_envelope_modulation.h
|
||||
include/ecasound/audiofx_filter.h
|
||||
include/ecasound/audiofx_impl.h
|
||||
include/ecasound/audiofx_ladspa.h
|
||||
include/ecasound/audiofx_misc.h
|
||||
include/ecasound/audiofx_mixing.h
|
||||
include/ecasound/audiofx_rcfilter.h
|
||||
include/ecasound/audiofx_reverb.h
|
||||
include/ecasound/audiofx_timebased.h
|
||||
include/ecasound/audiofx_vst.h
|
||||
include/ecasound/audiogate.h
|
||||
include/ecasound/audioio-buffered-proxy.h
|
||||
include/ecasound/audioio-cdr.h
|
||||
@ -47,12 +46,10 @@ include/ecasound/ctrl-source.h
|
||||
include/ecasound/dynamic-object.h
|
||||
include/ecasound/dynamic-parameters.h
|
||||
include/ecasound/eca-audio-format.h
|
||||
include/ecasound/eca-audio-object-map.h
|
||||
include/ecasound/eca-audio-objects.h
|
||||
include/ecasound/eca-audio-position.h
|
||||
include/ecasound/eca-audio-time.h
|
||||
include/ecasound/eca-chain.h
|
||||
include/ecasound/eca-chainop-map.h
|
||||
include/ecasound/eca-chainop.h
|
||||
include/ecasound/eca-chainsetup-position.h
|
||||
include/ecasound/eca-chainsetup.h
|
||||
@ -62,16 +59,13 @@ include/ecasound/eca-control-dump.h
|
||||
include/ecasound/eca-control-interface.h
|
||||
include/ecasound/eca-control-objects.h
|
||||
include/ecasound/eca-control.h
|
||||
include/ecasound/eca-controller-map.h
|
||||
include/ecasound/eca-debug.h
|
||||
include/ecasound/eca-error.h
|
||||
include/ecasound/eca-fileio-mmap.h
|
||||
include/ecasound/eca-fileio-stream.h
|
||||
include/ecasound/eca-fileio.h
|
||||
include/ecasound/eca-iamode-parser.h
|
||||
include/ecasound/eca-ladspa-plugin-map.h
|
||||
include/ecasound/eca-main.h
|
||||
include/ecasound/eca-midi.h
|
||||
include/ecasound/eca-object-factory.h
|
||||
include/ecasound/eca-object-map.h
|
||||
include/ecasound/eca-object.h
|
||||
@ -81,7 +75,6 @@ include/ecasound/eca-resources.h
|
||||
include/ecasound/eca-session.h
|
||||
include/ecasound/eca-static-object-maps.h
|
||||
include/ecasound/eca-version.h
|
||||
include/ecasound/eca-vst-plugin-map.h
|
||||
include/ecasound/ecasoundc.h
|
||||
include/ecasound/file-preset.h
|
||||
include/ecasound/finite-envelope.h
|
||||
@ -91,6 +84,12 @@ include/ecasound/ladspa.h
|
||||
include/ecasound/layer.h
|
||||
include/ecasound/linear-envelope.h
|
||||
include/ecasound/midi-cc.h
|
||||
include/ecasound/midi-client.h
|
||||
include/ecasound/midi-parser.h
|
||||
include/ecasound/midi-server.h
|
||||
include/ecasound/midiio-raw.h
|
||||
include/ecasound/midiio.h
|
||||
include/ecasound/osc-gen-file.h
|
||||
include/ecasound/osc-gen.h
|
||||
include/ecasound/osc-sine.h
|
||||
include/ecasound/oscillator.h
|
||||
@ -102,6 +101,7 @@ include/ecasound/samplebuffer.h
|
||||
include/ecasound/samplebuffer_functions.h
|
||||
include/ecasound/samplebuffer_impl.h
|
||||
include/ecasound/samplebuffer_iterators.h
|
||||
include/ecasound/stamp-ctrl.h
|
||||
include/ecasound/two-stage-linear-envelope.h
|
||||
include/kvutils/com_line.h
|
||||
include/kvutils/definition_by_contract.h
|
||||
@ -111,38 +111,30 @@ include/kvutils/locks.h
|
||||
include/kvutils/message_item.h
|
||||
include/kvutils/object_queue.h
|
||||
include/kvutils/procedure_timer.h
|
||||
include/kvutils/temporary_file_directory.h
|
||||
include/kvutils/value_queue.h
|
||||
lib/ecasound-plugins/libaudioio_af.so
|
||||
lib/ecasound-plugins/libaudioio_alsa.so
|
||||
lib/ecasound-plugins/libaudioio_alsa2.so
|
||||
lib/ecasound-plugins/libaudioio_alsa2_plugin.so
|
||||
lib/ecasound-plugins/libaudioio_alsa3.so
|
||||
lib/ecasound-plugins/libaudioio_alsa3_pcm.so
|
||||
lib/ecasound-plugins/libaudioio_alsalb.so
|
||||
lib/ecasound-plugins/libaudioio_arts.so
|
||||
lib/libecasound.a
|
||||
lib/libecasound.la
|
||||
lib/libecasound.so
|
||||
lib/libecasound.so.7
|
||||
lib/libecasoundc.a
|
||||
lib/libecasoundc.la
|
||||
lib/libecasoundc.so
|
||||
lib/libecasoundc.so.0
|
||||
lib/libkvutils.a
|
||||
lib/libkvutils.la
|
||||
lib/libkvutils.so
|
||||
lib/libkvutils.so.2
|
||||
lib/ecasound-plugins/libaudioio_af.la
|
||||
lib/ecasound-plugins/libaudioio_af.so
|
||||
lib/ecasound-plugins/libaudioio_alsa.la
|
||||
lib/ecasound-plugins/libaudioio_alsa.so
|
||||
lib/ecasound-plugins/libaudioio_alsa2.la
|
||||
lib/ecasound-plugins/libaudioio_alsa2.so
|
||||
lib/ecasound-plugins/libaudioio_alsa2_plugin.la
|
||||
lib/ecasound-plugins/libaudioio_alsa2_plugin.so
|
||||
lib/ecasound-plugins/libaudioio_alsa3.la
|
||||
lib/ecasound-plugins/libaudioio_alsa3.so
|
||||
lib/ecasound-plugins/libaudioio_alsalb.la
|
||||
lib/ecasound-plugins/libaudioio_alsalb.so
|
||||
lib/ecasound-plugins/libaudioio_arts.la
|
||||
lib/ecasound-plugins/libaudioio_arts.so
|
||||
share/ecasound/effect_presets
|
||||
share/ecasound/generic_oscillators
|
||||
%%WITH_PYECASOUND%%lib/%%PYTHON_VERSION%%/site-packages/libpyecasound.so
|
||||
%%WITH_PYECASOUND%%lib/%%PYTHON_VERSION%%/site-packages/pyeca.py
|
||||
@dirrm share/ecasound
|
||||
@dirrm include/ecasound
|
||||
@dirrm lib/ecasound-plugins
|
||||
@unexec rmdir %D/lib/python1.5/site-packages 2>/dev/null || true
|
||||
@exec /sbin/ldconfig -m %D/lib
|
||||
@unexec /sbin/ldconfig -R
|
||||
@dirrm include/ecasound
|
||||
@dirrm include/kvutils
|
||||
|
@ -1,151 +0,0 @@
|
||||
@name ecasound-1.8.5d15
|
||||
bin/ecaconvert
|
||||
bin/ecafixdc
|
||||
bin/ecanormalize
|
||||
bin/ecaplay
|
||||
bin/ecasignalview
|
||||
bin/ecasound
|
||||
bin/ecasound-config
|
||||
bin/ecasoundc-config
|
||||
include/ecasound/audiofx.h
|
||||
include/ecasound/audiofx_amplitude.h
|
||||
include/ecasound/audiofx_analysis.h
|
||||
include/ecasound/audiofx_compressor.h
|
||||
include/ecasound/audiofx_envelope_modulation.h
|
||||
include/ecasound/audiofx_filter.h
|
||||
include/ecasound/audiofx_impl.h
|
||||
include/ecasound/audiofx_ladspa.h
|
||||
include/ecasound/audiofx_mixing.h
|
||||
include/ecasound/audiofx_rcfilter.h
|
||||
include/ecasound/audiofx_reverb.h
|
||||
include/ecasound/audiofx_timebased.h
|
||||
include/ecasound/audiofx_vst.h
|
||||
include/ecasound/audiogate.h
|
||||
include/ecasound/audioio-buffered-proxy.h
|
||||
include/ecasound/audioio-cdr.h
|
||||
include/ecasound/audioio-cdr_impl.h
|
||||
include/ecasound/audioio-ewf.h
|
||||
include/ecasound/audioio-forked-stream.h
|
||||
include/ecasound/audioio-loop.h
|
||||
include/ecasound/audioio-mikmod.h
|
||||
include/ecasound/audioio-mp3.h
|
||||
include/ecasound/audioio-mp3_impl.h
|
||||
include/ecasound/audioio-null.h
|
||||
include/ecasound/audioio-ogg.h
|
||||
include/ecasound/audioio-oss.h
|
||||
include/ecasound/audioio-oss_impl.h
|
||||
include/ecasound/audioio-plugin.h
|
||||
include/ecasound/audioio-proxy-buffer.h
|
||||
include/ecasound/audioio-proxy-server.h
|
||||
include/ecasound/audioio-raw.h
|
||||
include/ecasound/audioio-rtnull.h
|
||||
include/ecasound/audioio-timidity.h
|
||||
include/ecasound/audioio-types.h
|
||||
include/ecasound/audioio-wave.h
|
||||
include/ecasound/audioio.h
|
||||
include/ecasound/ctrl-source.h
|
||||
include/ecasound/dynamic-object.h
|
||||
include/ecasound/dynamic-parameters.h
|
||||
include/ecasound/eca-audio-format.h
|
||||
include/ecasound/eca-audio-object-map.h
|
||||
include/ecasound/eca-audio-objects.h
|
||||
include/ecasound/eca-audio-position.h
|
||||
include/ecasound/eca-audio-time.h
|
||||
include/ecasound/eca-chain.h
|
||||
include/ecasound/eca-chainop-map.h
|
||||
include/ecasound/eca-chainop.h
|
||||
include/ecasound/eca-chainsetup-position.h
|
||||
include/ecasound/eca-chainsetup.h
|
||||
include/ecasound/eca-comhelp.h
|
||||
include/ecasound/eca-control-base.h
|
||||
include/ecasound/eca-control-dump.h
|
||||
include/ecasound/eca-control-interface.h
|
||||
include/ecasound/eca-control-objects.h
|
||||
include/ecasound/eca-control.h
|
||||
include/ecasound/eca-controller-map.h
|
||||
include/ecasound/eca-debug.h
|
||||
include/ecasound/eca-error.h
|
||||
include/ecasound/eca-fileio-mmap.h
|
||||
include/ecasound/eca-fileio-stream.h
|
||||
include/ecasound/eca-fileio.h
|
||||
include/ecasound/eca-iamode-parser.h
|
||||
include/ecasound/eca-ladspa-plugin-map.h
|
||||
include/ecasound/eca-main.h
|
||||
include/ecasound/eca-midi.h
|
||||
include/ecasound/eca-object-factory.h
|
||||
include/ecasound/eca-object-map.h
|
||||
include/ecasound/eca-object.h
|
||||
include/ecasound/eca-operator.h
|
||||
include/ecasound/eca-preset-map.h
|
||||
include/ecasound/eca-resources.h
|
||||
include/ecasound/eca-session.h
|
||||
include/ecasound/eca-static-object-maps.h
|
||||
include/ecasound/eca-version.h
|
||||
include/ecasound/eca-vst-plugin-map.h
|
||||
include/ecasound/ecasoundc.h
|
||||
include/ecasound/file-preset.h
|
||||
include/ecasound/finite-envelope.h
|
||||
include/ecasound/generic-controller.h
|
||||
include/ecasound/global-preset.h
|
||||
include/ecasound/ladspa.h
|
||||
include/ecasound/layer.h
|
||||
include/ecasound/linear-envelope.h
|
||||
include/ecasound/midi-cc.h
|
||||
include/ecasound/osc-gen.h
|
||||
include/ecasound/osc-sine.h
|
||||
include/ecasound/oscillator.h
|
||||
include/ecasound/plugin-paths.h
|
||||
include/ecasound/preset.h
|
||||
include/ecasound/resource-file.h
|
||||
include/ecasound/sample-specs.h
|
||||
include/ecasound/samplebuffer.h
|
||||
include/ecasound/samplebuffer_functions.h
|
||||
include/ecasound/samplebuffer_impl.h
|
||||
include/ecasound/samplebuffer_iterators.h
|
||||
include/ecasound/two-stage-linear-envelope.h
|
||||
include/kvutils/com_line.h
|
||||
include/kvutils/definition_by_contract.h
|
||||
include/kvutils/kvu_numtostr.h
|
||||
include/kvutils/kvutils.h
|
||||
include/kvutils/locks.h
|
||||
include/kvutils/message_item.h
|
||||
include/kvutils/object_queue.h
|
||||
include/kvutils/procedure_timer.h
|
||||
include/kvutils/value_queue.h
|
||||
lib/libecasound.a
|
||||
lib/libecasound.la
|
||||
lib/libecasound.so
|
||||
lib/libecasound.so.7
|
||||
lib/libecasoundc.a
|
||||
lib/libecasoundc.la
|
||||
lib/libecasoundc.so
|
||||
lib/libecasoundc.so.0
|
||||
lib/libkvutils.a
|
||||
lib/libkvutils.la
|
||||
lib/libkvutils.so
|
||||
lib/libkvutils.so.2
|
||||
lib/ecasound-plugins/libaudioio_af.la
|
||||
lib/ecasound-plugins/libaudioio_af.so
|
||||
lib/ecasound-plugins/libaudioio_alsa.la
|
||||
lib/ecasound-plugins/libaudioio_alsa.so
|
||||
lib/ecasound-plugins/libaudioio_alsa2.la
|
||||
lib/ecasound-plugins/libaudioio_alsa2.so
|
||||
lib/ecasound-plugins/libaudioio_alsa2_plugin.la
|
||||
lib/ecasound-plugins/libaudioio_alsa2_plugin.so
|
||||
lib/ecasound-plugins/libaudioio_alsa3.la
|
||||
lib/ecasound-plugins/libaudioio_alsa3.so
|
||||
lib/ecasound-plugins/libaudioio_alsalb.la
|
||||
lib/ecasound-plugins/libaudioio_alsalb.so
|
||||
lib/ecasound-plugins/libaudioio_arts.la
|
||||
lib/ecasound-plugins/libaudioio_arts.so
|
||||
share/ecasound/effect_presets
|
||||
share/ecasound/generic_oscillators
|
||||
lib/python1.5/site-packages/pyeca.py
|
||||
lib/python1.5/site-packages/libpyecasound.la
|
||||
lib/python1.5/site-packages/libpyecasound.so
|
||||
@dirrm share/ecasound
|
||||
@dirrm include/ecasound
|
||||
@dirrm lib/ecasound-plugins
|
||||
@unexec rmdir %D/lib/python1.5/site-packages 2>/dev/null || true
|
||||
@exec /sbin/ldconfig -m %D/lib
|
||||
@unexec /sbin/ldconfig -R
|
Loading…
Reference in New Issue
Block a user