www/py-requests: Update to 2.28.2

Changes:	https://github.com/psf/requests/releases
This commit is contained in:
Po-Chuan Hsieh 2023-01-30 20:35:53 +08:00
parent 60b1ea4002
commit 21eb1534ae
No known key found for this signature in database
GPG Key ID: 9A4BD10F002DD04B
3 changed files with 4 additions and 42 deletions

View File

@ -1,6 +1,5 @@
PORTNAME= requests
PORTVERSION= 2.28.1
PORTREVISION= 1
PORTVERSION= 2.28.2
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1656702532
SHA256 (requests-2.28.1.tar.gz) = 7c5599b102feddaa661c826c56ab4fee28bfd17f5abca1ebbe3e7f19d7c97983
SIZE (requests-2.28.1.tar.gz) = 109805
TIMESTAMP = 1674590070
SHA256 (requests-2.28.2.tar.gz) = 98b1b2782e3c6c4904938b84c0eb932721069dfdb9134313beff7c83c2df24bf
SIZE (requests-2.28.2.tar.gz) = 108206

View File

@ -1,37 +0,0 @@
Obtained from: https://github.com/psf/requests/commit/c57f1f0ca10e61771b459c857182c23626607312
--- requests/__init__.py.orig 2022-06-29 15:09:45 UTC
+++ requests/__init__.py
@@ -80,8 +80,8 @@ def check_compatibility(urllib3_version, chardet_versi
elif charset_normalizer_version:
major, minor, patch = charset_normalizer_version.split(".")[:3]
major, minor, patch = int(major), int(minor), int(patch)
- # charset_normalizer >= 2.0.0 < 3.0.0
- assert (2, 0, 0) <= (major, minor, patch) < (3, 0, 0)
+ # charset_normalizer >= 2.0.0 < 4.0.0
+ assert (2, 0, 0) <= (major, minor, patch) < (4, 0, 0)
else:
raise Exception("You need either charset_normalizer or chardet installed")
--- setup.cfg.orig 2022-06-29 15:13:33 UTC
+++ setup.cfg
@@ -5,7 +5,7 @@ provides-extra =
use_chardet_on_py3
requires-dist =
certifi>=2017.4.17
- charset_normalizer>=2,<3
+ charset_normalizer>=2,<4
idna>=2.5,<4
urllib3>=1.21.1,<1.27
--- setup.py.orig 2022-06-29 15:09:45 UTC
+++ setup.py
@@ -59,7 +59,7 @@ if sys.argv[-1] == "publish":
sys.exit()
requires = [
- "charset_normalizer>=2,<3",
+ "charset_normalizer>=2,<4",
"idna>=2.5,<4",
"urllib3>=1.21.1,<1.27",
"certifi>=2017.4.17",