audio/cava: Update to 0.7.1

Changes:	https://github.com/karlstav/cava/releases/tag/0.7.1
This commit is contained in:
Tobias Kortkamp 2020-06-25 03:56:24 +00:00
parent b8ff904140
commit 21cc94f049
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=540363
4 changed files with 16 additions and 21 deletions

View File

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= cava
DISTVERSION= 0.7.0
DISTVERSION= 0.7.1
CATEGORIES= audio
MAINTAINER= tobik@FreeBSD.org

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1590792822
SHA256 (karlstav-cava-0.7.0_GH0.tar.gz) = 1ced5b131b86f2aa86259c58c2d2dfd46201ab908395229191b5a8dec894b84c
SIZE (karlstav-cava-0.7.0_GH0.tar.gz) = 52865
TIMESTAMP = 1593045121
SHA256 (karlstav-cava-0.7.1_GH0.tar.gz) = 7dfb8f9c72722ded5b88bba967c72d024e9446fdabdf14938f4519262c901d06
SIZE (karlstav-cava-0.7.1_GH0.tar.gz) = 53018

View File

@ -2,7 +2,7 @@
does not recognize
- Do not install the Linux-only font
--- Makefile.am.orig 2020-05-26 20:29:47 UTC
--- Makefile.am.orig 2020-06-24 19:18:09 UTC
+++ Makefile.am
@@ -10,11 +10,11 @@ M_CPPFLAGS = -DSYSTEM_LIBINIPARSER=@SYSTEM_LIBINIPARSE
@ -12,19 +12,14 @@
+ output/raw.c
cava_LDFLAGS = -L/usr/local/lib -Wl,-rpath /usr/local/lib
cava_CPPFLAGS = -DPACKAGE=\"$(PACKAGE)\" -DVERSION=\"$(VERSION)\" \
- -D_POSIX_SOURCE -D _POSIX_C_SOURCE=200809L
-cava_CFLAGS = -std=c99 -Wall -Wextra -Wno-unused-result -Wno-maybe-uninitialized
+ -D_POSIX_SOURCE -D _POSIX_C_SOURCE=200809L -DFONT_DIR=\"@FONT_DIR@\"
- -D_POSIX_SOURCE -D _POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE_EXTENDED
-cava_CFLAGS = -std=c99 -Wall -Werror -Wextra -Wno-unused-result -Wno-unknown-warning-option -Wno-maybe-uninitialized
+ -D_POSIX_SOURCE -D _POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE_EXTENDED -DFONT_DIR=\"@FONT_DIR@\"
+cava_CFLAGS = -std=c99 -Wall -Wextra
if OSX
cava_CFLAGS += -DNORT
@@ -39,11 +39,11 @@ if SNDIO
endif
if NCURSES
- cava_SOURCES += output/terminal_bcircle.c output/terminal_ncurses.c
+ cava_SOURCES += output/terminal_ncurses.c
@@ -43,7 +43,7 @@ if NCURSES
endif
cava_font_dir = @FONT_DIR@

View File

@ -1,6 +1,6 @@
--- cava.c.orig 2020-05-26 20:29:47 UTC
--- cava.c.orig 2020-06-24 19:18:09 UTC
+++ cava.c
@@ -32,13 +32,11 @@
@@ -31,13 +31,11 @@
#include "util.h"
#ifdef NCURSES
@ -14,7 +14,7 @@
#include "input/alsa.h"
#include "input/common.h"
@@ -91,8 +89,6 @@ void cleanup(void) {
@@ -90,8 +88,6 @@ void cleanup(void) {
#else
;
#endif
@ -23,7 +23,7 @@
}
}
@@ -338,8 +334,12 @@ as of 0.4.0 all options are specified in config file,
@@ -337,8 +333,12 @@ as of 0.4.0 all options are specified in config file,
if (strncmp(ttyname(0), "/dev/ttys", 9) == 0)
inAtty = 0;
if (inAtty) {
@ -36,20 +36,20 @@
}
// We use unicode block characters to draw the bars and
@@ -547,12 +547,6 @@ as of 0.4.0 all options are specified in config file,
@@ -546,12 +546,6 @@ as of 0.4.0 all options are specified in config file,
height = lines * 8;
break;
#endif
- case OUTPUT_NONCURSES:
- get_terminal_dim_noncurses(&width, &lines);
- init_terminal_noncurses(p.col, p.bgcol, width, lines, p.bar_width);
- init_terminal_noncurses(inAtty, p.col, p.bgcol, width, lines, p.bar_width);
- height = (lines - 1) * 8;
- break;
-
case OUTPUT_RAW:
if (strcmp(p.raw_target, "/dev/stdout") != 0) {
// checking if file exists
@@ -998,10 +992,6 @@ as of 0.4.0 all options are specified in config file,
@@ -997,10 +991,6 @@ as of 0.4.0 all options are specified in config file,
p.gradient);
break;
#endif