- Update to 1.5.1

- Move manpage definitions to Makefile.man
- Use MLINKS macro to create manpage links
- Use USE_PKGCONFIG in favor of USE_GNOME=pkgconfig
- Use PORTDOCS to cut down pkg-plist size
- Convert to new options framework
- Trim Makefile header

PR:		ports/172853
Submitted by:	Eijiro Shibusawa <phd_kimberlite@yahoo.co.jp> (maintainer)
Approved by:	makc (mentor)
Feature safe:	yes
This commit is contained in:
Jason E. Hale 2012-10-22 13:00:47 +00:00
parent 08586f0b2b
commit 218252c9d0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=306272
5 changed files with 37 additions and 181 deletions

View File

@ -1,12 +1,7 @@
# New ports collection makefile for: hwloc
# Date created: 18 Dec 2011
# Whom: Eijiro Shibusawa <ej-sib@ice.uec.ac.jp>
#
# $FreeBSD$
#
PORTNAME= hwloc
PORTVERSION= 1.5
PORTVERSION= 1.5.1
CATEGORIES= devel
MASTER_SITES= http://www.open-mpi.org/software/hwloc/v1.5/downloads/ \
http://icl.cs.utk.edu/open-mpi/software/hwloc/v1.5/downloads/
@ -21,18 +16,22 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-static \
--enable-libxml2
USE_BZIP2= yes
USE_PKGCONFIG= build
USE_LDCONFIG= yes
USE_GNOME= libxml2 pkgconfig
USE_GNOME= libxml2 gnomehack
MAKE_JOBS_SAFE= yes
PORTDOCS= *
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= has not been ported to this architecture
OPTIONS= CAIRO "Enable CAIRO support" off
OPTIONS_DEFINE= CAIRO
.include <bsd.port.pre.mk>
.include "${.CURDIR}/Makefile.man"
.include <bsd.port.options.mk>
.if defined(WITHOUT_CAIRO)
.if empty(PORT_OPTIONS:MCAIRO)
CONFIGURE_ARGS+= --disable-cairo \
--without-x
.else
@ -42,26 +41,17 @@ LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo
USE_XORG= x11
.endif
.include "${FILESDIR}/manpages"
post-patch:
@${REINPLACE_CMD} -e \
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
${WRKSRC}/Makefile.in
.ifdef NOPORTDOCS
.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} -e \
's|^\(install-data-am:\) install-dist_pdfDATA \(install-man\)|\1 \2|g' \
${WRKSRC}/doc/Makefile.in
.endif
post-install:
@(cd ${MAN1PREFIX}/man/man1/ ;\
${LN} -sf lstopo.1.gz hwloc-info.1.gz ; \
${LN} -sf lstopo.1.gz hwloc-ls.1.gz ;\
${LN} -sf lstopo.1.gz lstopo-no-graphics.1.gz )
.ifdef !defined(NOPORTDOCS)
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/html
@${INSTALL_DATA} ${WRKSRC}/doc/doxygen-doc/html/* ${DOCSDIR}/html/.
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,3 +1,5 @@
# $FreeBSD$
MAN1= hwloc-assembler-remote.1 \
hwloc-assembler.1 \
hwloc-bind.1 \
@ -330,3 +332,7 @@ MAN3= HWLOC_API_VERSION.3 \
hwlocality_types.3
MAN7= hwloc.7
MLINKS= lstopo.1 hwloc-info.1 \
lstopo.1 hwloc-ls.1 \
lstopo.1 lstopo-no-graphics.1

View File

@ -1,2 +1,2 @@
SHA256 (hwloc-1.5.tar.bz2) = ba8519c27eb5637d184a0673a701265a94c4e8ab1ca6bfcf903bcd1f627474ea
SIZE (hwloc-1.5.tar.bz2) = 2887977
SHA256 (hwloc-1.5.1.tar.bz2) = d255bf369d8922bb3e1330b84e3bc5dd9a8ce6cb3c8cbb3af0f4288840087711
SIZE (hwloc-1.5.1.tar.bz2) = 2888571

View File

@ -1,11 +0,0 @@
--- configure.orig 2012-07-30 17:36:50.000000000 +0900
+++ configure 2012-08-01 19:12:58.000000000 +0900
@@ -7001,7 +7001,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking which CPU support to include" >&5
$as_echo_n "checking which CPU support to include... " >&6; }
case ${target} in
- i*86-*-*|x86_64-*-*)
+ i*86-*-*|x86_64-*-*|amd64-*-*)
case ${ac_cv_sizeof_void_p} in
4)

View File

@ -1,146 +1,3 @@
lib/libhwloc.so.6
lib/libhwloc.so
lib/libhwloc.la
lib/libhwloc.a
libdata/pkgconfig/hwloc.pc
share/hwloc/hwloc.dtd
share/hwloc/hwloc-valgrind.supp
%%PORTDOCS%%%%DOCSDIR%%/hwloc-a4.pdf
%%PORTDOCS%%%%DOCSDIR%%/hwloc-letter.pdf
%%PORTDOCS%%%%DOCSDIR%%/html/a00001.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00002.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00003.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00004.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00005.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00006.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00007.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00008.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00009.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00010.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00011.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00012.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00013.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00014.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00015.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00016.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00017.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00018.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00019.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00020.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00021.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00022.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00023.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00024.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00025.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00026.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00027_source.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00028_source.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00029_source.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00030_source.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00031_source.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00033_source.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00034_source.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00035_source.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00036_source.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00037_source.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00038.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00039.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00040.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00041.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00042.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00043.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00044.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00045.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00046.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00047.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00048.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00049.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00050.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00051.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00052.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00053.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00054.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00055.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00056.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00057.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00058.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00059.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00060.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00061.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00062.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00063.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00064.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00065.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00066.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00067.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00068.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00069.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00070.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00071.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00072.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00073.html
%%PORTDOCS%%%%DOCSDIR%%/html/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/html/bc_s.png
%%PORTDOCS%%%%DOCSDIR%%/html/bdwn.png
%%PORTDOCS%%%%DOCSDIR%%/html/classes.html
%%PORTDOCS%%%%DOCSDIR%%/html/closed.png
%%PORTDOCS%%%%DOCSDIR%%/html/devel09-pci.png
%%PORTDOCS%%%%DOCSDIR%%/html/diagram.png
%%PORTDOCS%%%%DOCSDIR%%/html/dir_5cb306d949c7931a3b6c77517393dd34.html
%%PORTDOCS%%%%DOCSDIR%%/html/dir_d44c64559bbebec7f509842c48db8b23.html
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.png
%%PORTDOCS%%%%DOCSDIR%%/html/dudley.png
%%PORTDOCS%%%%DOCSDIR%%/html/dynsections.js
%%PORTDOCS%%%%DOCSDIR%%/html/emmett.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2blank.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2cl.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2doc.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2folderclosed.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2folderopen.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2lastnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2link.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2mlastnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2mnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2mo.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2node.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2ns.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2plastnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2pnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2splitbar.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2vertline.png
%%PORTDOCS%%%%DOCSDIR%%/html/functions.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars.html
%%PORTDOCS%%%%DOCSDIR%%/html/hagrid.png
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/modules.html
%%PORTDOCS%%%%DOCSDIR%%/html/nav_f.png
%%PORTDOCS%%%%DOCSDIR%%/html/nav_g.png
%%PORTDOCS%%%%DOCSDIR%%/html/nav_h.png
%%PORTDOCS%%%%DOCSDIR%%/html/open.png
%%PORTDOCS%%%%DOCSDIR%%/html/pages.html
%%PORTDOCS%%%%DOCSDIR%%/html/ppc64-full-with-smt.png
%%PORTDOCS%%%%DOCSDIR%%/html/ppc64-with-smt.png
%%PORTDOCS%%%%DOCSDIR%%/html/ppc64-without-smt.png
%%PORTDOCS%%%%DOCSDIR%%/html/sync_off.png
%%PORTDOCS%%%%DOCSDIR%%/html/sync_on.png
%%PORTDOCS%%%%DOCSDIR%%/html/tab_a.png
%%PORTDOCS%%%%DOCSDIR%%/html/tab_b.png
%%PORTDOCS%%%%DOCSDIR%%/html/tab_h.png
%%PORTDOCS%%%%DOCSDIR%%/html/tab_s.png
%%PORTDOCS%%%%DOCSDIR%%/html/tabs.css
man/man1/hwloc-info.1.gz
man/man1/hwloc-ls.1.gz
man/man1/lstopo-no-graphics.1.gz
include/hwloc.h
include/hwloc/autogen/config.h
include/hwloc/bitmap.h
include/hwloc/cuda.h
include/hwloc/cudart.h
include/hwloc/helper.h
include/hwloc/myriexpress.h
include/hwloc/openfabrics-verbs.h
include/hwloc/rename.h
bin/hwloc-assembler
bin/hwloc-assembler-remote
bin/hwloc-bind
@ -152,8 +9,22 @@ bin/hwloc-ls
bin/hwloc-ps
bin/lstopo
bin/lstopo-no-graphics
include/hwloc.h
include/hwloc/autogen/config.h
include/hwloc/bitmap.h
include/hwloc/cuda.h
include/hwloc/cudart.h
include/hwloc/helper.h
include/hwloc/myriexpress.h
include/hwloc/openfabrics-verbs.h
include/hwloc/rename.h
lib/libhwloc.a
lib/libhwloc.la
lib/libhwloc.so
lib/libhwloc.so.6
libdata/pkgconfig/hwloc.pc
share/hwloc/hwloc-valgrind.supp
share/hwloc/hwloc.dtd
@dirrmtry share/hwloc
@dirrmtry include/hwloc/autogen
@dirrmtry include/hwloc
%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/html
%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
@dirrmtry share/hwloc