Decibel audio player is a very fast GTK+ audio player

with an emphasis on being very clean and user friendly.

* Utilizes the GStreamer plugins system
* Lighter footprint than most audio players
* Follows the Gnome Human Interface Guidelines
* Has quite a few plugins of it's own

WWW:	http://decibel.silent-blade.org/

PR:		ports/144817
Submitted by:	kipz <somicide at gmail dot com>
Approved by:	beat (co-mentor)
This commit is contained in:
Bernhard Froehlich 2010-09-23 15:17:17 +00:00
parent 70d0fcafa8
commit 215c1bdfe5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=261699
6 changed files with 249 additions and 0 deletions

View File

@ -128,6 +128,7 @@
SUBDIR += darkice
SUBDIR += dcd
SUBDIR += deadbeef
SUBDIR += decibel-audio-player
SUBDIR += dekagen
SUBDIR += denemo
SUBDIR += dir2ogg

View File

@ -0,0 +1,82 @@
# New ports collection makefile for: decibel-audio-player
# Date created: 2010-03-17
# Whom: kipz <somicide@gmail.com>
#
# $FreeBSD$
#
PORTNAME= decibel-audio-player
PORTVERSION= 1.05
CATEGORIES= audio multimedia gnome python
MASTER_SITES= http://decibel.silent-blade.org/uploads/Main/
MAINTAINER= somicide@gmail.com
COMMENT= A fast GTK+ audio player with an clean and user friendly interface
RUN_DEPENDS= py*-dbus>=0.80:${PORTSDIR}/devel/py-dbus \
py*-mutagen>=1.11:${PORTSDIR}/audio/py-mutagen
LICENSE= GPLv2
USE_PYTHON= 2.4+
USE_GNOME= pygnome2 pygtk2
USE_GSTREAMER= python good bad
USE_GETTEXT= yes
USE_GMAKE= yes
NO_BUILD= yes
MAN1= decibel-audio-player.1 decibel-audio-player-remote.1
#Audio gstreamer plugins
OPTIONS= FLAC "FLAC support" on \
MP3 "MP3 support" on \
MPEG4IP "AAC/MP4P support" on \
OGG "OGG support" on \
SPEEX "OGG/Speex support" off \
VORBIS "OGG/Vorbis support" on \
WAVPACK "Wavpack support" on
#A few extra requirements if we want to use some nifty plugins in decibel
OPTIONS+= EXTRAS "Extra dependencies for plugins" on
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_EXTRAS)
RUN_DEPENDS+= py*-imaging>=1.1.6:${PORTSDIR}/graphics/py-imaging \
py*-notify>=0.1.1:${PORTSDIR}/devel/py-notify
.endif
.if !defined(WITHOUT_FLAC)
USE_GSTREAMER+= flac
.endif
.if !defined(WITHOUT_MP3)
USE_GSTREAMER+= mp3
.endif
.if !defined(WITHOUT_MPEG4IP)
LIB_DEPENDS+= mp4v2.10:${PORTSDIR}/multimedia/mp4v2
USE_GSTREAMER+= faad
.endif
.if !defined(WITHOUT_OGG)
USE_GSTREAMER+= ogg
.endif
.if !defined(WITHOUT_SPEEX)
USE_GSTREAMER+= speex
.endif
.if !defined(WITHOUT_VORBIS)
USE_GSTREAMER+= vorbis
.endif
.if !defined(WITHOUT_WAVPACK)
LIB_DEPENDS+= wavpack.2:${PORTSDIR}/audio/wavpack
USE_GSTREAMER+= wavpack
.endif
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/Makefile
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (decibel-audio-player-1.05.tar.gz) = dfebf66d5d6063e99cda9ea6217a6a0b
SHA256 (decibel-audio-player-1.05.tar.gz) = 4cde7a50a8956f1aa4b9d744fa914231607a5646e8878472a52bf8c363ccf631
SIZE (decibel-audio-player-1.05.tar.gz) = 350196

View File

@ -0,0 +1,20 @@
--- Makefile.orig 2010-06-27 11:29:12.000000000 +0200
+++ Makefile 2010-09-17 20:28:10.000000000 +0200
@@ -8,7 +8,7 @@
PREFIX = $(DESTDIR)$(prefix)
BINDIR = $(PREFIX)/bin
-MANDIR = $(PREFIX)/share/man/man1
+MANDIR = $(PREFIX)/man/man1
DATADIR = $(PREFIX)/share/decibel-audio-player
SRCDIR = $(DATADIR)/src
PIXDIR = $(DATADIR)/pix
@@ -20,7 +20,7 @@
CONFIGURE_IN = sed -e 's!prefix!$(prefix)!g'
-LANGUAGES = `find locale/ -maxdepth 1 -mindepth 1 -type d -printf "%f "`
+LANGUAGES = `cd locale/ && find . -maxdepth 1 -mindepth 1 -type d | tr -d ./`
help:
@echo Usage:

View File

@ -0,0 +1,9 @@
Decibel audio player is a very fast GTK+ audio player
with an emphasis on being very clean and user friendly.
* Utilizes the GStreamer plugins system
* Lighter footprint than most audio players
* Follows the Gnome Human Interface Guidelines
* Has quite a few plugins of it's own
WWW: http://decibel.silent-blade.org/

View File

@ -0,0 +1,134 @@
@comment $FreeBSD$
bin/decibel-audio-player
bin/decibel-audio-player-remote
share/applications/decibel-audio-player.desktop
share/locale/ar/LC_MESSAGES/decibel-audio-player.mo
share/locale/bg/LC_MESSAGES/decibel-audio-player.mo
share/locale/bs/LC_MESSAGES/decibel-audio-player.mo
share/locale/ca/LC_MESSAGES/decibel-audio-player.mo
share/locale/cs/LC_MESSAGES/decibel-audio-player.mo
share/locale/da/LC_MESSAGES/decibel-audio-player.mo
share/locale/de/LC_MESSAGES/decibel-audio-player.mo
share/locale/el/LC_MESSAGES/decibel-audio-player.mo
share/locale/en_GB/LC_MESSAGES/decibel-audio-player.mo
share/locale/eo/LC_MESSAGES/decibel-audio-player.mo
share/locale/es/LC_MESSAGES/decibel-audio-player.mo
share/locale/fa/LC_MESSAGES/decibel-audio-player.mo
share/locale/fr/LC_MESSAGES/decibel-audio-player.mo
share/locale/ga/LC_MESSAGES/decibel-audio-player.mo
share/locale/he/LC_MESSAGES/decibel-audio-player.mo
share/locale/hr/LC_MESSAGES/decibel-audio-player.mo
share/locale/hu/LC_MESSAGES/decibel-audio-player.mo
share/locale/it/LC_MESSAGES/decibel-audio-player.mo
share/locale/ja/LC_MESSAGES/decibel-audio-player.mo
share/locale/kk/LC_MESSAGES/decibel-audio-player.mo
share/locale/ko/LC_MESSAGES/decibel-audio-player.mo
share/locale/nb/LC_MESSAGES/decibel-audio-player.mo
share/locale/nl/LC_MESSAGES/decibel-audio-player.mo
share/locale/nn/LC_MESSAGES/decibel-audio-player.mo
share/locale/pl/LC_MESSAGES/decibel-audio-player.mo
share/locale/pt/LC_MESSAGES/decibel-audio-player.mo
share/locale/pt_BR/LC_MESSAGES/decibel-audio-player.mo
share/locale/ro/LC_MESSAGES/decibel-audio-player.mo
share/locale/ru/LC_MESSAGES/decibel-audio-player.mo
share/locale/sl/LC_MESSAGES/decibel-audio-player.mo
share/locale/sr/LC_MESSAGES/decibel-audio-player.mo
share/locale/sv/LC_MESSAGES/decibel-audio-player.mo
share/locale/tr/LC_MESSAGES/decibel-audio-player.mo
share/locale/zh_CN/LC_MESSAGES/decibel-audio-player.mo
share/pixmaps/decibel-audio-player.png
%%DATADIR%%/pix/audioscrobbler.png
%%DATADIR%%/pix/cover-gloss.png
%%DATADIR%%/pix/cover-model.png
%%DATADIR%%/pix/cover-none.png
%%DATADIR%%/pix/decibel-audio-player-128.png
%%DATADIR%%/pix/decibel-audio-player-16.png
%%DATADIR%%/pix/decibel-audio-player-24.png
%%DATADIR%%/pix/decibel-audio-player-32.png
%%DATADIR%%/pix/decibel-audio-player-48.png
%%DATADIR%%/pix/decibel-audio-player-64.png
%%DATADIR%%/pix/decibel-audio-player.png
%%DATADIR%%/res/AudioCD.glade
%%DATADIR%%/res/AudioCDMenu.glade
%%DATADIR%%/res/Authentication.glade
%%DATADIR%%/res/Covers.glade
%%DATADIR%%/res/DesktopNotification.glade
%%DATADIR%%/res/Equalizer.glade
%%DATADIR%%/res/FileExplorer.glade
%%DATADIR%%/res/HelpDlg.glade
%%DATADIR%%/res/IMStatus.glade
%%DATADIR%%/res/Library.glade
%%DATADIR%%/res/MainWindow.glade
%%DATADIR%%/res/Preferences.glade
%%DATADIR%%/res/Progress.glade
%%DATADIR%%/res/SelectPath.glade
%%DATADIR%%/res/StatusFile.glade
%%DATADIR%%/res/StatusIconMenu.glade
%%DATADIR%%/res/Twitter.glade
%%DATADIR%%/src/decibel-audio-player.py
%%DATADIR%%/src/gui/__init__.py
%%DATADIR%%/src/gui/about.py
%%DATADIR%%/src/gui/authentication.py
%%DATADIR%%/src/gui/extListview.py
%%DATADIR%%/src/gui/extTreeview.py
%%DATADIR%%/src/gui/fileChooser.py
%%DATADIR%%/src/gui/help.py
%%DATADIR%%/src/gui/preferences.py
%%DATADIR%%/src/gui/progressDlg.py
%%DATADIR%%/src/gui/selectPath.py
%%DATADIR%%/src/gui/window.py
%%DATADIR%%/src/media/__init__.py
%%DATADIR%%/src/media/audioplayer.py
%%DATADIR%%/src/media/format/__init__.py
%%DATADIR%%/src/media/format/asf.py
%%DATADIR%%/src/media/format/flac.py
%%DATADIR%%/src/media/format/monkeysaudio.py
%%DATADIR%%/src/media/format/mp3.py
%%DATADIR%%/src/media/format/mp4.py
%%DATADIR%%/src/media/format/mpc.py
%%DATADIR%%/src/media/format/ogg.py
%%DATADIR%%/src/media/format/wavpack.py
%%DATADIR%%/src/media/playlist.py
%%DATADIR%%/src/media/track/__init__.py
%%DATADIR%%/src/media/track/cdTrack.py
%%DATADIR%%/src/media/track/fileTrack.py
%%DATADIR%%/src/modules/AudioCD.py
%%DATADIR%%/src/modules/AudioScrobbler.py
%%DATADIR%%/src/modules/CommandLine.py
%%DATADIR%%/src/modules/Covers.py
%%DATADIR%%/src/modules/CtrlPanel.py
%%DATADIR%%/src/modules/DBus.py
%%DATADIR%%/src/modules/DesktopNotification.py
%%DATADIR%%/src/modules/Equalizer.py
%%DATADIR%%/src/modules/Explorer.py
%%DATADIR%%/src/modules/FileExplorer.py
%%DATADIR%%/src/modules/GSTPlayer.py
%%DATADIR%%/src/modules/GnomeMediaKeys.py
%%DATADIR%%/src/modules/IMStatus.py
%%DATADIR%%/src/modules/Library.py
%%DATADIR%%/src/modules/ReplayGain.py
%%DATADIR%%/src/modules/StatusFile.py
%%DATADIR%%/src/modules/StatusIcon.py
%%DATADIR%%/src/modules/StatusbarTitlebar.py
%%DATADIR%%/src/modules/TrackPanel.py
%%DATADIR%%/src/modules/Tracklist.py
%%DATADIR%%/src/modules/Twitter.py
%%DATADIR%%/src/modules/Zeitgeist.py
%%DATADIR%%/src/modules/__init__.py
%%DATADIR%%/src/remote.py
%%DATADIR%%/src/tools/__init__.py
%%DATADIR%%/src/tools/consts.py
%%DATADIR%%/src/tools/icons.py
%%DATADIR%%/src/tools/log.py
%%DATADIR%%/src/tools/prefs.py
@dirrm %%DATADIR%%/src/tools
@dirrm %%DATADIR%%/src/modules
@dirrm %%DATADIR%%/src/media/track
@dirrm %%DATADIR%%/src/media/format
@dirrm %%DATADIR%%/src/media
@dirrm %%DATADIR%%/src/gui
@dirrm %%DATADIR%%/src
@dirrm %%DATADIR%%/res
@dirrm %%DATADIR%%/pix
@dirrm %%DATADIR%%
@dirrmtry share/applications