Rename this ports to use the real vendor package name. The advantage of this
is to allow our users' keyword search works and easier for users to file the Bugzilla report when they use our name of ports. Debian, Gentoo, NetBSD and other OSs have the correct package name, but not in our ports tree. My team, FreeBSD GNOME Team, have agreed with it. PR: ports/97985 Repocopy by: marcus
This commit is contained in:
parent
7bea5882ab
commit
211fede2cf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=163651
1
MOVED
1
MOVED
@ -2302,3 +2302,4 @@ devel/p5-Encode-compat|converters/p5-Encode-compat|2006-05-27|Move to better cat
|
||||
accessibility/gnomemag|accessibility/gnome-mag|2006-05-27|Renamed to use real vendor package name
|
||||
accessibility/gnomespeech|accessibility/gnome-speech|2006-05-27|Renamed to use real vendor package name
|
||||
deskutils/gnomeblog|deskutils/gnome-blog|2006-05-27|Renamed to use real vendor package name
|
||||
deskutils/gnomepim|deskutils/gnome-pim|2006-05-27|Renamed to use real vendor package name
|
||||
|
@ -50,7 +50,7 @@
|
||||
SUBDIR += gnochm
|
||||
SUBDIR += gnome-blog
|
||||
SUBDIR += gnome-menu-editor
|
||||
SUBDIR += gnomepim
|
||||
SUBDIR += gnome-pim
|
||||
SUBDIR += gnomeutils2
|
||||
SUBDIR += gnotime
|
||||
SUBDIR += goats
|
||||
|
@ -1,55 +0,0 @@
|
||||
# New ports collection makefile for: gnomepim
|
||||
# Date created: 17 Jan 1999
|
||||
# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gnomepim
|
||||
PORTVERSION= 1.4.9
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= deskutils gnome
|
||||
MASTER_SITES= http://www.jroger.in-berlin.de/gnome-pim/
|
||||
DISTNAME= gnome-pim-${PORTVERSION}
|
||||
DIST_SUBDIR= gnome
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= Gnome pim package
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_BISON= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomeprefix gnomehack gnomelibs libcapplet
|
||||
USE_GETTEXT= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CPPFLAGS= -I${LOCALBASE}/include
|
||||
LIBS= -L${LOCALBASE}/lib
|
||||
.if !defined(WITHOUT_PILOT)
|
||||
CONFIGURE_ARGS= --with-pisock=${LOCALBASE}
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
.endif
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
|
||||
LIBS="${LIBS}"
|
||||
|
||||
pre-extract:
|
||||
@${ECHO_MSG}
|
||||
.if defined(WITHOUT_PILOT)
|
||||
@${ECHO_MSG} "Palm Pilot support disabled. You will not be able to syncronize"
|
||||
@${ECHO_MSG} "your palm with gnomecard and gnomecal."
|
||||
.else
|
||||
@${ECHO_MSG} "You can disable Palm Pilot support by defining WITHOUT_PILOT."
|
||||
.endif
|
||||
@${ECHO_MSG}
|
||||
|
||||
post-patch:
|
||||
.for file in vcc.y vobject.c
|
||||
@${REINPLACE_CMD} -e "s/malloc[.]h/stdlib.h/g" ${WRKSRC}/libversit/${file}
|
||||
.endfor
|
||||
|
||||
pre-install:
|
||||
${MKDIR} ${PREFIX}/share/gnome/help/gnomecard/C \
|
||||
${PREFIX}/share/gnome/help/gnomecard/eu
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,3 +0,0 @@
|
||||
MD5 (gnome/gnome-pim-1.4.9.tar.gz) = 849babfa25e08eb7616d20e826f7fb6d
|
||||
SHA256 (gnome/gnome-pim-1.4.9.tar.gz) = 2176396e7e02d3af8d2974cfce4d8a8c2b68a1a745d4200bbb4adc5b8d19c9ea
|
||||
SIZE (gnome/gnome-pim-1.4.9.tar.gz) = 1467095
|
@ -1,14 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- gncal/Makefile.in.orig Thu Dec 6 11:29:15 2001
|
||||
+++ gncal/Makefile.in Thu Dec 6 11:29:15 2001
|
||||
@@ -138,7 +138,7 @@
|
||||
gnorbadir = $(sysconfdir)/CORBA/servers
|
||||
gnorba_DATA = gnomecal.gnorba
|
||||
|
||||
-help_base = $(datadir)/help/cal
|
||||
+help_base = $(datadir)/help/gnomecal
|
||||
|
||||
bin_PROGRAMS = gnomecal
|
||||
|
@ -1,19 +0,0 @@
|
||||
--- gnomecard/address-conduit.c.orig Tue Mar 14 01:39:27 2000
|
||||
+++ gnomecard/address-conduit.c Fri Jun 2 12:36:08 2000
|
||||
@@ -241,8 +241,16 @@
|
||||
{
|
||||
if (card->rev.prop.used) {
|
||||
time_t syncTime, revTime;
|
||||
+#ifdef __FreeBSD__
|
||||
+ struct tm *tmptm;
|
||||
+#endif
|
||||
syncTime = GET_CONDUIT_DATA(abs)->dbi->pu->lastSyncDate;
|
||||
+#ifdef __FreeBSD__
|
||||
+ tmptm = localtime(&syncTime);
|
||||
+ revTime = mktime(&card->rev.tm) - tmptm->tm_gmtoff;
|
||||
+#else
|
||||
revTime = mktime(&card->rev.tm)-timezone;
|
||||
+#endif
|
||||
LOG("Comparing rev time %lu with sync time %lu",revTime,syncTime);
|
||||
if (revTime > syncTime) return TRUE;
|
||||
}
|
@ -1,10 +0,0 @@
|
||||
--- configure.orig Fri May 31 16:29:25 2002
|
||||
+++ configure Fri May 31 16:30:03 2002
|
||||
@@ -6413,6 +6413,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
@ -1,4 +0,0 @@
|
||||
A GNOME Personal Information Manager (PIM), consisting of the iCal-based
|
||||
GNOME Calendar and the vCard-based GNOME Address Book.
|
||||
|
||||
WWW: http://www.gnome.org/gnome-office/gnome-pim.shtml
|
@ -1,83 +0,0 @@
|
||||
bin/gnomecal
|
||||
bin/gnomecard
|
||||
etc/CORBA/servers/gnomecal.gnorba
|
||||
etc/CORBA/servers/gnomecard.gnorba
|
||||
share/gnome/apps/Applications/gncal.desktop
|
||||
share/gnome/apps/Applications/gnomecard.desktop
|
||||
share/gnome/help/gnomecal/C/c26.html
|
||||
share/gnome/help/gnomecal/C/c61.html
|
||||
share/gnome/help/gnomecal/C/c67.html
|
||||
share/gnome/help/gnomecal/C/images/cal-props.png
|
||||
share/gnome/help/gnomecal/C/images/calday.png
|
||||
share/gnome/help/gnomecal/C/images/calmonth.png
|
||||
share/gnome/help/gnomecal/C/images/calweek.png
|
||||
share/gnome/help/gnomecal/C/images/calyear.png
|
||||
share/gnome/help/gnomecal/C/index.html
|
||||
share/gnome/help/gnomecal/C/topic.dat
|
||||
share/gnome/help/gnomecal/C/x102.html
|
||||
share/gnome/help/gnomecal/C/x164.html
|
||||
share/gnome/help/gnomecal/C/x83.html
|
||||
share/gnome/help/gnomecard/C/c12.html
|
||||
share/gnome/help/gnomecard/C/c16.html
|
||||
share/gnome/help/gnomecard/C/index.html
|
||||
share/gnome/help/gnomecard/C/topic.dat
|
||||
share/gnome/help/gnomecard/C/x36.html
|
||||
share/gnome/help/gnomecard/C/x39.html
|
||||
share/gnome/help/gnomecard/C/x81.html
|
||||
share/gnome/help/gnomecard/C/x84.html
|
||||
share/gnome/idl/GnomeCal.idl
|
||||
share/gnome/idl/gnome-pim.idl
|
||||
share/gnome/mime-info/gnome-pim.keys
|
||||
share/gnome/pixmaps/gnome-calendar-conduit.png
|
||||
share/gnome/pixmaps/gnome-gnomecard.png
|
||||
share/locale/az/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/ca/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/cs/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/cy/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/da/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/de/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/el/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/en_GB/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/es/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/et/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/eu/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/fi/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/fr/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/ga/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/gd/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/gl/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/gv/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/hu/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/it/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/ja/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/ko/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/kw/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/lt/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/nl/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/nn/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/no/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/pl/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/pt/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/ru/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/sk/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/sl/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/sv/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/tr/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/uk/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/vi/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/wa/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/gnome-pim.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/gnome-pim.mo
|
||||
@dirrmtry share/locale/gd/LC_MESSAGES
|
||||
@dirrmtry share/locale/gd
|
||||
@dirrmtry share/locale/gv/LC_MESSAGES
|
||||
@dirrmtry share/locale/gv
|
||||
@dirrmtry share/locale/kw/LC_MESSAGES
|
||||
@dirrmtry share/locale/kw
|
||||
@dirrm share/gnome/help/gnomecard/eu
|
||||
@dirrm share/gnome/help/gnomecard/C
|
||||
@dirrm share/gnome/help/gnomecard
|
||||
@dirrm share/gnome/help/gnomecal/C/images
|
||||
@dirrm share/gnome/help/gnomecal/C
|
||||
@dirrm share/gnome/help/gnomecal
|
Loading…
Reference in New Issue
Block a user