MFH: r476232

- Bump PORTREVISION
- Fix rc script errors
- Fix config file location

Approved by:	ports-secteam (with hat)
This commit is contained in:
Ryan Steinmetz 2018-08-05 21:46:39 +00:00
parent a2176bdc81
commit 20f74ab401
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q3/; revision=476478
6 changed files with 43 additions and 6 deletions

View File

@ -2,6 +2,7 @@
PORTNAME= cloud-init
PORTVERSION= 18.3
PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= http://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -40,7 +41,9 @@ ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= currently depends on dmidecode which is x86-only
post-patch:
@${RM} ${WRKSRC}/sysvinit/freebsd/cloudinit.orig
${REINPLACE_CMD} -e 's|"etc"|"${STAGEDIR}${PREFIX}/etc"|g' ${WRKSRC}/setup.py
${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' ${WRKSRC}/cloudinit/settings.py
@${RM} ${WRKSRC}/sysvinit/freebsd/*.orig
post-build:
@cd ${WRKSRC} && ${MV} sysvinit/freebsd/cloudconfig config/cloud.cfg

View File

@ -0,0 +1,10 @@
--- sysvinit/freebsd/cloudconfig.orig 2018-08-01 15:31:13 UTC
+++ sysvinit/freebsd/cloudconfig
@@ -22,4 +22,7 @@ cloudconfig_start()
}
load_rc_config $name
+
+: ${cloudconfig_enable="NO"}
+
run_rc_command "$1"

View File

@ -0,0 +1,10 @@
--- sysvinit/freebsd/cloudfinal.orig 2018-08-01 15:31:17 UTC
+++ sysvinit/freebsd/cloudfinal
@@ -22,4 +22,7 @@ cloudfinal_start()
}
load_rc_config $name
+
+: ${cloudfinal_enable="NO"}
+
run_rc_command "$1"

View File

@ -1,4 +1,4 @@
--- sysvinit/freebsd/cloudinit.orig 2018-01-01 11:58:33 UTC
--- sysvinit/freebsd/cloudinit.orig 2018-08-01 15:31:22 UTC
+++ sysvinit/freebsd/cloudinit
@@ -1,7 +1,7 @@
#!/bin/sh
@ -9,3 +9,11 @@
# BEFORE: cloudconfig cloudfinal
. /etc/rc.subr
@@ -22,4 +22,7 @@ cloudinit_start()
}
load_rc_config $name
+
+: ${cloudinit_enable="NO"}
+
run_rc_command "$1"

View File

@ -0,0 +1,10 @@
--- sysvinit/freebsd/cloudinitlocal.orig 2018-08-01 15:31:29 UTC
+++ sysvinit/freebsd/cloudinitlocal
@@ -22,4 +22,7 @@ cloudlocal_start()
}
load_rc_config $name
+
+: ${cloudinitlocal_enable="NO"}
+
run_rc_command "$1"

View File

@ -1,4 +0,0 @@
@comment @dir /etc/bash_completion.d
@comment @dir /%%ETCDIR%%/cloud.cfg.d
@comment @dir /%%ETCDIR%%/templates
@comment @dir /%%ETCDIR%%