Interviews 3.1 from Stanford/SGI
This commit is contained in:
parent
858050a5ee
commit
20e03c3e70
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=120
26
x11-toolkits/iv/Makefile
Normal file
26
x11-toolkits/iv/Makefile
Normal file
@ -0,0 +1,26 @@
|
||||
# New ports collection makefile for: iv
|
||||
# Version required: 3.1
|
||||
# Date created: 23.sept.1994
|
||||
# Whom: adam
|
||||
#
|
||||
# $Id: Makefile,v $
|
||||
#
|
||||
|
||||
EXTRACT_SUFFIX= .tar.Z
|
||||
VERSION= 3.1
|
||||
DISTNAME= iv-${VERSION}
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFFIX}
|
||||
WRKSRC= ${WRKDIR}/iv
|
||||
MAKEFILE= makefile
|
||||
|
||||
.if ${DISTNAME} != ${VERSION}
|
||||
pre-fetch:
|
||||
mkdir -p ${DISTDIR}/${DISTNAME}
|
||||
${MAKE} MASTER_SITES=ftp://interviews.stanford.edu/pub/ \
|
||||
DISTDIR=${DISTDIR}/${DISTNAME} DISTNAME=${VERSION} fetch
|
||||
mv ${DISTDIR}/${DISTNAME}/${VERSION}${EXTRACT_SUFFIX} \
|
||||
${DISTDIR}/${DISTFILES}
|
||||
rmdir ${DISTDIR}/${DISTNAME}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
280
x11-toolkits/iv/files/patch-aa
Normal file
280
x11-toolkits/iv/files/patch-aa
Normal file
@ -0,0 +1,280 @@
|
||||
*** src/bin/iclass/dialogs.c Wed Sep 23 09:45:09 1992
|
||||
--- /usr/oports/x11/iv/src/bin/iclass/dialogs.c Tue Apr 26 17:01:39 1994
|
||||
***************
|
||||
*** 45,51 ****
|
||||
#if !defined(AIXV3) && !defined(hpux) && !(defined(sun) && OSMajorVersion >= 5)
|
||||
/* sigh, not all systems have this prototype */
|
||||
extern "C" {
|
||||
! char* getcwd(char*, int);
|
||||
}
|
||||
#endif
|
||||
|
||||
--- 45,51 ----
|
||||
#if !defined(AIXV3) && !defined(hpux) && !(defined(sun) && OSMajorVersion >= 5)
|
||||
/* sigh, not all systems have this prototype */
|
||||
extern "C" {
|
||||
! char* getcwd(char*, unsigned int);
|
||||
}
|
||||
#endif
|
||||
|
||||
*** src/bin/scripts/Imakefile Thu Sep 12 15:01:39 1991
|
||||
--- /usr/oports/x11/iv/src/bin/scripts/Imakefile Tue Apr 26 17:01:52 1994
|
||||
***************
|
||||
*** 11,16 ****
|
||||
--- 11,17 ----
|
||||
|
||||
AllTarget($(PROGRAMS))
|
||||
|
||||
+ CPP = /usr/bin/cpp
|
||||
CppScriptTarget(cpu,cpu.cpp,-DCPU='"'"$(ARCH)"'"',always)
|
||||
CppScriptTarget(ibmkmf,ibmkmf.cpp,-DCONFIGDIRSPEC='$(CONFIGDIRSPEC)',always)
|
||||
CppScriptTarget(ivmkmf,ivmkmf.cpp,-DCONFIGDIRSPEC='$(CONFIGDIRSPEC)',always)
|
||||
*** src/bin/scripts/remind.cpp Wed Jun 3 21:37:00 1992
|
||||
--- /usr/oports/x11/iv/src/bin/scripts/remind.cpp Tue Apr 26 17:01:53 1994
|
||||
***************
|
||||
*** 34,40 ****
|
||||
' > $tmp
|
||||
|
||||
cat $MacrosFile $RemindersFile \
|
||||
! | /lib/cpp \
|
||||
| egrep -f $tmp \
|
||||
| awk '
|
||||
/[0-9][0-9]?:[0-9][0-9]?/ {
|
||||
--- 34,40 ----
|
||||
' > $tmp
|
||||
|
||||
cat $MacrosFile $RemindersFile \
|
||||
! | /usr/bin/cpp \
|
||||
| egrep -f $tmp \
|
||||
| awk '
|
||||
/[0-9][0-9]?:[0-9][0-9]?/ {
|
||||
*** src/config/InterViews/TIFF.def Fri Dec 11 15:33:54 1992
|
||||
--- /usr/oports/x11/iv/src/config/InterViews/TIFF.def Tue Apr 26 17:01:54 1994
|
||||
***************
|
||||
*** 90,95 ****
|
||||
--- 90,100 ----
|
||||
*
|
||||
*/
|
||||
#ifndef TIFFStdCDefines
|
||||
+ #if defined(FreebsdArchitecture)
|
||||
+ #define TIFFStdCDefines \
|
||||
+ -DCOLORIMETRY_SUPPORT -DYCBCR_SUPPORT -DMMAP_SUPPORT \
|
||||
+ -DHAVE_IEEEFP=1 -DUSE_VARARGS=1 -DUSE_PROTOTYPES=1 -DUSE_CONST=1
|
||||
+ #endif
|
||||
#if defined(SGIArchitecture)
|
||||
#define TIFFStdCDefines \
|
||||
-DCOLORIMETRY_SUPPORT -DJPEG_SUPPORT -DYCBCR_SUPPORT -DCMYK_SUPPORT \
|
||||
*** src/config/InterViews/arch.def Fri Dec 11 15:34:52 1992
|
||||
--- /usr/oports/x11/iv/src/config/InterViews/arch.def Tue Apr 26 17:01:55 1994
|
||||
***************
|
||||
*** 385,390 ****
|
||||
--- 385,400 ----
|
||||
#define MacroFile InterViews/iv-convex.cf
|
||||
#endif /* __convex__ */
|
||||
|
||||
+ #ifdef __FreeBSD__
|
||||
+ #undef freebsd
|
||||
+ #undef FREEBSD
|
||||
+ #define FreebsdArchitecture
|
||||
+ #define ArchitectureName FREEBSD
|
||||
+ #define architectureName freebsd
|
||||
+ #define MacroIncludeFile <InterViews/iv-freebsd.cf>
|
||||
+ #define MacroFile InterViews/iv-freebsd.cf
|
||||
+ #endif
|
||||
+
|
||||
#ifndef ArchitectureName
|
||||
XCOMM WARNING: Imakefile not configured; guessing at definitions!!!
|
||||
XCOMM This might mean that BOOTSTRAPCFLAGS was not set when building imake.
|
||||
*** src/config/InterViews/iv-freebsd.cf Wed Dec 31 16:00:00 1969
|
||||
--- /usr/oports/x11/iv/src/config/InterViews/iv-freebsd.cf Thu Jun 16 18:34:08 1994
|
||||
***************
|
||||
*** 0 ****
|
||||
--- 1,9 ----
|
||||
+ #include <freebsd.cf>
|
||||
+ #include <InterViews/xparams.cf>
|
||||
+ #undef CppCmd
|
||||
+ #define CppCmd /usr/bin/cpp
|
||||
+ #undef DependCCFlags
|
||||
+ #define DependCCFlags $(CCDEFINES) $(CCINCLUDES) -I/usr/include/g++
|
||||
+ #undef ExtraCCLdLibs
|
||||
+ #define ExtraCCLdLibs -lg++
|
||||
+ #define SharedCCFlags -fpic
|
||||
*** src/config/InterViews/local.def Tue Nov 24 12:08:51 1992
|
||||
--- /usr/oports/x11/iv/src/config/InterViews/local.def Thu Jun 16 18:34:11 1994
|
||||
***************
|
||||
*** 8,14 ****
|
||||
/*
|
||||
* If you are using gcc/g++, then uncomment the include below.
|
||||
*/
|
||||
! /* #include <InterViews/gcc.def> */
|
||||
|
||||
/*
|
||||
* Default customization of kits.
|
||||
--- 8,19 ----
|
||||
/*
|
||||
* If you are using gcc/g++, then uncomment the include below.
|
||||
*/
|
||||
! #include <InterViews/gcc.def>
|
||||
!
|
||||
! #if defined(FreebsdArchitecture)
|
||||
! #undef HasSunOSSharedLibs
|
||||
! #define HasSunOSSharedLibs YES
|
||||
! #endif
|
||||
|
||||
/*
|
||||
* Default customization of kits.
|
||||
***************
|
||||
*** 33,38 ****
|
||||
--- 38,48 ----
|
||||
#define BuildRPCClasses YES
|
||||
#endif
|
||||
|
||||
+ #if defined (FreebsdArchitecture)
|
||||
+ #undef BuildRPCClasses
|
||||
+ #define BuildRPCClasses NO
|
||||
+ #endif
|
||||
+
|
||||
/*
|
||||
* Delete this definition if your /tmp space is less than five megabytes.
|
||||
*/
|
||||
***************
|
||||
*** 49,55 ****
|
||||
* installed data files.
|
||||
*/
|
||||
#undef InstalledRoot
|
||||
! #define InstalledRoot /interviews
|
||||
|
||||
/*
|
||||
* If the X11 config files are not in /usr/lib/X11/config, the X11
|
||||
--- 59,65 ----
|
||||
* installed data files.
|
||||
*/
|
||||
#undef InstalledRoot
|
||||
! #define InstalledRoot /usr/local/interviews
|
||||
|
||||
/*
|
||||
* If the X11 config files are not in /usr/lib/X11/config, the X11
|
||||
***************
|
||||
*** 60,70 ****
|
||||
* If you have to set XConfigDir, don't forget to override XCONFIGDIR
|
||||
* on the command line when saying "make World" for the first time.
|
||||
*/
|
||||
! /*
|
||||
#undef XConfigDir
|
||||
! #define XConfigDir /usr/X11R5/lib/X11/config
|
||||
#undef XIncDir
|
||||
! #define XIncDir /usr/X11R5/include
|
||||
#undef XLibDir
|
||||
! #define XLibDir /usr/X11R5/lib
|
||||
! */
|
||||
--- 70,80 ----
|
||||
* If you have to set XConfigDir, don't forget to override XCONFIGDIR
|
||||
* on the command line when saying "make World" for the first time.
|
||||
*/
|
||||
!
|
||||
#undef XConfigDir
|
||||
! #define XConfigDir /usr/X386/lib/X11/config
|
||||
#undef XIncDir
|
||||
! #define XIncDir /usr/X386/include
|
||||
#undef XLibDir
|
||||
! #define XLibDir /usr/X386/lib
|
||||
!
|
||||
*** src/config/InterViews/rules.def Thu Sep 24 15:06:33 1992
|
||||
--- /usr/oports/x11/iv/src/config/InterViews/rules.def Thu Jun 16 18:34:12 1994
|
||||
***************
|
||||
*** 399,404 ****
|
||||
--- 399,421 ----
|
||||
/*
|
||||
* Make a shared library.
|
||||
*/
|
||||
+ #if defined(FreebsdArchitecture)
|
||||
+ #define NormalSunOSSharedLibraryTarget(libname,rev,depobjs,ldobjs) @@\
|
||||
+ AOUT = Concat(lib,libname.so.rev) @@\
|
||||
+ SHARED_CCFLAGS = SharedCCFlags @@\
|
||||
+ @@\
|
||||
+ AllTarget(Concat(lib,libname.so.rev)) @@\
|
||||
+ @@\
|
||||
+ Concat(lib,libname.so.rev): depobjs @@\
|
||||
+ @echo "building $@" @@\
|
||||
+ $(RM) $@~ @@\
|
||||
+ $(LD) -o $@~ -Bshareable ldobjs @@\
|
||||
+ $(RM) $@ @@\
|
||||
+ $(MV) $@~ $@ @@\
|
||||
+ @@\
|
||||
+ clean:: @@\
|
||||
+ $(RM) Concat(lib,libname.so.rev)
|
||||
+ #else
|
||||
#ifndef NormalSunOSSharedLibraryTarget
|
||||
#if OSMajorVersion < 5
|
||||
#define NormalSunOSSharedLibraryTarget(libname,rev,depobjs,ldobjs) @@\
|
||||
***************
|
||||
*** 434,439 ****
|
||||
--- 451,457 ----
|
||||
@@\
|
||||
clean:: @@\
|
||||
$(RM) Concat(lib,libname.so.rev)
|
||||
+ #endif
|
||||
#endif
|
||||
#endif
|
||||
|
||||
*** src/lib/IV-X11/xwindow.c Mon Nov 23 12:26:43 1992
|
||||
--- /usr/oports/x11/iv/src/lib/IV-X11/xwindow.c Tue Apr 26 17:03:44 1994
|
||||
***************
|
||||
*** 64,70 ****
|
||||
|
||||
/* no standard place for this */
|
||||
extern "C" {
|
||||
! extern int ioctl(int, int, ...);
|
||||
}
|
||||
|
||||
implementPtrList(WindowVisualList,WindowVisual)
|
||||
--- 64,70 ----
|
||||
|
||||
/* no standard place for this */
|
||||
extern "C" {
|
||||
! extern int ioctl(int, long unsigned int, ...);
|
||||
}
|
||||
|
||||
implementPtrList(WindowVisualList,WindowVisual)
|
||||
*** src/lib/OS/string.c Mon Jul 13 10:54:03 1992
|
||||
--- /usr/oports/x11/iv/src/lib/OS/string.c Thu Jun 16 18:37:30 1994
|
||||
***************
|
||||
*** 31,41 ****
|
||||
--- 31,43 ----
|
||||
*/
|
||||
|
||||
extern "C" {
|
||||
+ #ifndef __FreeBSD__
|
||||
#ifndef tolower
|
||||
extern int tolower(int);
|
||||
#endif
|
||||
#ifndef toupper
|
||||
extern int toupper(int);
|
||||
+ #endif
|
||||
#endif
|
||||
extern long int strtol(const char*, char**, int);
|
||||
extern double strtod(const char*, char**);
|
||||
*** src/lib/TIFF/mkg3states.c Fri Mar 6 11:11:03 1992
|
||||
--- /usr/oports/x11/iv/src/lib/TIFF/mkg3states.c Tue Apr 26 17:03:59 1994
|
||||
***************
|
||||
*** 68,73 ****
|
||||
--- 68,74 ----
|
||||
* END (from the original source)
|
||||
*/
|
||||
#include <stdio.h>
|
||||
+ #define va_dcl /**/
|
||||
#include "prototypes.h"
|
||||
|
||||
#ifndef TRUE
|
||||
*** src/lib/TIFF/prototypes.h Tue Feb 18 18:20:12 1992
|
||||
--- /usr/oports/x11/iv/src/lib/TIFF/prototypes.h Tue Apr 26 17:03:59 1994
|
||||
***************
|
||||
*** 25,30 ****
|
||||
--- 25,31 ----
|
||||
*/
|
||||
|
||||
#if USE_PROTOTYPES
|
||||
+ va_dcl
|
||||
#define DECLARE1(f,t1,a1) f(t1 a1)
|
||||
#define DECLARE2(f,t1,a1,t2,a2) f(t1 a1, t2 a2)
|
||||
#define DECLARE3(f,t1,a1,t2,a2,t3,a3) f(t1 a1, t2 a2, t3 a3)
|
26
x11-toolkits/iv/files/patch-ab
Normal file
26
x11-toolkits/iv/files/patch-ab
Normal file
@ -0,0 +1,26 @@
|
||||
*** makefile.old Sat Sep 24 06:49:19 1994
|
||||
--- makefile Sat Sep 24 05:47:49 1994
|
||||
***************
|
||||
*** 0 ****
|
||||
--- 1,21 ----
|
||||
+ CPU=FREEBSD
|
||||
+
|
||||
+ all: src/Makefile
|
||||
+ @$(MAKE) $(.MAKEFLAGS) -f Makefile 'CPU=$(CPU)'
|
||||
+
|
||||
+ # simple but brutal. Will not install to multiple destinations simultaneously.
|
||||
+ install: Makefile
|
||||
+ @rm -rf installed ${DESTDIR}/usr/local/interviews
|
||||
+ @mkdir -p ${DESTDIR}/usr/local/interviews
|
||||
+ @ln -s ${DESTDIR}/usr/local/interviews installed
|
||||
+ @$(MAKE) $(.MAKEFLAGS) -f Makefile 'CPU=$(CPU)' $@
|
||||
+
|
||||
+ src/Makefile: Makefile
|
||||
+ @$(MAKE) Makefiles
|
||||
+
|
||||
+ Makefile:
|
||||
+ imake -T "InterViews/template" -I./src/config \
|
||||
+ -I/usr/X386/lib/X11/config -DTOPDIR=. -DCURDIR=.
|
||||
+
|
||||
+ .DEFAULT: src/Makefile
|
||||
+ @$(MAKE) $(.MAKEFLAGS) -f Makefile 'CPU=$(CPU)' $@
|
1
x11-toolkits/iv/pkg-comment
Normal file
1
x11-toolkits/iv/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
InterViews 3.1 from Stanford University and Silicon Graphics.
|
2
x11-toolkits/iv/pkg-plist
Normal file
2
x11-toolkits/iv/pkg-plist
Normal file
@ -0,0 +1,2 @@
|
||||
@cwd /usr/local
|
||||
interviews
|
22
x11-toolkits/iv/scripts/configure
vendored
Normal file
22
x11-toolkits/iv/scripts/configure
vendored
Normal file
@ -0,0 +1,22 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
if [ $# -ne 3 ]; then
|
||||
echo "This script should only be run by the Makefile."
|
||||
exit 1
|
||||
fi
|
||||
|
||||
# First arg is top level ports directory, second is current directory,
|
||||
# third is the directory containing the dist.
|
||||
#
|
||||
PDIR=$1
|
||||
CDIR=$2
|
||||
WDIR=$3
|
||||
|
||||
touch ${WDIR}/src/config/freebsd.cf
|
||||
find ${WDIR} -name Makefile -print | xargs rm
|
||||
xpath=`/usr/bin/which imake 2>/dev/null`
|
||||
if [ -n $xpath ]; then
|
||||
xpath=`echo $xpath | sed 's;/bin/imake$;;'`
|
||||
sed "s;/usr/X386;$xpath;" ${WDIR}/makefile >${WDIR}/makefile.foo
|
||||
mv ${WDIR}/makefile.foo ${WDIR}/makefile
|
||||
fi
|
Loading…
Reference in New Issue
Block a user