add sircd
The Smart IRC Daemon
This commit is contained in:
parent
63a15f2970
commit
208b487577
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46791
@ -39,6 +39,7 @@
|
|||||||
SUBDIR += scrollz-doc
|
SUBDIR += scrollz-doc
|
||||||
SUBDIR += sic
|
SUBDIR += sic
|
||||||
SUBDIR += sirc
|
SUBDIR += sirc
|
||||||
|
SUBDIR += sircd
|
||||||
SUBDIR += slirc
|
SUBDIR += slirc
|
||||||
SUBDIR += tirc
|
SUBDIR += tirc
|
||||||
SUBDIR += tircproxy
|
SUBDIR += tircproxy
|
||||||
|
38
irc/sircd/Makefile
Normal file
38
irc/sircd/Makefile
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
# ex:ts=8
|
||||||
|
# New ports collection makefile for: sircd
|
||||||
|
# Date created: Jun 15, 2001
|
||||||
|
# Whom: ijliao
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
PORTNAME= sircd
|
||||||
|
PORTVERSION= 0.2.5a
|
||||||
|
CATEGORIES= irc
|
||||||
|
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||||
|
http://www.sircd.org/files/
|
||||||
|
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||||
|
DISTNAME= ${PORTNAME}-${PORTVERSION:S/a/-alpha/}
|
||||||
|
|
||||||
|
MAINTAINER= ports@FreeBSD.org
|
||||||
|
|
||||||
|
USE_OPENSSL= yes
|
||||||
|
WRKSRC= ${WRKDIR}/${DISTNAME}/server
|
||||||
|
USE_GMAKE= yes
|
||||||
|
ALL_TARGET= release
|
||||||
|
INSTALLS_SHLIB= yes
|
||||||
|
|
||||||
|
post-patch:
|
||||||
|
@${PERL} -pi -e "s,-lssl,-lssl -lcrypto,g" ${WRKSRC}/sircd/Makefile
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/sircd/sircd ${PREFIX}/sbin
|
||||||
|
${INSTALL} ${WRKSRC}/../syscore/libsyscore.so ${PREFIX}/lib
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/sircd/sircd.conf ${PREFIX}/etc/sircd.conf.sample
|
||||||
|
${MKDIR} ${PREFIX}/share/sircd/plugins
|
||||||
|
.for file in mod_base.so mod_oper.so
|
||||||
|
${INSTALL} ${WRKSRC}/plugins/${file} ${PREFIX}/share/sircd/plugins
|
||||||
|
.endfor
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/sircd/motd.txt ${PREFIX}/share/sircd
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
1
irc/sircd/distinfo
Normal file
1
irc/sircd/distinfo
Normal file
@ -0,0 +1 @@
|
|||||||
|
MD5 (sircd-0.2.5-alpha.tar.gz) = 001aef9c4e700a240a503f01d351b746
|
11
irc/sircd/files/patch-sircd::src::srv_commands.c
Normal file
11
irc/sircd/files/patch-sircd::src::srv_commands.c
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- sircd/src/srv_commands.c.orig Fri Jun 15 16:10:36 2001
|
||||||
|
+++ sircd/src/srv_commands.c Fri Jun 15 16:11:25 2001
|
||||||
|
@@ -11,6 +11,8 @@
|
||||||
|
*/
|
||||||
|
|
||||||
|
#include <srv_include.h>
|
||||||
|
+#include <sys/types.h>
|
||||||
|
+#include <sys/stat.h>
|
||||||
|
|
||||||
|
#ifdef WIN32
|
||||||
|
#pragma warning(disable : 4090) // const
|
1
irc/sircd/pkg-comment
Normal file
1
irc/sircd/pkg-comment
Normal file
@ -0,0 +1 @@
|
|||||||
|
The Smart IRC Daemon
|
3
irc/sircd/pkg-descr
Normal file
3
irc/sircd/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
The Smart IRC Daemon
|
||||||
|
|
||||||
|
WWW: http://www.sircd.org/
|
8
irc/sircd/pkg-plist
Normal file
8
irc/sircd/pkg-plist
Normal file
@ -0,0 +1,8 @@
|
|||||||
|
sbin/sircd
|
||||||
|
lib/libsyscore.so
|
||||||
|
etc/sircd.conf.sample
|
||||||
|
share/sircd/motd.txt
|
||||||
|
share/sircd/plugins/mod_base.so
|
||||||
|
share/sircd/plugins/mod_oper.so
|
||||||
|
@dirrm share/sircd/plugins
|
||||||
|
@dirrm share/sircd
|
Loading…
Reference in New Issue
Block a user