security/pssh: update to 2.3.4
ChangeLog https://github.com/lilydjwg/pssh/blob/master/ChangeLog * switch to the most viable fork * Set MAINTAINER PR: 248208 Submitted by: timp87@gmail.com
This commit is contained in:
parent
80fef8c45f
commit
2075313502
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=544341
@ -1,21 +1,22 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pssh
|
||||
PORTVERSION= 2.3.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 2.3.4
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= security net sysutils
|
||||
MASTER_SITES= CHEESESHOP
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Parallel versions of the openssh tools
|
||||
MAINTAINER= timp87@gmail.com
|
||||
COMMENT= Parallel version of OpenSSH and related tools
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
RUN_DEPENDS= rsync:net/rsync
|
||||
|
||||
NO_ARCH= yes
|
||||
USES= python
|
||||
USE_PYTHON= autoplist distutils concurrent optsuffix
|
||||
USES= python:3.5+
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= lilydjwg
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1478198607
|
||||
SHA256 (pssh-2.3.1.tar.gz) = 539f8d8363b722712310f3296f189d1ae8c690898eca93627fc89a9cb311f6b4
|
||||
SIZE (pssh-2.3.1.tar.gz) = 23427
|
||||
TIMESTAMP = 1595513049
|
||||
SHA256 (lilydjwg-pssh-v2.3.4_GH0.tar.gz) = 0f139e8c4d59f0ed9379ce96660d8ce4e008020b22524466d9c23eb9830c841c
|
||||
SIZE (lilydjwg-pssh-v2.3.4_GH0.tar.gz) = 51859
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- psshlib/cli.py.orig
|
||||
+++ psshlib/cli.py
|
||||
@@ -6,7 +6,7 @@
|
||||
import shlex
|
||||
import sys
|
||||
import textwrap
|
||||
-import version
|
||||
+from psshlib import version
|
||||
|
||||
_DEFAULT_PARALLELISM = 32
|
||||
_DEFAULT_TIMEOUT = 0 # "infinity" by default
|
@ -1,18 +0,0 @@
|
||||
--- psshlib/manager.py.orig
|
||||
+++ psshlib/manager.py
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
from errno import EINTR
|
||||
import os
|
||||
+import fcntl
|
||||
import select
|
||||
import signal
|
||||
import sys
|
||||
@@ -209,6 +210,7 @@
|
||||
|
||||
# Setup the wakeup file descriptor to avoid hanging on lost signals.
|
||||
wakeup_readfd, wakeup_writefd = os.pipe()
|
||||
+ fcntl.fcntl(wakeup_writefd, fcntl.F_SETFL, os.O_NONBLOCK)
|
||||
self.register_read(wakeup_readfd, self.wakeup_handler)
|
||||
# TODO: remove test when we stop supporting Python <2.5
|
||||
if hasattr(signal, 'set_wakeup_fd'):
|
@ -1,6 +1,6 @@
|
||||
--- psshlib/psshutil.py.orig
|
||||
--- psshlib/psshutil.py.orig 2020-04-05 06:12:36 UTC
|
||||
+++ psshlib/psshutil.py
|
||||
@@ -27,7 +27,10 @@
|
||||
@@ -28,7 +28,10 @@ def read_host_file(path, host_glob, default_user=None,
|
||||
Returns a list of (host, port, user) triples.
|
||||
"""
|
||||
lines = []
|
||||
|
@ -1,5 +1,4 @@
|
||||
This package provides parallel versions of the openssh tools. Included
|
||||
in the distribution:
|
||||
PSSH provides parallel versions of OpenSSH and related tools, including:
|
||||
|
||||
- Parallel ssh (pssh)
|
||||
- Parallel scp (pscp)
|
||||
@ -7,7 +6,14 @@ in the distribution:
|
||||
- Parallel nuke (pnuke)
|
||||
- Parallel slurp (pslurp)
|
||||
|
||||
What are these tools good for? Mainly for controlling large collections
|
||||
of nodes in the wide-area.
|
||||
The project includes psshlib which can be used within custom applications.
|
||||
The source code is written in Python 3.5+.
|
||||
|
||||
WWW: https://pypi.org/project/pssh/
|
||||
The original PSSH project was written and maintained by Brent N. Chun.
|
||||
Due to his busy schedule, Brent handed over maintenance to Andrew McNabb
|
||||
in October 2009. PSSH hasn't got any updates since 2014.
|
||||
|
||||
This package is a fork by 'lilydjwg' github user.
|
||||
It seems the most live fork that has been accumulating fixes past years.
|
||||
|
||||
WWW: https://github.com/lilydjwg/pssh
|
||||
|
Loading…
Reference in New Issue
Block a user