Update to version 0.7.1

PR:		ports/78738
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2005-03-13 09:29:48 +00:00
parent 75cc6c26d5
commit 20489eb044
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=131061
4 changed files with 64 additions and 64 deletions

View File

@ -9,7 +9,7 @@
#
PORTNAME= filtermail
PORTVERSION= 0.7
PORTVERSION= 0.7.1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://home.in.tum.de/baueran/%SUBDIR%/
@ -41,12 +41,12 @@ MAN5= filtermailex.5 filtermailrc.5
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
.if !defined(WITHOUT_NLS)
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
post-extract:

View File

@ -1,2 +1,2 @@
MD5 (mailfilter-0.7.tar.gz) = 015246adff2cf664398d6790cd50e8b7
SIZE (mailfilter-0.7.tar.gz) = 458864
MD5 (mailfilter-0.7.1.tar.gz) = be6d603081086c8780601cb0c8e19f67
SIZE (mailfilter-0.7.1.tar.gz) = 506799

View File

@ -1,5 +1,5 @@
--- src/Makefile.in.orig Sun Feb 15 02:36:23 2004
+++ src/Makefile.in Fri Mar 19 22:58:12 2004
--- src/Makefile.in.orig Sat Nov 27 22:29:44 2004
+++ src/Makefile.in Mon Mar 7 22:54:36 2005
@@ -198,7 +198,6 @@
i18n.hh \
rcfile.ll rcfile.hh \
@ -8,7 +8,7 @@
filtermail.hh filtermail.cc \
header.hh header.cc \
weeder.hh weeder.cc \
@@ -231,7 +230,7 @@
@@ -232,7 +231,7 @@
PROGRAMS = $(bin_PROGRAMS)
am_filtermail_OBJECTS = md5c.$(OBJEXT) rcfile.$(OBJEXT) rfc822.$(OBJEXT) \
@ -17,24 +17,24 @@
header.$(OBJEXT) weeder.$(OBJEXT) preferences.$(OBJEXT) \
feedback.$(OBJEXT) filter.$(OBJEXT) score.$(OBJEXT) \
account.$(OBJEXT) protocol.$(OBJEXT) socket.$(OBJEXT) \
@@ -246,7 +245,6 @@
@@ -247,7 +246,6 @@
am__depfiles_maybe = depfiles
@AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/account.Po ./$(DEPDIR)/apop.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/feedback.Po ./$(DEPDIR)/filter.Po \
-@AMDEP_TRUE@ ./$(DEPDIR)/getopt.Po ./$(DEPDIR)/getopt1.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/header.Po ./$(DEPDIR)/filtermail.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/md5c.Po ./$(DEPDIR)/pop3.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/preferences.Po ./$(DEPDIR)/protocol.Po \
@@ -315,8 +313,6 @@
@AMDEP_TRUE@ ./$(DEPDIR)/header.Po ./$(DEPDIR)/imap.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/filtermail.Po ./$(DEPDIR)/md5c.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/pop3.Po ./$(DEPDIR)/preferences.Po \
@@ -317,8 +315,6 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/apop.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/feedback.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/filter.Po@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/getopt.Po@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/getopt1.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/header.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/imap.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/filtermail.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/md5c.Po@am__quote@
@@ -568,8 +564,8 @@
@@ -571,8 +567,8 @@
rcparser.hh: y.tab.c
y.tab.c: rcfile.yy
$(YACC) -p rc $(YFLAGS) -o$@ $^; \
@ -45,12 +45,12 @@
$(CXXCOMPILE) -c rcparser.cc; \
touch y.tab.c
@@ -580,7 +576,7 @@
@@ -583,7 +579,7 @@
rfc822parser.hh: rfc822parser.cc
rfc822parser.cc: rfc822.yy
$(YACC) $(YFLAGS) -p rfc -o$@ $^; \
- mv --force y.tab.h rcparser.hh; \
+ mv -f y.tab.h rcparser.hh; \
$(CXXCOMPILE) -c rfc822parser.cc; \
$(YACC) $(YFLAGS) -p rfc -o$@ $^; \
- mv --force y.tab.h rfc822parser.hh;\
+ mv -f y.tab.h rfc822parser.hh;\
$(CXXCOMPILE) -c rfc822parser.cc; \
touch y.tab.c

View File

@ -1,7 +1,7 @@
--- src/preferences.cc.orig Sun Jan 25 21:56:46 2004
+++ src/preferences.cc Fri Mar 19 23:16:27 2004
@@ -34,7 +34,7 @@
#include "rcfile.hh"
--- src/preferences.cc.orig Sat Nov 20 23:39:15 2004
+++ src/preferences.cc Mon Mar 7 22:58:20 2005
@@ -35,7 +35,7 @@
extern "C"
{
-#include <wordexp.h>
@ -9,43 +9,43 @@
#include <sys/types.h>
#include <regex.h>
}
@@ -230,15 +230,15 @@
void Preferences :: set_headers_file (const char* name)
{
// Expand the given file name.
- wordexp_t result;
- if (wordexp (name, &result, 0) == 0)
- headers_file_name = result.we_wordv[0];
+ glob_t result;
+ if (glob (name, 0, NULL, &result) == 0)
+ headers_file_name = result.gl_pathv[0];
else
{
ERROR_MSG(_("Invalid file name: ") + (string)name + ".");
exit (-1);
}
- wordfree (&result);
+ globfree (&result);
}
@@ -233,15 +233,15 @@
void Preferences :: set_headers_file (const char* name)
{
// Expand the given file name.
- wordexp_t result;
- if (wordexp (name, &result, 0) == 0)
- headers_file_name = result.we_wordv[0];
+ glob_t result;
+ if (glob (name, 0, NULL, &result) == 0)
+ headers_file_name = result.gl_pathv[0];
else
{
ERROR_MSG(_("Invalid file name: ") + (string)name + ".");
exit (-1);
}
- wordfree (&result);
+ globfree (&result);
}
string Preferences :: headers_file (void)
@@ -256,15 +256,15 @@
// command line.
if (log_file_name.length () == 0)
{
- wordexp_t result;
- if (wordexp (name, &result, 0) == 0)
- log_file_name = result.we_wordv[0];
+ glob_t result;
+ if (glob (name, 0, NULL, &result) == 0)
+ log_file_name = result.gl_pathv[0];
else
{
ERROR_MSG(_("Invalid file name: ") + (string)name + ".");
exit (-1);
}
- wordfree (&result);
+ globfree (&result);
}
}
string Preferences :: headers_file (void)
@@ -259,15 +259,15 @@
// command line.
if (log_file_name.length () == 0)
{
- wordexp_t result;
- if (wordexp (name, &result, 0) == 0)
- log_file_name = result.we_wordv[0];
+ glob_t result;
+ if (glob (name, 0, NULL, &result) == 0)
+ log_file_name = result.gl_pathv[0];
else
{
ERROR_MSG(_("Invalid file name: ") + (string)name + ".");
exit (-1);
}
- wordfree (&result);
+ globfree (&result);
}
}