Update to 1.4.0rc2 and kill off the last vestages of the 1.2 series as well
as my former interest in pmk(1) as an auto* replacement.
This commit is contained in:
parent
c799407233
commit
2025c30c8f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=156567
@ -6,32 +6,24 @@
|
||||
#
|
||||
|
||||
PORTNAME= libmemcache
|
||||
PORTVERSION= 1.2.3
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.4.0.rc2
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://people.FreeBSD.org/~seanc/ports/libmemcache/
|
||||
MASTER_SITES= http://people.FreeBSD.org/~seanc/libmemcache/
|
||||
|
||||
MAINTAINER= seanc@FreeBSD.org
|
||||
COMMENT= The C library for accessing a memcache cluster
|
||||
|
||||
BUILD_DEPENDS= pmk:${PORTSDIR}/devel/pmk
|
||||
|
||||
USE_BZIP2= yes
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
NO_FILTER_SHLIBS= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
OPTIONS= DEBUG "Build with debugging turned on" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_DEBUG)
|
||||
PMKARGS= -e debug
|
||||
CONFIGURE_ARGS+=--enable-debug
|
||||
.endif
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC}; ${LOCALBASE}/bin/pmk ${PMKARGS}
|
||||
|
||||
post-install:
|
||||
# only files named lib*.so.[0-9] enter ld-elf.so.hints
|
||||
${LN} -sf ${PREFIX}/lib/libmemcache.so.1.2 ${PREFIX}/lib/libmemcache.so.1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (libmemcache-1.2.3.tar.bz2) = 018c4dd66b42c9a8605b2d9e08b910b4
|
||||
SHA256 (libmemcache-1.2.3.tar.bz2) = 52fe37d47d44ac6ed4d7cb64e8ed1cbf6492e6c83293c43b69c8574a379bf41c
|
||||
SIZE (libmemcache-1.2.3.tar.bz2) = 40321
|
||||
MD5 (libmemcache-1.4.0.rc2.tar.bz2) = 402c957cd71538c07a263542eeb513d1
|
||||
SHA256 (libmemcache-1.4.0.rc2.tar.bz2) = f496d41092c697384a7180720689da6a85d7c6ea2283eca69c8aaff2b58bebbf
|
||||
SIZE (libmemcache-1.4.0.rc2.tar.bz2) = 301136
|
||||
|
@ -1,82 +0,0 @@
|
||||
--- pmkfile.orig Wed Apr 27 14:54:44 2005
|
||||
+++ pmkfile Wed Apr 27 11:35:47 2005
|
||||
@@ -16,13 +16,13 @@
|
||||
|
||||
IF(!debug) {
|
||||
DEFINE {
|
||||
- CFLAGS = "-std=c99 -pipe -O3"
|
||||
+ CFLAGS = "-pipe -O3"
|
||||
}
|
||||
}
|
||||
|
||||
IF(debug) {
|
||||
DEFINE {
|
||||
- CFLAGS = "-std=c99 -g -Wall -Wunused -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wsign-compare -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wmissing-noreturn -Wformat -Wpacked -Wdeprecated-declarations -Wredundant-decls -Wnested-externs -Winline -Wdisabled-optimization -pipe -pedantic"
|
||||
+ CFLAGS = "-g -Wall -Wunused -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wsign-compare -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wmissing-noreturn -Wformat -Wpacked -Wdeprecated-declarations -Wredundant-decls -Wnested-externs -Winline -Wdisabled-optimization -pipe -pedantic"
|
||||
}
|
||||
}
|
||||
|
||||
@@ -121,24 +121,6 @@
|
||||
NAME="unistd.h"
|
||||
}
|
||||
|
||||
-CHECK_HEADER(include_socket) {
|
||||
- REQUIRED=TRUE
|
||||
- FUNCTION="socket"
|
||||
- NAME="sys/socket.h"
|
||||
-}
|
||||
-
|
||||
-CHECK_HEADER(include_setsockopt) {
|
||||
- REQUIRED=TRUE
|
||||
- FUNCTION="setsockopt"
|
||||
- NAME="sys/socket.h"
|
||||
-}
|
||||
-
|
||||
-CHECK_HEADER(include_connect) {
|
||||
- REQUIRED=TRUE
|
||||
- FUNCTION="setsockopt"
|
||||
- NAME="sys/socket.h"
|
||||
-}
|
||||
-
|
||||
CHECK_HEADER(include_freeaddrinfo) {
|
||||
REQUIRED=TRUE
|
||||
FUNCTION="freeaddrinfo"
|
||||
@@ -170,12 +152,6 @@
|
||||
NAME="ctype.h"
|
||||
}
|
||||
|
||||
-CHECK_HEADER(include_readv) {
|
||||
- REQUIRED=TRUE
|
||||
- FUNCTION="readv"
|
||||
- NAME="sys/uio.h"
|
||||
-}
|
||||
-
|
||||
CHECK_HEADER(include_errno) {
|
||||
REQUIRED=FALSE
|
||||
FUNCTION="errno"
|
||||
@@ -194,12 +170,6 @@
|
||||
NAME="unistd.h"
|
||||
}
|
||||
|
||||
-CHECK_HEADER(include_writev) {
|
||||
- REQUIRED=TRUE
|
||||
- FUNCTION="writev"
|
||||
- NAME="sys/uio.h"
|
||||
-}
|
||||
-
|
||||
CHECK_HEADER(include_snprintf) {
|
||||
REQUIRED=TRUE
|
||||
FUNCTION="snprintf"
|
||||
@@ -281,12 +251,6 @@
|
||||
REQUIRED=TRUE
|
||||
FUNCTION="bzero"
|
||||
NAME="strings.h"
|
||||
-}
|
||||
-
|
||||
-CHECK_HEADER(include_select) {
|
||||
- REQUIRED=TRUE
|
||||
- FUNCTIOn="select"
|
||||
- NAME="sys/select.h"
|
||||
}
|
||||
|
||||
CHECK_HEADER(include_strdup) {
|
@ -1,5 +1,7 @@
|
||||
include/memcache/_buffer.h
|
||||
include/memcache/buffer.h
|
||||
@dirrm include/memcache
|
||||
include/memcache.h
|
||||
lib/libmemcache.so.1.2
|
||||
lib/libmemcache.so.1
|
||||
lib/libmemcache.so.4
|
||||
lib/libmemcache.so
|
||||
lib/libmemcache.a
|
||||
|
Loading…
Reference in New Issue
Block a user