New ports security/libscep and security/p5-Crypt-LibSCEP
libscep is a client side implementation of the Simple Certificate Enrollment Protocol (SCEP) library. p5-Crypt-LibSCEP is a perl module using the libscep library to generate and read messages for the Simple Certificate Enrollment Protocol (SCEP) in perl applications. PR: 241195 Submitted by: Sergei Vyshenski <svysh.fbsd@gmail.com>
This commit is contained in:
parent
e14f1a651e
commit
2018f7d460
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=514406
@ -311,6 +311,7 @@
|
||||
SUBDIR += libpwstor
|
||||
SUBDIR += libressl
|
||||
SUBDIR += libressl-devel
|
||||
SUBDIR += libscep
|
||||
SUBDIR += libscrypt
|
||||
SUBDIR += libsecret
|
||||
SUBDIR += libsectok
|
||||
@ -542,6 +543,7 @@
|
||||
SUBDIR += p5-Crypt-Juniper
|
||||
SUBDIR += p5-Crypt-Khazad
|
||||
SUBDIR += p5-Crypt-LE
|
||||
SUBDIR += p5-Crypt-LibSCEP
|
||||
SUBDIR += p5-Crypt-License
|
||||
SUBDIR += p5-Crypt-Lite
|
||||
SUBDIR += p5-Crypt-Loki97
|
||||
|
43
security/libscep/Makefile
Normal file
43
security/libscep/Makefile
Normal file
@ -0,0 +1,43 @@
|
||||
# Created by: Sergei Vyshenski <svysh.fbsd@gmail.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libscep
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTVERSION= 0.06
|
||||
CATEGORIES= security
|
||||
|
||||
MAINTAINER= svysh.fbsd@gmail.com
|
||||
COMMENT= Client side SCEP library w/o clients
|
||||
|
||||
LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/README.md
|
||||
|
||||
BUILD_DEPENDS= check>=0.12.0:devel/check \
|
||||
curl>=7.64:ftp/curl \
|
||||
uriparser>=0.9.1:net/uriparser \
|
||||
${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
|
||||
RUN_DEPENDS= check>=0.12.0:devel/check \
|
||||
curl>=7.64:ftp/curl \
|
||||
uriparser>=0.9.1:net/uriparser
|
||||
|
||||
USES= cmake:noninja gmake ssl pkgconfig libtool python:build
|
||||
USE_LDCONFIG= yes
|
||||
USE_GCC= yes
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= openxpki
|
||||
|
||||
CMAKE_OFF= BUILD_CLI
|
||||
CMAKE_ARGS+= -DCHECK_INSTALL_DIR=${PREFIX}
|
||||
|
||||
PLIST_FILES= include/scep.h \
|
||||
lib/libscep.so \
|
||||
man/man1/libscep.1.gz
|
||||
|
||||
post-build:
|
||||
(cd ${WRKSRC}/docs;\
|
||||
BUILDDIR=${BUILD_WRKSRC} SPHINXBUILD=sphinx-build-${PYTHON_VER} ${GMAKE} -e man)
|
||||
|
||||
post-install:
|
||||
${INSTALL_MAN} ${BUILD_WRKSRC}/man/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
|
||||
|
||||
.include <bsd.port.mk>
|
3
security/libscep/distinfo
Normal file
3
security/libscep/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1562000984
|
||||
SHA256 (openxpki-libscep-v0.06_GH0.tar.gz) = 5c20cd23f4beb2d0c565831c509253b42a87d22a194e1bf627bf6ba09abd676b
|
||||
SIZE (openxpki-libscep-v0.06_GH0.tar.gz) = 149550
|
20
security/libscep/files/patch-cmake_FindCheck.cmake
Normal file
20
security/libscep/files/patch-cmake_FindCheck.cmake
Normal file
@ -0,0 +1,20 @@
|
||||
--- cmake/FindCheck.cmake.orig 2019-05-31 11:07:23 UTC
|
||||
+++ cmake/FindCheck.cmake
|
||||
@@ -23,7 +23,7 @@ INCLUDE( FindPkgConfig )
|
||||
PKG_SEARCH_MODULE( CHECK check )
|
||||
|
||||
# Look for CHECK include dir and libraries
|
||||
-IF( NOT CHECK_FOUND )
|
||||
+#IF( NOT CHECK_FOUND )
|
||||
IF ( CHECK_INSTALL_DIR )
|
||||
MESSAGE ( STATUS "Using override CHECK_INSTALL_DIR to find check" )
|
||||
SET ( CHECK_INCLUDE_DIR "${CHECK_INSTALL_DIR}/include" )
|
||||
@@ -50,7 +50,7 @@ IF( NOT CHECK_FOUND )
|
||||
ENDIF ( NOT Check_FIND_QUIETLY )
|
||||
ENDIF ( Check_FIND_REQUIRED )
|
||||
ENDIF ( CHECK_INCLUDE_DIR AND CHECK_LIBRARIES )
|
||||
-ENDIF( NOT CHECK_FOUND )
|
||||
+#ENDIF( NOT CHECK_FOUND )
|
||||
|
||||
# Hide advanced variables from CMake GUIs
|
||||
MARK_AS_ADVANCED( CHECK_INCLUDE_DIR CHECK_LIBRARIES )
|
6
security/libscep/pkg-descr
Normal file
6
security/libscep/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
A Client Side Simple Certificate Enrollment Protocol (SCEP) Library.
|
||||
libscep implements the SCEP protocol as a C library. The library
|
||||
gets initialized, then one or multiple operations can be executed
|
||||
and then it gets destroyed again.
|
||||
|
||||
WWW: https://github.com/openxpki/libscep
|
34
security/p5-Crypt-LibSCEP/Makefile
Normal file
34
security/p5-Crypt-LibSCEP/Makefile
Normal file
@ -0,0 +1,34 @@
|
||||
# Created by: Sergei Vyshenski <svysh.fbsd@gmail.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= Crypt-LibSCEP
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTVERSION= 0.06
|
||||
CATEGORIES= security perl5
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= svysh.fbsd@gmail.com
|
||||
COMMENT= Easy-to-use interface between LibSCEP and Perl programs
|
||||
|
||||
LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/Readme.md
|
||||
|
||||
BUILD_DEPENDS= libscep>=0.06:security/libscep
|
||||
RUN_DEPENDS= libscep>=0.06:security/libscep
|
||||
|
||||
USES= gmake perl5 ssl
|
||||
USE_PERL5= configure
|
||||
USE_GCC= yes
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= openxpki
|
||||
GH_PROJECT= libscep
|
||||
|
||||
WRKSRC_SUBDIR= src/clients/perl/${PORTNAME}
|
||||
DOTNAME= ${PORTNAME:S|-|.|g}
|
||||
NAME1= ${DOTNAME:R}
|
||||
NAME2= ${DOTNAME:E}
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/${NAME1}/${NAME2}/${NAME2}.so
|
||||
|
||||
.include <bsd.port.mk>
|
3
security/p5-Crypt-LibSCEP/distinfo
Normal file
3
security/p5-Crypt-LibSCEP/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1570458266
|
||||
SHA256 (openxpki-libscep-v0.06_GH0.tar.gz) = 5c20cd23f4beb2d0c565831c509253b42a87d22a194e1bf627bf6ba09abd676b
|
||||
SIZE (openxpki-libscep-v0.06_GH0.tar.gz) = 149550
|
6
security/p5-Crypt-LibSCEP/pkg-descr
Normal file
6
security/p5-Crypt-LibSCEP/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
Crypt::LibSCEP implements an easy-to-use interface between LibSCEP and Perl
|
||||
programs. Its goal is to provide Perl programs with the capability of
|
||||
generating and reading messages for the Simple Certificate Enrollment Protocol
|
||||
(SCEP).
|
||||
|
||||
WWW: https://github.com/openxpki/libscep/src/clients/perl/Crypt-LibSCEP/
|
3
security/p5-Crypt-LibSCEP/pkg-plist
Normal file
3
security/p5-Crypt-LibSCEP/pkg-plist
Normal file
@ -0,0 +1,3 @@
|
||||
%%SITE_ARCH%%/Crypt/LibSCEP.pm
|
||||
%%SITE_ARCH%%/auto/Crypt/LibSCEP/LibSCEP.so
|
||||
%%PERL5_MAN3%%/Crypt::LibSCEP.3.gz
|
Loading…
Reference in New Issue
Block a user