CLeanup u-boot-tools

- Do not overwrite do-build, it is not necessary
- Ensure the env variables are respected during configure phase
- Now that we use the regular do-build kernel we can pass gmake variables via
  arguments which allows to overwrites predefine ones without custom patches
- Force verbose mode when building to see what command line is invoke, in in
  particular which compiler is called
- Overwrite NOSTDINC_FLAGS because on freebsd we do actually want to use our
  regular standard include files
- Register the dependency on libssl/libcrypto

Approved by:	manu
Differential Revision:	https://reviews.freebsd.org/D13543
This commit is contained in:
Baptiste Daroussin 2017-12-19 15:08:41 +00:00
parent 5d36ee1c36
commit 2004ea81d9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=456722
3 changed files with 7 additions and 36 deletions

View File

@ -12,17 +12,19 @@ COMMENT= U-boot related tools
LICENSE= GPLv2
USES= tar:bzip2 gmake python:2.7,build
USES= tar:bzip2 gmake python:2.7,build ssl
CONFLICT= uboot-mkimage
ALL_TARGET= tools-only
MAKE_ARGS= ARCH=sandbox \
CC="${CC}" \
KBUILD_VERBOSE=1 \
NOSTDINC_FLAGS="" \
PLIST_FILES= bin/mkimage bin/mkenvimage bin/dumpimage bin/fit_info
do-configure:
(cd ${WRKSRC}/ && ${MAKE_CMD} sandbox_defconfig)
do-build:
(cd ${WRKSRC}/ && ${MAKE_CMD} ARCH=sandbox tools-only)
(cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} sandbox_defconfig)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tools/dumpimage ${STAGEDIR}${PREFIX}/bin

View File

@ -1,20 +0,0 @@
--- Makefile.orig 2017-09-11 18:10:40 UTC
+++ Makefile
@@ -338,7 +338,7 @@ LD = $(CROSS_COMPILE)ld.bfd
else
LD = $(CROSS_COMPILE)ld
endif
-CC = $(CROSS_COMPILE)gcc
+CC = $(CROSS_COMPILE)cc
CPP = $(CC) -E
AR = $(CROSS_COMPILE)ar
NM = $(CROSS_COMPILE)nm
@@ -633,7 +633,7 @@ UBOOTINCLUDE := \
-I$(srctree)/arch/$(ARCH)/include \
-include $(srctree)/include/linux/kconfig.h
-NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+NOSTDINC_FLAGS += -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
# FIX ME

View File

@ -1,11 +0,0 @@
--- scripts/Makefile.autoconf.orig 2017-09-11 18:10:40 UTC
+++ scripts/Makefile.autoconf
@@ -27,7 +27,7 @@ include scripts/Kbuild.include
# Need to define CC and CPP again here in case the top Makefile did not
# include config.mk. Some architectures expect CROSS_COMPILE to be defined
# in arch/$(ARCH)/config.mk
-CC = $(CROSS_COMPILE)gcc
+CC = $(CROSS_COMPILE)cc
CPP = $(CC) -E
include config.mk