- New port silo-4.6.1

A mesh and field I/O library and scientific database

Silo is a library for reading and writing a wide variety of scientific
data to binary, disk files. The files Silo produces and the data within
them can be easily shared and exchanged between wholly independently
developed applications running on disparate computing platforms.

Consequently, Silo facilitates the development of general purpose tools
for processing scientific data. One of the more popular tools that process
Silo data files is the VisIt visualization tool.

Silo supports gridless (point) meshes, structured meshes, unstructured-zoo
and unstructured-arbitrary-polyhedral meshes, block structured AMR meshes,
constructive solid geometry (CSG) meshes, piecewise-constant (e.g.
zone-centered) and piecewise-linear (e.g. node-centered) variables defined
on the node, edge, face or volume elements of meshes as well as the
decomposition of meshes into arbitrary subset hierarchies including
materials and mixing materials. In addition, Silo supports a wide variety
of other useful objects to address various scientific computing
application needs.Although the Silo library is a serial library, it has
some key features which enable it to be applied quite effectively and
scalably in parallel.

PR:		ports/125725
Submitted by:	Pedro F. Giffuni <giffunip at tutopia.com>
This commit is contained in:
Beech Rintoul 2008-07-20 21:19:13 +00:00
parent 6521811d9e
commit 1ff5f0c40d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=217227
6 changed files with 133 additions and 0 deletions

View File

@ -106,6 +106,7 @@
SUBDIR += qcl
SUBDIR += ruby-dcl
SUBDIR += ruby-gphys
SUBDIR += silo
SUBDIR += simlib
SUBDIR += svmlight
SUBDIR += szip

78
science/silo/Makefile Normal file
View File

@ -0,0 +1,78 @@
# New ports collection makefile for: silo
# Date created: 17 jul 2008
# Whom: Pedro F. Giffuni <giffunip@tutopia.com>
#
# $FreeBSD$
#
PORTNAME= silo
PORTVERSION= 4.6.1
CATEGORIES= science
MASTER_SITES= https://wci.llnl.gov/codes/${PORTNAME}/silo-${PORTVERSION}/
MAINTAINER= giffunip@tutopia.com
COMMENT= A mesh and field I/O library and scientific database
LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
USE_GMAKE= yes
CONFIGURE_ARGS= --enable-shared
USE_LDCONFIG= yes
USE_XLIB= yes
USE_QT_VER= 3
QT_COMPONENTS= moc uic
OPTIONS= PYTHON "Enable Python Module" On \
HDF5 "Enable HDF5 Driver" Off \
BROWSER "Enable Silex Browser" Off \
FORTRAN "Compile Fortran interface" Off \
OPTIMIZATION "Enable extra optimizations" On
.include <bsd.port.pre.mk>
.ifdef WITH_PYTHON
USE_PYTHON= yes
CONFIGURE_ARGS+= --enable-pythonmodule
PLIST_SUB+= WITH_PYTHON=""
.else
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
.ifdef WITH_HDF5
LIB_DEPENDS+= hdf5.0:${PORTSDIR}/science/hdf5
CONFIGURE_ARGS= --with-hdf5=${LOCALBASE}
PLIST_SUB+= WITH_HDF5=""
PLIST_SUB+= WITH_HDF5="@comment "
.else
PLIST_SUB+= WITH_HDF5="@comment "
PLIST_SUB+= WITH_NCDF=""
.endif
.ifdef WITH_BROWSER
CONFIGURE_ARGS+= --enable-silex
PLIST_SUB+= WITH_BROWSER=""
.else
PLIST_SUB+= WITH_BROWSER="@comment "
.endif
.ifdef WITH_FORTRAN
USE_FORTRAN= yes
CONFIGURE_ARGS+= --enable-fortran
.else
CONFIGURE_ARGS+= --disable-fortran
.endif
.ifdef WITH_OPTIMIZATION
CONFIGURE_ARGS+= --enable-optimization
.endif
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} check
.include <bsd.port.post.mk>

3
science/silo/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (silo-4.6.1.tar.gz) = 34b030e8c098b89bd79ee1b23477b283
SHA256 (silo-4.6.1.tar.gz) = 8e5c314db468613a2a6ddf7c3ce07a0a9f969e854e5957011f0cade184bf0ac7
SIZE (silo-4.6.1.tar.gz) = 2618748

View File

@ -0,0 +1,11 @@
--- tests/Makefile.in.orig 2008-03-27 13:56:49.000000000 -0500
+++ tests/Makefile.in 2008-03-27 13:57:36.000000000 -0500
@@ -407,7 +407,7 @@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
LDFLAGS = @LDFLAGS@
LIBOBJS = @LIBOBJS@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lcompat
LIBTOOL = @LIBTOOL@
LN_S = @LN_S@
LOCAL = @LOCAL@

24
science/silo/pkg-descr Normal file
View File

@ -0,0 +1,24 @@
A mesh and field I/O library and scientific database
Silo is a library for reading and writing a wide variety of scientific
data to binary, disk files. The files Silo produces and the data within
them can be easily shared and exchanged between wholly independently
developed applications running on disparate computing platforms.
Consequently, Silo facilitates the development of general purpose tools
for processing scientific data. One of the more popular tools that process
Silo data files is the VisIt visualization tool.
Silo supports gridless (point) meshes, structured meshes, unstructured-zoo
and unstructured-arbitrary-polyhedral meshes, block structured AMR meshes,
constructive solid geometry (CSG) meshes, piecewise-constant (e.g.
zone-centered) and piecewise-linear (e.g. node-centered) variables defined
on the node, edge, face or volume elements of meshes as well as the
decomposition of meshes into arbitrary subset hierarchies including
materials and mixing materials. In addition, Silo supports a wide variety
of other useful objects to address various scientific computing
application needs.Although the Silo library is a serial library, it has
some key features which enable it to be applied quite effectively and
scalably in parallel.
WWW: https://wci.llnl.gov/codes/silo/

16
science/silo/pkg-plist Normal file
View File

@ -0,0 +1,16 @@
%%WITH_BROWSER%%bin/browser
bin/silodiff
bin/silex
bin/silock
include/silo.h
include/silo.inc
include/pmpio.h
%%WITH_PYTHON%%lib/Silo.a
%%WITH_PYTHON%%lib/Silo.la
%%WITH_PYTHON%%lib/Silo.so
%%WITH_NCDF%%lib/libsilo.a
%%WITH_NCDF%%lib/libsilo.la
%%WITH_NCDF%%lib/libsilo.so
%%WITH_HDF5%%lib/libsiloh5.a
%%WITH_HDF5%%lib/libsiloh5.la
%%WITH_HDF5%%lib/libsiloh5.so