Add libisc port:

libisc is C utility library which is used as part of part of ISC's bind.

It includes functions for:
- assertion handling.
- balanced binary (AVL) trees.
- bit masks comparison.
- event based programs.
- heap-based priority queues.
- memory handling.
- program logging.

Reviewed by:	erwin
This commit is contained in:
Simon L. B. Nielsen 2005-12-13 21:16:18 +00:00
parent 045f4dc5ae
commit 1fe3abf60d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=151120
6 changed files with 112 additions and 0 deletions

View File

@ -486,6 +486,7 @@
SUBDIR += libhash
SUBDIR += libhoard
SUBDIR += libical
SUBDIR += libisc
SUBDIR += libltdl15
SUBDIR += libmatheval
SUBDIR += libmba

39
devel/libisc/Makefile Normal file
View File

@ -0,0 +1,39 @@
# New ports collection makefile for: libisc
# Date created: 26 Nov 2005
# Whom: Simon L. Nielsen <simon@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= libisc
PORTVERSION= 9.3.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
DISTNAME= bind-${ISCVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= simon@FreeBSD.org
COMMENT= ISC's utility library
# ISC releases things like 9.3.0rc1, which our versioning doesn't like
ISCVERSION= 9.3.1
GNU_CONFIGURE= yes
#CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MANCOMPRESSED= yes
BUILD_WRKSRC= ${WRKSRC}/lib/bind/freebsdportisc/
INSTALL_WRKSRC= ${BUILD_WRKSRC}
INSTALLS_SHLIB= yes
MAN3= assertions.3 eventlib.3 logging.3 tree.3 bitncmp.3 heap.3 \
memcluster.3
.if defined(NO_PROFILE) || defined(NOPROFILE)
PLIST_SUB+= PROFLIB="@comment "
.else
PLIST_SUB+= PROFLIB=""
.endif
.include <bsd.port.mk>

6
devel/libisc/distinfo Normal file
View File

@ -0,0 +1,6 @@
MD5 (bind-9.3.1.tar.gz) = 9ff3204eea27184ea0722f37e43fc95d
SHA256 (bind-9.3.1.tar.gz) = 9a9411115338d2554f2e99bc676c2e9a381a8d649bf9bd9c0b2ffa2cf74b563c
SIZE (bind-9.3.1.tar.gz) = 4673603
MD5 (bind-9.3.1.tar.gz.asc) = b2077443ade50ed778aa78a8014affaa
SHA256 (bind-9.3.1.tar.gz.asc) = 288cd81c1fc9e8cc2764f1c2464b948f0541af231d615df85803ba430314d803
SIZE (bind-9.3.1.tar.gz.asc) = 186

View File

@ -0,0 +1,40 @@
--- /dev/null Fri Nov 25 23:55:00 2005
+++ lib/bind/freebsdportisc/Makefile Fri Nov 25 23:57:32 2005
@@ -0,0 +1,37 @@
+# $FreeBSD$
+.PATH: ${.CURDIR}/../isc ${.CURDIR}/../include/isc
+
+LIB= isc
+
+SRCS= assertions.c base64.c bitncmp.c ctl_clnt.c ctl_p.c \
+ ctl_srvr.c ev_connects.c ev_files.c ev_streams.c \
+ ev_timers.c ev_waits.c eventlib.c heap.c hex.c logging.c \
+ memcluster.c movefile.c tree.c
+
+INCS= assertions.h ctl.h dst.h eventlib.h heap.h irpmarshall.h \
+ list.h logging.h memcluster.h misc.h tree.h
+
+SHLIB_MAJOR=1
+
+LIBDIR= ${PREFIX}/lib
+MANDIR= ${PREFIX}/man/man
+INCSDIR= ${PREFIX}/include/isc
+
+MAN= assertions.3 eventlib.3 logging.3 tree.3 \
+ bitncmp.3 heap.3 memcluster.3
+
+# Not elegant, but it works
+.for mp in ${MAN}
+${mp}:
+ ln -s ${.CURDIR}/../isc/${mp:S/.3/.mdoc/} ${mp}
+.endfor
+
+top_builddir = BSD/ports/libisc/work/bind-9.3.1/lib/bind
+
+CFLAGS+= -I${.CURDIR}/../include -I${.CURDIR}/.. \
+ -I${.CURDIR}/../port/freebsd/include
+
+beforeinstall:
+ test -d ${INCSDIR} || mkdir ${INCSDIR}
+
+.include <bsd.lib.mk>

10
devel/libisc/pkg-descr Normal file
View File

@ -0,0 +1,10 @@
libisc is C utility library which is used as part of part of ISC's bind.
It includes functions for:
- assertion handling.
- balanced binary (AVL) trees.
- bit masks comparison.
- event based programs.
- heap-based priority queues.
- memory handling.
- program logging.

16
devel/libisc/pkg-plist Normal file
View File

@ -0,0 +1,16 @@
lib/libisc.a
lib/libisc.so
lib/libisc.so.1
%%PROFLIB%%lib/libisc_p.a
include/isc/assertions.h
include/isc/ctl.h
include/isc/dst.h
include/isc/eventlib.h
include/isc/heap.h
include/isc/irpmarshall.h
include/isc/list.h
include/isc/logging.h
include/isc/memcluster.h
include/isc/misc.h
include/isc/tree.h
@dirrm include/isc