Update to 3.9.0
PR: ports/95821 Submitted by: Ports Fury
This commit is contained in:
parent
a14669440b
commit
1fc50e17e9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=163278
@ -6,24 +6,29 @@
|
||||
#
|
||||
|
||||
PORTNAME= dxpc
|
||||
PORTVERSION= 3.8.2
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 3.9.0
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://www.vigor.nu/dxpc/${PORTVERSION}/
|
||||
MASTER_SITES= http://www.vigor.nu/dxpc/%SUBDIR%/
|
||||
MASTER_SITE_SUBDIR= ${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Compressing X protocol proxy designed to support X11 over slow links
|
||||
|
||||
LIB_DEPENDS= lzo.1:${PORTSDIR}/archivers/lzo
|
||||
LIB_DEPENDS= lzo2.2:${PORTSDIR}/archivers/lzo2
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GNOME= gnometarget
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-lzo-lib=${LOCALBASE}
|
||||
MAKE_ARGS= CPPFLAGS="-I. -I${X11BASE}/include"
|
||||
|
||||
MAN1= dxpc.1
|
||||
PLIST_FILES= bin/dxpc
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_X_PREFIX= yes
|
||||
CONFIGURE_ARGS+= --with-lzo-lib=${LOCALBASE}
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${PREFIX}/bin/dxpc
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/dxpc ${PREFIX}/bin/dxpc
|
||||
${INSTALL_MAN} ${WRKSRC}/dxpc.man ${MANPREFIX}/man/man1/dxpc.1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (dxpc-3.8.2.tar.gz) = 3fbfb0e4bf769e64d27da331ecddbc9f
|
||||
SHA256 (dxpc-3.8.2.tar.gz) = 6fa9cd607f6b8d137f9858da737c15b9ff92912716c3e312d9ca755f1acfa243
|
||||
SIZE (dxpc-3.8.2.tar.gz) = 144909
|
||||
MD5 (dxpc-3.9.0.tgz) = ff8148868271b405a1a67b412e45d4e1
|
||||
SHA256 (dxpc-3.9.0.tgz) = 0d1ebae097b2be6b0d1fbf4558d3afcfa0c87edadf5c43932627fa9f71d6f63e
|
||||
SIZE (dxpc-3.9.0.tgz) = 190856
|
||||
|
22
x11/dxpc/files/patch-DecodeBuffer.C
Normal file
22
x11/dxpc/files/patch-DecodeBuffer.C
Normal file
@ -0,0 +1,22 @@
|
||||
--- DecodeBuffer.C.orig Wed Mar 1 05:46:52 2006
|
||||
+++ DecodeBuffer.C Thu Apr 13 12:33:30 2006
|
||||
@@ -1,6 +1,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <stddef.h>
|
||||
+#include <stdio.h>
|
||||
#include <assert.h>
|
||||
#include "DecodeBuffer.H"
|
||||
#include "IntCache.H"
|
||||
@@ -20,9 +21,9 @@
|
||||
|
||||
// #define DEBUG
|
||||
#ifdef DEBUG
|
||||
-# define DBG(fmt, ...) printf(fmt, __VA_ARGS__)
|
||||
+# define DBG(fmt, ARGS...) printf(fmt, ##ARGS)
|
||||
#else
|
||||
-# define DBG(fmt,...)
|
||||
+# define DBG(fmt, ARGS...)
|
||||
#endif
|
||||
|
||||
DecodeBuffer::DecodeBuffer(const unsigned char *data, unsigned int length)
|
14
x11/dxpc/files/patch-EncodeBuffer.C
Normal file
14
x11/dxpc/files/patch-EncodeBuffer.C
Normal file
@ -0,0 +1,14 @@
|
||||
--- EncodeBuffer.C.orig Wed Mar 1 05:46:52 2006
|
||||
+++ EncodeBuffer.C Thu Apr 13 12:16:46 2006
|
||||
@@ -13,9 +13,9 @@
|
||||
|
||||
// #define DEBUG
|
||||
#ifdef DEBUG
|
||||
-# define DBG(fmt, ...) printf(fmt, __VA_ARGS__)
|
||||
+# define DBG(fmt, ARGS...) printf(fmt, ##ARGS)
|
||||
#else
|
||||
-# define DBG(fmt,...)
|
||||
+# define DBG(fmt, ARGS...)
|
||||
#endif
|
||||
|
||||
static const int INITIAL_BUFFER_SIZE = 256;
|
Loading…
Reference in New Issue
Block a user