Add x11/inputplug

inputplug is a very simple daemon which monitors XInput events and runs
arbitrary scripts on hierarchy change events (such as a device being
attached, removed, enabled or disabled).

For example, inputplug can be used in shell scripts which monitor
attachments of keyboards in order to run change keyboard mappings with
commands like "setxkbmap -option ctrl:nocaps".

WWW: https://github.com/andrewshadura/inputplug
This commit is contained in:
Mateusz Piotrowski 2020-10-10 11:53:46 +00:00
parent 65f41e9981
commit 1f9979e09e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=551917
5 changed files with 51 additions and 0 deletions

View File

@ -107,6 +107,7 @@
SUBDIR += idesk
SUBDIR += imwheel
SUBDIR += innerspace
SUBDIR += inputplug
SUBDIR += j4-dmenu-desktop
SUBDIR += jgmenu
SUBDIR += kanshi

26
x11/inputplug/Makefile Normal file
View File

@ -0,0 +1,26 @@
# $FreeBSD$
PORTNAME= inputplug
DISTVERSION= 0.3
CATEGORIES= x11
MAINTAINER= 0mp@FreeBSD.org
COMMENT= XInput event monitor daemon
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= mk-configure>=0:devel/mk-configure
USES= localbase perl5 pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= andrewshadura
USE_PERL5= build
USE_XORG= x11 xcb xi
MAKE_CMD= mkcmake
MAKE_ARGS= MANDIR="${PREFIX}/share/man"
PLIST_FILES= bin/inputplug \
share/man/man1/inputplug.1.gz
.include <bsd.port.mk>

3
x11/inputplug/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1602328140
SHA256 (andrewshadura-inputplug-0.3_GH0.tar.gz) = acac8e3972f3f10f9b6791321d2441e6b54d93d97c2de81e13eb14734a635ef7
SIZE (andrewshadura-inputplug-0.3_GH0.tar.gz) = 7003

View File

@ -0,0 +1,12 @@
--- inputplug.c.orig 2020-10-10 11:36:14 UTC
+++ inputplug.c
@@ -3,6 +3,9 @@
#include <assert.h>
#include <unistd.h>
#include <errno.h>
+#if __FreeBSD__
+#include <signal.h>
+#endif
#include <stdio.h>
#include <stdbool.h>
#include <stdint.h>

9
x11/inputplug/pkg-descr Normal file
View File

@ -0,0 +1,9 @@
inputplug is a very simple daemon which monitors XInput events and runs
arbitrary scripts on hierarchy change events (such as a device being attached,
removed, enabled or disabled).
For example, inputplug can be used in shell scripts which monitor attachments
of keyboards in order to run change keyboard mappings with commands like
"setxkbmap -option ctrl:nocaps".
WWW: https://github.com/andrewshadura/inputplug